새 데이터베이스 수정 방법에 대한 자세한 정보

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Microsoft Office Access 2007 포함 되어 있는 모든 서식 파일은 미리 정의 된 테이블, 폼, 보고서, 쿼리, 매크로 및 관계를 포함 하는 완벽 한 추적 응용 프로그램입니다. 이러한 서식 파일은 있도록 즉시 유용한-의-기본, 신속 하 게 서식 파일과 실행할에 기반 하는 새 데이터베이스를 만들 수 있도록 합니다. 그러나 경우도 새 데이터베이스 수정 하려면-추가 하거나, 필드 이름 바꾸기 또는 보고서를 변경 하는 등입니다.

이 문서 서식 파일에서 만든 데이터베이스에 적용 하려는 경우 가장 일반적인 수정 작업을 수행 하는 방법을 설명 합니다. 특정 영역에 대 한 자세한 내용은 문서에 대 한 링크를 표시 합니다.

실행할 작업

테이블 및 필드의 기본 사항 알아보기

테이블에 필드 추가

테이블에서 필드 삭제

필드 또는 테이블 이름 바꾸기

폼 또는 보고서에 필드 추가

문서, 파일 또는 이미지를 저장 하는 필드 추가

필드 표시 방법 변경

테이블 및 필드 기본 사항 배우기

테이블에 데이터를 저장 하는 데이터베이스를 만들 때 등의 행과 열 주제별 목록입니다. 필드 (열)에서 추적 하려는 정보 항목을 저장 합니다. 예를 들어 연락처 테이블의 성, 이름, 전화 번호 및 주소에 대 한 필드를 만들 수 있습니다. Products 테이블에 대 한 제품 이름, 제품 ID 및 가격 필드를 만들 수 있습니다.

것이 필드는 신중 하 게 선택 하는 것이 중요 합니다. 예를 들어 일반적으로 좋습니다 잘못 된 계산 된 값을 저장할 필드를 만들 수 있습니다. 대부분의 경우에서 Office Access 2007 필요는 값을 계산을 할 수 있습니다. 필드를 선택 하면 유용한 가장 작은 부분에 정보를 저장 하려고 합니다. 예를 들어 대신 한 필드에는 전체 이름을 이름과 성으로 따로 저장를 살펴보겠습니다. 일반적으로, 보고, 정렬, 검색, 또는 정보 항목에서 계산을 수행 해야 할 경우 삽입 필드 단독으로 합니다.

데이터베이스 디자인 및 필드 선택에 대한 자세한 내용은 데이터베이스 디자인의 기초 문서를 참고하세요.

필드에는 정의 특성이 합니다. 예를 들어 모든 필드에 고유 하 게 표 내에서 필드를 식별 하는 이름입니다. 필드에는 해당 정보를 저장 하도록 선택 하는 데이터 형식에는 합니다. 데이터 형식 저장소 공간 공간을 각 값에 대해 따로 저장 될 수 있는 값과 해당 값에서 수행할 수 있는 작업도 결정 합니다. 모든 필드는 필드의 모양이 나 동작 특성을 정의 하는 속성 이라는 설정 관련된 그룹을 있습니다. Format 속성 필드의 디스플레이 레이아웃을 정의 하는 예를 들어 —, 즉 나타나는 모양을 표시 합니다.

맨 위로 이동

테이블에 필드 추가

데이터시트 보기에서 손쉽게 테이블에 필드를 추가할 수 있지만 디자인 보기에서도 테이블에 필드를 추가할 수 있습니다. 데이터시트 보기에서 필드를 추가하려면 새 필드 추가 열 머리글 아래의 셀에 데이터를 입력합니다.

Access의 새 필드 추가 열이 있는 데이터시트

1. 새 빈 필드입니다.

데이터시트 보기에서 필드 추가

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 새 필드를 추가할 테이블을 두 번 클릭합니다.

    데이터시트 보기에서 테이블이 열립니다.

  4. 새 필드 추가 열 머리글 아래의 셀에 데이터를 입력합니다.

    테이블에 이미 필드가 많은 경우에는 오른쪽으로 스크롤해야 새 필드 추가 열 머리글이 있는 열이 보일 수도 있습니다.

새 열에 데이터를 입력할 때 Office Access 2007 입력 된 필드에 대 한 적절 한 데이터 형식을 인식 하는 정보를 사용 합니다. 예를 들어 1/1/2007 등의 열에 날짜를 입력 하는 경우 Office Access 2007 날짜 및 날짜/시간 필드의 데이터 형식을 설정으로 입력 된 정보를 인식 합니다. Access에서 데이터 형식을 결정 하기 위해 입력 충분 한 정보가 없는 경우 데이터 형식 텍스트로 설정 됩니다.

하려는 경우 데이터를 입력 하 고 해당 Office Access 2007 선택 하는 무시 필드에 대 한 서식 지정 집합은 명시적으로, 데이터 시트 탭의 데이터 형식 및 서식 그룹에서 명령을 클릭 하 여 수행할 수 있습니다.

명시적으로 데이터 형식 설정

  • 데이터 시트 탭의 데이터 형식 및 서식 그룹에서 데이터 형식 옆에 있는 드롭다운 목록에서 화살표를 클릭 하 고 데이터 형식을 선택 합니다. 데이터 형식 및 서식 그룹 Access 리본 메뉴 이미지

  • 원하는 데이터 형식을 클릭합니다.

명시적으로 서식 설정

  1. 데이터 시트 탭의 데이터 형식 및 서식 그룹에서 서식 옆에 있는 드롭다운 목록에서 화살표를 클릭 하 고 서식을 선택 합니다. 데이터 형식 및 서식 그룹 Access 리본 메뉴 이미지

  2. 원하는 서식을 클릭합니다.

새 필드 추가 머리글 아래의 셀에 정보를 입력 하 여 필드를 추가 하면 Office Access 2007 필드에 이름을 자동으로 지정 합니다. 이러한 이름을 첫 번째 필드를 두 번째 필드에 대 한 Field2 Field1와 함께 시작 등에 합니다. 자세한 설명이 포함 된 필드 이름을 사용 하는 것이 좋습니다. 머리글을 마우스 오른쪽 단추로 클릭 한 다음 바로 가기 메뉴에서 열 이름 바꾸기를 클릭 하 여 필드 이름을 바꿀 수 있습니다.

데이터 시트 보기에서 필드를 추가 하는 것 외에도 디자인 보기에서 필드를 추가할 수 있습니다. 데이터 시트 보기를 사용 하면 가장 일반적인 필드 속성 설정, 있기 때문에 데이터 시트 보기에서 사용할 수 있는 속성을 설정 하려면 디자인 보기를 사용 하 여 필요한 찾을 수 있습니다.

디자인 보기에서 필드 추가

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 새 필드를 추가할 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 디자인 보기를 클릭합니다.

    디자인 보기에서 테이블이 열립니다.

  4. 필드 이름 열에서 첫 번째 빈 행을 클릭하고 새 필드의 이름을 입력합니다.

  5. 데이터 형식 열에서 인접한 셀을 클릭하고 목록에서 데이터 형식을 선택합니다.

  6. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

새 필드를 추가 하는 방법에 대 한 자세한 내용은 삽입, 추가 또는 테이블의 새 필드를 만들문서를 참고 하세요.

참고: 테이블에 새 필드를 추가해도 기존 폼이나 보고서에는 필드가 자동으로 추가되지 않으므로 기존 폼과 보고서에서 필드를 표시하려면 수동으로 추가해야 합니다.

맨 위로 이동

테이블에서 필드 삭제

제공된 된 서식 파일 중 하나에서 생성 된 데이터베이스에서 필드를 삭제 하지 말아야 합니다-필드 폼과 보고서와 같은 다른 데이터베이스 개체에서 사용 되는 것입니다. 따라서는 필드를 삭제 하면 만들어집니다 결과 필드를 사용 하는 다른 데이터베이스 개체 사용 하려고 할 때-데이터베이스 개체의 예상 대로 작동 하지 것입니다. 제대로 작동 하려면 해당 개체를 순서 대로 사용 하는 개체의 모든 필드에 대 한 참조를 제거 해야 합니다.

서식 파일을 사용하여 생성한 데이터베이스의 필드를 반드시 제거해야 하는 경우 데이터시트 보기나 디자인 보기에서 제거하면 됩니다. 이때 삭제한 필드를 참조하는 다른 데이터베이스 개체가 있으면 해당 개체를 수정하여 참조를 제거해야 합니다. 예를 들어 삭제한 필드에 바인딩된 컨트롤이 있는 보고서를 실행하면 해당 필드의 데이터를 찾을 수 없으므로 오류가 발생합니다.

필드를 삭제하면 해당 필드에 저장된 정보가 모두 영구히 삭제됩니다. 따라서 필드를 삭제할 때는 신중해야 하며 필드를 삭제하기 전에 데이터베이스의 복사본을 백업해 두어야 합니다.

필드를 삭제 하기 전에 모든 테이블 관계에 참여 하지 확인 해야 합니다. 관계가 있는 필드를 삭제 하려고 하면 Access 먼저 관계를 삭제 해야 한다는 경고를 표시 합니다. 테이블 관계 삭제 하는 방법에 대 한 단계별 지침 테이블 관계 삭제섹션을 참조 합니다.

데이터시트 보기에서 필드 삭제

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 삭제할 필드가 있는 테이블을 두 번 클릭합니다.

    데이터시트 보기에서 테이블이 열립니다.

  4. 삭제할 필드(열)를 선택합니다.

    팁: 필드(열)를 선택하려면 필드 선택기(열 머리글)를 클릭합니다.

  5. Delete 키를 누릅니다.

    또는

    데이터 시트 탭의 필드 및 열 그룹에서 삭제 를 클릭 합니다.

참고: 테이블 기본 키의 일부인 필드는 데이터시트 보기에서 삭제할 수 없습니다. 기본 키 필드를 삭제하려면 디자인 보기를 사용해야 합니다.

기본 키에 대 한 자세한 내용은 문서 추가, 설정, 변경 또는 기본 키 제거를 참고 하세요.

디자인 보기에서 필드 삭제

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 삭제할 필드가 있는 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 디자인 보기를 클릭합니다.

    디자인 보기에서 테이블이 열립니다.

  4. 삭제할 필드(행)를 선택합니다.

    팁: 행을 선택하려면 행 선택기를 클릭합니다.

  5. Delete 키를 누릅니다.

    또는

    디자인 탭의 도구 그룹에서 행 삭제 를 클릭 합니다.

  6. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

필드를 삭제하기 전에 해당 필드에 테이블 관계가 설정되어 있지 않은지 먼저 확인해야 합니다. 관계가 설정되어 있는 필드를 삭제하려고 하면 먼저 관계를 삭제해야 한다는 경고 메시지가 나타납니다. 테이블 관계를 삭제하려면 다음을 실행하십시오.

테이블 관계 삭제

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 테이블 관계에 참여하는 테이블이 열려 있으면 닫습니다. 열려 있는 테이블 간의 테이블 관계는 삭제할 수 없습니다.

  4. 데이터베이스 도구 탭의 표시/숨기기 그룹에서 관계를 클릭합니다.

  5. 테이블 관계가 설정된 테이블이 보이지 않으면 다음을 실행합니다.

    1. 디자인 탭의 표시/숨기기 그룹에서 테이블 이름을 클릭합니다.

    2. 테이블 표시 대화 상자에서 추가 클릭 한 다음 닫기를 클릭 테이블을 선택 합니다.

  6. 삭제할 테이블 관계의 관계선을 클릭하여 선택하고 Delete 키를 누릅니다. 선택한 관계선은 굵게 표시됩니다.

맨 위로 이동

필드 또는 테이블 이름 바꾸기

필드 또는 제공된 된 서식 파일 중 하나에서 생성 된 데이터베이스의 테이블 이름을 바꾸면 안, 즉 필드 또는 테이블 폼과 보고서와 같은 다른 데이터베이스 개체에 사용 되는 것입니다. 따라서, 필드 또는 테이블의 이름을 바꾸는 필드 또는 테이블을 사용 하는 다른 데이터베이스 개체 사용 하려고 할 때 결과 만들 수 있습니다. 다른 개체 여전히 이전 이름을 참조 하는 경우 예상 대로 작동 하지 않습니다. 제대로 작동 하려면 다른 개체에 대 한 이전 이름은 새 이름으로 변경 해야 합니다. Access 옵션 대화 상자의 현재 데이터베이스 범주에서 이름 자동 고침 실행 확인란을 선택 합니다 대부분의이 작업은 수를 자동으로 합니다.

데이터 시트 보기에서 열 머리글에 표시 되는 텍스트를 변경 하려면 될 수 있습니다. 이렇게 하려면 필드 이름을 변경 하지 않고 합니다. 열 머리글에 있는 텍스트 변경 하 고 필드 이름을 변경 하지 않을 경우 열 머리글에 표시 되는 텍스트 변경섹션을 참조 합니다.

필요한 경우 탐색 창에서 테이블의 이름을 바꿀 수도 있고 데이터 시트 보기 또는 디자인 보기에서 필드 이름을 바꿀 수 있습니다. 수동으로 구성 하기 전에 고려해 야 이름 자동 고침 옵션을 설정 아직 설정 하지 않은 경우.

이름 자동 고침 옵션 설정

필드, 테이블, 폼 또는 보고서를 같은 데이터베이스 개체의 이름을 바꿀 때 일반적으로 데이터베이스 전체에 전파 이름을 변경을 합니다. 그렇지 않은 경우 이전 이름을 참조 하는 개체 예상 대로 작동 하지 않습니다. Office Access 2007 이름 변경 내용을 적용 하는 데 도움이 되는 이름 자동 고침 기능을 제공 합니다. 기본적으로 이름 자동 고침 은 Office Access 2007 에서 모든 새 데이터베이스 설정 되어 있습니다. 그러나 설정 되어 있는 경우 설정 하 고 다음을 수행할 수 있습니다.

이름 자동 고침 옵션 설정

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 Access 옵션을 클릭합니다.

  2. Access 옵션 대화 상자의 왼쪽 창에서 현재 데이터베이스를 클릭합니다.

  3. 이름 자동 고침 옵션에서 이름 자동 고침 정보 추적 확인란과 이름 자동 고침 실행 확인란을 선택합니다.

  4. 이름 자동 고침 기능에서 수행하는 각 변경 내용을 테이블에 기록하려면 이름 자동 고침 변경 내용 기록 확인란을 선택합니다.

  5. 확인을 클릭합니다.

  6. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

참고: 이름 자동 고침 기능은 자동 고침 기능과는 다릅니다. 이름 자동 고침은 개체 간의 참조를 수정하고, 자동 고침 기능은 자주 틀리는 단어나 구를 고칩니다.

데이터시트 보기에서 필드 이름 바꾸기

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 이름을 바꿀 필드가 있는 테이블을 두 번 클릭합니다.

    데이터시트 보기에서 테이블이 열립니다.

  4. 이름을 바꿀 필드의 열 머리글을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 열 이름 바꾸기를 클릭합니다.

  5. 필드의 새 이름을 입력하고 Enter 키를 누릅니다.

디자인 보기에서 필드 이름 바꾸기

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 이름을 바꿀 필드가 있는 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 디자인 보기를 클릭합니다.

    디자인 보기에서 테이블이 열립니다.

  4. 이름을 바꿀 필드의 필드 이름 열에 있는 셀을 클릭합니다.

    팁: 전체 필드 이름을 선택하려면 이름 첫 문자의 바로 왼쪽을 가리키고 포인터가 화살표로 바뀌면 클릭합니다.

  5. 텍스트를 편집하여 필드 이름을 변경합니다.

  6. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

테이블 이름 바꾸기

탐색 창에서 바로 테이블 이름과 대부분의 다른 데이터베이스 개체 이름을 바꿀 수 있습니다.

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 이름을 바꿀 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 이름 바꾸기를 클릭합니다.

    참고: 테이블 이름을 바꾸려면 먼저 열려 있는 개체 중에서 해당 테이블을 참조하는 개체를 모두 닫아야 합니다.

  4. 새 이름을 입력하고 Enter 키를 누릅니다.

  5. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

열 머리글에 표시되는 텍스트 변경

캡션은 제목이 나 머리글 필드의 캡션 속성을 설정 하 여 필드에 할당할 수 있는입니다. 캡션 필드 이름의 별개인-모든 필드에 필드 이름이 및 캡션을 할 수도 있습니다. 예를 들어 필드 이름이 포함 된 공백 없이 한 단어를 세울 수 있습니다. 공백을 포함 하는 자세한 설명이 포함 된 이름을 만들려면 캡션 속성을 사용할 수 있습니다. 레이블 및 쿼리, 폼 및 보고서에서 제목 및 데이터 시트 보기에서 필드 이름 대신 캡션이 표시 됩니다.

캡션 속성에 대 한 텍스트를 입력 하지 않으면, 필드 이름은 기본적으로 사용 됩니다.

데이터 시트 보기의 열 머리글에 표시 되는 이름을 변경 하려면 해당 필드의 캡션 속성을 설정 하 여 필드 이름을 변경 하지 않고 하면 됩니다. 필드의 캡션 속성을 변경 하려면 다음을 실행 합니다.

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 캡션을 변경할 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 디자인 보기를 클릭합니다.

    디자인 보기에서 테이블이 열립니다.

  4. 캡션 속성을 설정할 필드의 필드 이름 열에서 셀을 클릭 합니다.

  5. 아래쪽 구역에 있는 필드 속성 아래의 일반 탭에서 캡션을 클릭합니다.

  6. 필드의 새 캡션을 입력합니다.

  7. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

다음에 데이터시트 보기에서 테이블을 열 때 열 머리글에 필드 이름 대신 캡션이 표시됩니다.

맨 위로 이동

폼 또는 보고서에 필드 추가

서식 파일에 기반 하는 데이터베이스를 만들 때 다양 한 기본 제공, 미리 디자인 된 폼과 보고서 즉시 작업할 수 있도록 하는 데이터베이스에 포함 됩니다. 하지만 수를 찾았으면, 폼 또는 보고서에 추가 필드를 추가 해야 합니다. 폼 또는 보고서에 필드를 추가 하면 컨트롤이라는 만들 수 있습니다.

컨트롤 소개

컨트롤은 개체는 데이터를 표시 하 고 작업을 수행 하도록 표시 하 고 사용자 인터페이스와 레이블 및 이미지 등을 개선 하는 정보에 대해 작업할 수 있습니다. 컨트롤을 바운드, 언바운드 및 계산 될 수 있습니다.

  • 바운드 컨트롤    데이터 원본이 테이블이 나 쿼리의 필드 컨트롤입니다. 바운드 컨트롤을 사용 하 여 데이터베이스에서 필드의 값을 표시 합니다. 값은 텍스트, 날짜, 숫자, 예/아니요 값, 그림 또는 수 그래프. 텍스트 상자에 바인딩된 컨트롤의 가장 일반적인 형식입니다. 예를 들어 직원의 성을 표시 되는 폼의 텍스트 상자 Employees 테이블의 성과 이름 필드에서이 정보를 가져올 수 있습니다.

  • 언바운드 컨트롤    이 유형의 컨트롤 (필드 또는 식) 데이터 원본이 없는 것입니다. 언바운드 컨트롤을 사용 하 여 정보, 선, 사각형 및 그림을 표시 합니다. 예를 들어 폼의 제목을 표시 하는 레이블은 언바운드 컨트롤입니다.

  • 계산 컨트롤    데이터 원본이 필드가 아닌 식을 컨트롤입니다. 컨트롤에 대 한 데이터 원본으로 을 정의 하 여 컨트롤에 원하는 값을 지정 합니다. 식 연산자의 조합입니다 ( = 같은 및 + ), 이름, 필드 이름, 단일 값 및 상수 값을 반환 하는 함수를 제어 합니다. 예를 들어 다음 식은 상수 값 (0.75) 단가 필드에 값을 곱하여 25% 할인 된 항목의 가격을 계산 합니다.

= [Unit Price] * 0.75

폼에서 원본으로 사용하는 테이블 또는 쿼리의 필드에 있는 데이터나 폼의 컨트롤에 있는 데이터를 식에 사용할 수 있습니다. 식에 대한 자세한 내용을 보려면 이 문서의 참고 항목 섹션에서 해당 링크를 클릭하십시오.

텍스트 상자는 바운드 컨트롤, 언바운드 컨트롤 또는 계산된 컨트롤 될 수 있습니다. 바운드, 언바운드 사용 하는 폼을 만드는 경우 되며 계산된 컨트롤을 하는 것이 효율적 추가 하 고 모든 바운드 컨트롤을 먼저 정렬 특히 폼에 컨트롤이 대부분을 구성 하는 경우. 그런 다음 디자인 보기에서 디자인 탭의 컨트롤 그룹에 있는 도구를 사용 하 여 디자인을 완료 하는 언바운드 컨트롤 및 계산 컨트롤을 추가할 수 있습니다.

데이터를 가져올 원본 필드를 식별하여 텍스트 상자 컨트롤을 필드에 바인딩합니다. 필드 목록 창에서 폼으로 선택한 필드를 끌어 필드에 바인딩되는 컨트롤을 만들 수 있습니다. 필드 목록 창에는 폼에서 원본으로 사용하는 테이블이나 쿼리의 필드가 표시됩니다. 필드 목록 창을 표시하려면 디자인 탭의 도구 그룹에서 기존 필드 추가를 클릭합니다. 필드를 필드 목록 창에서 폼의 디자인 눈금으로 끌면 텍스트 상자가 삽입됩니다.

또는 자체 컨트롤 또는 컨트롤의 속성 시트에서 컨트롤 원본 값에 대 한 상자에서 필드 이름을 입력 하 여 필드에 컨트롤을 바인딩할 수 있습니다. 속성 시트 컨트롤을 해당 이름 등의 특성, 해당 데이터 원본 형식으로 된 정의합니다.

다음과 같은 두 가지 이유로 인해, 바운드 텍스트 상자를 만들 때는 필드 목록 창을 사용하는 것이 가장 효과적입니다.

  • 바운드 텍스트 상자에는 기본적으로 필드 이름(또는 원본으로 사용하는 테이블이나 쿼리의 해당 필드에 대해 정의된 캡션)을 캡션으로 사용하는 레이블이 연결되어 있으므로 사용자가 직접 캡션을 입력할 필요가 없습니다.

  • 바운드 텍스트 상자를 다양 한 원본 테이블이 나 쿼리 (예: 형식, DecimalPlaces입력 마스크 속성)의 필드와 같은 설정을 상속합니다. 따라서는 이러한 필드의이 속성을 동일 하 게 유지이 필드에 바인딩된 텍스트 상자를 만들 때마다 하도록 할 수 있습니다.

언바운드 컨트롤 이미 만들고 필드에 바인딩하려면 경우 필드의 이름을 컨트롤의 ControlSource 속성을 설정 합니다.

레이아웃 보기에서 폼 또는 보고서에 필드 추가

폼 이나 보고서를 만든 후 레이아웃 보기에서 작업 하 여 해당 디자인을 세부적으로 쉽게 있습니다. 실제 실시간 데이터를 바탕을 사용 하 여 필드 너비를 조정할 수 있으며 필드를 다시 정렬할 수 있습니다. 폼 또는 보고서에 새 필드를 배치 한 폼 또는 보고서와 해당 컨트롤에 대 한 속성을 설정할 수 있습니다.

탐색 창에서 레이아웃 보기로 전환 하려면 폼 이나 보고서를 마우스 오른쪽 단추로 클릭 한 다음 바로 가기 메뉴에서 레이아웃 보기 를 클릭 합니다. 또는 Access 상태 표시줄에 있는 레이아웃 보기 단추를 클릭 하거나 폼 이나 보고서의 문서 탭을 마우스 오른쪽 단추로 클릭 하 고 바로 가기 메뉴에서 레이아웃 보기 를 클릭 합니다.

레이아웃 보기로 전환

  • 탐색 창에서 폼이나 보고서를 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 레이아웃 보기를 클릭합니다.

    또는

    Access 상태 표시줄에 있는 레이아웃 보기 단추를 클릭 합니다.

    또는

    폼 또는 보고서의 문서 탭을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 레이아웃 보기를 클릭합니다.

레이아웃 보기에서 폼 또는 보고서가 나타납니다.

속성 시트 열기

  • 정렬 탭의 도구 그룹에서 속성 시트를 클릭합니다.

    바로 가기 키 F4 키를 누릅니다.

필드 목록 창을 사용 하 여 필드를 추가 하려면 원본 테이블이 나 쿼리를 디자인 수 있습니다. 필드 목록 창을 표시 하려면 서식 탭의 컨트롤 그룹에 기존 필드 추가 클릭 합니다. 다음 필드 목록 창에서 직접 디자인으로 필드를 끌 수 있습니다.

필드 목록 창 표시

  • 서식 탭의 컨트롤 그룹에서 기존 필드 추가를 클릭합니다.

필드 목록 창에서 필드 추가

  • 한 필드만 추가하려면 필드 목록 창에서 폼 또는 보고서의 원하는 구역으로 필드를 끕니다.

  • 여러 필드를 한번에 추가하려면 Ctrl 키를 누른 상태에서 추가할 필드를 모두 클릭하여 선택하고 폼 또는 보고서로 끕니다.

필드를 구역으로 끌면 각 필드에 대해 바운드 텍스트 상자 컨트롤이 만들어지고 각 필드 옆에 레이블 컨트롤이 자동으로 배치됩니다.

폼 및 보고서에 대 한 자세한 내용은 폼 도구를 사용 하 여 폼 만들기간단한 보고서 만들기문서를 참고 합니다.

맨 위로 이동

문서, 파일 또는 이미지를 저장하는 필드 추가

하나 이상의 문서, 파일 또는 이미지를 저장 하려면 첨부 파일 데이터 형식으로 필드를 추가 하려면 Office Access 2007 를 사용할 수 있습니다. 단일 필드에 여러 파일을 저장 하려면 첨부 파일 필드를 사용할 수 있습니다. 해당 필드에도 두 개 이상 형식의 파일을 저장할 수 있습니다. 예를 들어 구직 지원자 데이터베이스에서 하나 이상의 이력서, 사진, 외에도 각 연락처에 대 한 레코드에 첨부할 수 있습니다.

테이블에 첨부 파일 필드 추가

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 필드를 추가할 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 디자인 보기를 클릭합니다.

    디자인 보기에서 테이블이 열립니다.

  4. 필드 이름 열에서 첫 번째 빈 행을 클릭하고 새 필드의 이름을 입력합니다.

  5. 데이터 형식 열에서 인접한 셀을 클릭하고 목록에서 첨부 파일을 선택합니다.

  6. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

    테이블을 저장한 후에는 변경 내용을 취소할 수 없다는 메시지가 나타납니다. 즉, 필드를 다른 데이터 형식으로 변환할 수는 없지만 오류가 있는 경우 필드를 삭제할 수 있습니다.

  7. 를 클릭하여 변경합니다.

테이블에 첨부 파일 필드를 추가한 후에는 첨부 파일 대화 상자를 사용하여 레코드에 문서, 파일 또는 이미지를 추가할 수 있습니다.

필드에 첨부 파일 추가

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 첨부 파일을 추가할 테이블을 두 번 클릭합니다.

    데이터시트 보기에서 테이블이 열립니다.

  4. 테이블에서 첨부 파일 필드를 두 번 클릭합니다.

    첨부 파일 대화 상자가 나타납니다.

  5. 추가를 클릭합니다.

    파일 선택 대화 상자가 나타납니다.

  6. 찾는 위치 목록을 사용하여 레코드에 첨부할 파일을 찾아 선택하고 열기를 클릭합니다.

    지원되는 데이터 형식의 파일을 여러 개 선택할 수 있습니다.

  7. 첨부 파일 대화 상자에서 확인을 클릭하여 테이블에 파일을 추가합니다.

    필드에 파일이 추가되고 그에 따라 첨부 파일을 나타내는 숫자가 증가합니다.

  8. 필요에 따라 이 단계를 반복하여 테이블의 현재 필드나 다른 필드에 파일을 추가합니다.

첨부 파일 필드에 대 한 자세한 내용은 첨부 파일 및 그래픽 데이터베이스의 레코드에문서를 참고 하세요.

맨 위로 이동

필드 표시 방법 변경

필드 표시 될 때 표시 되는 방식을 사용자 지정할 수 있습니다. 예를 들어 폼과 보고서에서 또는 테이블 데이터 시트 보기에서 열 때와 같은 데이터베이스를 전체에서 사용 하 여 표시 형식을 설정할 수 있습니다. 표시 형식을 설정 하려면 필드의 형식 속성을 설정할 수 있습니다. 필드의 형식 속성은 새 양식에서 자동으로 상속 합니다 및 보고서를 만들 수 있습니다.

데이터시트 보기에서 표시 형식 설정

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 필드 형식을 설정 하려면이 포함 된 테이블을 두 번 클릭 합니다.
    테이블을 데이터 시트 보기에서 열이 있습니다.

  4. 표시 형식을 설정할 필드를 클릭합니다.

  5. 데이터 시트 탭의 데이터 형식 및 서식 그룹에서 서식 옆에 있는 드롭다운 목록에서 화살표를 클릭 하 고 서식을 선택 합니다. 데이터 형식 및 서식 그룹 Access 리본 메뉴 이미지

    새 표시 형식으로 필드가 표시됩니다.

디자인 보기에서 표시 형식 설정

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 열기를 클릭합니다.

  2. 열기 대화 상자에서 데이터베이스를 선택하여 엽니다.

  3. 탐색 창에서 표시 형식을 변경할 필드가 있는 테이블을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 디자인 보기를 클릭합니다.

    디자인 보기에서 테이블이 열립니다.

  4. 표시 형식을 설정할 필드를 클릭합니다.

  5. 필드 속성일반 탭에서 형식을 클릭합니다.

  6. 드롭다운 목록을 클릭하여 표시 형식을 선택합니다.

  7. 변경 내용을 저장하려면 빠른 실행 도구 모음에서 저장을 클릭합니다.

필드의 모양을 변경 하는 방법에 대 한 자세한 내용은 문서 행과 열 데이터 서식 지정을참고 하세요.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×