새 데이터베이스 만들기

새 데이터베이스 만들기

참고: 사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서가 여기 있습니다.

이 문서에서는 Access 시작 하는 기본 단계를 설명 하 고 데이터베이스를 만드는 동안 사용 될 데스크톱 컴퓨터에서 아닌 웹 합니다. 서식 파일을 사용 하 여 데스크톱 데이터베이스를 만드는 방법 및 직접 테이블, 폼, 보고서 및 다른 데이터베이스 개체를 만들어 처음부터 데이터베이스를 작성 하는 방법을 설명 합니다. 새 데이터베이스에 기존 데이터를 가져오는 데 사용할 수 있는 몇 가지 방법을 설명 합니다.

이 문서의 내용

개요

서식 파일을 사용 하 여 데이터베이스 만들기

서식 파일을 사용 하지 않고 데이터베이스 만들기

Access 테이블에 다른 원본에서 데이터를 복사

가져오기, 추가 또는 다른 원본에서 데이터에 연결

응용 프로그램 요소 추가

기존 Access 데이터베이스 열기

Access 2007을 사용 하 시겠습니까?

개요

Access를 처음 시작할 때 또는 Access를 닫지 않고 데이터베이스를 닫은 경우 Microsoft Office Backstage 보기 표시 됩니다.

Backstage 보기는 시작 점으로 수 있는 새 데이터베이스 만들기, 기존 데이터베이스 열기, Office.com 에서 주요 콘텐츠 보기-Access를 사용 하 여 데이터베이스 파일 또는 외부하는 대신 데이터베이스의 하기 위해 모든 작업 내 데이터베이스입니다.

데이터베이스 만들기

Access를 열 때 Backstage 보기의 새로 만들기 탭을 표시 합니다. 새로 만들기 탭의 새 데이터베이스를 만들 수 있는 여러 가지 방법으로 제공 합니다.

  • 새 데이터베이스    원하는 경우 처음부터 시작할 수 있습니다. 매우 특정 디자인 요구 사항이 있거나 수용할 수 있도록 하거나 통합 해야 하는 기존 데이터가 있는 경우에 적합 한 옵션입니다.

  • Access와 함께 설치 되는 서식 파일    새 프로젝트 시작 되 고 유리한 구입할 경우 서식 파일을 사용 하는 것이 좋습니다. 기본적으로 설치 하는 몇 가지 서식 파일 액세스를 제공 합니다.

  • Office.com 의 서식 파일    Access와 함께 제공 되는 서식 파일을 외에도 Office.com 에서 다양 한 서식 파일을 찾을 수 있습니다. 브라우저를 열고도 없는, 서식 파일이 새로 만들기 탭에서 사용할 수 있습니다.

데이터베이스에 추가

데이터베이스에서 작업을 수행한 후에 필드, 표 또는 응용 프로그램 요소를 추가할 수 있습니다.

응용 프로그램 요소는 하나 듯 여러 관련된 데이터베이스 개체를 함께 사용할 수 있도록 하는 기능입니다. 예를 들어 테이블 및 테이블에 기반 하는 양식 응용 프로그램 요소 구성 될 수 있습니다. 응용 프로그램 요소를 사용 하 여 동시에 테이블과 폼을 추가할 수 있습니다.

쿼리, 폼, 보고서, 매크로-작업에 사용 되는 모든 데이터베이스 개체를 만들 수도 있습니다.

서식 파일을 사용 하 여 데이터베이스 만들기

Access에는 다른 이름으로 사용할 수 있는 서식 파일의 다양 한 함께-는 또는 시작 지점입니다. 서식 파일은 모든 테이블, 쿼리, 폼, 매크로 및 특정 작업을 수행 하는 데 필요한 보고서를 포함 하는 즉시 사용 하 여 데이터베이스입니다. 예를 들어 문제를 추적 하거나, 연락처를 관리 하거나 경비의 기록을 유지 하는 데 사용할 수 있는 서식 파일입니다. 일부 서식 파일 사용 방법을 보여 위해 몇 가지 예제 레코드가 포함 합니다.

필요에 맞는 이러한 서식 파일 중 하나 것은 보통입니다 빠르게 시작 하 여 데이터베이스를 가져올 수 있습니다. 그러나 Access로 가져올 다른 프로그램의 데이터가 있는 경우 서식 파일을 사용 하지 않고 데이터베이스를 만드는 것이 좋습니다 결정할 수 있습니다. 서식 파일에 이미 정의 데이터 구조를 포함 하 고 많은 서식 파일의 구조를 기존 데이터에 맞게 작업이 필요할 수 있습니다.

  1. 데이터베이스를 열고 파일 탭에 있는 경우 닫기 를 클릭 합니다. Backstage 보기의 새로 만들기 탭을 표시합니다.

  2. 여러 가지 서식 파일에 Access에 작성 중 일부는 새로 만들기 탭에서 사용할 수 있습니다. Office.com 에서 추가 서식 파일을 다운로드할 수 있습니다. 자세한 내용은이 문서의 다음 섹션을 참조 합니다.

  3. 사용 하려는 서식 파일을 선택 합니다.

  4. Access에서 파일 이름을 파일 이름 상자에 데이터베이스에 대 한 제안 등 원하는 경우 파일 이름을 변경할 수 있습니다. 데이터베이스 파일 이름 상자 아래에 표시 된 것과에서 다른 폴더를 저장 하려면 단추 이미지 , 저장 한 다음 확인 을 클릭 하려는 폴더를 찾습니다. 필요에 따라 만들 수 있으며 SharePoint 사이트에 데이터베이스 연결.

    참고: SharePoint 사용 모두 하지만 SharePoint 사이트에 연결 된 데스크톱 데이터베이스는 없습니다 Access Services를 사용 하 여 웹 데이터베이스와 동일 합니다. 데스크톱 데이터베이스를 사용 하려면 Access가 설치 되어 있어야 합니다. 웹 브라우저와 웹 데이터베이스를 사용할 수 있습니다.

  5. 만들기를 클릭합니다.

    Access를 선택 하 고 데이터베이스를 연 다음 서식 파일에서 데이터베이스를 만듭니다. 여러 서식 파일에 대 한 데이터 입력 시작할 수 있는 폼 표시 됩니다. 서식 파일에 예제 데이터가 있는 경우 (회색으로 표시 된 상자 또는 레코드의 왼쪽에 막대) 레코드 선택기를 클릭 하 고 다음을 수행 하 여 각 레코드를 삭제할 수 있습니다.

    탭의 레코드 그룹에서 삭제 를 클릭 합니다. 단추 이미지

  6. 데이터 입력을 시작 하려면 양식에서 첫 번째 빈 셀에서을 클릭 하 고 입력을 시작 합니다. 탐색 창 를 사용 하 여 다른 폼 이나 보고서를 사용 하려는 경우를 찾습니다. 일부 서식 파일 다른 데이터베이스 개체 사이 이동할 수 있는 탐색 폼을 포함 합니다.

서식 파일 사용에 대 한 자세한 내용은 Access 데스크톱 데이터베이스를 만들려면 서식 파일 사용문서를 참고 하세요.

맨 위로 이동

서식 파일을 사용 하지 않고 데이터베이스 만들기

서식 파일을 사용 하 여 원하지 않는 경우 직접 테이블, 폼, 보고서 및 다른 데이터베이스 개체를 작성 하 여 데이터베이스를 만들 수 있습니다. 대부분의 경우에서이에서는 다음 중 하나 이상을 수행 합니다.

  • 입력, 붙여넣기, 또는 새 데이터베이스를 만들 때 만들어진 테이블로 데이터를 가져오는, 만들기 탭의 명령을 사용 하 여 만든 새 테이블을 사용 하 여 프로세스를 반복 합니다.

  • 다른 원본에서 데이터 가져오기 및 프로세스에서 새 테이블 만들기.

새 데이터베이스 만들기

  1. 파일 탭에서 새로 만들기를 클릭 한 다음 새 데이터베이스 를 클릭 합니다.

  2. 파일 이름 상자에 파일 이름을 입력 합니다. 기본에서 파일의 위치를 변경 하려면 ( 파일 이름 상자) 옆에 있는 데이터베이스를 저장할 위치 찾아보기 단추 이미지 , 새 위치를 찾아 한 다음 확인 을 클릭 합니다.

  3. 만들기를 클릭합니다.

    표 1 이라는 빈 테이블이 있는 데이터베이스 만들어져 다음 표 1 데이터 시트 보기에서 열립니다. 커서 추가를 클릭 하 여 열에 있는 첫 번째 빈 셀에 배치 됩니다.

  4. 입력 하 여 데이터를 추가 하거나 Access 테이블에 다른 원본에서 데이터를 복사섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수 있습니다.

데이터 시트 보기에서 데이터 입력 매우 유사 Excel 워크시트에서 작동 하도록 설계 되었습니다. 표 구조 데이터를 입력 하는 동안 만들어집니다. 데이터 시트에 새 열을 추가할 때 새 필드가 테이블에 정의 되어 있습니다. 자동으로 입력 하면 데이터에 따라 각 필드의 데이터 형식을 설정 합니다.

현재 표 1에 데이터를 입력 하려면 단추 이미지 닫기를 클릭 합니다. 테이블을 변경한 경우 변경 내용을 저장 하려면 묻는 메시지가 나타납니다. 변경 내용을 저장을 취소 하려면 아니요 클릭 하거나 취소 를 클릭 하는 테이블을 열어 둘 를 클릭 합니다.

팁: Access 라는 Blank.accdb [설치 드라이브]에 있는 폴더에 파일을 찾습니다: \Program Files\Microsoft Office\Templates\1033\Access\ 합니다. 이 있으면 Blank.accdb 는 모든 새 빈 데이터베이스에 대 한 서식 파일 웹 데이터베이스를 제외 합니다. 포함 된 모든 콘텐츠는 모든 새 빈 데이터베이스에서 상속 됩니다. 부품 번호 또는 회사 법적 고 지 사항 및 정책 등의 기본 콘텐츠 배포 하는 좋은 방법입니다. 기억 Blank.accdb 비어 있는 새 웹 데이터베이스를 만들에 영향이 없습니다.

중요: 표 1을 한 번 이상 저장 하지 않고 닫은 경우 Access에 데이터를 입력 한 경우에 전체 표를 삭제 합니다.

테이블 추가

만들기 탭의 그룹의 명령을 사용 하 여 기존 데이터베이스에 새 테이블을 추가할 수 있습니다.

Access 리본 메뉴 이미지

데이터 시트 보기에서 시작 테이블 만들기    데이터 시트 보기에서 즉시 데이터를 입력 하 고 액세스 하 여 문서의 표 구조를 만들 수 있도록 수 있습니다. (Field1, Field2, 및 등) 필드 이름은 숫자로 지정 되 고 입력 하는 데이터에 따라 각 필드의 데이터 형식이 자동으로 설정 합니다.

  1. 만들기 탭의 그룹에서 를 클릭 합니다. 단추 이미지

    Access 테이블 만들고 추가를 클릭 하 여 열에서 첫 번째 빈 셀을 선택 합니다.

  2. 필드 탭의 추가 및 삭제 그룹에서 추가 하려는 필드의 유형을 클릭 합니다. 원하는 형식을 보이지 않으면 단추 이미지 추가 필드 클릭 합니다.

  3. 자주 사용 되는 필드 형식 목록이 표시 됩니다. 원하는 필드 형식을 클릭 하 고 액세스 삽입 포인터 위치에 데이터 시트에 새 필드를 추가 합니다.

    필드를 끌어 이동할 수 있습니다. 데이터 시트에서 필드를 끌어 필드를 넣을 세로 삽입 모음이 표시 됩니다.

  4. 데이터를 추가 하려면 첫 번째 빈 셀에 입력을 시작 하거나 데이터를 Access 테이블에 다른 출처를 복사해섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣습니다.

  5. 열(필드) 이름을 바꾸려면 열 머리글을 두 번 클릭하고 새 이름을 입력합니다.

    필드 목록 창에 표시 되 면 내용 알 수 있도록 각 필드에는 의미 있는 이름을 제공 해야 합니다.

  6. 열을 이동 하려면 열을 선택 하 여 머리글을 클릭 한 다음 원하는 위치에 열을 끕니다. 여러 개의 인접 한 열 선택한 다음 한 번에 새 위치로 끕니다 수도 있습니다. 여러 개의 인접 한 열을 선택 하려면 첫 번째 열의 열 머리글을 클릭 한 다음 shift 키를 누른 채 마지막 열의 열 머리글을 클릭 합니다.

디자인 보기에서 시작 테이블 만들기    디자인 보기에서 먼저 표 구조를 만듭니다. 하면 다음 데이터를 입력 하려면 데이터 시트 보기로 전환 하거나, 붙여 넣거나 가져오기 등의 다른 방법을 사용 하 여 데이터를 입력 합니다.

  1. 만들기 탭의 그룹에서 표 디자인 을 클릭 합니다. 단추 이미지

  2. 테이블에서 각 필드에 대 한 필드 이름 열에 이름을 입력 하 고 데이터 형식 목록에서 데이터 형식을 선택 합니다.

  3. 원하는 경우 설명 열에서 각 필드에 대 한 설명을 입력할 수 있습니다. 데이터 시트 보기에서 해당 필드에 커서가 있는 경우 상태 표시줄에 대 한 설명을 표시 됩니다. 설명도으로 사용 됩니다 상태 표시줄의 텍스트 폼 이나 보고서의 필드 목록 창에서 필드를 끌어 만들기를에서 모든 컨트롤에 대 한 만든 컨트롤에 대 한 해당 필드에 대 한 폼 마법사 또는 보고서 마법사를 사용 합니다.

  4. 모든 필드를 추가한 후 테이블을 저장 합니다.

    • 파일 탭에서 저장을 클릭합니다.

  5. 데이터 시트 보기로 전환 하 고 첫 번째 빈 셀을 클릭 하 여 언제 든 지는 테이블에 데이터 입력을 시작할 수 있습니다. Access 테이블에 다른 원본에서 데이터를 복사섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수도 있습니다.

디자인 보기에서 필드 속성 설정    표를 만든 방법에 관계 없이 것이 검토 및 필드 속성을 설정 하는 것이 좋습니다. 일부 속성을 데이터 시트 보기에서 사용할 수 있는 몇 가지 속성 디자인 보기에서만 설정할 수 있습니다. 디자인 보기로 전환 하려면 탐색 창에서 테이블을 마우스 오른쪽 단추로 클릭 한 다음 디자인 보기 를 클릭 합니다. 필드 속성을 보려면 디자인 눈금에서 필드를 클릭 합니다. 속성은 디자인 눈금에서 필드 속성 아래에 표시 됩니다.

각 필드 속성에 대 한 설명을 보려면 속성을 클릭 하 고 필드 속성 에서 속성 목록 옆의 상자에서 설명을 읽습니다. 도움말 단추를 클릭 하 여 보다 자세한 정보를 확인할 수 있습니다.

다음 표에서 일반적으로 조정 하는 필드 속성의 일부에 대해 설명 합니다.

속성

설명

필드 크기

텍스트 필드에서이 속성에서 최대 필드에 저장 될 수 있는 문자 수를 설정 합니다. 최대값은 255입니다. 숫자 필드에 대 한이 속성 설정 저장 되는 숫자 형식 (정수 (Long), 이중 등에). 가장 효율적으로 데이터 저장소에 대 한 데이터에 대 한 필요할 판단 되는 공간을 최소한 할당 하는 좋습니다. 값을 조정할 수 변경 해야 할 경우 이후 위쪽으로 합니다.

서식

이 속성의 데이터 표시 되는 방식을 설정 합니다. 필드에 저장 된 실제 데이터가 변경 되지 않습니다. 미리 정의 된 서식을 선택 하거나 사용자 지정 형식을 입력할 수 있습니다.

입력 마스크

이 속성을 사용 하 여이 필드에 입력할 수 있는 모든 데이터에 대 한 패턴을 지정할 수 있습니다. 이렇게 하면 모든 데이터를 올바르게 입력 되어 있고 필요한 개수의 문자가 포함 되어 있는지 확인 합니다. 입력된 마스크를 작성 하는 방법에 대 한 도움말을 작성기 단추 속성 상자의 오른쪽에 있는 클릭 합니다.

기본값

이 속성을 사용 하 여 새 레코드를 추가할 때마다가이 필드에 표시 될 기본 값을 지정 합니다. 예를 들어 있는 항상 기록 하려는 레코드가 추가 되는 날짜를 날짜/시간 필드에 있는 경우의 기본값 (따옴표 제외) "date ()"를 입력할 수 있습니다.

필수

이 속성 값이이 필드에 필요 여부를 설정 합니다. 에이 속성을 설정 하는 경우 Access는이 필드에 대 한 값을 입력 하지 않으면 새 레코드를 추가할 수 없습니다.

맨 위로 이동

Access 테이블에 다른 원본에서 데이터를 복사

데이터를 Excel 등의 다른 프로그램에서 현재 저장 되어 있는 경우 복사 한 Access 테이블에 붙여 넣을 수 있습니다. 일반적으로이 작업은 데이터 열을 분할할 이미 Excel 워크시트에 있는. 데이터가 word 처리 프로그램 경우에 탭을 사용 하 여 데이터의 열을 구분 하는 데 하거나 데이터를 복사 하기 전에 워드 프로세서 프로그램의 테이블로 데이터를 변환 하는 가장 좋습니다. 데이터 편집 또는 조작 (예를 들어 구분 전체 이름 이름과 성으로)을 필요한 경우이 작업을 수행 데이터를 복사 하기 전에 Access에 잘 알고 있다면 하는 경우에 특히 좋습니다.

빈 테이블에 데이터를 붙여 넣으면 Access 데이터의 종류 찾는다는 점을 있는지에 따라 각 필드의 데이터 형식을 설정 합니다. 예를 들어 붙여 넣은 필드 날짜 값만 포함, Access에서 날짜/시간 데이터 적용 해당 필드에 입력 합니다. 붙여 넣은 필드에 단어 "예"와 "없음", Access에서 예를 적용/데이터가 없는 필드에 입력 합니다.

Access 발견 붙여 넣은 데이터의 첫 번째 행에서에 따라 필드의 이름을 지정 합니다. 붙여 넣은 데이터의 첫 번째 행을 따라 행 글꼴로 유사한 경우 첫 번째 행 데이터의 일부 이며 필드 (F1, F2 등)의 일반적인 이름이 할당 액세스 결정 합니다. 붙여 넣은 데이터의 첫 번째 행을 팔 로우 하는 행에 비슷하지 없는 경우 첫 번째 행의 필드 이름으로 구성 되며 액세스 결정 합니다. Access 필드를 적절 하 게 이름을 지정 하 고 첫 번째 행의 데이터에 포함 되어 있지 않습니다.

Access에서 일반적인 필드 이름이 할당을 혼동을 방지 하려면 가능한 한 빨리 필드 바꿔야 합니다. 다음 절차를 따르십시오.

  1. 테이블을 저장 하려면 CTRL + S를 누릅니다.

  2. 데이터 시트 보기에서 각 열 머리글을 두 번 클릭 하 고 각 열에 대 한 설명이 포함 된 필드 이름을 입력 합니다.

  3. 테이블을 다시 저장 합니다.

참고: 디자인 보기로 전환 하 고 필드 이름을 편집 하 여 필드 이름을 변경할 수 있습니다. 디자인 보기로 전환 하려면 탐색 창에서 테이블을 마우스 오른쪽 단추로 클릭 하 고 디자인 보기 를 클릭 합니다. 데이터 시트 보기로 다시 전환 하려면 탐색 창에서 테이블을 두 번 클릭 합니다.

맨 위로 이동

가져오기, 추가 또는 다른 원본에서 데이터에 연결

다른 프로그램에서 저장 된 데이터에 있을 수 있으며 해당 데이터를 새 테이블로 가져오기 또는 Access의 기존 테이블에 추가 하려는 합니다. 또는 다른 프로그램에서 해당 데이터를 유지 하는 사람과 작업할 수와 연결 하 여 Access에서 사용 하 여 작업 하려는 경우 두 가지 방법, Access로 쉽게 다른 원본에서 데이터를 사용 합니다. Excel 워크시트, 다른 Access 데이터베이스에서 테이블, SharePoint 목록 또는 다양 한 다른 원본에서에서 데이터를 가져올 수 있습니다. 사용 하는 프로세스 약간, 원본에 따라 다르지만 다음 절차에 따라 시작할 수 있습니다.

  1. Access에서 외부 데이터 탭의 가져오기 및 연결 그룹에서 가져올 파일 형식에 대 한 명령을 클릭 합니다.

    외부 데이터 탭의 가져오기 및 연결 그룹

    예를 들어 Excel 워크시트에서 데이터를 가져오는 경우 Excel 을 클릭 합니다. 필요한 프로그램 종류 보이지 않으면 자세히 를 클릭 합니다.

    참고: 가져오기 및 연결 그룹에서 올바른 형식을 찾을 수 없는 원래 데이터를 만든 프로그램을 시작 하 고 다음 해당 프로그램을 사용 하 여 수 있는 impor 하기 전에 일반 파일 형식 (예: 분리된 텍스트 파일 )의 데이터를 저장 해야 할 수도 있습니다. t 해당 데이터를 Access로 합니다.

  2. 외부 데이터 가져오기 대화 상자에서 원본 데이터 파일을 찾으려면 찾아보기를 클릭 하거나 파일 이름 상자에 원본 데이터 파일의 전체 경로 입력 합니다.

  3. 원하는 옵션을 클릭 (모든 프로그램을 통해 가져올 수 및 일부를 사용 하면 추가 하거나 연결) 현재 데이터베이스에서 데이터를 저장 하는 방법과 위치 를 지정 합니다. 가져온된 데이터를 사용 하는 새 테이블 만들거나 (일부 프로그램과) 기존 테이블에 데이터를 추가 하거나 데이터 원본 프로그램에 대 한 링크를 유지 하는 연결 된 테이블을 만들 수 있습니다.

  4. 마법사가 시작 되 면 마법사의 다음 몇 페이지의 지침을 따릅니다. 마법사의 마지막 페이지에서 완료 를 클릭 합니다.

    Access 데이터베이스에서 테이블을 연결 하거나 개체를 가져오는 경우 개체 가져오기 또는 연결 테이블 대화 상자가 나타납니다. 선택 하 고 확인 을 클릭 한 다음 항목을 선택 합니다.

    정확한 프로세스, 추가, 가져오거나 데이터 연결 선택 되는지 여부에 따라 다릅니다.

  5. Access 방금 완료 된 가져오기 작업의 세부 정보를 저장 하려는 여부에 대 한 표시 됩니다. 실행 해야 할 것으로 생각 경우 동일한 가져오기 작업을 나중에 다시, 가져오기 단계 저장 을 클릭 한 다음 세부 정보를 입력 합니다. 다음 작업을 나중에 외부 데이터 탭의 가져오기 및 연결 그룹에서 저장 된 데이터 가져오기단추 이미지 를 클릭 하 여 쉽게 반복할 수 있습니다. 작업의 세부 정보를 저장 하지 않으려면 닫기 를 클릭 합니다.

테이블 가져오기 하도록 선택한 경우 Access에서 데이터를 새 테이블에 가져온 한 다음 탐색 창에서 테이블 그룹에서 테이블을 표시 합니다. 기존 테이블에 데이터를 추가 하도록 선택한 경우 해당 테이블에 데이터 추가 됩니다. 데이터에 연결 하도록 선택한 경우 탐색 창에서 테이블 그룹에서 연결 된 테이블이 만들어집니다.

맨 위로 이동

응용 프로그램 요소 추가

기존 데이터베이스에 기능을 추가 하려면 응용 프로그램 요소를 사용할 수 있습니다. 응용 프로그램 요소 단일 테이블 처럼 간단한 항목 일 수도 있고 테이블과 바운드 폼 등의 여러 관련된 개체가 구성 될 수 있습니다.

예를 들어 메모 응용 프로그램 요소 일련 번호 ID 필드, date 필드 및 메모 필드가 있는 테이블의 구성 됩니다. 모든 데이터베이스에 추가 하 고 다른 이름으로 사용 하 여-되었거나 최소한의 사용자 지정 합니다.

  1. 응용 프로그램 요소를 추가 하려면 데이터베이스를 엽니다.

  2. 만들기 탭을 클릭합니다.

  3. 서식 파일 그룹에서 응용 프로그램 요소 를 클릭 합니다. 사용 가능한 부품 목록이 열립니다.

  4. 추가 하려는 응용 프로그램 요소를 클릭 합니다.

맨 위로 이동

기존 Access 데이터베이스 열기

  1. 파일 탭에서 열기를 클릭합니다.

  2. 열기 대화 상자에서 열고자 하는 데이터베이스를 찾습니다.

  3. 다음 중 하나를 수행합니다.

    • 데이터베이스를 Access 옵션 대화 상자 또는 관리 정책에 설정 된 모드에 지정 된 기본 모드에서 열려면 두 번 클릭 합니다.

    • 열기 및 다른 사용자가 읽고 데이터베이스에 쓸 수 있도록 다중 사용자 환경에서 공유 액세스에 대 한 데이터베이스를 열을 클릭 합니다.

    • 열기 단추 옆의 화살표를 클릭 하 고 볼 수 있지만 편집 하지 않도록 읽기 전용 액세스에 대 한 데이터베이스를 읽기 전용으로 열기 클릭 합니다. 여전히 다른 사용자가 읽고 데이터베이스에 쓸 수 있습니다.

    • 열기 단추 옆의 화살표를 클릭 한 다음 단독으로 열기 단독 액세스를 사용 하는 데이터베이스를 열 수를 클릭 합니다. 단독으로 열기 데이터베이스가 있는 다른 사용자가 데이터베이스를 열려고 "파일이 이미 사용 중" 메시지를 받습니다.

    • 열기 단추 옆의 화살표를 클릭 한 다음 읽기 전용 액세스에 대 한 데이터베이스를 단독 읽기 전용으로 열기 클릭 합니다. 다른 사용자가 데이터베이스를 열 수 있지만 읽기 전용 모드로 제한 됩니다.

참고: DBASE, Microsoft Exchange 또는 Excel과 같은 외부 파일 형식으로 데이터 파일을 직접 열 수 있습니다. 모든 ODBC 데이터 원본, Microsoft SQL Server와 같은 직접 열 수 있습니다. 자동으로 새 Access 데이터베이스를 데이터 파일로 같은 폴더에 만들어져 외부 데이터베이스의 각 테이블에 대 한 링크를 추가 합니다.

  • 파일 탭에서 최근에 열었던된 데이터베이스 중 하나를 열려면 최근에 사용한 항목 을 클릭 한 다음 해당 데이터베이스 파일 이름을 클릭 합니다. Access 데이터베이스를 열 때 지난번 있던 동일한 옵션 설정을 사용 하 여 엽니다. 최근에 사용한 파일 목록이 표시 되지 않으면 파일 탭에서 옵션 을 클릭 합니다. Access 옵션 대화 상자에서 클라이언트 설정 을 클릭 합니다. 표시 에서 문서를 50 최대 최근 문서 목록에 표시할 번호를 입력 합니다.

    탐색 모음의 Backstage 보기를 두 번 클릭 하 여 액세스에서 최근에 사용한 데이터베이스를 표시할 수도 있습니다: 1)의 파일 탭, 2) 최근에 사용한 데이터베이스를 열려는 합니다. 최근 탭 아래쪽 빠르게 액세스할이 수 최근에 사용한 데이터베이스의 확인란을 선택 하 고 표시 하는 데이터베이스의 수를 조정 합니다.

  • 파일 탭에서 열기 명령을 클릭 하 여 데이터베이스를 열 경우 열기 대화 상자에서 내 최근 문서 클릭 하 여 이미 열려 있는 데이터베이스에 바로 가기 키 목록을 볼 수 있습니다.

맨 위로 이동

Access 2007을 사용 하 시겠습니까?

Access를 처음 시작할 때 또는 Access를 닫지 않고 데이터베이스를 닫은 경우 Microsoft Office Access 시작 페이지가 표시 됩니다.

Microsoft Office Access 시작 페이지

이 페이지를 열거나 수 있는 새 데이터베이스 만들기, 기존 데이터베이스를 Microsoft Office Online에서 주요 콘텐츠를 볼 시작 지점입니다.

Access에서는 다양 한 속도 데이터베이스 만들기 프로세스를 사용할 수 있는 서식 파일을 제공 합니다. 서식 파일은 모든 테이블, 쿼리, 폼 및 보고서 특정 작업을 수행 하는 데 필요한 포함 하는 즉시 사용 하 여 데이터베이스입니다. 예를 들어 문제를 추적 하거나, 연락처를 관리 하거나 경비의 기록을 유지 하는 데 사용할 수 있는 서식 파일입니다. 일부 서식 파일 사용 방법을 보여 위해 몇 가지 예제 레코드가 포함 합니다. 서식 파일 데이터베이스를 수도 있고 사용자 지정할 수 있습니다에 맞게 사용자의 필요에 따라 사용할 수 있습니다.

필요에 맞는 이러한 서식 파일 중 하나 것은 보통입니다 빠르게 시작 하 여 데이터베이스를 가져올 수 있습니다. 그러나 Access로 가져올 다른 프로그램의 데이터가 있는 경우 서식 파일을 사용 하지 않고 데이터베이스를 만드는 것이 좋습니다 결정할 수 있습니다. 서식 파일에 이미 정의 데이터 구조를 포함 하 고 많은 서식 파일의 구조를 기존 데이터에 맞게 작업이 필요할 수 있습니다.

  1. 데이터베이스를 열고 있는 경우 Microsoft Office 단추 를 클릭 한 다음 Microsoft Office Access 시작 페이지를 표시 하려면 단추 이미지 데이터베이스 닫기를 클릭 합니다.

  2. 몇 가지 주요 서식 파일 Microsoft Office Access 시작 페이지 가운데에 표시 되 고 자세히를 사용할 수 있는 서식 파일 범주 창에서 링크를 클릭 합니다. Office Online 웹 사이트에서 추가 서식 파일을 다운로드할 수 있습니다. 자세한 내용은이 문서의 다음 섹션을 참조 합니다.

  3. 사용 하려는 서식 파일을 클릭 합니다.

  4. Access에서 파일 이름을 파일 이름 상자에 데이터베이스에 대 한 제안 등 원하는 경우 파일 이름을 변경할 수 있습니다. 데이터베이스 파일 이름 상자 아래에 표시 된 것과에서 다른 폴더를 저장 하려면 단추 이미지 , 저장 한 다음 확인 을 클릭 하려는 폴더를 찾습니다. 필요에 따라 만들 수 있으며 SharePoint 사이트에 데이터베이스 연결.

  5. 만들기 (또는 다운로드 Office Online 서식 파일에 대 한)를 클릭 합니다.

    또는 데이터베이스 다운로드 만들어져 다음 열립니다. 양식에는 데이터 입력 시작할 수 있는 표시 됩니다. 서식 파일에 예제 데이터가 있는 경우 (회색으로 표시 된 상자 또는 레코드의 왼쪽에 막대) 레코드 선택기를 클릭 하 고 다음을 수행 하 여 각 레코드를 삭제할 수 있습니다.

    탭의 레코드 그룹에서 삭제 를 클릭 합니다. 단추 이미지

  6. 데이터 입력을 시작 하려면 양식에서 첫 번째 빈 셀에서을 클릭 하 고 입력을 시작 합니다. 탐색 창을 사용 하 여 다른 폼 이나 보고서를 사용 하려는 경우를 찾습니다.

Microsoft Office Access 시작 페이지에서 필요에 맞는 서식 파일을 찾을 수 없는 경우 인터넷에 연결 된 큰 선택 영역에 대 한 Office Online 웹 사이트를 탐색할 수 있습니다.

  1. Microsoft Office Access 시작 페이지에서 Office Online의 기타, 서식 파일 을 클릭 합니다.

    Office Online에서 서식 파일 홈 페이지는 브라우저 창에 표시 됩니다.

  2. Office Online 탐색 및 검색 도구를 사용 하 여 하 고 지침에 따라 다운로드를 구입할 Access 서식 파일을 찾을 수 있습니다. 서식 파일을 다운로드 하면 데이터베이스 파일을 컴퓨터에 다운로드 이며 Access의 새 인스턴스에서 열린 됩니다. 대부분의 서식 파일 바로 데이터 입력을 시작할 수 있도록 데이터 입력 폼을 열고 하도록 설계 되었습니다.

서식 파일 사용에 대 한 자세한 내용은 문서 Access 2007 서식 파일에 대 한 지침을 참고 하세요.

맨 위로 이동

서식 파일을 사용 하 여 원하지 않는 경우 직접 테이블, 폼, 보고서 및 다른 데이터베이스 개체를 작성 하 여 데이터베이스를 만들 수 있습니다. 대부분의 경우에서이 일반적으로에서는 다음 중 하나 이상을 수행 합니다.

  • 입력, 붙여넣기, 또는 새 데이터베이스를 만들 때 만들어진 테이블로 데이터를 가져오는, 만들기 탭의 명령을 사용 하 여 만든 새 테이블을 사용 하 여 프로세스를 반복 합니다.

  • 다른 원본에서 데이터 가져오기 및 프로세스에서 새 테이블 만들기.

  1. Microsoft Office Access 시작 페이지에서 새 데이터베이스새 데이터베이스 를 클릭 합니다.

    새 데이터베이스 단추

  2. 새 데이터베이스 창에서 파일 이름 상자에 파일 이름을 입력 합니다. 파일 이름 확장명을 지정 하지 않으면 경우 Access를 추가 합니다. 기본에서 파일의 위치를 변경 하려면 ( 파일 이름 상자) 옆에 있는 데이터베이스를 저장할 위치 찾아보기 단추 이미지 , 새 위치를 찾아 한 다음 확인 을 클릭 합니다.

  3. 만들기를 클릭합니다.

    표 1 이라는 빈 테이블이 있는 데이터베이스 만들어져 다음 표 1 데이터 시트 보기에서 열립니다. 새 필드 추가 열에서 첫 번째 빈 셀에 커서를 배치 됩니다.

  4. 입력 하 여 데이터를 추가 하거나 Access 테이블에 다른 원본에서 데이터를 복사섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수 있습니다.

데이터 시트 보기에서 정보를 입력 매우 유사 Microsoft Office Excel 2007 워크시트에서 작동 하도록 설계 되었습니다. 표 구조 데이터를 입력 하는 동안 만들어지는-테이블에 새 열을 추가 하면 언제 든 지 새 필드를 정의 합니다. 자동으로 입력 하는 데이터에 따라 각 필드의 데이터 형식을 설정 합니다.

표 1에서 현재 정보를 입력 하려면 단추 이미지 닫기를 클릭 합니다. 테이블을 변경한 경우 테이블에 변경 내용을 저장 하려면 묻는 메시지가 나타납니다. 변경 내용을 저장을 취소 하려면 아니요 클릭 하거나 취소 를 클릭 하는 테이블을 열어 둘 를 클릭 합니다.

중요: 표 1을 한 번 이상 저장 하지 않고 닫은 경우 Access에 데이터를 입력 한 경우에 전체 표를 삭제 합니다.

만들기 탭의 그룹의 명령을 사용 하 여 기존 데이터베이스에 새 테이블을 추가할 수 있습니다.

Access 리본 메뉴 이미지

데이터 시트 보기에서 시작 테이블 만들기    데이터 시트 보기에서 즉시 데이터를 입력 하 고 액세스 하 여 문서의 표 구조를 만들 수 있도록 수 있습니다. (Field1, Field2, 및 등) 필드 이름은 숫자로 지정 되 고 입력 하는 데이터에 따라 각 필드의 데이터 형식이 자동으로 설정 합니다.

  1. 만들기 탭의 그룹에서 를 클릭 합니다. 단추 이미지

    Access 테이블 만들고 새 필드 추가 열에서 첫 번째 빈 셀을 선택 합니다.

    참고: 새 필드 추가 열 보이지 않으면 데이터 시트 보기 대신 디자인 보기에서 수 있습니다. 데이터 시트 보기로 전환 하려면 탐색 창에서 테이블을 두 번 클릭 합니다. Access 새 테이블을 저장 하 라는 메시지를 표시 한 다음 데이터 시트 보기로 전환 합니다.

  2. 데이터 시트 탭의 필드 및 열 그룹에서 새 필드 를 클릭 합니다. 단추 이미지

    자주 사용 되는 필드 형식 목록이 들어 있는 필드 서식 파일 창이 표시 됩니다. 두 번 클릭 하 여 데이터 시트에 이러한 필드 중 하나를 끌어 경우, Access 해당 이름으로 필드를 추가 하 고 필드 형식에 대 한 적절 한 값을 해당 속성을 설정 합니다. 원하는 경우 나중에, 속성을 변경할 수 있습니다. 필드를 끌어 데이터가 포함 된 데이터 시트의 영역 끌어 놓아야 있습니다. 필드를 넣을 보여 주는 세로 삽입 막대가 나타납니다.

  3. 데이터를 추가 하려면 첫 번째 빈 셀에 입력을 시작 하거나 데이터를 Access 테이블에 다른 출처를 복사해섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣습니다.

  4. 열(필드) 이름을 바꾸려면 열 머리글을 두 번 클릭하고 새 이름을 입력합니다.

    필드 목록 창에 표시 되 면 내용 알 수 있도록 각 필드에는 의미 있는 이름을 지정 하는 것이 좋습니다.

  5. 열을 이동 하려면 열을 선택 하 여 머리글을 클릭 한 다음 원하는 위치에 열을 끕니다.

    여러 개의 인접 한 열 선택한 다음 한 번에 새 위치로 끕니다 수도 있습니다. 여러 개의 인접 한 열을 선택 하려면 첫 번째 열의 열 머리글을 클릭 한 다음 shift 키를 누른 채 마지막 열의 열 머리글을 클릭 합니다.

디자인 보기에서 시작 테이블 만들기    디자인 보기에서 먼저 새 테이블의 구조를 만듭니다. 하면 다음 데이터를 입력 하려면 데이터 시트 보기로 전환 하거나, 붙여 넣거나 가져오기 등의 다른 방법을 사용 하 여 데이터를 입력 합니다.

  1. 만들기 탭의 그룹에서 표 디자인 을 클릭 합니다. 단추 이미지

  2. 테이블에서 각 필드에 대 한 필드 이름 열에 이름을 입력 하 고 데이터 형식 목록에서 데이터 형식을 선택 합니다.

    참고: 필드 이름데이터 형식 열 보이지 않으면 디자인 보기 대신 데이터 시트 보기에서 수 있습니다. 디자인 보기로 전환 하려면 탐색 창에서 테이블을 마우스 오른쪽 단추로 클릭 한 다음 디자인 보기 단추 이미지 를 클릭 합니다. Access 새 테이블에 대 한 이름에 대 한 메시지를 표시 한 다음 디자인 보기로 전환 합니다.

  3. 원하는 경우 설명 열에서 각 필드에 대 한 설명을 입력할 수 있습니다. 데이터 시트 보기에서 해당 필드에 커서가 있는 경우 상태 표시줄에 대 한 설명을 표시 됩니다. 설명도으로 사용 됩니다 상태 표시줄의 텍스트 폼 이나 보고서의 필드 목록 창에서 필드를 끌어 만들기를에서 모든 컨트롤에 대 한 만든 컨트롤에 대 한 해당 필드에 대 한 폼 마법사 또는 보고서 마법사를 사용 합니다.

  4. 모든 필드를 추가한 후 테이블을 저장 합니다.

    • Microsoft Office 단추 를 클릭 하 고 저장 을 클릭 하거나 단추 모양 CTRL + S 누릅니다.

  5. 데이터 시트 보기로 전환 하 고 첫 번째 빈 셀을 클릭 하 여 언제 든 지는 테이블에 데이터 입력을 시작할 수 있습니다. Access 테이블에 다른 원본에서 데이터를 복사섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣을 수도 있습니다.

서식 파일을 사용 하 여 테이블 만들기    Access는 테이블의 일반적으로 사용 되는 형식에 대 한 서식 파일을 제공합니다. 단일 마우스 클릭으로 필드가 이미 구성 되어 있는 완전 한 표 구조를 만들 수 있으며 즉시 사용 가능한 키를 누릅니다. 필요한 경우 다음을 추가 하거나 제거할 수 있습니다 필드 테이블 요구 사항에 맞도록 합니다.

  1. 만들기 탭의 그룹에서 표 서식 파일 을 클릭 한 다음 목록에서 사용 가능한 서식 파일 중 하나를 선택 합니다.

  2. 데이터를 추가 하려면 첫 번째 빈 셀에 입력을 시작 하거나 Access 테이블에 다른 원본에서 데이터를 복사섹션에 설명 된 대로 다른 원본에서 데이터를 붙여 넣습니다.

    • 열을 삭제 하려면   

      1. 열 머리글을 마우스 오른쪽 단추로 클릭 한 다음 단추 이미지 열 삭제 클릭 합니다.

    • 새 열을 추가 하려면   

      1. 데이터 시트 탭의 필드 및 열 그룹에서 새 필드 를 클릭 합니다. 단추 이미지

      2. 자주 사용 되는 필드 형식 목록이 들어 있는 필드 서식 파일 창이 표시 됩니다. 두 번 클릭 하 여 데이터 시트에 이러한 필드 중 하나를 끌어 경우, Access 해당 이름으로 필드를 추가 하 고 필드 형식에 대 한 적절 한 값을 해당 속성을 설정 합니다. 원하는 경우 나중에, 속성을 변경할 수 있습니다. 필드를 끌어 데이터가 포함 된 데이터 시트의 영역 끌어 놓아야 있습니다. 필드를 넣을 보여 주는 세로 삽입 막대가 나타납니다.

  3. 테이블을 저장 합니다.

    • Microsoft Office 단추 를 클릭 하 고 저장 을 클릭 하거나 단추 모양 CTRL + S 누릅니다.

디자인 보기에서 필드 속성 설정    표를 만든 방법에 관계 없이 것이 검토 및 필드 속성을 설정 하는 것이 좋습니다. 디자인 보기에서만 수행할 수 있습니다. 디자인 보기로 전환 하려면 탐색 창에서 테이블을 마우스 오른쪽 단추로 클릭 한 다음 디자인 보기 를 클릭 합니다. 필드 속성을 보려면 디자인 눈금에서 필드를 클릭 합니다. 속성은 디자인 눈금에서 필드 속성 아래에 표시 됩니다.

각 필드 속성에 대 한 설명을 보려면 속성을 클릭 하 고 필드 속성 에서 속성 목록 옆의 상자에서 설명을 읽습니다. F1 키를 눌러 보다 자세한 정보를 확인할 수 있습니다.

다음 표에서 일반적으로 조정 하는 필드 속성의 일부에 대해 설명 합니다.

속성

설명

필드 크기

텍스트 필드에서이 속성에서 최대 필드에 저장 될 수 있는 문자 수를 설정 합니다. 최대값은 255입니다. 숫자 필드에 대 한이 속성 설정 저장 되는 숫자 형식 (정수 (Long), 이중 등에). 가장 효율적으로 데이터 저장소에 대 한 데이터에 대 한 필요할 판단 되는 공간을 최소한 할당 하는 좋습니다. 값을 조정할 수 변경 해야 할 경우 이후 위쪽으로 합니다.

서식

이 속성의 데이터 표시 되는 방식을 설정 합니다. 필드에 저장 된 실제 데이터가 변경 되지 않습니다. 미리 정의 된 서식을 선택 하거나 사용자 지정 형식을 입력할 수 있습니다.

입력 마스크

이 속성을 사용 하 여이 필드에 입력할 수 있는 모든 데이터에 대 한 패턴을 지정할 수 있습니다. 이렇게 하면 모든 데이터를 올바르게 입력 되어 있고 필요한 개수의 문자가 포함 되어 있는지 확인 합니다. 입력된 마스크를 작성 하는 방법에 대 한 도움말을 작성기 단추 속성 상자의 오른쪽에 있는 클릭 합니다.

기본값

이 속성을 사용 하 여 새 레코드를 추가할 때마다가이 필드에 표시 될 기본 값을 지정 합니다. 예를 들어 있는 항상 기록 하려는 레코드가 추가 되는 날짜를 날짜/시간 필드에 있는 경우의 기본값 (따옴표 제외) "date ()"를 입력할 수 있습니다.

필수

이 속성 값이이 필드에 필요 여부를 설정 합니다. 에이 속성을 설정 하는 경우 Access는이 필드에 대 한 값을 입력 하지 않으면 새 레코드를 추가할 수 없습니다.

맨 위로 이동

데이터 Office Excel 2007 등의 다른 프로그램에서 현재 저장 되어 있는 경우 복사 한 Access 테이블에 붙여 넣을 수 있습니다. 일반적으로이 작업은 데이터 열을 분할할 이미 Excel 워크시트에 있는. 데이터가 word 처리 프로그램 경우에 탭을 사용 하 여 데이터의 열을 구분 하는 데 하거나 데이터를 복사 하기 전에 워드 프로세서 프로그램의 테이블로 데이터를 변환 하는 가장 좋습니다. 데이터 편집 또는 조작 (예를 들어 구분 전체 이름 이름과 성으로)을 필요한 경우 Access에 잘 알고 있다면 하는 경우에 특히 데이터를 복사 하기 전에 다음을 수행 하는 것이 좋습니다.

빈 테이블에 데이터를 붙여 넣으면 Access 데이터의 종류 찾는다는 점을 있는지에 따라 각 필드의 데이터 형식을 설정 합니다. 예를 들어 붙여 넣은 필드 날짜 값만 포함, Access에서 날짜/시간 데이터 적용 해당 필드에 입력 합니다. 붙여 넣은 필드에 단어 "예"와 "없음", Access에서 예를 적용/데이터가 없는 필드에 입력 합니다.

Access 발견 붙여 넣은 데이터의 첫 번째 행에서에 따라 필드의 이름을 지정 합니다. 붙여 넣은 데이터의 첫 번째 행을 따라 행 글꼴로 유사한 경우 첫 번째 행 데이터의 일부 이며 필드 (F1, F2 등)의 일반적인 이름이 할당 액세스 결정 합니다. 붙여 넣은 데이터의 첫 번째 행을 팔 로우 하는 행에 비슷하지 없는 경우 첫 번째 행의 필드 이름으로 구성 되며 액세스 결정 합니다. Access 필드를 적절 하 게 이름을 지정 하 고 첫 번째 행의 데이터에 포함 되어 있지 않습니다.

Access에서 일반적인 필드 이름이 할당을 혼동을 방지 하려면 가능한 한 빨리 필드 바꿔야 합니다. 다음 절차를 따르십시오.

  1. 테이블을 저장 합니다.

    • Microsoft Office 단추 를 클릭 하 고 저장 을 클릭 하거나 단추 모양 CTRL + S 누릅니다.

  2. 데이터 시트 보기에서 각 열 머리글을 두 번 클릭 한 다음 각 열에 대 한 유효한 필드 이름을 입력 합니다. 이 데이터를 입력 하는 열 머리글 행에 데이터가 아닌 필드 이름이 포함 되어 있지만 처럼 표시 될 수 있습니다.

  3. 테이블을 다시 저장 합니다.

참고: 디자인 보기로 전환 하 고 필드 이름을 편집 하 여 필드 이름을 변경할 수 있습니다. 디자인 보기로 전환 하려면 탐색 창에서 테이블을 마우스 오른쪽 단추로 클릭 하 고 디자인 보기 를 클릭 합니다. 데이터 시트 보기로 다시 전환 하려면 탐색 창에서 테이블을 두 번 클릭 합니다.

맨 위로 이동

다른 프로그램에서 저장 된 데이터를 있을 수 있으며 새 테이블에 해당 데이터를 가져오거나 Access의 기존 테이블에 추가 하려고 합니다. 또는 다른 프로그램에서 해당 데이터를 유지 하는 사람과 작업할 수와 연결 하 여 Access에서 사용 하 여 작업 하려는 경우 두 가지 방법, Access로 쉽게 다른 원본에서 데이터를 사용 합니다. Excel 워크시트, 다른 Access 데이터베이스에서 테이블, SharePoint 목록 또는 다양 한 다른 원본에서에서 데이터를 가져올 수 있습니다. 사용 하는 프로세스 약간, 원본에 따라 다르지만 다음 절차에 따라 시작할 수 있습니다.

  1. Access에서 외부 데이터 탭의 가져오기 그룹에서 가져올 파일 형식에 대 한 명령을 클릭 합니다.

    Access 리본 메뉴 이미지

    예를 들어 Excel 워크시트에서 데이터를 가져오는 경우 Excel 을 클릭 합니다. 필요한 프로그램 종류 보이지 않으면 자세히 를 클릭 합니다.

    참고: 원래 데이터를 만든 프로그램을 시작 하 고 다음 해당 프로그램을 사용 하 여 일반적인 파일에 데이터를 저장 해야 할 수 가져오기 그룹에서 올바른 형식을 찾을 수 없는 경우 해당 데이터를 가져올 수 있습니다 (예: 분리된 텍스트 파일 ) 서식 지정 에 액세스 합니다.

  2. 외부 데이터 가져오기 대화 상자에서 원본 데이터 파일을 찾으려면 찾아보기를 클릭 하거나 파일 이름 상자에 원본 데이터 파일의 전체 경로 입력 합니다.

  3. 원하는 옵션을 클릭 (모든 프로그램을 가져올 수 있도록 및 추가 하거나 연결 수 있도록 일부) 현재 데이터베이스에서 데이터를 저장 하는 방법과 위치 를 지정 합니다. 가져온된 데이터를 사용 하는 새 테이블 만들거나 (일부 프로그램과) 기존 테이블에 데이터를 추가 하거나 데이터 원본 프로그램에 대 한 링크를 유지 하는 연결 된 테이블을 만들 수 있습니다.

  4. 마법사가 시작 되 면 마법사의 다음 몇 페이지의 지침을 따릅니다. 마법사의 마지막 페이지에서 완료 를 클릭 합니다.

    Access 데이터베이스에서 테이블을 연결 하거나 개체를 가져오는 경우 개체 가져오기 또는 연결 테이블 대화 상자가 나타납니다. 선택 하 고 확인 을 클릭 하는 항목을 선택 합니다.

    정확한 프로세스, 추가, 가져오거나 데이터 연결 선택 되는지 여부에 따라 다릅니다.

  5. Access 방금 완료 된 가져오기 작업의 세부 정보를 저장 하려는 여부에 대 한 표시 됩니다. 실행 해야 할 것으로 생각 경우 동일한 가져오기 작업을 나중에 다시, 가져오기 단계 저장 을 클릭 한 다음 세부 정보를 입력 합니다. 다음 외부 데이터 탭의 가져오기 그룹에서 저장 된 데이터 가져오기단추 이미지 를 클릭 하 여 나중에 작업을 쉽게 반복할 수 있습니다. 작업의 세부 정보를 저장 하지 않으려면 닫기 를 클릭 합니다.

테이블 가져오기 하도록 선택한 경우 Access에서 데이터를 새 테이블에 가져온 한 다음 탐색 창에서 테이블 그룹에서 테이블을 표시 합니다. 기존 테이블에 데이터를 추가 하도록 선택한 경우 해당 테이블에 데이터 추가 됩니다. 데이터에 연결 하도록 선택한 경우 탐색 창에서 테이블 그룹에서 연결 된 테이블이 만들어집니다.

맨 위로 이동

  1. Microsoft Office 단추를 클릭하고 열기를 클릭합니다.

  2. 열기 대화 상자에서 열고자 하는 데이터베이스를 찾습니다.

  3. 다음 중 하나를 수행합니다.

    • 데이터베이스를 Access 옵션 대화 상자 또는 관리 정책에 설정 된 모드에 지정 된 기본 모드에서 열려면 두 번 클릭 합니다.

    • 열기 및 다른 사용자가 읽고 데이터베이스에 쓸 수 있도록 다중 사용자 환경에서 공유 액세스에 대 한 데이터베이스를 클릭 합니다.

    • 열기 단추 옆의 화살표를 클릭 하 고 볼 수 있지만 편집 하지 않도록 읽기 전용 액세스에 대 한 데이터베이스를 읽기 전용으로 열기 클릭 합니다. 여전히 다른 사용자가 읽고 데이터베이스에 쓸 수 있습니다.

    • 열기 단추 옆의 화살표를 클릭 한 다음 단독으로 열기 단독으로 데이터베이스를 열 수를 클릭 합니다. 단독으로 열기 데이터베이스가 있는 다른 사용자가 데이터베이스를 열려고 "파일이 이미 사용 중" 메시지를 받습니다.

    • 열기 단추 옆의 화살표를 클릭 한 다음 읽기 전용 액세스에 대 한 데이터베이스를 단독 읽기 전용으로 열기 클릭 합니다. 다른 사용자가 데이터베이스를 열 수 있지만 읽기 전용 모드로 제한 됩니다.

열려는 데이터베이스를 찾을 수 없는 경우   

  1. 열기 대화 상자에서 내 컴퓨터 를 클릭 하거나 찾는 위치 드롭다운 목록에서 내 컴퓨터 를 클릭 합니다.

  2. 드라이브 목록을 생각 하 고 드라이브를 마우스 오른쪽 단추로 데이터베이스를 포함 하 고 검색 을 클릭 될 수 있습니다.

  3. 검색 결과 대화 상자에 검색 조건을 입력 한 다음 데이터베이스에 대 한 검색 하려면 검색 클릭 합니다.

  4. 데이터베이스를 발견 하는 경우 열을 두 번 클릭 합니다.

  5. 열려는 데이터베이스에 대 한 열기 대화 상자에서 취소 를 클릭 해야 합니다. 그런 다음 검색 결과 대화 상자를 닫습니다.

참고: DBASE, Paradox, Microsoft Exchange 또는 Excel과 같은 외부 파일 형식으로 데이터 파일을 직접 열 수 있습니다. 모든 ODBC 데이터 원본, Microsoft SQL Server 또는 Microsoft FoxPro 같은 직접 열 수 있습니다. 자동으로 새 Access 데이터베이스를 데이터 파일로 같은 폴더에 만들어져 외부 데이터베이스의 각 테이블에 대 한 링크를 추가 합니다.

  • 가장 최근에 열었던된 데이터베이스 중 하나를 열려면 Microsoft Office Access 시작 페이지에서 최근에 사용한 데이터베이스 열기 목록에서 해당 데이터베이스에 대 한 파일 이름을 클릭 합니다. Access 데이터베이스를 열 때 지난번 있던 동일한 옵션 설정을 사용 하 여 엽니다. 최근에 사용한 파일 목록이 표시 되어 있지 않으면 Microsoft Office 단추 를 클릭 한 다음 Access 옵션 을 클릭 합니다. Access 옵션 대화 상자에서 고급 을 클릭 합니다. 표시 에서 문서를 최대 9까지 최근 문서 목록에 표시할 번호를 입력 합니다.

  • Microsoft Office 단추 를 클릭 하 고 열기 명령을 사용 하 여 데이터베이스를 열 경우 내 최근 문서열기 를 클릭 하 여 이미 열려 있는 데이터베이스에 바로 가기 키 목록을 볼 수 있습니다. 대화 상자입니다.

맨 위로 이동

새 데이터베이스를 만들 때 데이터를 입력할 수 있지만 데이터베이스의 다른 개체를 만들고 새 테이블이 열립니다. 만드는 모든 새 데이터베이스에서 폼, 보고서, 매크로 또는 추가 테이블 프레젠테이션와 같은 다른 개체를 원하는 경우 해당 개체가 포함 된 빈 사용자 지정 서식 파일을 만들 수 있습니다. 그런 다음 다음 새 데이터베이스를 만들 때 이미 개체를 포함 합니다 해당 서식 파일에 있습니다. 이러한 개체가 외에도 서식 파일 테이블 데이터를 뿐만 아니라 모든 특수 구성 설정, 데이터베이스 속성, 참조 또는 코드에 해당 모든 새 데이터베이스에 있는 미리 채워져를 포함할 수 있습니다.

예를 들어 있는 모든 프로젝트에 사용 하려는 매크로의 모음입니다. 이러한 매크로가 포함 된 빈 서식 파일을 만드는 경우 액세스 만드는 모든 새 데이터베이스에 포함 됩니다.

Office Access 2007 파일 형식, Access 2002-2003 파일 형식 또는 Access 2000 파일 형식에서 빈 서식 파일을 만들 수 있습니다. 서식 파일 이름을 지정 해야 Blank.accdb Office Access 2007 파일 형식과 Blank.mdb에 대 한 이전 파일 형식입니다.

  • 기본 파일 형식을 Access 2000 또는 Access 2002-2003에서는 설정 되어 있는 경우 Blank.mdb 빈 서식 파일 이름으로 사용 됩니다. 새 데이터베이스에서 같은 파일 형식 Blank.mdb으로 만들어집니다. 예를 들어 기본 파일 형식을 Access 2000 이면 Blank.mdb 명명 된 서식 파일을 Access 2002-2003 파일 형식에서, 경우에 만드는 모든 새 데이터베이스 Access 2002-2003 형식으로 됩니다.

  • 기본 파일 형식을 Access 2007로 설정 되 면 Blank.accdb 빈 서식 파일에 대 한 파일 이름이 사용 됩니다.

기본 파일 형식을 변경 하려면 어떻게 해야 하나요?

  1. Microsoft Office 단추를 클릭한 다음 Access 옵션을 클릭합니다.

  2. Access 옵션 대화 상자에서 개인 설정을 클릭 합니다.

  3. 데이터베이스 만들기 기본 파일 형식 드롭다운 목록에서 원하는 서식을 선택 합니다.

빈 서식 파일을 만들려면 다음 중 하나를 실행 합니다.

  • (비어 있음 이름을 지정 하거나 수 임시 이름을) 새 데이터베이스를 만든 후 가져오거나 서식 파일에 포함 하려는 개체를 만듭니다.

  • 서식 파일에서 원하는 개체를 이미 포함 되어 있는 기존 데이터베이스 복사본 하 고 하지 않으려면 모든 개체를 삭제 합니다.

서식 파일에서 원하는 개체를 만든 후 특정 위치에 저장 해야 합니다.

  1. Microsoft Office 단추 를 클릭 한 다음 다른 이름으로 저장 을 가리킵니다.

  2. 다른 형식으로 데이터베이스 저장 에서 서식 파일에 사용할 파일 형식을 클릭 합니다.

  3. 다른 이름으로 저장 대화 상자에서 다음 두 가지 서식 파일 폴더 중 하나를 찾습니다.

    • 시스템 서식 파일 폴더    예를 들어 C:\Program Files\Microsoft Office\Templates\1033\Access

    • 사용자 서식 파일 폴더    예를 들어:

      • C:\Users\user name\AppData\Roaming\Microsoft\Templates Windows Vista 에서   

      • Microsoft Windows XP 또는 Microsoft Windows Server 2003에서    C:\Documents and Settings\user name\Application Data\Microsoft\Templates

        참고: 빈 서식 파일 시스템 서식 파일 폴더에 있는 사용자 서식 파일 폴더에 있는 빈 서식 파일에서 무시 됩니다.

  4. 파일 이름 상자에 Blank.accdb (또는 Blank.mdb이전 버전 서식 파일을 만드는 경우)를 입력 한 다음 저장 을 클릭 합니다.

새 서식 파일 설정 되 고 새 데이터베이스를 만들 때, 했으므로 서식 파일의 개체 기본적으로 만든 모든 새 데이터베이스에 포함 됩니다. Access 서식 파일을 사용 하지 않고 빈 새 데이터베이스를 만들 때와 마찬가지로 데이터 시트 보기에서 새 테이블을 엽니다.

빈 서식 파일 사용을 중지 하려면 삭제 또는 명명 된 Blank.accdb (또는 이전 버전의 Access에 대 한 Blank.mdb) 파일의 이름을 바꿉니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×