복제된 데이터베이스를 Access 2007 형식으로 저장할 수 없음

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

증상

복제 된 이전 버전의 Access에서 만든 데이터베이스에서 Microsoft Office Access 2007 (합니다. MDB 형식)의 새 저장할 수 없습니다. ACCDB 파일 형식입니다. 옵션이 흐리게 (사용할 수 없음) 으로 데이터베이스 저장 명령을 사용 하 려 할 때 ( Office 단추 이미지 Microsoft Office 단추 클릭 한 다음 다른 이름으로 저장 옆의 화살표를 클릭).

원인

.ACCDB 파일 형식은 복제를 지원하지 않습니다.

해결 방법

복제된 데이터베이스를 .MDB 파일 형식으로 사용

복제된 데이터베이스를 계속 .MDB 파일 형식으로 사용할 수 있습니다. .MDB 파일 형식에 대해서는 복제 기능이 계속 지원됩니다.

Office Access 2007 파일 형식으로 데이터베이스를 수동으로 다시 만들기

새 파일 형식을 사용하는 것이 복제 데이터베이스를 사용하는 것보다 더 효과적이라고 생각되면 Office Access 2007 형식으로 데이터베이스를 새로 만들어 복제된 데이터베이스를 수동으로 다시 만들 수 있습니다.

참고: 이 방법은 모든 복제 데이터베이스에 대해 사용할 수 있지만, 복제 데이터베이스 집합에 있는 다른 모든 복제 데이터베이스와 동기화된 전체 복제 데이터베이스를 사용하는 경우가 아니면 복제 데이터베이스 내에 들어 있지 않은 데이터 및 프로젝트는 새 데이터베이스에 포함되지 않습니다.

데이터베이스를 다시 만들려면 먼저 복제 데이터베이스에서 숨겨진 개체와 시스템 개체가 모두 표시되는지 확인해야 합니다. 이렇게 해야 데이터베이스를 다시 만들 때 복제 데이터베이스의 복제 관련 필드에 액세스할 수 있습니다.

  1. 변환할 복제 데이터베이스를 엽니다. 숨겨진 필드와 시스템 필드를 표시하려면 복제 데이터베이스를 만들 때 사용한 원래 Access와 동일한 버전을 사용하여 복제 데이터베이스를 열어야 합니다.

  2. 도구 메뉴에서 옵션을 클릭합니다. 옵션 대화 상자가 열립니다.

  3. 화면 표시 탭의 표시 구역에서 숨겨진 개체시스템 개체를 선택합니다. 확인을 클릭하여 새 설정을 적용하고 옵션 대화 상자를 닫습니다.

수동으로 데이터베이스 다시 만들기

  1. 빈 데이터베이스를 만들어 엽니다.

    참고: Table1이라는 비어 있는 새 테이블이 만들어지는데 이 테이블은 삭제해야 합니다. 테이블을 아무 것도 변경하지 않고 즉시 닫으면 테이블이 삭제됩니다. 해당 개체 탭을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 닫기를 클릭합니다. 

  2. 외부 데이터 탭에 있는 가져오기 그룹에서 Access를 클릭합니다.

    외부 데이터 가져오기 - Access 데이터베이스 대화 상자가 나타납니다.

  3. 찾아보기를 클릭하여 복제 데이터베이스를 찾습니다.

  4. 새 데이터베이스로 다시 만들려는 데이터베이스 개체가 들어 있는 복제된 데이터베이스를 클릭하고 열기를 클릭합니다.

  5. 외부 데이터 가져오기 - Access 데이터베이스 대화 상자에서 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스로 가져옵니다.를 클릭하고 확인을 클릭합니다.

  6. 새 데이터베이스로 가져오려는 데이터베이스 개체를 클릭합니다. 모든 개체를 가져오려는 경우에는 각 탭에서 모두 선택을 클릭합니다.

    중요    이 단계에서는 테이블을 선택하지 마십시오. 이후 단계에서 테이블을 다시 만듭니다.

  7. 개체 선택을 마친 후에 확인을 클릭하여 해당 개체를 가져옵니다.

    필요한 경우 마법사의 마지막 페이지에서 나중에 사용할 수 있도록 가져오기 단계를 저장할 수 있습니다. 이렇게 하려면 가져오기 단계 저장 확인란을 선택하고 적절한 정보를 입력한 다음 가져오기 저장을 클릭합니다.

  8. Office Access 2007에서 복제 데이터베이스를 엽니다. 그런 다음 복제 데이터베이스의 각 테이블에 대해 테이블 만들기 쿼리를 만듭니다. 테이블 만들기 쿼리는 이전 테이블의 모든 데이터를 가져와 해당 데이터로 새 데이터베이스에 테이블을 만듭니다.

    참고: s_GUID가 기본 키이고 다른 테이블의 외래 키가 s_GUID를 참조하는 경우에는 새 테이블에 s_GUID 필드를 포함해야 합니다. s_GUID 필드가 기본 키로 사용되지 않는 경우에는 새 테이블에 보관하지 않아도 됩니다. s_Lineage 및 s_Generation 필드는 새 테이블에 복사하지 마십시오.

    기본적으로 s_GUID, s_Lineage 및 s_Generation 필드는 숨겨져 있습니다. 이러한 필드를 표시하려면 다음 절차를 따릅니다.

    1. 복제 데이터베이스에서 모든 테이블이 닫혀 있는지 확인합니다.

    2. 탐색 창의 맨 위를 마우스 오른쪽 단추로 클릭하고 탐색 옵션을 클릭합니다. 탐색 옵션 대화 상자가 열립니다.

    3. 표시 옵션 구역에서 시스템 개체 표시를 선택하고 확인을 클릭합니다.

      실행 방법

      1. 새 테이블에 포함할 레코드가 들어 있는 테이블을 선택하여 쿼리를 만듭니다.

        실행 방법

        1. 만들기 탭의 기타 그룹에서 쿼리 디자인을 클릭합니다.

        2. 테이블 표시 대화 상자에서 사용할 데이터가 들어 있는 테이블이 나열되어 있는 탭을 클릭합니다.

        3. 쿼리에 추가하려는 각 개체의 이름을 두 번 클릭하고 닫기를 클릭합니다.

        4. 디자인 눈금의 필드 행에 필드를 추가합니다.

        5. 쿼리 결과를 보려면 보기 메뉴를 클릭하고 데이터시트 보기를 클릭합니다.

      2. 쿼리 디자인 보기의 디자인 탭에 있는 쿼리 유형 그룹에서 테이블 만들기를 클릭합니다. 테이블 만들기 대화 상자가 나타납니다.

      3. 테이블 이름 상자에서 만들거나 복제하려는 테이블의 이름을 입력합니다.

      4. 다른 데이터베이스를 클릭한 다음 새 테이블을 배치하려는 데이터베이스 경로를 입력하거나 찾아보기를 클릭하여 데이터베이스를 찾습니다.

      5. 확인을 클릭합니다.

      6. 디자인 탭의 결과 그룹에서 실행 을 클릭 합니다. 새 테이블을 만듭니다.

        참고: 이때 만들어지는 새 테이블은 원본 테이블의 필드 속성 또는 기본 키 설정을 상속받지 않습니다.

  9. 새 데이터베이스의 각 테이블에 대해 복제 데이터베이스의 테이블에 사용된 것과 같은 색인 및 기본 키를 만듭니다.

    실행 방법

    1. 디자인 보기에서 테이블을 엽니다.

    2. 창 위쪽에서 색인를 만들려는 필드를 클릭합니다.

    3. 창 아래쪽에서 인덱스/Indexed 속성 상자를 클릭한 다음 예(중복 가능)/Yes (Duplicates OK) 또는 예(중복 불가능)/Yes (No Duplicates)를 클릭합니다.

    4. 기본 키를 구성할 필드를 하나 이상 선택합니다.

    5. 디자인 탭의 도구 그룹에서 기본 키를 클릭합니다.

  10. 새 데이터베이스의 각 테이블에 대해 복제 데이터베이스의 테이블에 적용되었던 것과 같은 관계를 만듭니다.

    실행 방법

    테이블 간의 관계를 만들 때 관련된 필드 이름이 같이 필요가 없습니다. 그러나 관련된 필드 기본 키 필드 일련 번호 필드는 경우가 아니면 동일한 데이터 형식 있어야 합니다. 숫자 필드와 일련 번호 필드 일치 필드의 두 가지 모두의 비해 속성이 같은 경우에 연결할 수 있습니다. 예를 들어 두 필드의 비해 속성이 정수 (Long)가 일련 번호 필드와 숫자 필드를 서로 맞출 수 있습니다. 일치 하는 필드가 둘 다 숫자 필드, 경우에 속성 설정에는 동일한 비해 있어야 합니다.

    1-다 정의 또는 일대일 관계

    1. 열려 있는 테이블을 모두 닫습니다. 열린 테이블 간에는 관계를 만들거나 관계를 수정할 수 없습니다.

    2. 데이터베이스 도구 탭의 표시/숨기기 그룹에서 관계를 클릭합니다.

    3. 아직 데이터베이스에 관계를 정의하지 않은 경우 테이블 표시 대화 상자가 자동으로 표시됩니다.

      관계를 만들려는 테이블을 추가해야 하는 경우 테이블 표시 대화 상자가 표시되지 않으면 디자인 탭의 표시/숨기기 그룹에서 테이블 표시 단추를 클릭하여 대화 상자를 실행합니다.

    4. 관계를 만들 테이블의 이름을 두 번 클릭한 다음 테이블 표시 대화 상자를 닫습니다. 테이블 자신에 대한 관계를 만들려면 해당 테이블을 두 번 추가합니다.

    5. 테이블에서 관계를 만들려는 필드를 끌어 다른 테이블의 관련된 필드에 놓습니다.

      여러 필드를 끌어서 놓으려면 Ctrl 키를 누른 상태로 각 필드를 클릭한 다음 끌면 됩니다.

      대부분의 경우에는 테이블에서 굵은 텍스트로 표시되는 기본 키 필드를 다른 테이블에 있는 외래 키라는 유사한 필드(보통 이름이 같음)로 끌어서 놓습니다.

    6. 관계 편집 대화 상자가 표시됩니다. 두 열에 표시되는 필드 이름이 올바른지 확인하십시오. 필요한 경우 필드 이름을 수정할 수 있습니다.

      필요한 경우 관계 옵션을 설정합니다.

    7. 만들기 단추를 클릭하여 관계를 만듭니다.

    8. 관계를 만들려는 각 테이블 쌍에 대해 4-7단계를 반복합니다.

      관계 창을 닫으면 레이아웃을 저장할 것인지 묻는 메시지가 표시됩니다. 레이아웃 저장 여부에 관계없이 만든 관계는 데이터베이스에 저장됩니다.

    다대다 관계 정의

    1. 다대다 관계를 적용할 두 테이블을 만듭니다.

    2. 정션 테이블이라고 하는 세 번째 테이블을 만들고, 다른 두 테이블의 기본 키 필드와 정의가 같은 새 필드를 정션 테이블에 추가합니다. 정션 테이블에서 기본 키 필드는 외래 키 역할을 합니다. 다른 테이블에서와 마찬가지로 정션 테이블에도 다른 필드를 추가할 수 있습니다.

    3. 정션 테이블에서 기본 키에 다른 두 테이블의 기본 키 필드가 포함되도록 설정합니다. 예를 들어 Order Details 정션 테이블의 기본 키는 OrderID 및 ProductID 필드로 구성될 수 있습니다.

      실행 방법

      1. 디자인 보기에서 테이블을 엽니다.

      2. 기본 키로 정의하려는 하나 이상의 필드를 선택합니다.

        하나의 필드를 선택하려면 원하는 필드의 행 선택기를 클릭합니다.

        여러 필드를 선택하려면 Ctrl 키를 누른 상태로 각 필드의 행 선택기를 클릭합니다.

      3. 디자인 탭의 도구 그룹에서 기본 키를 클릭합니다.

        참고: 다중 필드 기본 키에 있는 필드의 순서를 테이블에 있는 필드의 순서와 다르게 지정하려면 표시/숨기기 그룹의 인덱스 단추를 클릭하여 색인 창을 표시한 다음 이름이 PrimaryKey인 색인의 필드 이름 순서를 다시 지정합니다.

    4. 각각의 두 가지 기본 테이블 및 접합 테이블 간에 일대다 관계 를 정의 합니다.

  11. 새 데이터베이스를 저장합니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×