보기 전환을 위한 단추 추가

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Microsoft Office InfoPath에서 동일한 양식 서식 파일의 여러 가지 뷰를 만들 수 있습니다. 뷰는 양식 서식 파일에서 데이터를 표시 하는 다른 방법입니다. 양식 서식 파일에 기초한 양식 채우기, 사용자가 폼에 표시 되는 데이터의 양을 선택 하도록 뷰 간에 전환할 수 있습니다. 예를 들어 상태 보고서 양식 서식 파일에 대 한 상세 보기 외에도 요약 보기를 디자인할 수 있습니다. 그런 다음 필요한 정보에는 어떤 종류에 따라 살펴 보기가 선택할 수 있습니다.

뷰 자주 규칙을 사용 하도록 설계 합니다. 규칙을 사용 하 여 이벤트 나 양식을 작성 하는 사용자가 주도하는 작업에 대 한 응답에서 양식 서식 파일의 특정 작업을 자동화할 수 있습니다. 예를 들어이 문서에서는 단추는 양식 서식 파일에 삽입 하 여 다음 해당 단추를 클릭할 때 보기를 전환 하는 규칙을 만들어야 하는 방법에 대해 설명 합니다.

이 문서의 내용

1 단계: 각 보기에서 단추 삽입

2 단계: 보기를 전환 하는 규칙 만들기

3 단계: 테스트 사용자 환경

1 단계: 각 보기에서 단추 삽입

참고: 다음 절차를 완료 하려면 두 가지 기존 뷰가 포함 된 양식 서식 파일이 있어야 합니다. 참고 항목 섹션에서 보기를 만드는 방법에 대 한 자세한 내용은에 대 한 링크를 찾습니다.

  1. 보기 메뉴에서 보기 관리 를 클릭 합니다.

  2. 보기를 선택 하세요 아래에서 단추를 추가 하려면 원하는 보기를 클릭 합니다.

  3. 양식 서식 파일에 있는 단추를 삽입 하려면 커서를 놓습니다.

  4. 삽입 메뉴에서 기타 컨트롤 을 클릭 하거나 눌러 ALT + I, C.

  5. 컨트롤 삽입 에서 컨트롤 작업창에서 단추 를 클릭 합니다.

  6. 양식 서식 파일에 삽입 단추를 두 번 클릭 합니다.

  7. 일반 탭을 클릭합니다.

  8. 레이블 상자에서 단추를 표시할 텍스트를 입력 한 다음 확인 을 클릭 합니다.

  9. 보기 메뉴에서 보기 관리 를 클릭 합니다.

  10. 보기를 선택 하세요 아래에서 두 번째 보기의 이름을 클릭 합니다.

  11. 3-두 번째 보기 단추를 추가 하려면 8 단계를 따릅니다.

맨 위로 이동

2 단계: 보기를 전환 하는 규칙 만들기

단추 각 보기에 양식 서식 파일에서을 추가한 후 사용자가 해당 단추를 클릭할 때 보기를 전환 하는 규칙을 만들어 해야 합니다.

  1. 보기 메뉴에서 보기 관리 를 클릭 합니다.

  2. 보기를 선택 하세요 아래에서 작업에 사용할 보기를 클릭 합니다.

  3. 양식 서식 파일에서 이전 절차의 삽입 단추를 두 번 클릭 합니다.

  4. 일반 탭을 클릭합니다.

  5. 작업 목록에서 규칙 및 사용자 지정 코드를 클릭 합니다.

  6. 규칙 을 클릭 합니다.

  7. 규칙 대화 상자에서 추가 클릭 합니다.

  8. 이름 상자에 보기 2 스위치와 같은 규칙의 이름을 입력 합니다. 디자인 모드에서 뷰를 사용할 때이 이름이 표시 됩니다. 그러나 이름의 양식을 작성 사람이 볼 수 없습니다.

  9. 작업 추가 클릭 합니다.

  10. 작업 목록에서 보기 전환을 클릭 합니다.

  11. 보기 목록에서 전환 하려는 보기를 클릭 한 다음 확인 을 클릭 합니다.

  12. 열기 대화 상자가 모두 닫힐 때까지 확인 클릭 합니다.

  13. 보기 작업창의 보기 선택 아래에서 두 번째 보기를 클릭 합니다.

  14. 두 번째 보기에 있는 단추에 대 한 규칙을 만들려면 12-3 단계를 수행 합니다.

맨 위로 이동

3 단계: 테스트 사용자 환경

보기에 단추를 추가 하면 필요한 규칙을 만든 후 것이 예상 대로 작동 하는지 확인 하 여 양식 서식 파일을 테스트 하는 것이 좋습니다.

  1. 변경 내용을 테스트하려면 표준 도구 모음에서 미리 보기를 클릭하거나 Ctrl+Shift+B를 누릅니다.

    참고: 보기에서에서 작업 하는 가장 최근에 미리 보기 창에 표시 될 보기가입니다.

  2. 보기를 전환 하기 위한 단추가 제대로 작동 하는지를 테스트 하려면 이전 절차의 작성 단추를 클릭 합니다.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×