매크로 만들기 또는 실행

Word에서 매크로를 만들고 실행하여 자주 사용하는 작업을 자동화할 수 있습니다. 매크로는 자동으로 작업을 수행하기 위해 하나의 명령으로 그룹화하는 일련의 명령과 지침입니다.

반복되는 작업에서 시간을 아끼려면 단계를 한 매크로로 묶습니다. 먼저 매크로를 기록합니다. 그런 다음 빠른 실행 도구 모음의 단추를 클릭하거나 키 조합을 눌러 매크로를 실행할 수 있습니다. 이는 설정 방식에 따라 달라집니다.

  1. 보기 > 매크로 > 매크로 기록을 클릭합니다.

    매크로 기록 명령

  2. 매크로의 이름을 입력합니다.

    매크로 이름 상자

  3. 새로 만드는 모든 문서에서 이 매크로를 사용하려면 매크로 저장 위치 상자에 모든 문서(Normal.dotm)가 표시되어 있어야 합니다.

    매크로를 저장할 위치를 선택하는 상자

  4. 단추를 클릭해 매크로를 실행하려면 단추를 클릭합니다.

    클릭하여 단추에 매크로를 할당

  5. 새 매크로(Normal.NewMacros.<매크로 이름>과 같은 형식의 이름이 지정됨)를 클릭하고 추가를 클릭합니다.

    매크로 및 추가 단추

  6. 수정을 클릭합니다.

    빠른 실행 도구 모음 사용자 지정 상자의 수정 단추

  7. 단추 모양을 선택하고 원하는 이름을 입력한 후 확인을 두 번 클릭합니다.

    단추 수정 상자의 단추 옵션

  8. 이번에는 단계를 기록할 차례입니다. 명령을 클릭하거나 작업의 각 단계에 해당하는 키를 누릅니다. 클릭 및 입력한 키가 기록됩니다.

    참고: 매크로를 기록하는 동안 키보드를 사용하여 텍스트를 선택합니다. 매크로는 마우스로 선택한 항목은 기록하지 않습니다.

  9. 기록을 중지하려면 보기 > 매크로 > 기록 중지를 클릭합니다.

    기록 중지 명령

매크로에 해당하는 단추가 빠른 실행 도구 모음에 나타납니다.

빠른 실행 도구 모음의 매크로 단추

매크로를 실행하려면 해당 단추를 클릭합니다.

  1. 보기 > 매크로 > 매크로 기록을 클릭합니다.

    매크로 기록 명령

  2. 매크로의 이름을 입력합니다.

    매크로 이름 상자

  3. 새로 만드는 모든 문서에서 이 매크로를 사용하려면 매크로 저장 위치 상자에 모든 문서(Normal.dotm)가 표시되어 있어야 합니다.

    매크로를 저장할 위치를 선택하는 상자

  4. 바로 가기 키를 눌러 매크로를 실행하려면 키보드를 클릭합니다.

    클릭하여 단추에 바로 가기 키를 할당

  5. 새 바로 가기 키 상자에 키 조합을 입력합니다.

  6. 해당 조합이 이미 다른 용도로 지정되어 있지 않은지 확인합니다. 지정되어 있다면 다른 조합을 시도합니다.

  7. 새로 만드는 모든 문서에서 이 바로 가기 키를 사용하려면 저장할 파일 상자에 Normal.dotm이 표시되어 있어야 합니다.

  8. 지정을 클릭합니다.

  9. 이번에는 단계를 기록할 차례입니다. 명령을 클릭하거나 작업의 각 단계에 해당하는 키를 누릅니다. 클릭 및 입력한 키가 기록됩니다.

    참고: 매크로를 기록하는 동안 키보드를 사용하여 텍스트를 선택합니다. 매크로는 마우스로 선택한 항목은 기록하지 않습니다.

  10. 기록을 중지하려면 보기 > 매크로 > 기록 중지를 클릭합니다.

    기록 중지 명령

매크로를 실행하려면 바로 가기 키를 누릅니다.

매크로를 실행하려면 빠른 실행 도구 모음에서 단추를 클릭하거나 바로 가기 키를 누릅니다. 또는 매크로 목록에서 매크로를 실행할 수도 있습니다.

  1. 보기 > 매크로 > 매크로 보기를 클릭합니다.

    매크로 보기 명령

  2. 매크로 이름 아래의 목록에서 실행할 매크로를 클릭합니다.

  3. 실행을 클릭합니다.

특정 문서의 매크로를 새로운 모든 문서에서 사용할 수 있도록 하려면 Normal.dotm 서식 파일에 추가합니다.

  1. 매크로가 포함된 문서를 엽니다.

  2. 보기 > 매크로 > 매크로 보기를 클릭합니다.

    매크로 보기 명령

  3. 구성 도우미를 클릭합니다.

    매크로 보기 상자의 구성 도우미 단추

  4. Normal.dotm 서식 파일에 추가할 매크로를 클릭하고 복사를 클릭합니다.

  1. 파일 > 옵션 > 리본 사용자 지정을 클릭합니다.

  2. 다음에서 명령 선택에서 매크로를 클릭합니다.

  3. 원하는 매크로를 클릭합니다.

  4. 리본 메뉴 사용자 지정에서 매크로에 추가할 탭과 사용자 지정 그룹을 클릭합니다.

사용자 지정 그룹이 없는 경우 새 그룹을 클릭합니다. 그런 다음 이름 바꾸기를 클릭하고 사용자 지정 그룹의 이름을 입력합니다.

  1. 추가를 클릭합니다.

  2. 이름 바꾸기를 클릭하여 매크로의 이미지를 선택하고 원하는 이름을 입력합니다.

  3. 확인을 두 번 클릭합니다.

  1. 개발 도구 탭의 코드 그룹에서 매크로를 클릭합니다.

  2. 매크로 이름 상자에 매크로의 이름을 입력합니다.

    참고: Word에서 기본 제공 매크로와 동일한 이름을 새 매크로에 지정하면 새 매크로 작업이 기본 제공 매크로를 대체합니다. 기본 제공 매크로 목록을 보려면 매크로 위치 목록에서 Word 명령을 클릭합니다.

  3. 매크로 위치 목록에서 매크로를 저장할 서식 파일 또는 문서를 클릭합니다.

    모든 문서에서 매크로를 사용할 수 있게 하려면 Normal.dotm을 클릭해야 합니다.

  4. 만들기를 클릭하여 Visual Basic Editor를 엽니다.

Visual Basic Editor를 연 후 Visual Basic for Applications를 사용하는 방법에 대한 자세한 내용을 확인하는 것이 좋습니다. 자세한 내용을 보려면 도움말 메뉴에서 Microsoft Visual Basic 도움말을 클릭하거나 F1 키를 누르세요.

작업 시퀀스를 기록하거나, Visual Basic Editor에서 Visual Basic for Applications 코드를 입력하여 매크로를 처음부터 작성할 수 있습니다.

참고: Office Word 2007에서 매크로를 사용하려면 개발자 탭을 표시해야 합니다.

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 Word 옵션을 클릭합니다.

  2. 인기 항목을 클릭합니다.

  3. Word에서 가장 많이 사용하는 옵션에서 리본 메뉴에 개발 도구 탭 표시 확인란을 선택합니다.

    참고: 리본은 Microsoft Office Fluent 사용자 인터페이스의 구성 요소입니다.

  1. 개발 도구 탭의 코드 그룹에서 매크로 기록을 클릭합니다.

    개발 도구 탭의 코드 그룹
  2. 매크로 이름 상자에 매크로의 이름을 입력합니다.

    참고: Office Word 2007에서 기본 제공 매크로와 동일한 이름을 새 매크로에 지정하면 새 매크로 작업이 기본 제공 매크로를 대체합니다. 기본 제공 매크로 목록을 보려면 개발자 탭의 코드 그룹에서 매크로를 클릭합니다. 매크로 위치 목록에서 Word 명령을 클릭합니다.

  3. 매크로 저장 위치 상자에서 매크로를 저장할 서식 파일 또는 문서를 클릭합니다.

    중요: 모든 문서에서 매크로를 사용할 수 있게 하려면 Normal.dotm을 클릭해야 합니다.

  4. 설명 상자에 매크로 설명을 입력합니다.

  5. 다음 중 하나를 실행합니다.

    • 기록 시작    빠른 실행 도구 모음의 단추 또는 바로 가기 키에 할당하지 않고 매크로 기록을 시작하려면 확인을 클릭합니다.

    • 단추 만들기    빠른 실행 도구 모음의 단추에 매크로를 할당하려면 다음을 실행합니다.

      1. 단추를 클릭합니다.

      2. 빠른 실행 도구 모음 사용자 지정에서 빠른 실행 도구 모음에 매크로를 추가할 문서(또는 모든 문서)를 선택합니다.

        중요: 모든 문서에서 매크로를 사용할 수 있게 하려면 Normal.dotm을 클릭해야 합니다.

      3. 명령 선택 대화 상자에서 기록 중인 매크로를 클릭한 다음 추가를 클릭합니다.

      4. 단추를 사용자 지정하려면 수정을 클릭합니다.

      5. 기호 아래에서 단추에 사용할 기호를 클릭합니다.

      6. 표시 이름 상자에 표시할 매크로 이름을 입력합니다.

      7. 확인을 두 번 클릭하여 매크로 기록을 시작합니다.

        선택한 기호가 빠른 실행 도구 모음에 표시됩니다. 입력한 이름은 기호를 가리킬 때 표시됩니다.

    • 바로 가기 키 할당    바로 가기 키에 매크로를 할당하려면 다음을 실행합니다.

      1. 키보드를 클릭합니다.

      2. 명령 상자에서 기록 중인 매크로를 클릭합니다.

      3. 새 바로 가기 키 상자에 원하는 키 시퀀스를 입력하고 할당을 클릭합니다.

      4. 닫기를 클릭하여 매크로 기록을 시작합니다.

  6. 매크로에 포함할 작업을 실행합니다.

    참고: 매크로를 기록할 때 마우스를 사용하여 명령 및 옵션을 클릭할 수 있지만 텍스트는 선택할 수 없습니다. 텍스트를 선택하려면 키보드를 사용해야 합니다. 키보드를 사용하여 텍스트를 선택하는 방법에 대한 자세한 내용은 텍스트 선택을 참조하세요.

  7. 작업 기록을 중지하려면 코드 그룹에서 기록 중지를 클릭합니다.

매크로에 대한 바로 가기 키 변경

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 Word 옵션을 클릭합니다.

  2. 사용자 지정을 클릭합니다.

  3. 바로 가기 키 옆에 있는 사용자 지정을 클릭합니다.

  4. 범주 목록에서 매크로를 클릭합니다.

  5. 매크로 목록에서 변경할 매크로를 클릭합니다.

  6. 새 바로 가기 키 상자에 선택할 키 조합을 입력합니다.

  7. 현재 키 상자를 확인하여 다른 작업을 수행하는 데 이미 사용 중인 키 조합을 할당하지 않도록 합니다.

  8. 변경 내용 저장 위치 목록에서 매크로를 실행하려는 위치와 일치하는 옵션을 클릭합니다.

    중요: 모든 문서에서 매크로를 사용할 수 있게 하려면 Normal.dotm을 클릭해야 합니다.

  9. 닫기를 클릭합니다.

  1. 개발 도구 탭의 코드 그룹에서 매크로를 클릭합니다.

    개발 도구 탭의 코드 그룹

  2. 매크로 이름 아래의 목록에서 실행할 매크로를 클릭합니다.

  3. 실행을 클릭합니다.

  1. 개발 도구 탭의 코드 그룹에서 매크로를 클릭합니다.

    개발 도구 탭의 코드 그룹

  2. 매크로 이름 상자에 매크로의 이름을 입력합니다.

    참고: Office Word 2007에서 기본 제공 매크로와 동일한 이름을 새 매크로에 지정하면 새 매크로 작업이 기본 제공 매크로를 대체합니다. 기본 제공 매크로 목록을 보려면 매크로 위치 목록에서 Word 명령을 클릭합니다.

  3. 매크로 위치 목록에서 매크로를 저장할 서식 파일 또는 문서를 클릭합니다.

    모든 문서에서 매크로를 사용할 수 있게 하려면 Normal.dotm을 클릭해야 합니다.

  4. 만들기를 클릭하여 Visual Basic Editor를 엽니다.

Visual Basic Editor를 연 후 Visual Basic for Applications를 사용하는 방법에 대한 자세한 내용을 확인하는 것이 좋습니다. 자세한 내용을 보려면 도움말 메뉴에서 Microsoft Visual Basic 도움말을 클릭하거나 F1 키를 누르세요.

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×