매크로 기록

Microsoft Office Project에서 작업을 반복적으로 수행 하는 경우 매크로를 사용 하 여 작업을 자동화할 수 있습니다. 매크로는 모듈 에 저장 되며 작업을 수행 해야 할 때마다 실행할 수 있는 일련의 명령 및 함수입니다.

  1. 보기 탭에서 매크로를 선택한 다음 매크로 기록을선택 합니다.

    (Project 2007의 도구 메뉴에서 매크로를 가리킨 다음 새 매크로 기록을선택 합니다.)

  2. 매크로 이름 상자에 매크로 의 이름을 입력 합니다.

    매크로 이름의 첫 번째 문자는 문자 이어야 합니다. 다른 문자는 문자, 숫자 또는 밑줄 문자 일 수 있습니다. 빈 공백은 매크로 이름에 사용할 수 없지만 밑줄은 단어 구분 기호 처럼 작동 합니다.

  3. 바로 가기 키 를 눌러 매크로를 실행할 수 있으려면 바로 가기 키 상자에 문자나 키 조합을 입력 합니다.

    CTRL + 문자 (소문자 용) 또는 CTRL + SHIFT + 문자 (대문자)는 키보드의 문자 키 이지만 숫자나 특수 문자는 사용할 수 없습니다. Microsoft Office Project에서 이미 사용 중인 키 조합은 사용할 수 없습니다.

  4. 매크로 저장 위치 목록에서 매크로를 저장 하려는 위치를 선택 합니다.

    • Project를 사용할 때마다 매크로를 사용할 수 있도록 하려면 전역 파일을 선택 합니다.

    • 현재 프로젝트 에서만 매크로를 사용할 수 있도록 하려면 이 프로젝트를 선택 합니다.

  5. 매크로에 대 한 설명을 포함 하려면 설명 상자에 설명을 입력 합니다.

  6. 매크로를 기록 하는 동안 셀을 선택 하면 열에 대 한 절대 참조가 기록 되므로 매크로가 실행 될 때마다 동일한 열 (필드)이 선택 됩니다. 매크로를 실행할 때 활성 셀의 위치에 관계 없이 열을 선택 하려면 열 참조에서 상대 를 선택 합니다.

    반대로, 매크로를 실행할 때 활성 셀의 위치에 관계 없이 행에 대 한 상대 참조를 기록 하기 때문에 매크로가 행을 선택 합니다. 매크로에서 처음에 선택한 셀에 관계 없이 항상 같은 행을 선택 하도록 하려면 행 참조에서 절대 (ID) 를 선택 합니다.

    참고: 설정을 변경 하거나 Project를 닫을 때까지 매크로를 기록 하는 동안 project에서 계속 이러한 설정을 사용 합니다.

  7. 확인을 선택 하 고 기록 하려는 작업을 수행 합니다.

  8. 기록할 모든 작업을 완료 했으면 보기 탭에서 매크로를 선택한 다음 기록 중지를 선택 합니다.

    (Project 2007의 도구 메뉴에서 매크로를 가리킨 다음 기록 중지를 선택 합니다.)

보안 정보: 매크로는 바이러스를 포함할 수 있으므로 실행할 때 주의 해야 합니다. 컴퓨터에서 최신 바이러스 백신 소프트웨어를 실행 하면 다음과 같은 주의를 취해야 합니다. 매크로 보안 수준을 높음으로 설정 합니다. 설치 된 모든 추가 기능과 서식 파일을 안전 하 게 신뢰 확인란의 선택을 취소 합니다. 디지털 서명 사용 신뢰할 수 있는 게시자 목록을 유지 합니다.

참고:  이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 정보가 도움이 되는지 알려주세요. 참조할 수 있는 영문 문서가 여기 있습니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×