데이터 시각화 도우미 다이어그램 만들기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

Excel 통합 문서에서 게시되는 세부 Visio 순서도를 자동으로 만들고 싶으신가요? 데이터 시각화 도우미 템플릿을 사용하면 됩니다. 각 템플릿에는 Visio에서 프로세스 데이터를 순서도로 변환하는 데 사용되는 Excel 통합 문서가 연결되어 있습니다. 데이터에서 다이어그램 만들기 마법사에서 사용자 지정 Excel 서식 파일을 만들고, Excel 데이터를 도형에 매핑하고, 다이어그램을 자동으로 만들 수도 있습니다. 또한 Excel에서 Visio 도형 데이터로 변환되는 다른 데이터 열을 추가할 수도 있습니다.

Visio는 Visio 다이어그램과 Excel 통합 문서 간의 양방향 동기화도 지원합니다. Excel에서 데이터를 편집하고 Visio에서 다이어그램을 새로 고쳐 순서도를 만들 수 있을 뿐만 아니라 Visio 다이어그램을 변경한 다음 다이어그램에서 Excel 데이터를 업데이트할 수도 있습니다. 

데이터 시각화 도우미 개요

데이터 시각화 도우미 템플릿을 사용하는 기능은 현재 릴리스 채널에서는 Visio Online 요금제 2에서만 사용할 수 있습니다. 사용 중인 Visio 버전이 확실하지 않은 경우 파일 > 계정 > Visio 정보를 선택합니다. Visio의 구독판에 대한 자세한 내용은 Visio Online 요금제 2를 참조하세요.

데이터 시각화 도우미 템플릿이 표시되지 않거나 시작에 관한 다른 질문이 있는 경우 데이터 시각화 도우미에 대한 자주 묻는 질문 페이지를 방문하세요.

참고: 이 기능을 사용하려면 Office 365 구독이 있어야 합니다. Office 365 구독자인 경우 최신 Office 버전을 보유하고 있는지 확인하세요. Office 365 업데이트 프로세스를 관리하는 IT 전문가인 경우 채널 릴리스 페이지를 확인하여 각 채널에 제공되는 업데이트를 알아보세요.

이 문서의 내용

데이터 시각화 도우미 다이어그램 만들기

시작하기 전에

아이디어를 수집하고 용지에 초안 양식으로 또는 수동 입력으로 표현합니다. 이 대략적인 초안은 작업을 바로 시작하고 다음 단계를 더 원활하게 진행하는 데 도움이 될 수 있습니다.

데이터 시각화 도우미 다이어그램을 만들려면 Excel 및 Visio에서 동시에 작업하면 됩니다. Windows 장치의 두 개 창 또는 다중 모니터 환경에서 더 쉽게 작업할 수 있습니다. Excel과 Visio에서 시각적으로 작업을 비교하면 의도한 대로 작업하고 있는지를 확인하는 데 도움이 됩니다.

권장    다음 Microsoft Office 비디오를 보고 실제로 작동해 보세요. 데이터 시각화 도우미: 데모

1단계: 데이터 시각화 도우미 템플릿 선택

  1. Visio를 열거나, 다이어그램을 편집하는 경우 파일 > 새로 만들기를 선택합니다.

  2. 템플릿을 선택합니다.

    서식 파일 명령
  3. 순서도를 선택합니다.

    순서도 명령
  4. 기본 순서도-데이터 시각화, 부서간 업무 흐름도-데이터 시각화 를 또는 감사 다이어그램-데이터 시각화를 선택 합니다.

    데이터 시각화 도우미 서식 파일

    데이터 시각화 도우미 서식 파일의 왼쪽 위에는 Excel 아이콘이 있습니다.

순서도 및 해당 셰이프에 대한 자세한 내용은 기본 순서도 만들기부서간 업무 흐름도 만들기를 참조하세요.

2단계: Excel 통합 문서 만들기

  1. 템플릿 미리 보기에서 Excel 데이터 서식 파일을 선택합니다.

    Excel 데이터 서식 파일 링크 선택

    참고    이 문서에 사용된 샘플 Excel 서식 파일을 참조로 사용하려는 경우 다음 링크에서 해당 서식 파일을 다운로드할 수 있습니다.

  2. 파일 > 저장을 선택하고, 컴퓨터, 네트워크 서버 또는 SharePoint 문서 라이브러리를 지정한 다음, 파일 이름을 입력하고 저장을 선택합니다.

  3. 새 워크시트를 추가하려면 통합 문서 아래쪽에서 새 시트 새 시트 단추 를 선택합니다.

  4. Excel 표를 만듭니다. Excel 표 사용에 대한 자세한 내용은 Excel 표 개요, Excel 표 만들기 또는 삭제행 및 열을 추가하거나 제거하여 표 크기 조정을 참조하세요.

  5. Visio 다이어그램을 만드는 데 사용 되는 테이블에 열과 행을 추가 합니다. Excel 표 열 머리글 및 값에 대 한 특정 요구 사항이 있습니다. 시각적 가이드로 Visio 순서도 구성 요소와 상호 작용 방식을 Excel 열 섹션에서 사용 합니다.

3단계: Excel 표에 도형 데이터 더 추가(선택 사항)

  1. Excel 서식 파일에서 프로세스 맵 탭을 검토합니다. Excel 표의 열에 파란색 및 녹색이 지정됩니다. 색은 열 간의 차이점에 대한 시각적 힌트를 제공합니다.

    파란색 열은 Visio 다이어그램에서 순서도를 만드는 데 사용됩니다. 모든 열은 셰이프 데이터로도 추가됩니다.

  2. 셰이프 데이터를 더 추가하려면 Excel 표에 하나 이상의 열을 추가합니다.

    녹색 열은 각 셰이프에 추가할 수 있는 추가 셰이프 데이터를 나타냅니다. 많은 열을 더 추가할 수 있습니다. 기본적으로 데이터 그래픽을 추가하지 않는 한 이 데이터는 다이어그램에 표시되지 않습니다. Visio 다이어그램에서 셰이프 데이터를 보려면 데이터 > 셰이프 데이터 창을 선택합니다. 셰이프 데이터 및 데이터 그래픽에 대한 자세한 내용은 셰이프에 데이터 추가데이터 그래픽, 개요를 참조하세요.

4단계: 마법사를 사용하여 Visio 다이어그램 만들기

  1. 다시 Visio로 전환하여 템플릿 미리 보기에서 측정 단위를 선택한 다음 만들기를 선택합니다.

  2. 데이터에서 다이어그램 만들기 마법사의 첫 페이지에서 다음을 수행합니다.

    1. 데이터로 어떤 다이어그램을 만들고 싶으세요?에서 기본 순서도, 부서간 업무 흐름도(가로) 또는 부서간 업무 흐름도(세로) 템플릿 중에서 선택합니다.

    2. Excel 통합 문서 선택 아래의 최근에 사용한 통합 문서 목록에서 통합 문서를 선택하거나 찾아보기를 선택하여 2단계에서 만든 통합 문서를 찾습니다.

    3. 통합 문서에서 표 또는 사용자 지정 범위 선택에서 Excel 프로세스 데이터가 들어 있는 표를 선택합니다.

    4. 마침을 선택합니다. Visio가 마법사의 다른 페이지를 채우는 모든 기본값이 적용됩니다.

그 결과 컨테이너 내부에 다이어그램이 자동으로 만들어집니다. 순서도의 크기에 따라 Visio 페이지가 더 추가됩니다.

5단계: Visio 다이어그램 저장

  • 파일 > 저장을 선택하고 위치를 찾은 다음 파일 이름을 입력하고 저장을 선택합니다.

Excel 파일과 Visio 파일이 함께 작동하므로 같은 위치에 두는 것이 좋습니다.

6단계: 데이터 및 다이어그램 동기화

데이터 시각화 도우미로 다이어그램을 만든 후 다이어그램을 변경하고 싶을 수 있습니다. Visio는 원본 데이터와 다이어그램 간의 양방향 동기화를 지원합니다.

    작업을 완료한 후 두 파일을 동기화하고 최신 상태로 유지하세요. Excel 데이터를 변경할 때는 다이어그램을 새로 고치고, 다이어그램 내용을 변경할 때는 Excel 데이터를 업데이트합니다.

Excel에서 데이터를 수정한 후 다이어그램을 새로 고치려면

  1. Excel 표의 원본 데이터를 변경합니다. 행을 추가, 업데이트 또는 삭제할 수 있습니다.

  2. Excel 통합 문서를 저장합니다.

  3. Visio에서 다이어그램 컨테이너를 클릭하여 리본의 데이터 도구 디자인 탭을 사용하도록 설정하고 다이어그램 새로 고침을 선택합니다.

그 결과 Excel 통합 문서에서 변경한 내용이 Visio 다이어그램에 표시됩니다. 다음 사항을 참조하세요.

  • 새로 고친 후 손실될 수 있는 다이어그램을 변경한 경우 Visio에는 다이어그램 충돌 새로 고침 대화 상자가 표시됩니다.

  • 새로 고침은 컨테이너 내부의 셰이프 및 연결에만 변경 내용을 적용합니다.

  • 컨테이너 내부의 셰이프 또는 연결선에 대해 수행한 모든 서식 변경 내용은 유지됩니다.

  • 모든 다이어그램 셰이프 및 연결선은 컨테이너 내부에 유지하세요. 페이지에서 컨테이너 외부에 있는 다른 모든 개체는 영향을 받지 않습니다. 컨테이너에 대한 자세한 내용은 컨테이너 및 목록을 사용하여 다이어그램 구조를 명확하게 표시를 참조하세요.

다이어그램에서 콘텐츠를 수정한 후 Excel에서 데이터를 업데이트하려면

  1. Visio 다이어그램을 변경합니다. 셰이프 및 연결선을 추가, 업데이트 또는 삭제할 수 있습니다.

  2. Excel 통합 문서가 데스크톱 컴퓨터 또는 네트워크 파일 서버에 있는 경우에는 저장된 후 닫혔는지 확인합니다.

  3. 다이어그램 컨테이너를 클릭하여 리본의 데이터 도구 디자인 탭을 사용하도록 설정하고 원본 데이터 업데이트를 선택합니다.

그 결과 Visio 다이어그램에서 변경한 내용이 Excel 통합 문서에서 업데이트됩니다. Excel에서 데이터가 손실될 수 있는 경우 Visio에는 원본 데이터 충돌 업데이트 대화 상자가 표시됩니다. 문제를 방지하려면 다음 모범 사례를 따르세요.

  • 변경 사항을 덮어쓰기 전에 Excel 데이터의 백업을 저장합니다.

  • Excel 통합 문서에서는 사용자 지정 범위가 아닌 Excel 표를 데이터 원본으로 사용합니다. 원본 데이터 업데이트 대화 상자에서 덮어쓰기를 선택하면, Visio에서 사용자 지정 범위가 Excel 표로 변환됩니다.

  • Excel 데이터 원본에 수식을 사용하지 마세요. 원본 데이터 업데이트 대화 상자에서 덮어쓰기를 선택하면, Visio에서 수식이 수식 결과로 변환됩니다.

  • 데이터 열이 함수 및 단계에 매핑되는 데이터에서 다이어그램 만들기 마법사에서 다음 옵션을 사용하여 다이어그램을 작성했습니다. 매핑 > 기타 옵션 > 생성할 데이터의 열 값 순서 유지 > 기능 또는 스윔 레인 선택 또는 단계 또는 시간 표시 막대 선택. 이 경우 Visio에서는 셰이프 간의 연결을 나타내기 위해 데이터에 추가 열이 필요합니다. 원본 데이터 업데이트 대화 상자에서 덮어쓰기를 선택하면 또 하나의 열이 추가됩니다.

  • Excel에서 데이터 값의 순서를 기반으로 스윔 레인 및 단계를 모두 사용하여 부서간 업무 흐름도를 만들었습니다. 데이터 열이 프로세스 단계 및 작업에 연결되는 데이터에서 다이어그램 만들기 마법사에서 다음 옵션을 사용하여 다이어그램을 작성했습니다. 매핑 > 프로세스 단계/작업을 연결할 방법 지정 > 순차적으로 연결. 이 경우 Visio에서는 도형 간의 연결을 나타내기 위해 데이터에 추가 열이 필요합니다. 다이어그램에서 스윔 레인 또는 단계의 순서를 변경하면 데이터 원본에서 순서가 변경됩니다. 원본 데이터 업데이트 대화 상자에서 덮어쓰기를 선택하면 다이어그램의 스윔 레인 및 단계가 더 이상 Excel 통합 문서의 데이터 순서를 따르지 않습니다.

7단계: Excel 표와 Visio 다이어그램 간의 상호 작용 사용자 지정(선택 사항)

데이터 시각화 도우미 다이어그램 만들기를 사용자 지정하고 싶은 경우가 있습니다. 예를 들어 조직 표준을 준수하기 위해 다른 셰이프를 사용하거나 Excel 표의 다른 열 이름에 매핑하고 싶을 수 있습니다.

  1. 만들기를 선택하여 데이터에서 다이어그램 만들기 마법사로 들어간 다음 첫 페이지에서 값을 입력(4단계 참조)한 후 다음 또는 뒤로를 선택하여 마법사에서 각 페이지를 표시합니다.

  2. 도움말(?)을 선택하여 페이지에서 각 옵션을 사용자 지정하는 방법에 대한 자세한 내용을 확인합니다. 자세한 내용은 데이터에서 다이어그램 만들기 마법사 사용을 참조하세요.

맨 위로 이동

Excel 열이 Visio 순서도 구성 요소와 상호 작용하는 방법

다음 이미지 연습을 통해 Visio 순서도를 만드는 데 각 Excel 열이 사용되는 방법을 이해합니다.

프로세스 단계 ID   순서도에서 각 셰이프를 식별하는 번호입니다. 이 열은 필수이며, Excel 표의 각 값은 고유하고 비어 있지 않아야 합니다. 이 값은 순서도에 표시되지 않습니다.

Visio 순서도와 Excel 프로세스 맵 상호 작용: 프로세스 단계 ID

프로세스 단계 설명   순서도의 각 셰이프에 추가된 텍스트입니다.

Visio 순서도와 Excel 프로세스 맵 상호 작용: 프로세스 단계 설명

다음 단계 ID   시퀀스에서 다음 셰이프의 프로세스 단계 ID입니다. 분기 셰이프에는 다음 단계가 두 개 있으며 4,5와 같이 쉼표로 구분된 숫자로 표시됩니다. 두 개 이상의 다음 단계가 있을 수 있습니다.

Visio 순서도와 Excel 프로세스 맵 상호 작용: 다음 단계 ID

연결선 레이블   분기 셰이프의 경우 연결선 레이블은 예,아니요와 같이 쉼표로 구분된 텍스트로 표시됩니다. 예제에서 예는 4에 해당하고 아니요는 5에 해당합니다.

Visio 순서도와 Excel 프로세스 맵 상호 작용: 연결선 레이블

셰이프 형식   Visio 다이어그램에 나타내려는 셰이프의 형식입니다(예: 프로세스 또는 판단). 선택 항목의 유효성을 검사하려면 드롭다운 목록을 사용하는 것이 좋습니다.

Visio 순서도와 Excel 프로세스 맵 상호 작용: 셰이프 형식

기능 및 단계    각 셰이프가 속하는 기능(또는 스윔 레인) 및 단계(또는 시간 표시 막대)입니다. 이 열은 부서간 업무 흐름도 다이어그램에만 적용되고 기본 순서도 다이어그램에서는 무시됩니다.

Visio 순서도와 Excel 프로세스 맵 상호 작용: 기능 및 단계

맨 위로 이동

다른 스텐실을 사용하여 데이터 시각화 도우미 다이어그램 만들기

데이터 시각화 서식 파일을 사용 하 여 외에도 데이터 시각화 다이어그램을 만들 때 다른 템플릿의 스텐실도 사용할 수 있습니다. 예를 들어 금융 거래 또는 재고 관리에 대 한 프로세스 다이어그램을 만듭니다. 다른 프로세스 지향 스텐실 작업 흐름 개체 및 BPMN 기본 서식 파일을 포함 하 여 가지가 있습니다. 내 셰이프 스텐실을 사용 하 여 사용자 지정 셰이프를 추가할 수도 있습니다. 자세한 내용은 만들기, 저장 및 사용자 지정 스텐실 공유를 참조 합니다.

  1. 이미 작성한 데이터 시각화 도우미 다이어그램(기본 순서도 또는 부서간 업무 흐름도)을 엽니다.

  2. 만들기를 선택하여 데이터에서 다이어그램 만들기 마법사로 들어간 다음 첫 페이지에서 값을 입력한 후 도형 매핑 페이지가 마법사에 표시될 때까지 다음을 선택합니다.

  3. 다른 셰이프 옵션을 사용하여 하나 이상의 스텐실을 추가합니다.

  4. 아무 셰이프나 선택한 후 드래그하여 셰이프 형식 열의 데이터 값에 매핑합니다.

맨 위로 이동

다이어그램에 데이터 그래픽 적용

다이어그램에서 셰이프 데이터를 시각화하는 데 도움이 되는 데이터 그래픽을 추가하여 다이어그램을 향상할 수 있습니다. 실제로는 데이터 그래픽이 셰이프 데이터를 기반으로 하는 데이터 그래픽 아이콘을 사용하여 KPI(핵심 성과 지표) 정보를 표시하는 프로세스 대시보드로 다이어그램을 변환할 수 있습니다.

  1. 데이터 시각화 도우미 다이어그램을 엽니다.

    데이터 그래픽을 적용할 컨테이너를 선택합니다.

  2. 데이터 > 데이터 그래픽 필드를 선택합니다.

  3. 다이어그램에 추가할 데이터 그래픽 필드를 선택합니다.

    Visio 데이터 시각화 도우미 다이어그램에 대한 데이터 그래픽 적용

    데이터 그래픽은 전체 다이어그램에 적용됩니다. 특정 셰이프에 대한 데이터 그래픽을 숨기려면 Excel 통합 문서에서 해당 행의 데이터 열 값을 빈 상태로 둡니다.

  4. 원하는 경우 데이터 탭에서 추가 옵션을 설정할 수 있습니다. 자세한 내용은 데이터 그래픽, 개요를 참조하세요.

맨 위로 이동

다음 단계

다음은 데이터 시각화 도우미 다이어그램을 만든 후 수행할 수 있는 몇 가지 작업입니다.

  • 테마    Visio의 테마는 클릭 한 번으로 드로잉에 적용할 수 있는 색과 효과의 모음입니다. 테마를 사용하면 드로잉을 보다 세련된 모양으로 간편하게 꾸밀 수 있습니다. 자세한 내용은 테마를 사용하여 드로잉에 세련된 모양 적용을 참조하세요.

  • 레이아웃    Visio에는 다이어그램에서 셰이프의 맞춤과 간격을 올바르게 설정하도록 돕기 위한 수동 안내선과 자동 도구가 있습니다. 이를 사용하면 드로잉을 최대한 깔끔하게 잘 정렬된 모양으로 만들 수 있습니다. 자세한 내용은 다이어그램에서 셰이프 맞춤 및 위치 지정을 참조하세요.

  • 내보내기    데이터 시각화 도우미 다이어그램 및 연결된 Excel 통합 문서를 Visio 서식 파일 패키지(.vtpx)로 내보냅니다. Visio 서식 파일 패키지는 다른 사용자가 데이터 시각화 도우미 다이어그램을 만들기 위한 빠른 시작점으로 사용할 수 있도록 다이어그램 설정, 스텐실, 및 데이터를 저장합니다. 다른 사용자는 컴퓨터에 서식 파일 패키지를 설치할 수 있습니다. 자세한 내용은 데이터 시각화 도우미 서식 파일 패키지 내보내기 및 설치를 참조하세요.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×