데이터베이스 모델(엔터티 관계 다이어그램) 만들기

참고:  사용자 언어로 가능한 한 빨리 가장 최신의 도움말 콘텐츠를 제공하고자 합니다. 이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 이 페이지 하단의 정보가 도움이 되었다면 알려주세요. 쉽게 참조할 수 있는 영어 문서 가 여기 있습니다.

데이터베이스 모델 다이어그램 템플릿을 사용 하 여 새 모델 또는 관계를 사용 하 여 모델로 리버스 엔지니어링 기존 데이터베이스를 만들거나 개체 관계 모델링 개념입니다. SQL92 및 이전 표준에 기반 하는 모델 데이터베이스에 엔터티 관계 스텐실을 사용 합니다. 한 형식 모델 데이터베이스에 SQL99 및 이상 표준에 따라 사용에 대 한 추가 셰이프가 있는 개체 관계형 스텐실을 사용 합니다.

데이터베이스 모델 예

데이터베이스 모델 다이어그램 템플릿을 사용 하 여 새 모델 또는 관계를 사용 하 여 모델로 리버스 엔지니어링 기존 데이터베이스를 만들거나 개체 관계 모델링 개념입니다. SQL92 및 이전 표준에 기반 하는 모델 데이터베이스에 엔터티 관계 스텐실을 사용 합니다. 한 형식 모델 데이터베이스에 SQL99 및 이상 표준에 따라 사용에 대 한 추가 셰이프가 있는 개체 관계형 스텐실을 사용 합니다.

이 문서에서는 데이터베이스 모델을 만드는 방법 및 수행할 수 있는 모델이 포함 된를 만든 후에 대해 설명 합니다.

데이터베이스 모델 기능을 찾을 수 없는 경우

Microsoft Visio의 모든 버전에 데이터베이스 모델 기능이 있습니다. 이 문서에 나와 있는 절차에 설명 된 기능을 찾을 수 없는 경우 포함 하지 않는 visio 버전이 되어 있을 가능성이 큽니다.

  • Microsoft Visio Standard 데이터베이스 모델 다이어그램 템플릿을 포함 되지 않습니다.

  • Microsoft Visio Professional, Premium 에디션 (즉, 기존 데이터베이스를 사용 하 여 Visio에서 모델을 만드는) 데이터베이스 모델 다이어그램 서식 파일에 대 한 리버스 엔지니어링 기능을 지원 하지만 (을 사용 하 여 Visio 전달 공학 지원 하지 않습니다. 데이터베이스 모델 SQL 코드를 생성할 수)입니다.

  1. 데이터베이스 모델 다이어그램을 시작 하려면 다음 중 하나를 실행 합니다.

    처음부터 새 모델 다이어그램 만들기

    시작 지점으로 사용 하려면 기존 데이터베이스를가 없는 경우 빈 데이터베이스 모델을 사용 하 여 시작 한 테이블 및 관계 추가 수 있습니다.

    1. 파일 탭을 클릭합니다.

    2. 새로 만들기 를 클릭 소프트웨어 및 데이터베이스를 클릭 한 다음 데이터베이스 모델 다이어그램 을 두 번 클릭 합니다.

    3. 데이터베이스 탭의 관리 그룹에서 표시 옵션 을 클릭 합니다.

    4. 데이터베이스 문서 옵션 대화 상자에서 기호 집합을 사용 하 고 다른 테이블 및 관계 옵션을 선택한 다음 확인 을 클릭 합니다.

    기존 데이터베이스 시작 점으로 사용

    데이터베이스를 모델링 더 나은 이해 하거나 새 모델에 대 한 시작 지점으로 사용할 수 있도록 하려는 경우 스키마 또는 데이터베이스의 구조를 추출 하 고 새 모델을 작성 하 리버스 엔지니어링 마법사를 사용할 수 있습니다.

    마법사를 시작 하기 전에

    1. 역방향 인 경우 마법사를 시작 하기 전에 Microsoft Excel 통합 문서를 엔지니어링 해야 통합 문서를 열고 열 머리글이 포함 된 셀의 그룹 (또는 범위)의 이름을 지정 합니다. 하나 이상의 워크시트를 사용 하려는 경우 각 워크시트에 있는 열의 셀 그룹의 이름을 합니다. 이러한 범위 마법사의 테이블 처럼 처리 됩니다. 셀 범위의 이름을 지정 하는 방법에 대 한 자세한 내용은 Excel 도움말 이라는 제목의 명명 된 셀 참조 또는 범위 정의에서 항목을 참고 합니다.

    2. 최상의 결과 위해 기본 드라이버 리버스 엔지니어링 마법사를 실행 하기 전에 리버스 엔지니어링 하려는 대상 데이터베이스를 설정 합니다. 이렇게 하면 마법사가 원시 데이터 형식을 올바르게 매핑하고 마법사에서 추출 된 모든 코드가 코드 창에 올바르게 표시 됩니다.

    3. 파일 탭을 클릭합니다.

    4. 새로 만들기 를 클릭 소프트웨어 및 데이터베이스를 클릭 한 다음 데이터베이스 모델 다이어그램 을 두 번 클릭 합니다.

    5. 데이터베이스모델 그룹에서 리버스 엔지니어링 을 클릭 합니다.

    6. 리버스 엔지니어링 마법사의 첫 번째 화면에서 다음을 수행 합니다.

      1. 데이터베이스 관리 시스템 (DBMS)에 대 한 데이터베이스 드라이버를 선택 합니다. 특정 ODBC 데이터 원본으로 Visio 데이터베이스 드라이버를 이미 연결 하지 않은 경우 설치 프로그램 을 클릭 합니다.

        참고: Excel 워크시트를 리버스 엔지니어링 경우 ODBC 일반 드라이버를 선택 합니다.

      2. 업데이트 하는 데이터베이스의 데이터 원본을 선택 합니다. 기존 데이터베이스에 대 한 데이터 원본을 아직 만들지 않은 경우 않았다면 지금 새로 만들기 클릭 합니다.

        새 출처를 만들면 해당 이름은 데이터 원본 목록에 추가 됩니다.

      3. 설정, 끝나면 다음 을 클릭 합니다.

    7. 모든 관련 드라이버 대화 상자에서 지침을 따릅니다.

      예를 들어 데이터 원본 연결 대화 상자에서 사용자 이름 및 암호를 입력 한 다음 확인 을 클릭 합니다.

      참고: ODBC 일반 드라이버를 사용 하는 경우 리버스 엔지니어링 된 정보가 완료 되지 않는 없다는 오류 메시지가 나타날 수 있습니다. 대부분의 경우에서이 문제가 되지 않습니다- 확인 을 클릭 하 고 마법사를 계속 합니다.

    8. 추출 하려는 정보의 형식에 대 한 확인란을 선택 하 고 을 클릭 합니다.

      참고: 일부 항목을 사용할 수 없는 (회색으로 표시) 모든 데이터베이스 관리 시스템 모든 종류의 마법사를 추출할 수 있는 요소를 지원 합니다.

    9. 추출, 또는 모두 선택 추출한 클릭 하려는 테이블 (및 보기, 있는 경우)에 대 한 확인란을 선택 모두을 하 고 다음 을 클릭 합니다.

      참고: Excel 워크시트를 리버스 엔지니어링 되 고이 목록에 아무것도 표시 되지 않는 경우에 워크시트에 열 머리글이 포함 된 셀 범위의 이름을 지정 해야 할 가능성이 합니다.

    10. 저장 프로시저 확인란을 선택한 경우, 추출 하려는 프로시저를 선택 하거나 클릭 모두 선택 에 추출 모두을 하 고 다음 을 클릭 합니다.

    11. 현재 페이지에 자동으로 추가 되도록 리버스 엔지니어링 된 항목을 원하는 지 여부를 선택 합니다.

      참고: 마법사가 자동으로 나열 하는 테이블 및 뷰 창에서 리버스 엔지니어링 된 항목에 드로잉을 추가로 만듭니다를 선택할 수 있습니다. 자동으로 만들어진 드로잉이 하지 않으려는 경우 수동으로 데이터베이스 모델을 조합 하 여 드로잉 페이지로 끌어다 놓습니다 테이블 및 뷰 창에서 항목을 끌 수 있습니다.

    12. 하 고 완료 를 클릭 한 다음 정보를 추출 하 고 있는지 확인 하 여 선택 항목을 검토 합니다.

      마법사의 선택한 정보를 추출 및 출력 창에 추출 과정에 대 한 메모를 표시 합니다.

    기존 모델 구체화 및 가져오기

    기존 VisioModeler 또는 백 금 ERwin 모델 사이트가 있는 경우 Visio 데이터베이스 모델 다이어그램을 가져올 수 있습니다. 이 기능은 VisioModeler 2.0 또는 이후 사전 모델 (.imd) 파일 및 2.6, 3.0 및 3.52 플래티넘 ERwin.erx 파일 제한 됩니다.

    1. 파일 탭을 클릭합니다.

    2. 새로 만들기 를 클릭 소프트웨어 및 데이터베이스를 클릭 한 다음 데이터베이스 모델 다이어그램 을 두 번 클릭 합니다.

    3. 모델 그룹에서 데이터베이스 탭에서 가져오기 를 클릭 하 고 모델 종류를 클릭 합니다.

    4. 가져오거나 모델 파일을 찾은 찾아보기 단추를 클릭 하려는 모델에 대 한 경로 파일 이름을 입력 한 다음 열기 를 클릭 합니다.

    5. 가져오기 대화 상자에서 확인 을 클릭 합니다.

      Visio 파일을 가져옵니다를 출력 창에 해당 진행률을 표시 합니다. 가져온된 테이블 테이블 및 뷰 창에 표시 됩니다.

    6. 테이블 및 뷰 창에서 모델을 추가할 테이블을 선택 하 고 드로잉 페이지로 끌어다 놓습니다.

  2. 데이터베이스 모델 다이어그램을 만든 후 다이어그램을 구체화 작업을 시작 합니다. 수 추가 하 고 테이블 및 뷰를 사용자 지정, 관계를 만들고 열과 데이터 형식 사용자 지정 합니다.

    테이블

    엔터티 셰이프를 사용 하 여 다이어그램에서 테이블을 만들 수 있습니다.

    1. 엔터티 관계 또는 개체 관계 스텐실에서 드로잉 엔터티 셰이프를 끌어다 놓습니다.

    2. 데이터베이스 속성 창을 열려면 도형을 두 번 클릭 합니다.

    3. 범주 정의 클릭 하 고 테이블의 이름을 입력 합니다.

    4. 범주 을 클릭 하 고 이름을 입력 데이터 형식을 선택 합니다.

    5. Null 값을 가질 수 없는 열에 대 한 필수 확인란을 선택 합니다.

    6. 데이터베이스 테이블의 각 행을 고유 하 게 식별 하는 열에 대 한 PK (기본 키) 확인란을 선택 합니다.

    7. 범주 인덱스, 트리거, 확인 또는 확장 이러한 선택적 요소 만들기를 클릭 합니다.

    데이터 형식 및 기본 키를 포함 하 여 열에 대 한 속성을 추가 하거나 변경할 데이터베이스 속성 창을 사용 합니다.

    1. 다이어그램에서 테이블을 두 번 클릭 합니다.

    2. 데이터베이스 속성 창에서 범주 을 클릭 합니다.

    3. 첫 번째 빈 실제 이름 셀을 클릭 하 고 이름을 입력 합니다.

    4. 열에 대 한 데이터 형식을 변경 하려면 해당 열의 데이터 형식 필드를 클릭 한 다음 목록에서 데이터 형식을 선택 또는 목록에 입력 합니다. 예를 들어 decimal(8,2) 또는 char(30)입력할 수 있습니다.

    5. Null 값을 방지 하기 위해 필수 확인란을 선택 합니다.

    6. 열이 기본 키를 지정 하려면 PK 확인란을 선택 합니다.

    7. 범주를 클릭 하면 나타나는 것 외에도 추가 열 속성을 보려면 열을 선택 하 고 편집 을 클릭 합니다.

    관계

    관계 기본 키 및 외래 키를 사용 하 여 관련된 테이블의 행과 단일 테이블에서 행과 일치 하는 데이터베이스를 허용 하도록 합니다. 다이어그램에서 해당 관계를 표시할 수 있습니다. 카디널리티 (예를 들어-일대다)를 설정 하 고 Crow의 피트, 관계형 또는 IDEF1X 사용 수 또한 표시법 카디널리티를 표시할 수 있습니다. 데이터베이스 모델 다이어그램 서식 파일에서 이러한 표시법 중 하나를 사용 하려면 다대다 관계를 표시할 수 없습니다.

    1. 테이블 간의 관계를 만듭니다.

      1. 두 테이블의 다이어그램에 표시 되어 있는지 확인 합니다. 리버스 엔지니어링 기존 데이터베이스에서 모델을 하나 또는 둘 다 테이블 및 뷰 창에서 드로잉 페이지로 끌어 할 수 있습니다.

      2. 관계의 기본 키 쪽에 사용할 테이블을 두 번 클릭 합니다.

      3. 데이터베이스 속성 창에서 범주 을 클릭 합니다.

      4. 눈금에서 각 테이블의에서 행을 고유 하 게 식별 하는 데 사용할 열을 클릭 하 고 기본 키로 설정 하려면 PK 확인란을 선택 합니다.

      5. 개체 관계 또는 엔터티 관계 스텐실에서 관계 셰이프를 끌어 하 고 페이지의 빈 공간에 놓습니다.

      6. 높은 끝 부모 테이블이 포함 된 테이블에 연결 합니다.

      7. 다른 쪽 끝 자식 테이블에 연결 합니다.

        두 번째 테이블의 기본 키로 같은 이름의 열 없으면 모델러 추가 두 번째 테이블의 외래 키로 합니다.

        참고: 관계 선이 사라지면 데이터베이스 탭에서 관리 그룹에서 표시 옵션 을 클릭 합니다. 관계 탭의 표시 에서 관계 확인란을 선택 합니다.

    2. 관계의 카디널리티를 설정 합니다.

      1. 관계를 두 번 클릭 합니다.

      2. 데이터베이스 속성 창에서 범주기타 를 클릭 합니다.

      3. 카디널리티 관계에 가장 적합 한 카디널리티를 선택 합니다. 일대다 관계 0 이상 또는 하나 이상의 가장 좋은 방법이입니다. 일대일 관계에 대 한 가장 좋은 방법은 0 이상 또는 정확히 1 입니다.

  3. (예: 인덱스, 검사 절 및 트리거 만들기) 다이어그램에 다른 구체화 하려면 다음을 수행할 수 있습니다.

    인덱스 만들기

    인덱스가 성능 또는 쿼리를 실행 하 여 데이터베이스의 속도 향상 됩니다.

    1. 데이터베이스 모델 다이어그램을 엽니다.

    2. 인덱스를 추가할 테이블을 두 번 클릭 하 고 범주 목록에서 데이터베이스 속성 창에서 인덱스 를 클릭 합니다.

    3. 새로 만들기를 클릭합니다.

    4. 인덱스 만들기 대화 상자에서 인덱스의 이름을 입력 한 다음 확인 을 클릭 합니다.

    5. 인덱스 형식 목록에서 또는 아닌 고유 인덱스를 만들려면 옵션을 선택 합니다.

    6. 사용 가능한 열 목록에서 다음을 클릭 하 고이 인덱스에 포함 하려는 각 열의 이름을 선택 추가 > 합니다.

    7. 인덱싱된 열 목록에서 인덱스를 오름차순으로 정렬 순서를 만들려면 Asc 확인란을 선택 하거나 내림차순 정렬 된 인덱스를 만들려면 확인란의 선택을 취소 합니다.

      데이터베이스 모델 다이어그램 업데이트 됩니다.

    보기 만들기

    보기를 저장된 한 쿼리 생각할 수 있습니다. 보기는 반복 해 서 여러 테이블에서 동일한 정보에 액세스 해야 할 경우 또는 실제 테이블을 변경 하지 않고 사용자에 게 데이터를 표시 하려는 경우 더욱 간편 하 게 됩니다.

    엔터티 관계 또는 개체 관계 스텐실에서 셰이프를 드로잉 페이지로 끌어다 놓습니다.

    테이블 및 뷰 확장된 속성 설정

    데이터베이스 관리 시스템 (DBMS)에 따라 테이블 또는 저장 위치를 확인 하려면 보기에 대 한 확장된 속성을 설정할 수 있습니다.

    테이블을 두 번 클릭 하거나 확장된 속성을 설정 하 고, 보고 범주 목록에서 데이터베이스 속성 창에서 확장 을 클릭 합니다.

    검사 절 만들기

    검사 절을 사용 하 여 열에 입력 된 데이터 값의 특정 범위 내의 인지 확인 합니다. 예를 들어 "기간을" 넘는 65 라는 열에서 데이터를 필요로 하는 검사 절을 만들 수 있습니다.

    1. 데이터베이스 속성 창을 열려면 테이블을 두 번 클릭 합니다.

    2. 범주 을 클릭 한 다음 검사 절을 추가 하려면 열을 클릭 합니다.

    3. 편집을 클릭합니다.

    4. 열 속성 대화 상자의 검사 탭에서 원하는 제약 조건을 입력 합니다.

      검사 절 코드 창의 로컬 코드 에 추가 됩니다.

    저장된 프로시저 및 사용자 정의 함수 만들기

    저장된 프로시저 및 사용자 정의 함수를 사용 하 여 동일한 작업을 반복적으로 수행 하는 다시 사용할 수 있는 코드 패킷을 만들 수 있습니다. 하지만 값을 반환 하지 않고 코드를 실행 하는 저장된 프로시저의 주된 차이점 두 개의 사용자 정의 함수 값을 반환 합니다.입니다.

    1. 데이터베이스 탭의 표시/숨기기 그룹에서 코드 창을 열려면 코드 확인란을 선택 합니다.

    2. 전역 코드 를 클릭 한 다음 새로 만들기 를 클릭 합니다.

    3. 코드 편집기속성 탭, 만들려는 코드의 종류를 클릭 하 고 코드의 이름을 입력 합니다.

    4. 본문 탭의 코드를 입력 한 다음 확인 을 클릭 합니다.

    트리거 만들기

    트리거는 데이터베이스에서 특정 이벤트가 발생할 때 실행할 트리거에 지정 된 SQL 코드를 발생 합니다.

    1. 데이터베이스 속성 창을 열려면 테이블을 두 번 클릭 합니다.

    2. 범주 트리거 를 클릭 한 다음 추가 클릭 합니다.

    3. 속성 탭에서 트리거 이름을 입력 합니다.

    4. 본문 탭의 코드를 입력 한 다음 확인 을 클릭 합니다.

      트리거 코드 창의 로컬 코드 에 추가 됩니다.

이 문서에서는 데이터베이스 모델을 만드는 방법 및 수행할 수 있는 모델이 포함 된를 만든 후에 대해 설명 합니다. 파일 메뉴에서 빠른 시작에 대 한 새로 만들기 를 가리킨 소프트웨어 및 데이터베이스를 가리킨 다음 데이터베이스 모델 다이어그램 을 클릭 합니다.

데이터베이스 모델 기능을 찾을 수 없는 경우

대부분의 경우 중인 Microsoft Office Visio 버전에 원하는 기능 포함 되지 않습니다. 있는 Visio의 버전을 알아보려면 도움말 메뉴에서 Microsoft Office Visio 정보 를 클릭 합니다. 대화 상자에서 텍스트의 첫 줄에는 버전의 이름이 나타납니다.

  • Microsoft Office Standard Visio에서 데이터베이스 모델 다이어그램 템플릿을 포함 되지 않습니다.

  • Microsoft Office Visio Professional (즉, 기존 데이터베이스를 사용 하 여 Visio에서 모델을 만드는) 데이터베이스 모델 다이어그램 서식 파일에 대 한 리버스 엔지니어링 기능을 지원 하지만 전달 공학 (을 사용 하 여 Visio 데이터베이스를 지원 하지 않습니다. SQL 코드를 생성할 모델)입니다.

  • 데이터베이스의 전체 제품군을 엔터프라이즈 설계자에 대 한 Visio에서 리버스 엔지니어링 및 앞으로 공학을 비롯 한 모델링 기능을 찾을 수 있습니다. 엔터프라이즈 설계자에 대 한 Visio Visual Studio Professional 및 Visual Studio Team System 역할 기반 버전에서 사용할 수는 MSDN Premium 구독에 포함 됩니다.

  1. 데이터베이스 모델 다이어그램을 시작 하려면 다음 중 하나를 실행 합니다.

    처음부터 새 모델 다이어그램 만들기

    시작 지점으로 사용 하려면 기존 데이터베이스를가 없는 경우 빈 데이터베이스 모델을 사용 하 여 시작 한 테이블 및 관계 추가 수 있습니다.

    1. 파일 메뉴에서 새로 만들기 를 가리킨 소프트웨어 및 데이터베이스를 가리킨 다음 데이터베이스 모델 다이어그램 을 클릭 합니다.

    2. 데이터베이스 메뉴에서 옵션 을 가리킨 다음 문서 를 클릭 합니다.

    3. 데이터베이스 문서 옵션 대화 상자에서 기호 집합을 사용 하 고 다른 테이블 및 관계 옵션을 선택한 다음 확인 을 클릭 합니다.

    기존 데이터베이스 시작 점으로 사용

    데이터베이스를 모델링 더 나은 이해 하거나 새 모델에 대 한 시작 지점으로 사용할 수 있도록 하려는 경우 스키마 또는 데이터베이스의 구조를 추출 하 고 새 모델을 작성 하 리버스 엔지니어링 마법사를 사용할 수 있습니다.

    참고: 마법사를 시작 하기 전에

    1. 역방향 인 경우 마법사를 시작 하기 전에 Microsoft Office Excel 통합 문서를 엔지니어링 해야 통합 문서를 열고 열 머리글이 포함 된 셀의 그룹 (또는 범위)의 이름을 지정 합니다. 하나 이상의 워크시트를 사용 하려는 경우 각 워크시트에 있는 열의 셀 그룹의 이름을 합니다. 이러한 범위 마법사의 테이블 처럼 처리 됩니다. 셀 범위의 이름을 지정 하는 방법에 대 한 자세한 내용은 Microsoft Office Excel에서 명명 된 셀 참조 또는 범위 제목된 정의 하는 데 도움이 항목을 참조 합니다.

    2. 최상의 결과 위해 기본 드라이버 리버스 엔지니어링 마법사를 실행 하기 전에 리버스 엔지니어링 하려는 대상 데이터베이스를 설정 합니다. 이렇게 하면 마법사가 원시 데이터 형식을 올바르게 매핑하고 마법사에서 추출 된 모든 코드가 코드 창에 올바르게 표시 됩니다.

    3. 파일 메뉴에서 새로 만들기 를 가리킨 소프트웨어 및 데이터베이스를 가리킨 다음 데이터베이스 모델 다이어그램 을 클릭 합니다.

    4. 데이터베이스 메뉴에서 리버스 엔지니어링 을 클릭 합니다.

    5. 리버스 엔지니어링 마법사의 첫 번째 화면에서 다음을 수행 합니다.

      1. 데이터베이스 관리 시스템 (DBMS)에 대 한 Microsoft Office Visio 데이터베이스 드라이버를 선택 합니다. 특정 ODBC 데이터 원본으로 Visio 데이터베이스 드라이버를 이미 연결 하지 않은 경우 설치 프로그램 을 클릭 합니다.

        참고: Excel 워크시트를 리버스 엔지니어링 경우 ODBC 일반 드라이버를 선택 합니다.

      2. 업데이트 하는 데이터베이스의 데이터 원본을 선택 합니다. 기존 데이터베이스에 대 한 데이터 원본을 아직 만들지 않은 경우 않았다면 지금 새로 만들기 클릭 합니다.

        새 출처를 만들면 해당 이름은 데이터 원본 목록에 추가 됩니다.

      3. 설정, 끝나면 다음 을 클릭 합니다.

    6. 모든 관련 드라이버 대화 상자에서 지침을 따릅니다.

      예를 들어 데이터 원본 연결 대화 상자에서 사용자 이름 및 암호를 입력 한 다음 확인 을 클릭 합니다. 데이터 원본에 암호로 보호 된 경우 바로 확인 을 클릭 합니다.

      참고: ODBC 일반 드라이버를 사용 하는 경우 리버스 엔지니어링 된 정보가 완료 되지 않는 없다는 오류 메시지가 나타날 수 있습니다. 대부분의 경우에서이 문제가 되지 않습니다- 확인 을 클릭 하 고 마법사를 계속 합니다.

    7. 추출 하려는 정보의 형식에 대 한 확인란을 선택 하 고 을 클릭 합니다.

      참고: 일부 항목을 사용할 수 없는 (회색으로 표시) 모든 데이터베이스 관리 시스템 모든 종류의 마법사를 추출할 수 있는 요소를 지원 합니다.

    8. 추출, 또는 모두 선택 추출한 클릭 하려는 테이블 (및 보기, 있는 경우)에 대 한 확인란을 선택 모두을 하 고 다음 을 클릭 합니다.

      참고: Excel 워크시트를 리버스 엔지니어링 되 고이 목록에 아무것도 표시 되지 않는 경우에 워크시트에 열 머리글이 포함 된 셀 범위의 이름을 지정 해야 할 가능성이 합니다.

    9. 5 단계에서 저장 프로시저 확인란을 선택한 경우, 추출 하려는 프로시저 선택 하거나 모두 선택 추출한 클릭 모두을 하 고 다음 을 클릭 합니다.

    10. 현재 페이지에 자동으로 추가 되도록 리버스 엔지니어링 된 항목을 원하는 지 여부를 선택 합니다.

      참고: 마법사가 자동으로 나열 하는 테이블 및 뷰 창에서 리버스 엔지니어링 된 항목에 드로잉을 추가로 만듭니다를 선택할 수 있습니다. 자동으로 만들어진 드로잉이 하지 않으려는 경우 수동으로 데이터베이스 모델을 조합 하 여 드로잉 페이지로 끌어다 놓습니다 테이블 및 뷰 창에서 항목을 끌 수 있습니다.

    11. 하 고 완료 를 클릭 한 다음 정보를 추출 하 고 있는지 확인 하 여 선택 항목을 검토 합니다.

      마법사의 선택한 정보를 추출 및 출력 창에 추출 과정에 대 한 메모를 표시 합니다.

    기존 모델 구체화 및 가져오기

    기존 VisioModeler 또는 백 금 ERwin 모델 사이트가 있는 경우 Visio 데이터베이스 모델 다이어그램을 가져올 수 있습니다. 이 기능은 VisioModeler 2.0 또는 이후 사전 모델 (.imd) 파일 및 2.6, 3.0 및 3.52 플래티넘 ERwin.erx 파일 제한 됩니다.

    1. 파일 메뉴에서 새로 만들기 를 가리킨 소프트웨어 및 데이터베이스를 가리킨 다음 데이터베이스 모델 다이어그램 을 클릭 합니다.

    2. 데이터베이스 메뉴에서 가져오기, 가리킨 다음 < 모델 형식 > 가져오기 를 클릭 합니다.

    3. 가져오거나 모델 파일을 찾은 찾아보기 단추를 클릭 하려는 모델에 대 한 경로 파일 이름을 입력 한 다음 열기 를 클릭 합니다.

    4. 가져오기 대화 상자에서 확인 을 클릭 합니다.

      Visio 파일을 가져옵니다를 출력 창에 해당 진행률을 표시 합니다. 가져온된 테이블 테이블 및 뷰 창에 표시 됩니다.

    5. 테이블 및 뷰 창에서 모델을 추가할 테이블을 선택 하 고 드로잉 페이지로 끌어다 놓습니다.

  2. 데이터베이스 모델 다이어그램을 만든 후 다이어그램을 구체화 작업을 시작 합니다. 수 추가 하 고 테이블 및 뷰를 사용자 지정, 관계를 만들고 열과 데이터 형식 사용자 지정 합니다.

    테이블

    엔터티 셰이프를 사용 하 여 다이어그램에서 테이블을 만들 수 있습니다.

    1. 엔터티 관계 또는 개체 관계 스텐실에서 드로잉 엔터티 셰이프를 끌어다 놓습니다.

    2. 데이터베이스 속성 창을 열려면 도형을 두 번 클릭 합니다.

    3. 범주 정의 클릭 하 고 테이블의 이름을 입력 합니다.

    4. 범주 을 클릭 하 고 이름을 입력 데이터 형식을 선택 합니다.

    5. Null 값을 가질 수 없는 열에 대 한 필수 확인란을 선택 합니다.

    6. 데이터베이스 테이블의 각 행을 고유 하 게 식별 하는 열에 대 한 PK (기본 키) 확인란을 선택 합니다.

    7. 범주 인덱스, 트리거, 확인 또는 확장 이러한 선택적 요소 만들기를 클릭 합니다.

    데이터 형식 및 기본 키를 포함 하 여 열에 대 한 속성을 추가 하거나 변경할 데이터베이스 속성 창을 사용 합니다.

    1. 다이어그램에서 테이블을 두 번 클릭 합니다.

    2. 데이터베이스 속성 창에서 범주 을 클릭 합니다.

    3. 첫 번째 빈 실제 이름 을 클릭, 셀 및 이름을 입력 합니다.

    4. 열에 대 한 데이터 형식을 변경 하려면 해당 열의 데이터 형식 필드를 클릭 한 다음 목록에서 데이터 형식을 선택 또는 목록에 입력 합니다. 예를 들어 decimal(8,2) 또는 char(30)입력할 수 있습니다.

    5. Null 값을 방지 하기 위해 필수 확인란을 선택 합니다.

    6. 열이 기본 키를 지정 하려면 PK 확인란을 선택 합니다.

    7. 범주를 클릭 하면 나타나는 것 외에도 추가 열 속성을 보려면 열을 선택 하 고 편집 을 클릭 합니다.

    관계

    관계 기본 키 및 외래 키를 사용 하 여 관련된 테이블의 행과 단일 테이블에서 행과 일치 하는 데이터베이스를 허용 하도록 합니다. 다이어그램에서 해당 관계를 표시할 수 있습니다. 카디널리티 (예를 들어-일대다)를 설정 하 고 Crow의 피트, 관계형 또는 IDEF1X 사용 수 또한 표시법 카디널리티를 표시할 수 있습니다. 데이터베이스 모델 다이어그램 서식 파일에서 이러한 표시법 중 하나를 사용 하려면 다대다 관계를 표시할 수 없습니다.

    1. 테이블 간의 관계를 만듭니다.

      1. 두 테이블의 다이어그램에 표시 되어 있는지 확인 합니다. 리버스 엔지니어링 기존 데이터베이스에서 모델을 하나 또는 둘 다 테이블 및 뷰 창에서 드로잉 페이지로 끌어 할 수 있습니다.

      2. 관계의 기본 키 쪽에 사용할 테이블을 두 번 클릭 합니다.

      3. 데이터베이스 속성 창에서 범주 을 클릭 합니다.

      4. 눈금에서 각 테이블의에서 행을 고유 하 게 식별 하는 데 사용할 열을 클릭 하 고 기본 키로 설정 하려면 PK 확인란을 선택 합니다.

      5. 개체 관계 또는 엔터티 관계 스텐실에서 관계 셰이프를 끌어 하 고 페이지의 빈 공간에 놓습니다.

      6. 높은 끝 부모 테이블이 포함 된 테이블에 연결 합니다.

      7. 다른 쪽 끝 자식 테이블에 연결 합니다.

        두 번째 테이블의 기본 키로 같은 이름의 열 없으면 모델러 추가 두 번째 테이블의 외래 키로 합니다.

        참고: 관계 선이 사라지면 데이터베이스 메뉴에서 옵션 을 가리킨 다음 문서 를 클릭 합니다. 관계 탭의 표시 에서 관계 확인란을 선택 합니다.

    2. 관계의 카디널리티를 설정 합니다.

      1. 관계를 두 번 클릭 합니다.

      2. 데이터베이스 속성 창에서 범주기타 를 클릭 합니다.

      3. 카디널리티 관계에 가장 적합 한 카디널리티를 선택 합니다. 일대다 관계 0 이상 또는 하나 이상의 가장 좋은 방법이입니다. 일대일 관계에 대 한 가장 좋은 방법은 0 이상 또는 정확히 1 입니다.

  3. (예: 인덱스, 검사 절 및 트리거 만들기) 다이어그램에 다른 구체화 하려면 다음을 수행할 수 있습니다.

    인덱스 만들기

    인덱스가 성능 또는 쿼리를 실행 하 여 데이터베이스의 속도 향상 됩니다.

    1. 데이터베이스 모델 다이어그램을 엽니다.

    2. 인덱스를 추가할 테이블을 두 번 클릭 하 고 범주 목록에서 데이터베이스 속성 창에서 인덱스 를 클릭 합니다.

    3. 새로 만들기를 클릭합니다.

    4. 인덱스 만들기 대화 상자에서 인덱스의 이름을 입력 한 다음 확인 을 클릭 합니다.

    5. 인덱스 형식 목록에서 또는 아닌 고유 인덱스를 만들려면 옵션을 선택 합니다.

    6. 사용 가능한 열 목록에서 다음을 클릭 하 고이 인덱스에 포함 하려는 각 열의 이름을 선택 추가 > 합니다.

    7. 인덱싱된 열 목록에서 인덱스를 오름차순으로 정렬 순서를 만들려면 Asc 확인란을 선택 하거나 내림차순 정렬 된 인덱스를 만들려면 확인란의 선택을 취소 합니다.

      데이터베이스 모델 다이어그램 업데이트 됩니다.

    보기 만들기

    보기를 저장된 한 쿼리 생각할 수 있습니다. 보기는 반복 해 서 여러 테이블에서 동일한 정보에 액세스 해야 할 경우 또는 실제 테이블을 변경 하지 않고 사용자에 게 데이터를 표시 하려는 경우 더욱 간편 하 게 됩니다.

    엔터티 관계 또는 개체 관계 스텐실에서 셰이프를 드로잉 페이지로 끌어다 놓습니다.

    테이블 및 뷰 확장된 속성 설정

    데이터베이스 관리 시스템 (DBMS)에 따라 테이블 또는 저장 위치를 확인 하려면 보기에 대 한 확장된 속성을 설정할 수 있습니다.

    테이블을 두 번 클릭 하거나 확장된 속성을 설정 하 고, 보고 범주 목록에서 데이터베이스 속성 창에서 확장 을 클릭 합니다.

    검사 절 만들기

    검사 절을 사용 하 여 열에 입력 된 데이터 값의 특정 범위 내의 인지 확인 합니다. 예를 들어 "기간을" 넘는 65 라는 열에서 데이터를 필요로 하는 검사 절을 만들 수 있습니다.

    1. 데이터베이스 속성 창을 열려면 테이블을 두 번 클릭 합니다.

    2. 범주 을 클릭 한 다음 검사 절을 추가 하려면 열을 클릭 합니다.

    3. 편집을 클릭합니다.

    4. 열 속성 대화 상자의 검사 탭에서 원하는 제약 조건을 입력 합니다. 선택 사항에 대 한 자세한 내용은 열 및 필드 속성 대화 상자 (검사 탭)을참조 하십시오.

      검사 절 코드 창의 로컬 코드 에 추가 됩니다.

    저장된 프로시저 및 사용자 정의 함수 만들기

    저장된 프로시저 및 사용자 정의 함수를 사용 하 여 동일한 작업을 반복적으로 수행 하는 다시 사용할 수 있는 코드 패킷을 만들 수 있습니다. 하지만 값을 반환 하지 않고 코드를 실행 하는 저장된 프로시저의 주된 차이점 두 개의 사용자 정의 함수 값을 반환 합니다.입니다.

    1. 데이터베이스 메뉴에서 보기 를 가리킨 다음 코드 의 코드 창 열기를 클릭 합니다.

    2. 전역 코드 를 클릭 한 다음 새로 만들기 를 클릭 합니다.

    3. 코드 편집기속성 탭, 만들려는 코드의 종류를 클릭 하 고 코드의 이름을 입력 합니다.

    4. 본문 탭의 코드를 입력 한 다음 확인 을 클릭 합니다.

    트리거 만들기

    트리거는 데이터베이스에서 특정 이벤트가 발생할 때 실행할 트리거에 지정 된 SQL 코드를 발생 합니다.

    1. 데이터베이스 속성 창을 열려면 테이블을 두 번 클릭 합니다.

    2. 범주 트리거 를 클릭 한 다음 추가 클릭 합니다.

    3. 속성 탭에서 트리거 이름을 입력 합니다.

    4. 본문 탭의 코드를 입력 한 다음 확인 을 클릭 합니다.

      트리거 코드 창의 로컬 코드 에 추가 됩니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×