데이터베이스 개체 미리 보기 및 인쇄

이 문서에서는 Microsoft Office Access 2007에서 사용할 수 있는 여러 가지 미리 보기 및 인쇄 옵션을 보여 주고 테이블, 폼 또는 보고서의 레코드 전체 또는 일부를 인쇄하는 방법을 설명합니다. 또한 테이블 관계와 코드 모듈 등의 기타 정보를 인쇄하는 방법에 대해서도 살펴봅니다.

실행할 작업

인쇄 옵션 살펴보기

미리 보지 않고 인쇄

미리 본 후 인쇄

인쇄 옵션 설정

데이터시트에서 인쇄

피벗 테이블 또는 피벗 차트 보기 인쇄

폼에서 데이터 인쇄

보고서에서 데이터 인쇄

인쇄 옵션 살펴보기

Office Access 2007에는 인쇄하는 대상을 관리하는 데 사용할 수 있는 다양한 명령이 있습니다. 예를 들어 빠른 인쇄 명령을 사용하여 인쇄 설정에 대한 변경 없이 데이터시트, 폼, 보고서 또는 매크로를 기본 프린터로 전송하거나, 인쇄 명령을 사용하여 프린터, 인쇄 매수, 용지 방향 및 기타 인쇄 옵션을 설정할 수 있습니다. 인쇄 명령을 사용하면 개체를 인쇄하기 전에 레이아웃을 변경하거나 보기 좋게 만들 수 있습니다. 또한 인쇄 미리 보기 명령을 사용하면 인쇄 페이지에 데이터가 어떻게 표시될지 보거나, 여백을 변경하고 데이터만 인쇄하도록 설정하고 열 설정을 변경하는 등 인쇄하기 전에 여러 가지 변경 사항을 적용할 수 있습니다.

참고: VBA(Visual Basic for Applications) 코드 모듈을 인쇄할 때는 인쇄 미리 보기를 사용할 수 없습니다.

맨 위로 이동

미리 보지 않고 인쇄

인쇄 모양을 미리 확인하지 않고 개체를 빠르게 인쇄하려면 빠른 인쇄 명령을 사용하여 기본 설정으로 인쇄하거나 인쇄 명령을 사용하여 프린터 또는 인쇄 매수를 선택하는 등 기본적인 인쇄 설정을 변경한 후 인쇄합니다.

  • Microsoft Office 단추 Office 단추 이미지 를 클릭하고 인쇄를 가리킨 다음 빠른 인쇄를 클릭합니다.

개체를 인쇄하기 전에 인쇄 설정을 변경하려면 인쇄 명령을 사용합니다.

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 인쇄를 클릭합니다.

  2. 인쇄 대화 상자에서 원하는 옵션을 선택합니다.

맨 위로 이동

미리 본 후 인쇄

테이블과 쿼리, 폼, 보고서 및 매크로의 데이터시트를 해당 개체가 보기에 열려 있는 동안 미리 보거나 탐색 창에서 직접 미리 보려면 다음 단계를 실행합니다.

  1. 탐색 창에서 미리 볼 개체를 클릭합니다.

  2. Microsoft Office 단추 Office 단추 이미지 를 클릭하고 인쇄를 가리킨 다음 인쇄 미리 보기를 클릭합니다.

    인쇄 미리 보기에 개체가 열리고 리본 메뉴에 인쇄 미리 보기 탭이 추가됩니다.

테이블 관계 다이어그램 미리 보기

Access에서는 데이터베이스 테이블 간의 관계에 대한 시각적인 보고서를 만들 수 있습니다. 관계 보고서를 만들면 해당 보고서가 인쇄 미리 보기에 자동으로 표시됩니다.

  1. 데이터베이스 도구 탭의 표시/숨기기 그룹에서 관계를 클릭합니다.

    관계 탭이 나타나고 현재 데이터베이스의 테이블이 표시됩니다. 테이블 사이에 관계가 있는 경우에는 이러한 관계도 함께 표시됩니다.

  2. 디자인 탭의 도구 그룹에서 관계 보고서를 클릭합니다.

    테이블 관계 보고서의 인쇄 미리 보기

    인쇄 미리 보기 탭의 페이지 레이아웃 그룹에 있는 컨트롤을 사용하여 인쇄 옵션을 변경합니다.

    페이지 레이아웃 그룹 `

    예를 들어 여백을 클릭하여 인쇄 작업의 여백을 설정하거나 변경하고 세로 또는 가로를 클릭하여 페이지 방향을 변경합니다.

테이블 정의 인쇄

데이터베이스에 테이블이 여러 개 있는 경우 데이터베이스 구조 분석 기능을 사용하여 레코드에 대한 테이블 정의를 인쇄할 수 있습니다.

데이터베이스 구조 분석 사용

구조 분석할 개체 유형뿐만 아니라 구조 분석할 구체적인 개체도 선택할 수 있습니다.

  1. 데이터베이스 도구 탭의 분석 그룹에서 데이터베이스 구조 분석 단추 이미지 을 클릭합니다.

    데이터베이스 구조 분석 대화 상자가 나타납니다.

  2. 구조 분석할 개체에 해당하는 탭을 선택합니다.

    예를 들어 쿼리 탭을 클릭하여 데이터베이스의 쿼리에 대한 보고서를 만들 수 있습니다.

  3. 구조 분석할 개체를 선택한 다음 확인을 클릭합니다.

데이터베이스 구조 분석을 실행하면 보고서가 생성되어 인쇄 미리 보기에서 자동으로 열립니다.

맨 위로 이동

인쇄 옵션 설정

  1. 개체가 열려 있지 않은 경우 탐색 창에서 개체를 선택합니다.

  2. Microsoft Office 단추 Office 단추 이미지 를 클릭하고 인쇄를 가리킨 다음 인쇄 미리 보기를 클릭합니다.

    인쇄 미리 보기 열기

    인쇄 미리 보기에 개체가 열리고 리본 메뉴에 인쇄 미리 보기 탭이 추가됩니다.

  3. 페이지 레이아웃 그룹에서 사용할 명령을 클릭합니다.

    예를 들어 여백을 클릭하여 인쇄 작업의 여백을 설정하거나 변경합니다. 또는 가로를 클릭하거나 세로(현재 가로로 설정되어 있는 경우)를 클릭하여 페이지 방향을 변경합니다.

    참고: 프린터 선택, 인쇄 범위 설정, 인쇄 매수 선택 등과 같이 페이지 레이아웃 그룹의 명령으로는 변경할 수 없는 옵션을 변경해야 할 경우에는 인쇄 그룹에서 인쇄를 클릭한 다음 인쇄 대화 상자에서 옵션을 선택하십시오.  

코드 모듈의 인쇄 옵션 설정

  1. 탐색 창에서 인쇄할 모듈을 마우스 오른쪽 단추로 클릭한 다음 바로 가기 메뉴에서 디자인 보기를 클릭합니다. 그러면 Visual Basic Editor가 시작됩니다.

    코드 모듈의 인쇄 옵션 설정

  2. 파일 메뉴에서 인쇄를 클릭합니다.

  3. 인쇄 대화 상자에서 설정을 클릭합니다.

  4. 인쇄 설정 대화 상자에서 원하는 옵션을 선택한 다음 확인을 클릭합니다.

맨 위로 이동

데이터시트에서 인쇄

    1. 데이터시트 전체를 인쇄하려면 탐색 창에서 인쇄할 테이블이나 쿼리를 두 번 클릭합니다.

    2. 데이터시트의 하위 데이터시트도 인쇄하려면 인쇄할 각 하위 데이터시트의 각 행 옆에 있는 확장 표시기(+)를 클릭합니다.

      하위 데이터시트를 모두 확장하면 예기치 않게 많은 페이지가 인쇄될 수 있으므로 인쇄하기 전에 하위 데이터시트의 개수를 확인하십시오.

    3. Microsoft Office 단추 Office 단추 이미지 를 클릭하고 인쇄를 가리킨 후 다음 중 하나를 실행합니다.

      • 인쇄 대화 상자의 설정을 변경하려면 인쇄를 클릭한 다음 원하는 옵션을 선택합니다.

        데이터시트에서 일부 레코드 인쇄

      • 데이터시트의 레코드 중 일부만 인쇄하려면 인쇄할 레코드를 선택합니다. 다음 표에서는 데이터시트에서 데이터나 레코드를 선택하는 절차를 설명합니다.

선택 대상

실행 방법

필드에 있는 데이터

선택할 데이터를 마우스로 끕니다.

전체 필드

포인터가 더하기 포인터 더하기 포인터 로 바뀌는 지점인 데이터시트 필드의 왼쪽 가장자리를 클릭합니다.

인접한 필드

필드의 왼쪽 가장자리를 클릭한 다음 끌어서 원하는 레코드를 모두 선택합니다.

열 머리글을 클릭합니다.

인접한 열

열의 맨 위에 있는 필드 이름을 클릭한 다음 끌어서 원하는 열을 모두 선택합니다.

레코드

언어 설정에 따라 행의 왼쪽 또는 오른쪽에 사각형으로 표시되는 레코드 선택기를 클릭합니다. 레코드 선택기가 표시되지 않는 경우 Shift+스페이스바를 누릅니다. 

여러 레코드

첫 번째 레코드의 레코드 선택기를 클릭한 다음 끌어서 원하는 레코드를 모두 선택합니다.

모든 레코드

탭의 찾기 그룹에서 선택 옆의 아래쪽 화살표를 클릭한 다음 모두 선택 단추 이미지 을 클릭합니다.

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 인쇄를 클릭합니다.

    인쇄 대화 상자가 나타납니다.

  2. 인쇄 범위에서 선택한 레코드를 클릭합니다.

맨 위로 이동

피벗 테이블 또는 피벗 차트 보기 인쇄

데이터베이스에 인쇄할 피벗 테이블 보기 또는 피벗 테이블 보기피벗 차트 보기가 포함되어 있으면 다음 단계를 실행합니다.

  1. 탐색 창에서 인쇄할 개체를 두 번 클릭합니다.

  2. 탭의 보기 그룹에서 보기의 아래쪽 화살표를 클릭한 다음 피벗 테이블 보기 또는 피벗 차트 보기를 클릭합니다.

  3. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 인쇄를 클릭합니다.

맨 위로 이동

폼에서 데이터 인쇄

일부 폼은 인쇄했을 때 컨트롤 및 회사 로고와 같은 레이아웃 구성 요소가 데이터와 함께 인쇄됩니다. 이러한 레이아웃 구성 요소가 인쇄되는지 여부는 인쇄 형식/Layout for Print 속성 설정에 따라 달라집니다. 인쇄 형식/Layout For Print 속성이 예/Yes로 설정되어 있는 경우 데이터만 인쇄하려면 설정을 아니요/No로 변경합니다. 인쇄 형식/Layout For Print아니요/No로 설정하면 폼이나 보고서의 디자인에 따라 데이터 위치가 달라집니다. 폼을 올바르게 인쇄하려면 인쇄 미리 보기에서 폼을 연 다음 필요에 따라 인쇄 옵션을 설정하거나 변경해야 합니다.

폼이나 보고서 인쇄

  1. 탐색 창에서 인쇄할 폼 또는 보고서를 선택합니다.

  2. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 인쇄를 클릭합니다.

  3. 인쇄 대화 상자에서 원하는 인쇄 옵션을 선택한 다음 확인을 클릭합니다.

폼의 개별 레코드 인쇄

폼에 데이터시트(하위 폼 또는 하위 보고서)가 포함되어 있는 경우에는 개별 레코드를 선택하여 인쇄할 수 있습니다.

  1. 탐색 창에서 인쇄할 폼을 두 번 클릭합니다.

  2. 폼의 데이터시트 구역에서 인쇄할 특정 레코드를 선택합니다.

    다음 절차에 따라 데이터시트에서 데이터나 레코드를 선택할 수 있습니다.

선택 대상

실행 방법

필드에 있는 데이터

선택할 데이터를 마우스로 끕니다.

전체 필드

포인터가 더하기 포인터 더하기 포인터 로 바뀌는 지점인 데이터시트 필드의 왼쪽 가장자리를 클릭합니다.

인접한 필드

필드의 왼쪽 가장자리를 클릭한 다음 끌어서 원하는 레코드를 모두 선택합니다.

열 머리글을 클릭합니다.

인접한 열

열의 맨 위에 있는 필드 이름을 클릭한 다음 끌어서 원하는 열을 모두 선택합니다.

레코드

언어 설정에 따라 행의 왼쪽 또는 오른쪽에 사각형으로 표시되는 레코드 선택기를 클릭합니다. 레코드 선택기가 표시되지 않는 경우 Shift+스페이스바를 누릅니다.

여러 레코드

첫 번째 레코드의 레코드 선택기를 클릭한 다음 끌어서 원하는 레코드를 모두 선택합니다.

모든 레코드

탭의 찾기 그룹에서 선택 옆의 아래쪽 화살표를 클릭한 다음 모두 선택 단추 이미지 을 클릭합니다.

  1. 원하는 레코드를 선택한 후 Microsoft Office 단추 Office 단추 이미지 를 클릭하고 인쇄를 클릭합니다.

    인쇄 대화 상자가 나타납니다.

  2. 인쇄 범위에서 선택한 레코드를 클릭합니다.

맨 위로 이동

보고서에서 데이터 인쇄

보고서를 인쇄하려면 데이터시트 또는 폼을 인쇄할 때와 동일한 기본 단계를 실행합니다. 그러나 데이터시트 또는 폼과는 달리 인쇄할 레코드를 선택할 수 없습니다. 보고서에서는 페이지 범위를 선택하는 방법으로만 인쇄 대상을 제한할 수 있습니다.

  1. Microsoft Office 단추 Office 단추 이미지 를 클릭한 다음 인쇄를 클릭합니다.

  2. 보고서에 있는 데이터의 일부만 인쇄하려면 인쇄 범위에서 인쇄할 페이지를 클릭한 다음 시작 상자에 값을 입력합니다.

    예를 들어 보고서의 5페이지만 인쇄하려면 시작 상자에 5를 입력합니다.

보고서의 디자인을 변경하는 데 필요한 권한이 있는 경우에는 페이지 설정 대화 상자(설정을 클릭하여 페이지 설정 대화 상자 표시)에서 인쇄 모양을 변경하여 보고서가 인쇄되는 방법을 추가적으로 변경할 수 있습니다.

다른 인쇄 옵션 사용

보고서의 데이터를 사용하여 3개 열 형식으로 우편물 레이블을 인쇄하는 것과 같이 특수한 형식으로 인쇄해야 하는 경우에는 페이지 설정 대화 상자를 사용하여 필요에 맞게 설정을 변경할 수 있습니다.

  1. 탐색 창에서 인쇄할 보고서를 선택합니다.

  2. Microsoft Office 단추 Office 단추 이미지 를 클릭하고 인쇄를 가리킨 다음 인쇄 미리 보기를 클릭합니다.

  3. 인쇄 미리 보기 탭의 페이지 레이아웃 그룹에서 페이지 설정을 클릭합니다.

  4. 페이지 설정 대화 상자에서 탭을 클릭하고 원하는 옵션을 선택한 다음 확인을 클릭합니다.

인쇄 미리 보기 및 인쇄에 대한 자세한 내용을 보려면 참고 항목 섹션에서 해당 링크를 클릭하십시오.

맨 위로 이동

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×