Топталған немесе жиынтық есеп жасау

Маңызды :  This article is machine translated, see the disclaimer. Please find the English version of this article here for your reference.

Information is often easier to understand when it is divided into groups. For example, a report that groups sales by region can highlight trends that otherwise might go unnoticed. In addition, placing totals at the end of each group in your report can replace a lot of manual interaction with a calculator.

Microsoft Office Access 2007 makes working with grouped reports easy. You can create a basic grouped report by using the Report Wizard, you can add grouping and sorting to an existing report, or you can revise grouping and sorting options that have already been defined.

Бұл мақалада

Understand grouping, report sections, and controls

Есеп шеберін пайдалана отырып жаңа топталған есепті құрастыру

Fine-tune your report

Add fields or other controls to an existing report

Бар есепте топтауды және сұрыптауды қосу немесе өзгерту

Save, print, or send your report

Ескертпелер

Understand grouping, report sections, and controls

If you're new to grouped reports, it helps to have some background on grouping and sorting, as well as the different report sections and types of controls. If you feel comfortable with these concepts already, you can skip this section and go to the section Build a new grouped report by using the Report Wizard.

About grouping and sorting

When you print a report, you usually want to organize the records in a particular order. For example, if you’re printing a list of suppliers, you might want to sort the records alphabetically by company name.

For many reports, sorting the records isn't enough. You may also want to divide them into groups. A group is a collection of records, along with any introductory and summary information displayed with the records, such as a header. A group consists of a group header, nested groups (if any), detail records, and a group footer.

Grouping allows you to separate groups of records visually and to display introductory and summary data for each group. For example, the following report groups sales by date shipped and calculates the total amount of sales for each day.

Қорытындысы бар топтастырылған есеп хат

1. The date introduces the group.

2. The total summarizes the group.

You can see how grouping works by comparing the List of Products by Category report (shown in the following illustration) to the datasheet for its underlying query, Product List. Both the report and the query sort products by category, but the report also prints the name of each category on a separate line at the beginning of each group (in the group header) and the number of products for each category on a separate line at the end of each group (in the group footer).

Өнімдерді санаттар бойынша топтастыратын есеп хат

1. The category name appears in every row in the datasheet.

2. The category name appears once for each group in the report, in the group header.

3. The total for the category appears at the end of each group, in the group footer.

4. The records appear as one large group in the datasheet.

5. The records for each category appear as a separate section in the report, preceded by a group header and followed by a group footer.

You can group on any fields and expressions you sort on (up to 10). You can group on the same field or expression more than once. When you group on more than one field or expression, Office Access 2007 nests the groups according to their group level. The first field you group on is the first and most significant group level; the second field you group on is the next group level; and so on. The following illustration shows how Office Access 2007 nests the groups.

Үстіңгі және төменгі дерек атауларының иерархиясы

1. Each group header is paired with a group footer.

You usually use a group header to display data that identifies the group in a separate section at the beginning of the group. You usually use a group footer to summarize the data in the group in a separate section at the end of the group.

Беттің жоғары бөлігі

About the report sections

In Access, the design of a report is divided into sections. To create useful reports, you need to understand how each section works. For instance, the section in which you choose to place a calculated control determines how Access calculates the results. The following list shows a summary of the section types and their uses.

  • Report Header    Printed once at the beginning of the report. Use the report header for information that might normally appear on a cover page, such as a logo, or a title and date. The report header prints before the page header. When you place a calculated control in the report header, the value is calculated for the entire report. For example, placing a control that uses the Sum aggregate function in the report header calculates the sum for the entire report.

  • Page Header    Printed at the top of every page. Use a page header, for example, to repeat the report title on every page.

  • Group Header    Printed at the beginning of each new group of records. Use the group header to print the group name. For example, in a report that is grouped by product, use the group header to print the product name. When you place a calculated control that uses the Sum aggregate function in the group header, the sum is for the current group.

  • Detail    Printed once for every row in the record source. The Detail section is where you place the controls that make up the main body of the report.

  • Group Footer    Printed at the end of each group of records. Use a group footer to print summary information for a group.

  • Page Footer    Printed at the end of every page. Use a page footer to print page numbers or per-page information.

  • Report Footer    Printed once at the end of the report. Use the report footer to print report totals or other summary information for the entire report.

    Ескерту : In Design view, the report footer appears below the page footer. However, when the report is printed or previewed, the report footer appears above the page footer, just after the last group footer or detail line on the final page.

Беттің жоғары бөлігі

About controls

Controls are objects that display data, perform actions, and let you view and work with information that enhances the user interface, such as labels and images. Access supports three types of controls: bound, unbound, and calculated. The following list shows a summary of these controls and their uses.

  • Bound control    A control whose source of data is a field in a table or query. You use bound controls to display values from fields in your database. The values can be text, dates, numbers, Yes/No values, pictures, or graphs. A text box is the most common type of bound control. For example, a text box in a form that displays an employee's last name might get this information from the Last Name field in the Employees table.

  • Unbound control    A control that doesn't have a source of data. You use unbound controls to display information, lines, rectangles, and pictures. For example, a label that displays the title of a report is an unbound control.

  • Calculated control    A control whose source of data is an expression rather than a field. You specify the value that you want in the control by defining an expression as the source of data for the control. An expression is a combination of operators (such as = and + ), control names, field names, functions that return a single value, and constant values. For example, the following expression calculates the price of an item with a 25 percent discount by multiplying the value in the Unit Price field by a constant value (.75).

= [Unit Price] * .75

An expression can use data from a field in the report's underlying table or query, or from a control on the report.

When you create a report, it's probably most efficient to add and arrange all the bound controls first, especially if they make up the majority of the controls on the report. You can then add the unbound and calculated controls that complete the design by using the tools in the Controls group of the Design tab.

Access таспасының суреті

You bind a control to a field by identifying the field from which the control gets its data. You can create a control that is bound to the selected field by dragging the field from the Field List pane to the report. (The Field List pane displays the fields of the report's underlying table or query. To display the Field List pane, do one of the following:

  • On the Design tab, in the Tools group, click Add Existing Field. Түймешік суреті

  • ALT+F8 пернелер тіркесімін басыңыз.

When you double-click a field or drag it from the Field List pane to the report, you create a bound control.

Alternatively, you can bind a field to a control by typing the field name in the control itself or in the box for the ControlSource value in the control's property sheet. The property sheet defines the characteristics of the control, such as its name, the source of its data, and its format. To display the property sheet, press F4.

Using the Field List pane is the best way to create a bound control for two reasons:

  • A bound control has an attached label, and the label takes the name of the field (or the caption defined for that field in the underlying table or query) as its caption by default, so you don't have to type the caption yourself.

  • A bound control inherits many of the same settings as the field in the underlying table or query (such as for the Format, DecimalPlaces, and InputMask properties). Therefore, you can be sure that these properties for the field remain the same whenever you create a control that is bound to that field.

If you already have an unbound control and want to bind it to a field, set the control's ControlSource property to the name of the field.

Беттің жоғары бөлігі

Есеп шеберін пайдалана отырып жаңа топталған есепті құрастыру

Есеп шебері бірқатар сұрақтарды береді, содан кейін жауаптарыңыздың негізінде есепті жасайды. Бұл сұрақтардың ішінде есепті топтау үшін пайдаланылатын өрісті немесе өрістерді сұрайтын сұрақ бар. Есеп жасалғаннан кейін оны бар күйінде пайдалануға немесе оны қажеттіліктеріңізге жақсырақ жарайтындай өзгертуге болады. Есеп шеберімен жұмысты бастау алдында деректер көзін таңдау керек.

Choose a record source

A report consists of information pulled from a table or query, and information stored with the report design, such as labels, headings, and graphics. The table or query that provides the underlying data is also known as the report's record source. Before you start creating your report, you should first think about the information you want to include. Among the fields you choose must be those you wish to group on or summarize. If the fields you want to include all exist in a single table, use that table as the record source. If the fields are pulled from more than one table, you'll want to use a query as the record source. That query may already exist in your database, or you may need to create a query specifically to fit the needs of your report.

To learn more about queries, follow the links in the See Also section of this article.

Есеп шеберін іске қосу

  1. On the Create tab, in the Reports group, click Report Wizard. Түймешік суреті

    Access бағдарламасы Есеп шебері құралын іске қосады.

    Есеп шеберіндегі өрісті таңдау

  2. Кестелер/сұраулар ашылмалы тізімін басып, есепте болуы керек өрістерді қамтитын кестені немесе сұрауды таңдаңыз.

  3. Қол жетімді өрістер тізіміндегі өрістерді екі рет басып таңдаңыз.

    Access оларды Таңдалған өрістер тізіміне жылжытады. Я болмаса, Қол жетімді өрістер жолағы мен Таңдалған өрістер жолағы арасында орналасқан түймешіктерді басып, таңдалған өрісті қосуға немесе жоюға я болмаса өрістердің барлығын қосуға немесе жоюға болады.

  4. Егер басқа кестеде немесе сұрауда есепке қосқыңыз келетін өрістер бар болса, Кестелер/сұраулар ашылмалы тізімін қайтадан басып, басқа кестені немесе сұрауды таңдап, өрістерді қосуды жалғастырыңыз.

  5. Өрістерді қосуды аяқтағаннан кейін Келесі пәрменін таңдаңыз.

Есеп шеберінде жазбаларды топтау

Топтау жазбаларды аймақ немесе сатушы сияқты топ бойынша жазбаларды реттеуге мүмкіндік береді. Топтарды кірістіруге болады, осылайша топтар арасындағы қатынастарды оңай анықтауға және қажет ақпаратты тез табуға болады. Сондай-ақ, топтауды қорытындылар және пайыздар сияқты жиынтық ақпаратты есептеу үшін пайдалануға болады.

Есепке бірнеше кестені қосқанда, шебер кестелер арасындағы қатынастарды қарап шығады және ақпаратты қалай көргіңіз келуі мүмкін екенін анықтайды.

  1. Қандай да топтау деңгейлерін қосу керек пе? деп сұрайтын есеп шеберінің бетінде тізімдегі өріс атауларының біреуін басыңыз да, Келесі пәрменін таңдаңыз.

  2. Топтау деңгейлерін қосу үшін тізімдегі өріс атауларының кез келгенін екі рет басып, есепке қосыңыз.

    Сондай-ақ, топтау деңгейін диалогтық терезенің оң жағындағы бет дисплейінде екі рет басу арқылы жоюға болады. Көрсеткі түймешіктерді пайдаланып топтау деңгейлерін қосыңыз және жойыңыз, таңдау және жоғары немесе төмен басымдық түймешіктерін басу арқылы топтау деңгейінің басымдығын реттеңіз. Access әр топтау деңгейін қосады және оны өзінің негізгі топтау деңгейінің ішінде кірістірілген етіп көрсетеді.

    Есеп шеберінде топтау деңгейлерін қосу

  3. Топтау параметрлері пәрменін таңдап Топтау аралықтары диалогтық терезесін көрсетіңіз.

    Есеп шеберіндегі топтау аралықтары

  4. Таңдау бойынша, әр топтау деңгейінің өрісі үшін топтау аралығын таңдаңыз.

    Топтау аралығы жазбаларды топтау жолын теңшеуге мүмкіндік береді. Алдыңғы суретте жазбалар Күн/Уақыт деректер түріне жататын ЖіберілгенКүні өрісі бойынша топталған. Есеп шебері Топтау аралықтары тізімінде өріс түріне тиісті таңдауларды ұсынады. Осылайша, ЖіберілгенКүні Күн/Уақыт түріне жататындықтан, нақты мән (Қалыпты), Жыл, Тоқсан, Ай, Апта, Күн, Сағат және Минут бойынша топтауды таңдауға болады. Егер өріс Мәтін деректер түріне жатқанда, бүкіл өріс (Қалыпты) бойынша немесе мүмкін бірінші бірден беске дейінгі таңбалар бойынша топтауды таңдай алатын едіңіз. Сандық деректер түрі үшін таңдалған артулармен мән (Қалыпты) бойынша немесе ауқым бойынша топтауды таңдауға болады.

    Топтау аралығын таңдағаннан кейін OK түймешігін басыңыз.

  5. Шебердің келесі бетіне өту үшін Келесі түймешігін басыңыз.

Жазбаларды сұрыптау және топтау

Жазбаларды төрт өріске дейін, артуы немесе кемуі ретімен сұрыптауға болады.

  1. Бірінші ашылмалы тізімді басып, сұрыптау үшін пайдаланылатын өрісті таңдаңыз.

    Артуы бойынша және кемуі бойынша реті арасында ажырата қосу үшін тізімнің оң жағындағы түймешікті басуға болады (Артуы бойынша — әдепкі параметр). Таңдау бойынша, қосымша сұрыптау өрістерін таңдау үшін екінші, үшінші және төртінші ашылмалы тізімдерді басыңыз.

    Есеп шеберіндегі сұрыптау реттері

  2. Сандық өрістердің кез келгенін топтау керек болса, Жиындар параметрлері пәрменін таңдаңыз.

    Жиындар параметрлері түймешігі тек егер есептің «Мәліметтер» бөлімінде бір немесе одан көп сандық өрістер бар болса ғана көрінетініне назар аударыңыз. Шебер қол жетімді сандық өрістерді көрсетеді.

    Есеп шеберіндегі жиындар параметрлері

  3. Таңдаған Қосынды, Орташа, Ең аз немесе Ең көп астында құсбелгіні қойып, сол есептеулерді топтың төменгі деректемесіне қосыңыз.

    Сондай-ақ, мәліметтерді және жиынтықты немесе тек жиынтықты көрсетуді таңдауға болады. Соңғы жағдайда, әр ЖіберілгенКүні мәнінің қорытындылары көрсетіледі (мысалы, егер Қосынды құсбелгісін қойған болсаңыз), бірақ тапсырыс мәліметтері өткізіп жіберіледі. Сондай-ақ, қосындылар үшін қорытынды есептеулерінің пайызын көрсетуді таңдауға болады.

  4. OK түймешігін басыңыз.

  5. Есеп шеберінің қалған беттеріндегі нұсқауларды орындаңыз. Соңғы бетте есеп тақырыбын өңдеуге болады. Бұл тақырып есептің бірінші бетінде көрсетіледі, сондай-ақ, Access тақырыпты құжат атауы ретінде пайдаланып есепті сақтайды. Тақырыпты және құжат атауын кейінірек өңдеуге болады.

  6. Дайын түймешігін басыңыз. Access бағдарламасы есепті автоматты түрде сақтайды және оны алдын ала қарауды көрсетеді. Онда есеп басылғандағыдай көрсетіледі.

Алдын ала қарау тақтасының төменгі жағындағы шарлау түймешіктерін пайдаланып есептің беттерін ретті түрде қарауға немесе есептегі кез келген бетке өтуге болады. Шарлау түймешіктерінің біреуін басыңыз немесе бет нөмірі жолағында көргіңіз келетін бет нөмірін теріңіз, содан кейін ENTER пернесін басыңыз.

Алдын ала қарауда мәліметтерді көру үшін ұлғайтуға немесе деректердің бетте қаншалықты жақсы орналасқанын көру үшін кішілеуге болады. Тінтуір меңзерін есеп үстінде орналастырып, бір рет басыңыз. Масштабтаудың әсерін түзету үшін қайтадан басыңыз. Сондай-ақ, күй жолағындағы масштабтауды басқару элементін пайдалануға болады.

Беттің жоғары бөлігі

Fine-tune your report

It is likely that the Report Wizard will not produce the exact results that you are looking for in your report. For example, you may want to add text, adjust column widths, add a logo, etc. Access provides two views in which you can make modifications to your report: Layout view and Design view. These are discussed briefly in this section.

About Layout view

Layout view is the most easy-to-use view for making report changes, and provides most of the tools you need to fine-tune your report. You can adjust column widths, rearrange columns, and add or modify grouping levels and totals. You can place new fields on the report design and set the properties for the report and its controls. The advantage of Layout view is that you can see your data while making changes to the report format, so you can immediately see how your changes affect the display of the data.

To open a report in Layout view, right-click the report in the Navigation Pane, and then click Layout view Түймешік суреті .

You can use the property sheet to modify the properties for the report and its controls and sections. To display the property sheet, press F4.

You can use the Field List pane to add fields from the underlying table or query to your report design. To show the Field List pane:

  1. On the Format tab, in the Controls group, click Add Existing Fields Түймешік суреті .

    Кеңес :  Access 2010 includes new conditional formatting features that can greatly improve the readability of a report.

About Design view

If you are unable to make a specific change to your report in Layout view, try Design view. Design view shows you the underlying structure of the report, and provides a few more design tools and capabilities than Layout view. For example, you can place a wider variety of controls on the report, you can adjust the alignment of controls more precisely, and you have the ability to set more properties than you do in Layout view.

To open a report in Design view, right-click the report in the Navigation Pane, then click Design View Түймешік суреті .

Беттің жоғары бөлігі

Add fields or other controls to an existing report

Every field, label, line, or picture you see on your report is created using some type of control. The most frequently-used control on a report is the text box. This is what is normally used to display data from the report's underlying record source. You can create text boxes that are already bound to fields in the record source by adding fields from the Field List pane, or you can add them to the report while working in Design view (but then you must "bind" them to fields in the record source yourself). The advantage of Design view is that you can add many other types of controls besides bound text boxes, such as rectangles, page breaks, and charts. This section describes both methods of adding controls to a report.

Add fields to an existing report

Layout view is the recommended view for adding fields to a report, but it can also be done in Design view. To add a field, first make sure that the Field List pane is displayed. The Field List pane contains a list of all of the fields that are available to be placed on the report. To display the Field List pane, press ALT+F8.

Add fields from the Field List pane

  • To add a single field, drag the field from the Field List pane to the section on the report where you want it displayed.

  • To add several fields at once, click the first field that you want, and then hold down CTRL and click each additional field that you want. Then, drag the selected fields onto the report.

When you drop the fields, Access creates a bound text box control for each field and automatically places a label control beside each field.

Ескерту : 

  • If you add a field from a related table, Access will add the appropriate grouping level for you.

  • If you add a field from another (non-related) table, Access will display a dialog box where you can specify how to relate the table to the existing data source for the report.

To see what table relationships have already been specified for your database, or to add new ones:

  1. On the Database Tools tab, in the Show/Hide group, click Relationships. Түймешік кескіні

For more information, see the article Create, edit or delete a relationship.

Add other controls to an existing report

When you add a field from the Field List pane to your report, a bound text box control for it is created automatically. Other controls such as labels, lines, and images can be added by switching to Design view and using the tools in the Controls group on the Design tab.

Access таспасының суреті

Determine the name of a tool

  • Place the mouse pointer over the tool.

    Access displays the name of the tool.

Create a control by using the tools in the Controls group

  • Click the tool for the type of control that you want to add. For example, to create a check box, click the Check Box tool Түймешік суреті .

  • Click in the report design where you want to position the upper-left corner of the control. Click once to create a default-sized control, or click and drag in the report to create a control of the size that you want.

  • If you don't position the control perfectly on the first try, you can move it by using the following procedure:

    • Click the control to select it.

    • Position the pointer over the control until it turns into a four-headed arrow Жылжыту көрсеткіші , and then drag the control to the desired location.

This process creates an "unbound" control. If the control is the type that can display data (a text box or check box, for example), you will need to enter a field name or expression in the Control Source property for the control before it will display any data.

Display the property sheet

  • Press F4.

Ескерту : When your new report is complete, be sure to save your work.

Беттің жоғары бөлігі

Бар есепте топтауды және сұрыптауды қосу немесе өзгерту

Егер есеп бар болса және оған сұрыптауды немесе топтауды қосу керек болса я болмаса есептің бар сұрыптауын немесе топтауын өзгерту керек болса, бұл бөлім жұмысты бастауға көмектеседі.

Add grouping, sorting, and totals in Layout view

You can perform simple sorting, grouping and totaling operations by right-clicking fields in Layout view and then choosing the operation you want from the shortcut menu. To switch to Layout view, right-click the report in the Navigation Pane and then click Layout view Түймешік суреті .

Ескерту : Бұл бөлімдегі нұсқаулар Топтау, сұрыптау және жиындар бөлігін тікелей пайдаланбағанымен, жұмыс барысында бөлікті ашып, қалай өзгергенін бақылап отырған жөн. Access не істеп жатқаны туралы жақсырақ түсінік аласыз және Group, Sort, and Total бөлігімен жұмысқа жақсырақ бейімделгенде, оны пайдаланып есепке қосымша реттеулерді жасауға болады. Топтау, сұрыптау және жиындар бөлігін көрсету үшін:

  1. On the Format tab, in the Grouping & Totals group, click Group & Sort. Түймешік суреті

Бір өрісте сұрыптау

  • Right-click any value in the field that you want to sort.

  • On the shortcut menu, click the sort option you want. For example, to sort a text field in ascending order, click Sort A to Z Түймешік суреті . To sort a numeric field in descending order, click Sort Largest to Smallest Түймешік суреті .

Access есепті көрсетілгендей сұрыптайды. Егер Топтау, сұрыптау және жиындар бөлігі ашық болса, өріс үшін жаңа Сұрыптау жолы қосылғанын көресіз.

Бірнеше өрісте сұрыптау

Ескерту : When you apply sorting by right-clicking a field in Layout view, you can only sort one field at a time. Applying sorting to another field removes the sorting on the first field. This differs from the sorting behavior in forms, where multiple sort orders can be established by right-clicking each field in turn and the choosing the sort order you want. To create multiple sorting levels, see the section Add grouping, sorting, and totals by using the Group, Sort, and Total pane.

Өрісте топтау

  • Топтауда пайдаланылатын өрістегі кез келген мәнді тінтуірдің оң жақ түймешігімен басыңыз.

  • On the shortcut menu, click Group On Түймешік суреті .

Access топтау деңгейін қосады және ол үшін топ тақырыбын жасайды. Егер Топтау, сұрыптау және жиындар бөлігі ашылмаса, өріс үшін жаңа Топтау жолы қосылғанын көресіз.

Өріске қорытындыны қосу

Бұл параметр өріс үшін қосындыны, орташа мәнді, санын немесе басқа статистикалық өрнекті есептеуге мүмкіндік береді. Есептің соңында жалпы қорытынды қосылады және есепте бар кез келген топтарға топ қорытындылары қосылады.

  • Қорытындысын алу керек өрісте кез келген мәнді тінтуірдің оң жақ түймешігімен басыңыз.

  • Қорытынды пәрменін таңдаңыз.

  • Орындау керек әрекетті таңдаңыз: Қосынды, Орташа, Жазбалар саны (барлық жазбаларды санау үшін), Count Values (осы өрістегі мән бар жазбаларды ғана санау үшін), Ең көп, Ең аз, Стандартты ауытқу немесе Дисперсия.

Access есептің төменгі деректемесіне жалпы қорытындыны жасайтын есептелетін мәтін ұясы басқару элементін қосады. Сондай-ақ, есепте қандай да топтау деңгейлері бар болса, Access топ төменгі деректемелерін қосады (бар болмаса) және әр төменгі деректемеге қорытындыны орналастырады.

Ескерту : You can also add totals by clicking the field that you want totaled and then, on the Format tab, in the Grouping & Totals group, click Totals Түймешік суреті .

Топтау, сұрыптау және жиындар бөлігін пайдалана отырып топтауды, сұрыптауды және қорытындыларды қосу

Топтау, сұрыптау және жиындар бөлігінде жұмыс істеу есепте топтар, сұрыптау реттері немесе қорытындылар параметрлерін қосу немесе өзгерту керек кезде ең үлкен икемділікті береді. Орналасу көрінісінде жұмыс істеген жөн, өйткені өзгертулер деректердің көрсетілуіне қалай әсер ететінін көру әлдеқайда оңай.

Топтау, сұрыптау және жиындар бөлігін көрсету

  • In Layout view:

    On the Format tab, in the Grouping & Totals group, click Group & Sort. Түймешік суреті

  • In Design view:

    On the Design tab, in the Grouping & Totals group, click Group & Sort. Түймешік суреті

Access displays the Group, Sort, and Total pane.

Топтау, сұрыптау және жиындар бөлігі

Жаңа сұрыптау немесе топтау деңгейін қосу үшін Топты қосу немесе Сұрыптауды қосу пәрменін таңдаңыз.

Топтау, сұрыптау және жиындар бөлігіне жаңа жол қосылады және қол жетімді өрістер тізімі көрсетіледі.

Топтау, сұрыптау және жиындар бөлігіндегі өрістер тізімі

You can click one of these field names or you can click expression below the list of fields to enter an expression. Once you choose a field or enter an expression, Access adds the grouping level to the report. If you are in Layout view, the display changes immediately to show the grouping or sort order.

Ескертулер : 

  • Егер бірнеше сұрыптау немесе топтау деңгейі анықталып қойылған болса, Топты қосу және Сұрыптауды қосу түймешіктерін көру үшін Топтау, сұрыптау және жиындар бөлігінде төмен жылжу керек болуы мүмкін.

  • Есепте 10-ға дейін топтау және сұрыптау деңгейін анықтауға болады.

Топтау параметрлерін өзгерту

Әр сұрыптау немесе топтау деңгейінде қажет нәтижелерді алу үшін орнатуға болатын бірқатар параметр болады.

Топтау параметрлері

  • Топтау немесе сұрыптау деңгейінің барлық параметрлерін көрсету үшін өзгерту керек деңгейде Қосымша пәрменін таңдаңыз.

    Топтау параметрлері (шығарып алынған)

  • Параметрлерді жасыру үшін Азырақ пәрменін таңдаңыз.

Сұрыптау реті    Сұрыптау ретін сұрыптау ретінің ашылмалы тізімін басу, содан кейін қажет параметрді басу арқылы өзгертуге болады.

Топтау аралығы    Бұл параметрр жазбалардың қалай топталатынын анықтайды. МЫсалы, «А» деп басталатынның барлығы, «Б» деп басталатынның барлығы және т.с.с. топталуы үшін мәтіндік өрістің бірінші таңбасы бойынша топтауға болады. Күн өрісі үшін күн, апта, ай, тоқсан бойынша топтауға болады немесе теңшелетін аралықты енгізуге болады.

Қорытындылар    Қорытындыларды қосу үшін осы параметрді басыңыз. Бірнеше өрістегі қорытындыларды қосуға болады және бір өрісте бірнеше қорытындылар түрін жасауға болады.

Қорытындылар қалқымалы терезесі

  • Қорытындыны анықтау ашылмалы тізім көрсеткішсін басып, қосындысын анықтау керек өрісті таңдаңыз.

  • Түрі ашылмалы тізім көрсеткісін басып, орындайтын есептеу түрін таңдаңыз.

  • Есептің соңына жалпы қорытындыны қосу үшін Жалпы қорытындыны көрсету пәрменін таңдаңыз (есептің төменгі деректемесінде).

  • Топтың төменгі деректемесіне әр топ үшін жалпы қорытынды пайызын есептейтін басқару элементін қосу үшін Топ қорытындыларын жалпы қорытынды % ретінде көрсету пәрменін таңдаңыз.

  • Қалаған орында қорытындыны көрсету үшін Топтың тақырыбында көрсету немесе Топтың аңғартпасында көрсету параметрін таңдаңыз.

Өріс үшін барлық параметрлер таңдалғаннан кейін процесті қайталауға және Қосындыны анықтау ашылмалы тізімінен басқа өрісті таңдау арқылы басқа өрісте қорытындыны анықтауға болады. Я болмаса, жабу үшін Қорытындылар қалқымалы терезесінің сыртында басыңыз.

Тақырып    Бұл қосындысы анықталып жатқан өрістің тақырыбын өзгертуге мүмкіндік береді. Бұл баған тақырыбы үшін және тақырыптар мен аңғартпалардағы жиынтық өрістерді белгілеу үшін пайдаланылады.

Тақырыпты қосу немесе өзгерту үшін:

  • Көк мәтінді, содан кейін тақырыпты басыңыз.

    Масштабтау диалогтық терезесі көрсетіледі.

  • Диалогтық терезеде жаңа тақырыпты теріп, OK түймешігін басыңыз.

Тақырып бөлімімен/онсыз    Бұл параметрді әр топтың алдында болатын тақырып бөлімін қосу немесе жою үшін пайдаланыңыз. Тақырып бөлімін қосқанда, Access топтау өрісін тақырыпқа жылжытады. Топтау өрісінен басқа тақырып бөлімін жойғанда, Access басқару элементтерін жоюды растауды сұрайды.

Аңғартпа бөлімімен/онсыз    Бұл бөлімді әр топтан кейін келетін аңғартпа бөлімін қосу немесе жою үшін пайдаланыңыз. Басқару элементтерін қамтитын аңғартпа бөлімін жойғанда, Access басқару элементтерін жоюды растауды сұрайды.

Топты бірге сақтау    Бұл параметр есепті басып шығарғанда топтар бетте қалай орналасатынын анықтайды. Бүкіл топты көру үшін қажет бетті аудару мөлшерін барынша азайту үшін топтарды бірге сақтағыңыз келуі мүмкін. Дегенмен, бұл әдетте есепті басып шығару үшін қажет қағаз мөлшерін арттырады, өйткені беттердің көпшілігінде төменгі жағында біраз бос орын болады.

  • Топты бір бетте бірге сақтамау    Бұл параметрді бет үзілімдері бөлетін топтар туралы ойлану керек болмаса пайдаланыңыз. Мысалы, 30 элементтен тұратын топта беттің төменгі жағында 10 элемент болуы және қалған 20 элемент келесі беттің жоғарғы жағында болуы мүмкін.

  • Бүкіл топты бір бетте бірге сақтау    Бұл параметр топтағы бет үзілімдерін барынша азайтуға көмектеседі. Егер беттегі қалған кеңістікке сыймаса, Access бұл кеңістікті бос қалдырады және топты келесі бетте бастайды. Үлкен топтар бәрібір бірнеше бетке созылуы мүмкін, бірақ бұл параметр топ ішіндегі бет үзілімдерінің санын мүмкіндігінше азайтады.

  • Тақырыпты және бірінші жазбаны бір бетте бірге сақтау    Топ тақырыптары бар топтар үшін бұл топ тақыры беттің төменгі жағында тек өзі басып шығарылмауын қамтамасыз етеді. Егер Access тақырыптан кейін кемінде бір деректер жолы үшін жеткілікті бос орын жоқ екенін анықтаса, топ келесі бетте басталады.

Топтау басымдығын және сұрыптау деңгейлерін өзгерту

Топтау басымдығын немесе сұрыптау деңгейін өзгерту үшін Топтау, сұрыптау және жиындар бөлігінде жолды басыңыз, содан кейін жолдың оң жағында жоғары көрсеткіні немесе төмен көрсеткіні басыңыз.

Топтау және сұрыптау деңгейлерін жою

Топтау немесе сұрыптау деңгейін жою үшін Топтау, сұрыптау және жиындар бөлігінде жою керек жолды басыңыз да, DELETE пернесін басыңыз немесе жолдың оң жағында Жою түймешігін басыңыз. Топтау деңгейін жойғанда, топтау өрісі топ тақырыбында немесе аңғартпасында болса, Access оны есептің «Мәліметтер» бөліміне жылжытады. Топ тақырыбында немесе топ аңғартпасында болған кез келген басқа басқару элементтері жойылады.

Беттің жоғары бөлігі

Жиынтық есепті жасау (жазба мәліметтері жоқ)

If you want to show only totals (that is, just the information in header and footer rows), on the Format tab, (or on the Design tab in Design view), in the Grouping & Totals group, click Hide Details. Doing this hides the records at the next lower level of grouping, resulting in a much more compact presentation of the summary data. Although the records are hidden, the controls in the hidden section are not deleted. Click Hide Details again to restore the Detail rows to the report.

Create a grouping effect without using headers

You can achieve a grouping effect on your report without the use of headers. Removing headers creates a more compact report because less vertical space is used by the header lines.

The general procedure involves removing the header for each group, which moves each grouping field into the Detail section of the report. To restore the visual grouping effect, you set the Hide Duplicates property of each grouping field to Yes.

Мысал

Consider this typical grouped report that uses group headers:

Топтарының үстіңгі дерек атаулары бар, топтастырылған есеп хат

As you can see, each company name takes up an entire line, as does each order ID.

In this example, you will edit the report so that it looks like the following illustration:

Топтарының үстіңгі дерек атаулары жойылған есеп хаттар

  1. Open the report in Layout view by right-clicking it in the Navigation Pane, and then clicking Layout View Түймешік суреті .

  2. On the Format tab, in the Grouping & Totals group, click Group & Sort. Түймешік суреті

    Ескерту :  It is a good idea to start with the lowest-level group and work your way up; otherwise, the display of the report can become confusing while you are working.

  3. Click the lowest grouping level in the list, and then click More.

  4. From the header section drop-down list, select without a header section.

    When you remove a header, Access preserves the text box for the grouping field by moving it to the Detail section. However, any other controls in the group header might be deleted. Access warns you if any controls are going to be deleted as a result of this action. If there are controls in the group header that you want to preserve, be sure to move them to another report section before performing this step. You will need to switch to Design view to move the controls to other sections.

    The resulting report is shown in the following illustration. Notice that the first OrderID is on the same line as the first detail record, instead of on its own line.

    Тапсырыс коды жойылған, топтарға бөлінген есеп хат

    Unfortunately, the OrderID repeats on every detail line, and this makes it hard to see exactly how many orders there are. At this point, setting the text box control's Hide Duplicates property is useful. Follow these steps to set this property:

    • Select one of the repeating values.

    • If the property sheet is not currently displayed, press F4 to display it.

    • On the Format tab of the property sheet, click the drop-down list for Hide Duplicates and then click Yes.

      The duplicate order IDs are hidden. Note that you can see how many orders there are, and how many products there are per order.

      Қайталанбалы тапсырыс кодтары жасырылған, топтарға бөлінген есеп хат

  5. For this example, we repeat step 4 for the Company Name grouping level. The final report looks like the following illustration:

    Топтарының үстіңгі дерек атаулары жойылған есеп хаттар

    The Company Name value is now on the same line as the first detail record, and the Hide Duplicates property prevents the Company Name value from repeating on every line. For a long report that uses several grouping levels, this can result in a significant paper savings.

Беттің жоғары бөлігі

Save, print, or send your report

After you save your report design, you can use it multiple times. The report's design stays the same, but you see current data every time you print the report. If your reporting needs change, you can modify the report design or create a new, similar report that is based on the original.

Есепті сақтау

  1. Click the Microsoft Office Button Түймешік суреті , and then click Save, or press CTRL+S Түймешік суреті .

    Alternatively, you can click Save Түймешік суреті on the Quick Access Toolbar.

  2. If the report is untitled, type a name in the Report Name box and then click OK.

Save your report design under a new name

  1. Click the Microsoft Office Button Түймешік суреті , and then click Save As Түймешік суреті .

  2. In the Save As dialog box, type a name in the Save Report To box, click Report in the As box, and then click OK.

Print your report

You can print a report from Print Preview, Layout view, Design view, Report view, or from the Navigation Pane. Before you print, you should double check page settings, such as margins and page orientation. Access saves the page settings with the report, so you need to set them only once. You can save the settings later, if your needs change.

Change the page settings

  1. Open the report in any view.

  2. On the Page Layout tab, in the Page group, click an option:

    • Size Түймешік суреті allows you to select from a number of paper sizes, or to enter a custom paper size.

    • Portrait Түймешік суреті orients the page vertically.

    • Landscape Түймешік суреті orients the page horizontally.

    • Margins Түймешік суреті allows you to select from several predefined margin widths, or you can click Advanced to enter custom margin widths by using the Page Setup dialog box.

    • Show Margins toggles the display of margins on and off (Layout view only).

    • Columns displays the Page Setup dialog box. Enter the number of columns you want, set your desired column size, and then click OK.

    • Print Data Only suppresses the printing of any labels you have placed on your report. Only the controls that are bound to data in the underlying table or query will be printed. This feature can be helpful on reports that you occasionally print on pre-printed forms. You can suppress the printing of labels in those situations, and then enable the printing of labels when you are printing the report on blank paper.

Ескерту : To use more detailed page settings, click the Page Setup button at the lower right corner of the Page Layout group to display the Page Setup dialog box. You can use the Page Setup dialog box to adjust all the settings that are available on the Page Layout tab, and also to select a specific printer for the report.

Send your report to a printer

  1. Open the report in any view, or just select the report in the Navigation Pane.

  2. Click the Microsoft Office Button Түймешік суреті , and then click Print. Басып шығару түймешігі

  3. In the Print dialog box, enter your choices for options such as printer, print range, and number of copies.

  4. ОК түймешігін басыңыз.

Беттің жоғары бөлігі

Send your report as an e-mail message

You can send your report to users as an e-mail message instead of printing a paper copy.

  1. In the Navigation Pane, click the report to select it, click the Microsoft Office Button Түймешік суреті , and then click E-mail Түймешік суреті .

  2. In the Send Object As dialog box, click the file format that you want to use.

    Нысанды тілқатысу терезесі ретінде жіберу

  3. Complete any remaining dialog boxes.

  4. When your e-mail program appears, type the message details and send the message.

Беттің жоғары бөлігі

Ескертпелер

A problem can arise if you have a report in an .accdb file that sorts or groups on a lookup field, and you want to import that report into an .mdb file and then open it with an earlier version of Access.

The internal method by which lookup fields are sorted and grouped in .accdb files is incompatible with .mdb files. If you create a report in an .accdb file that uses grouping or sorting on a lookup field, and you then export it into an .mdb file (or use the Save As command to save the database as an .mdb file) and then try to open the report with an earlier version of Access, the report will fail to load.

To revise the report so that you can import it into an .mdb file and open it in an earlier version of Access, do the following:

  1. In the .accdb file, create a copy of the report.

  2. Open the copy of the report in Layout view.

  3. If the Group, Sort, and Total pane is not displayed:

    1. On the Format tab, in the Grouping & Totals group, click Group & Sort. Түймешік суреті

  4. Delete all the lines in the Group, Sort, and Total pane by clicking the Delete button to the right of each line.

  5. Click the Microsoft Office Button Түймешік суреті , and then click Save, or press CTRL+S Түймешік суреті .

  6. Click the Microsoft Office Button Түймешік суреті , and then click Close Database. Түймешік суреті

  7. Click the Microsoft Office Button Түймешік суреті , and then click Open. Түймешік суреті

  8. Browse to the .mdb file into which you want to import the report, and then click Open.

  9. Import the report copy into the .mdb file.

    Қалай?

    1. On the External Data tab, in the Import group, click Access. Түймешік бейнесі

    2. Шолу түймешігін басыңыз.

    3. Browse to the .accdb file containing the report, and click Open.

    4. You are not importing any tables at this time, so it does not matter whether you choose to import or link to the source data. Click OK to continue.

    5. In the Import Objects dialog box, click the Reports tab.

    6. Click the report you want to import, and then click OK.

    7. If the import operation is successful, Access asks if you want to save the import steps for later use. If you want to save the steps, select the Save import steps check box, enter the requested information, and click Save Import. If you do not want to save the steps, click Close.

      Access imports the report and displays it in the Navigation Pane.

  10. Open the report in Layout view.

  11. If the Field List pane is not displayed:

    1. On the Format tab, in the Controls group, click Add Existing Fields Түймешік суреті .

  12. In the Fields available in related tables pane, find the table that contains the field you want displayed on the report. This field will contain the same values that you currently see displayed by the lookup field on the report.

  13. Drag the field to the report.

    You now have two columns displaying the same information.

  14. Right-click the display field you just added, and click the sorting option you want to use.

  15. Delete the display field that you just added and sorted.

  16. If the Group, Sort, and Total pane is not displayed:

    1. On the Format tab, in the Grouping & Totals group, click Group & Sort. Түймешік суреті

  17. Click Add a group.

  18. In the Field/Expression pop-up window, click the name of the lookup field on the report.

The report is now sorted and grouped as it was in the .accdb file. Save and close the report.

Беттің жоғары бөлігі

Ескерту : Machine Translation Disclaimer: This article has been translated by a computer system without human intervention. Microsoft offers these machine translations to help non-English speaking users enjoy content about Microsoft products, services and technologies. Because the article was machine translated, it may contain errors in vocabulary, syntax or grammar.

Дағдыларды жетілдіру
Оқыту курсымен танысыңыз
Жаңа мүмкіндіктерге бірінші болып қол жеткізу
Office Insider бағдарламасына қосылу

Осы ақпарат пайдалы болды ма?

Пікіріңіз үшін рақмет!

Пікіріңізге рақмет! Сізді Office қолдау көрсету қызметіндегі агенттердің бірімен байланыстырған жөн болуы мүмкін.

×