XML ファイル (Power Query) に接続します。

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

Excel の取得に使用すると、XML ファイルに接続する (Power Query) のエクスペリエンスを変換します。

  1. [データ] タブの [データの取り込み] をクリックして >ファイルから>から XMLします。[データの取り込み] ボタンが表示されない場合は、新しいクエリをクリックして >ファイルから>から XMLします。

  2. [XML ブラウズから] ダイアログ ボックスでファイルの URL を参照または入力し、ファイルをインポートするか、ファイルにリンクします。

  3. [開く] をクリックします。

    接続に成功すると、[ナビゲーター] ウィンドウを使用して、XML ファイルのアイテムのコレクションをテーブル形式で参照、プレビューできます。

  1. Power Queryリボン タブで、[ファイルから] をクリックして >から XMLします。

    Power Query からファイル] ダイアログ
  2. [XML ブラウズから] ダイアログ ボックスでファイルの URL を参照または入力し、ファイルをインポートするか、ファイルにリンクします。

  3. [開く] をクリックします。

    接続に成功すると、[ナビゲーター] ウィンドウを使用して、XML ファイルのアイテムのコレクションをテーブル形式で参照、プレビューできます。

重要: ダウンロードしてPower Query アドインがインストールされているかどうかを確認します。

注: Excel 2007 では、power Query はサポートされていませんが、XML データをインポートするのには、外部データの取り込みメソッドを使用することができます。

  1. [データ] タブ、[外部データの取り込み] をクリックして >他のデータ ソースから>から XMLします。

  2. データ ソースの選択] ダイアログ ボックスで、参照、インポートするファイルの URL を入力またはファイルへのリンクを新しいソースオプションを選択します。

数式の例

Power Queryの数式を作成するのにクエリ エディターを使用することもできます。例えば:

= Xml.Tables(File.Contents("C:\Downloads\XML Example.xml"))

注: クエリ エディターは、Power Query を使用して新しいクエリの読み込み、編集、または作成を行うときにのみ表示されます。 次のビデオは、Excel ブックからクエリを編集した後で表示される [クエリ エディター] ウィンドウを示します。 既存のブック クエリを読み込んだり編集したりせずにクエリ エディターを表示するには、[Power Query] リボン タブの [外部データの取り込み] セクションから [その他のデータ ソース]、[空のクエリ] の順に選びます。 次のビデオは、クエリ エディターを表示する 1 つの方法を示します。

Excel でクエリ エディターを表示する方法

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

Power Query は Excel 2016 では [取得して変換] と呼ばれています

外部データ ソースからデータをインポートする

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×