Visio でマクロを記録する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

繰り返し実行する手順やプロセスを自動化するマクロを作成します。マクロを記録するためのコマンドは、[開発] タブにあります。

注:  マクロは、セキュリティ警告の原因となることがあります。不正な目的でマクロが作成されて使われることもあるからです。マクロのリスクと、セキュリティ警告への対応方法の詳細については、「Office ドキュメントのマクロを有効または無効にする」をご覧ください。

  1. [開発] タブの [マクロの記録] をクリックします ([開発] タブが表示されていない場合は、後の「[開発] タブを表示する」を参照してください)。

    [マクロ] のコマンド

  2. [マクロ名] ボックスにマクロの名前を入力します。

  3. [ショートカット キー] ボックスに、このマクロを実行するために Ctrl キーと共に使うショートカット キーを入力します。

  4. [マクロの保存先] ボックスでは、このマクロを保存するドキュメントをクリックします。

  5. [説明] ボックスに、マクロの説明を入力します。

  6. [OK] をクリックすると、マクロの記録が開始します。

  7. マクロに記録したい操作を実行します。必要に応じて、[開発] タブの [記録の一時停止] を使います。

    マクロを記録するときは、マウスを使ってコマンドやオプションをクリックすることや、図面内の図形やオブジェクトの作業を行うことができます。

  8. マクロの記録を停止するには、[開発] タブの [記録終了] をクリックします。

マクロ記録の一時停止と再開は、[記録] ツール バーを使って行うこともできます。

生成されたコードを表示するには、[ツール] メニューの [マクロ] をポイントし、[マクロ] をクリックし、マクロ名をクリックしてから [編集] をクリックします。

[開発] タブを表示する

  1. [ファイル] タブをクリックし、[オプション] をクリックします。

  2. [リボンのユーザー設定] をクリックします。

  3. [リボンのユーザー設定] および [メイン タブ] の下の [開発] チェック ボックスをオンにします。

    [開発] タブは、リボンの [ファイル] タブとは反対側の端に表示されます。

関連項目

ウイルスが含まれている可能性があるマクロを確認する

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×