UML ユース ケース図を作成します。

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

Visio を使用すると、ユース ケース図を作成するには、Unified Modeling Language (UML) を使用します。統合 Modeling Language (UML) は、ソフトウェアのモデルを描画する標準的な方法です。

"システム境界と、境界外のアクターが境界内のユースケースに与える影響を定義するユース ケース図"

吹き出し 1 システム境界を定義すると、外部またはシステム内部と見なされるを決定します。

吹き出し 2 アクター外部のオブジェクトによって実行される役割を表します。1 つのオブジェクトでは、いくつかの役割を再生することがあり、このため、複数のアクターによって表されます。

吹き出し 3 の通信関係は、ユース ケースのアクターへの参加を示しています。

吹き出し 4 のユース ケースは、アクターがシステムを使用してプロセスを終了するときに発生するイベントのセットです。通常、ユース ケースは比較的大きなプロセス、いない、個別のステップまたはトランザクションです。

  1. [ファイル] タブには、新規作成] をポイントし、空の図を開きます。

  2. [その他の図形] をクリックして >ソフトウェアおよびデータベース>ソフトウェア> UML ユース ケースします。

    ユース ケース図を作成します。

  3. ユース ケース図でサブシステムを示す

    1. サブシステム] 図形を図面ページにドラッグします。システム全体または主要なコンポーネント、サブシステムを表すことができます。

    2. サブシステム] 図形をダブルクリックしての新しい名前を入力する、または既存の名前を削除するのには、DEL キーを押します。図面ページ上の図形の外側をクリックします。

    3. サブシステムのサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

  4. ユース ケース] ステンシルからユース ケースの図形をドラッグして、サブシステム境界内に配置サブシステム境界の外側に[アクター] 図形をドラッグします。

  5. コネクタ図形を使用して、ケースとアクター間のリレーションシップを使用してを示します。利用可能なは次の 5 つのコネクタがあります。

    • 関連付け: アクター ユース ケースとの関係を示しています。

    • 依存関係: 1 つのユース ケース別に依存していることを示します。

    • 汎化: ユース ケースが一般的なユース ケースの目標を達成するために特定の方法であることを示します。

    • 含める: 小さなステップにユース ケースを分割する方法を示しています。

    • 拡張: 1 つのユース ケースが他の機能を追加することを示しています。

    例: アクターとユース ケース間の関係を示す

    1. ユース ケース図では、[関連コネクタ図形を図面ページにドラッグします。

    2. [アクター ] 図形を接続ポイントに、関連図形の 1 つの点に接着します。ユース ケースの図形に接続ポイントを他の端点を接着します。

  6. 図面を保存します。

関連項目

ユース ケース図の詳細については、ユース ケース図を作成するのには、Microsoft Visual Studio を使用するための手順) 用に移動するUML を使用してケース図: 参照します。

  1. [ファイル] タブの [新規] をポイントします。

  2. [テンプレートの分類] の [ソフトウェアおよびデータベースをクリックします。

    ソフトウェアおよびデータベースを選択します。

  3. UML モデル図をクリックします。空白の図面ページが表示されます。

    UML モデル図を選択します。

  4. ツリー ビューでは、パッケージまたはユース ケース図を追加し、[新規作成] をポイントするサブシステムを右クリックし、[ユース ケース図] をクリックします。

    ユース ケース図をクリックします。

    空白のページが表示されたら、[ UML ユース ケース] ステンシルが最上部のステンシルになります。図面を表すアイコンは、ツリー ビューに追加されます。

    ユース ケースがツリー ビューに追加されます。

    注: 表示/非表示] で、ツリー ビューが表示されていない場合はタブの [UMLモデル エクスプ ローラーを選択します。

  5. ユース ケース図では、システム境界を示す

    1. システム境界図形を図面ページにドラッグします。

      システム境界を選択します。

    2. システム境界図形をダブルクリックし、[システムの新しい名前を入力するか、既存の名前を削除するのには、DEL キーを押します。図面ページ上の図形の外側をクリックします。

    3. システム境界のサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

  6. ユース ケース] ステンシルからユース ケースの図形をドラッグして、システム境界内に配置システム境界の外側に[アクター] 図形をドラッグします。

  7. 通信] 図形 を使用して、ユース ケースとアクター間のリレーションシップを示します。

    アクターとユース ケース間の関係を示す

    1. ユース ケース図では、[通信] 図形を図面ページにドラッグします。

    2. [アクター ] 図形の接続ポイント 接続ポイントの画像 - 青い X通信] 図形の 1 つのエンドポイント 終点の画像 (緑色の四角形の中にプラス記号) に接着します。ユース ケースの図形に接続ポイントを他の端点を接着します。

    3. 情報の流れを示すための矢印を追加するには、次の操作を行います。

      • [通信] 図形をダブルクリックして、関連付け] の下の [終了、編集する] をクリックしますし、[プロパティ] をクリックします。

      • 関連端] カテゴリで、チェックIsNavigable[OK] をクリックし、もう一度 [ OK ] をクリックします。

      • [通信] 図形を右クリックし、[図形の表示オプション] をクリックします。最後のオプション] で [終端の誘導可能性を選択し、[ OK] をクリックします。

  8. ユース ケース間の関係を示すには、使用し、 [拡張の図形を使用します。

    2 つのユースケース間で関数を使って関係を示す

    1. ユース ケース図では、[リレーションシップ]を使用して図形を図面ページにドラッグします。

    2. その他のユース ケースの動作を使用するユース ケースの図形の接続ポイント 接続ポイントの画像 - 青い X に矢印がないを使用して点に接着します。

    3. (矢印) があるを使用しているユース ケースの接続ポイントの使用のポイントの点に接着します。

    4. UML 汎化プロパティ] ダイアログ ボックスを開くを使用して図形をダブルクリックします。プロパティ値を追加し、[ OK] をクリックします。

    示すために、次の 2 つのユース ケース間のリレーションシップを拡張します。

    1. ユース ケース図では、[拡張] 図形を図面ページにドラッグします。

    2. 拡張エンドポイント 終点の画像 (緑色の四角形の中にプラス記号) はせず、接続矢印は、拡張するユース ケースの 接続ポイントの画像 - 青い X をポイントに接着します。

    3. 基本ユース ケースの接続ポイントに矢印の付いた拡張端点を接着します。

    4. [UML 汎化のプロパティ] ダイアログ ボックスを開く拡張] 図形をダブルクリックします。プロパティ値を追加し、[ OK] をクリックします。

  9. システム境界図形以外) の任意の図形をダブルクリックして、名前、属性、操作、およびその他のプロパティの値を追加するUML プロパティ] ダイアログ ボックスを開きます。

  10. 図面を保存します。

  1. [ファイル] メニューで、新規作成] をポイントし、[ソフトウェアおよびデータベース] をポイントUML モデル図] をクリックします。

    ソフトウェアおよびデータベースを選択します。

  2. ツリー ビューでは、パッケージまたはのユース ケース図、新規作成] をポイントして、ユース ケース図] をクリックするサブシステムを右クリックします。

    Selece ユース ケース図

    空白のページが表示されたら、[ UML ユース ケース] ステンシルが最上部のステンシルになります。図面を表すアイコンは、ツリー ビューに追加されます。

    注: ツリー ビューが表示されない場合は、[UML] メニューの [ビュー] をポイントし、[モデル エクスプローラー] をクリックします。

  3. ユース ケース図でシステム境界を示す

    1. システム境界図形を図面ページにドラッグします。

      大文字と小文字のステンシルを使用します。

    2. システム境界図形をダブルクリックし、[システムの新しい名前を入力するか、既存の名前を削除するのには、DEL キーを押します。図面ページ上の図形の外側をクリックします。

    3. システム境界のサイズを変更するには、図形を選択し、選択ハンドルをドラッグします。

  4. ユース ケース] ステンシルからユース ケースの図形をドラッグして、システム境界内に配置システム境界の外側に[アクター] 図形をドラッグします。

  5. 通信] 図形 を使用して、ユース ケースとアクター間のリレーションシップを示します。

    アクターとユース ケース間の関係を示す

    1. ユース ケース図では、[通信] 図形を図面ページにドラッグします。

    2. [アクター ] 図形の接続ポイント 接続ポイントの画像 - 青い X通信] 図形の 1 つのエンドポイント 終点の画像 (緑色の四角形の中にプラス記号) に接着します。ユース ケースの図形に接続ポイントを他の端点を接着します。

    3. 情報の流れを示すための矢印を追加するには、次の操作を行います。

      • [通信] 図形をダブルクリックして、関連付け] の下の [終了、編集する] をクリックしますし、[プロパティ] をクリックします。

      • 関連端] カテゴリで、チェックIsNavigable[OK] をクリックし、もう一度 [ OK ] をクリックします。

      • [通信] 図形を右クリックし、[図形の表示オプション] をクリックします。最後のオプション] で [終端の誘導可能性を選択し、[ OK] をクリックします。

  6. ユース ケース間の関係を示すには、使用し、 [拡張の図形を使用します。

    2 つのユースケース間で関数を使って関係を示す

    1. ユース ケース図では、[リレーションシップ]を使用して図形を図面ページにドラッグします。

    2. その他のユース ケースの動作を使用するユース ケースの図形の接続ポイント 接続ポイントの画像 - 青い X に矢印がないを使用して点に接着します。

    3. (矢印) があるを使用しているユース ケースの接続ポイントの使用のポイントの点に接着します。

    4. UML 汎化プロパティ] ダイアログ ボックスを開くを使用して図形をダブルクリックします。プロパティ値を追加し、[ OK] をクリックします。

    示すために、次の 2 つのユース ケース間のリレーションシップを拡張します。

    1. ユース ケース図では、[拡張] 図形を図面ページにドラッグします。

    2. 拡張エンドポイント 終点の画像 (緑色の四角形の中にプラス記号) はせず、接続矢印は、拡張するユース ケースの 接続ポイントの画像 - 青い X をポイントに接着します。

    3. 基本ユース ケースの接続ポイントに矢印の付いた拡張端点を接着します。

    4. [UML 汎化のプロパティ] ダイアログ ボックスを開く拡張] 図形をダブルクリックします。プロパティ値を追加し、[ OK] をクリックします。

  7. システム境界図形以外) の任意の図形をダブルクリックして、名前、属性、操作、およびその他のプロパティの値を追加するUML プロパティ] ダイアログ ボックスを開きます。

  8. 図面を保存します。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×