Project Online と Project Server のユーザーのカスタマイズされたユーザーのアイテムをエクスポートするデータを検索します。

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

この記事では、Project Online や Project Server でのユーザー データのエクスポートを実行するときに特定のユーザー独自に定義した (ビュー、フィルター、添付ファイル、テーブル、およびマクロ) プロジェクト内の項目を検索する方法について説明します。 これが含まれています。

この記事の手順では、次に必要です。

  • プロジェクトの MPP ファイル

  • プロジェクトの XML ファイル

Project online では、両方のファイルが提供するProject Online からのユーザー データをエクスポートするの手順を使用してユーザー データをエクスポートするときにします。

Project Server の XML ファイルを作成するのには、XML 形式に特定のプロジェクト ファイルを保存する必要があります。

注: Project Professional の XML 形式のプロジェクト ファイルを保存する場合は、最新の更新プログラムを適用していることを確認します。

検索し、カスタマイズしたビューを保存するには

  1. テキスト エディターで特定のプロジェクトの XML ファイルを開きます。

  2. テキストでは、プロジェクトのユーザー ビューのリストを見つけるには、 < ビュー >を探します。

  3. ビューの一覧でIsCustomizedプロパティがtrueに設定されているすべてのビューを探します。 たとえば、次のことを意味アクティブなタスクをという名前のビューがグローバル/既定のテンプレートからカスタマイズされました。

    <View>
    <Name>Task Sheet</Name>
    <IsCustomized>true</IsCustomized>
    </View>
    
  4. これで Project Online のデスクトップ クライアントまたは Project Professional 2016 でプロジェクトの MPP ファイルを開きます。

  5. リボンを開き、リボンの[その他の表示] ドロップダウン メニューを選択する [表示] メニューをクリックし、[その他のビュー] をクリックします。

  6. 他のビューウィンドウで、[ビュー] リストには、[適用] をクリックして、探しているビューを選びます。

    複数のフィルター
  7. 選択したビューが表示されます。 ビューのスクリーン ショットを保存してください。

  8. XML ファイルを参照する残りのすべてのユーザー設定ビューには、同じ手順を使用します。

各プロジェクトのユーザーのカスタマイズしたビューを検索するのには、この手順を繰り返すことができます。

検索し、カスタマイズしたフィルターを保存するには

  1. テキスト エディターで特定のプロジェクトの XML ファイルを開きます。

  2. テキストで< フィルター > 、プロジェクトのユーザー フィルターの一覧を検索します。

  3. フィルターの一覧で、[ IsCustomizedプロパティがtrueに設定されているすべてのフィルターを探します。 たとえば、次のことを意味アクティブなタスクをという名前のフィルターがグローバル/既定のテンプレートからカスタマイズされました。

    <Filters>
    <Name>Active Tasks</Name>
    <IsCustomized>true</IsCustomized>
    </Filter>
    
  4. ビューを保存するには、Project Online のデスクトップ クライアントまたは Project Professional 2016 でプロジェクトの MPP ファイルを開きます。

  5. [表示] メニューをクリックし、[フィルター ] ドロップダウン メニューで、その他のフィルターを選択します。

  6. [その他のフィルター ] メニューで [編集] をクリックして、探しているフィルターを選択します。

    複数のフィルター
  7. フィルターのフィルターの定義が表示されます。 フィルターの定義のスクリーン ショットを保存します。

  8. XML ファイルを参照する残りのすべてのユーザー設定フィルターのと同じ手順を使用します。

各プロジェクトの検索、ユーザーのフィルターをカスタマイズするのには、この手順を繰り返すことができます。

検索し、添付ファイルを保存するには

  1. テキスト エディターで特定のプロジェクトの XML ファイルを開きます。

  2. テキストでは、プロジェクトのユーザーのタスクの一覧を見つけるには、 < タスク >を探します。

  3. タスクの一覧でNoteContainsObjectsプロパティがtrueに設定されているすべてのタスクを探します。 たとえば、18 のタスクを次の方法には、添付ファイルが含まれています。

    <Task>
    <UID>18</UID>
    <NoteContainsObjects>true</NoteContainsObjects>
    </Task>
    
  4. 添付ファイルを保存するには、Project Online のデスクトップ クライアントまたは Project Professional 2016 でプロジェクトの MPP ファイルを開きます。

  5. [タスク] メニューをクリックして、添付ファイル (たとえば、タスク 18) に関連付けられているタスクを開きます。

  6. [タスク情報] 画面で、[メモ] タブを選択します。 アイテムの添付ファイルを表示する必要があります。

    タスクに添付ファイル
  7. 添付ファイルの項目を開き、保存します。

  8. XML ファイルで検索した残りすべての添付ファイルに対して同じ手順を使用します。

各プロジェクトのユーザーの添付ファイルを検索するのには、この手順を繰り返すことができます。

検索して、カスタマイズしたテーブルを保存します。

  1. テキスト エディターで特定のプロジェクトの XML ファイルを開きます。

  2. テキストでは、プロジェクト内のテーブルを検索する< テーブル >を探します。

  3. テーブルの一覧で、[ IsCustomizedプロパティがtrueに設定されているすべてのテーブルを探します。 たとえば、次のことを意味入力] テーブルがグローバル/既定のテンプレートからカスタマイズされました。

    <Tables>
    <Table>Entry</Name>
    <IsCustomized>true</IsCustomized>
    </Table>
    
  4. これで Project Online のデスクトップ クライアントまたは Project Professional 2016 でプロジェクトの MPP ファイルを開きます。

  5. リボンを開き、リボンで、テーブルのドロップダウン メニューを選択する [表示] メニューをクリックし、[その他のテーブル] をクリックします。

  6. 他のテーブルウィンドウで、[テーブル] リストで、[編集] をクリックして、探しているテーブルを選択します。

    テーブル定義
  7. 選択したテーブルの [テーブルの定義が表示されます。 定義] ウィンドウですべての情報のスクリーン ショットを取るし、保存します。

  8. XML ファイルを参照する残りのすべてのカスタマイズされたテーブルには、同じ手順を使用します。

各プロジェクトのユーザーのカスタマイズされたテーブルを検索するのには、この手順を繰り返すことができます。

検索して、ユーザーのマクロを保存します。

注: VBA マクロが含まれている場合、プロジェクトの XML ファイルはフラグされません。 手動で VBA マクロが含まれているかどうかを確認するユーザーのプロジェクトを開く必要があります。

  1. Project Online のデスクトップ クライアントまたは Project Professional 2016 では、プロジェクトの MPP ファイルを開きます。

  2. リボンを開きして、リボンの [マクロ] ドロップダウン メニューで、[表示] メニューをクリックし、[マクロの表示] をクリックします。

  3. [マクロ] ページで、[Visual Basic エディターを開くには、 Visual Basic ] を選びます。

  4. Visual Basic エディターでファイルを保存できます各ユーザーのカスタム VBA します。

各プロジェクトのユーザーのカスタマイズのマクロを検索するのには、この手順を繰り返すことができます。

関連項目

Project Online からのユーザー データをエクスポートします。

Project Server からのユーザー データをエクスポートします。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×