Microsoft Office Visio 2007 のデータ接続機能の概要

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

Microsoft Office Visio 2007は、図や図面よりもはるかに多くのものを作成できます。また、データの視覚化、整理、理解、プレゼンテーションを行うのに役立ちます。

Visio 図面内の各図形には、異なるデータセットが表示されることがあります。次の図では、各図形は別の地域の売上データを示しているため、現在の年数と前年度の両方について、売上実績地域と地域を簡単に比較することができます。

フラグで状態を表示する

作業対象のデータが既にブックまたはデータベーステーブルに保存されている場合は、各情報を手動で入力する代わりに、そのデータを Office Visio 図形に直接インポートできます。

この記事の内容

データを図面に接続するための推奨される方法を教えてください。

以前のバージョンの Visio で行ったように、データに接続できますか?

データリンク機能を使用して、データを図に接続する必要があるかどうかを確認します。

データを図面に接続するための推奨される方法を教えてください。

Visio には複数のデータ接続機能がありますが、ほとんどの場合、データセレクタウィザードを使用してデータソースを図面に接続することをお勧めします ([データ] メニューの [データを図形にインポート] をクリックします)。ウィザードを使用すると、[外部データ] ウィンドウにデータが表示されます。接続された図形を図面に追加すると、図形にデータが表示されます。Office Visio 2007には、選択や変更を行うことができる一連のデータグラフィックも含まれています。

データリンクとデータグラフィック機能の詳細については、次の記事を参照してください。

以前のバージョンの Visio で行ったように、データに接続できますか?

はい.Office Visio 2007のデータリンク機能は、以前のバージョンの Visio の機能を置き換えるものではありません。データに接続するための特別な機能を備えたソリューションと、2つのデータベース接続アドオンを引き続き使うことができます。

2つのデータベース接続アドオンは、データベースウィザードと [ ODBC データベースへのリンク] コマンドです。これらの機能にアクセスするには、[ツール] メニューの [アドオン] をポイントし、[ Visio エキストラ] をポイントして、[データベースウィザード] または [ ODBC データベースへのリンク] をクリックします。

一部のテンプレートには、特定の種類のデータを図面に接続したり、データから図面を生成したりするために使用できる特別なツールもあります。

  • 組織図テンプレート    組織図ウィザードを使用して、microsoft Exchange Server データ、microsoft Office Excel データ、テキストファイル、その他の ODBC 準拠のデータソースに接続して、組織図を生成します。組織図の図では、[組織図] メニューの [組織図データのインポート] をクリックします。組織図が生成されたら、データセレクターウィザードを使用して、他の外部データにリンクすることができます。詳細については、「 Visio 組織図を作成する」を参照してください。

  • タイムラインテンプレート    タイムラインのインポートウィザードを使用して、Microsoft Office Project データに接続します。[データ] メニューの [データソリューションの挿入] をポイントし、[タイムライン] をクリックします。詳細については、「 Project から Visio タイムラインにデータをインポートする」を参照してください。

  • 予定表テンプレート    outlook データのインポートウィザードを使用して、Microsoft Office outlook データに接続します。[データ] メニューの [データソリューションの挿入] をポイントし、[予定表] をクリックします。

  • ブレーンストーミング図テンプレート    ブレーンストーミング図では、[ブレーンストーミング] メニューの [データのインポート] コマンドを使用して、XML ファイルに接続します。詳細については、「ブレーンストーミング図を作成する」を参照してください。

  • ガントチャートテンプレート    プロジェクトデータのインポートウィザードを使用して、Office project データに接続します。ガントチャートの [ガントチャート] メニューで、[インポート] をクリックします。詳細については、「 Project から Visio ガントチャートにデータをインポートする」を参照してください。

  • データベースモデル図テンプレート    リバースエンジニアリングウィザードを使用して、ODBC 準拠のデータベースをリバースエンジニアリングします。データベースモデル図の [データベース] メニューで、[リバースエンジニアリング] をクリックします。データセレクターウィザードは、テンプレートに含まれている他のウィザードに加えて、その他のデータをインポートしたり、それらの図のデータを表すために使うことができます。詳細については、記事「既存のデータベースをデータベースモデルにリバースエンジニアリングする」を参照してください。

データリンク機能を使用して、データを図に接続する必要があるかどうかを確認します。

次のシナリオでは、データセレクターウィザード以外の方法を使用して図のデータを操作することができる特定の状況について説明します。

  • 以前にデータベースウィザードを使用して作成した図面を操作しています。

  • データベースウィザードを使用して、データソースに影響を与えるために Visio 図面のデータ変更を行う場合などに、双方向データ接続を使用することをお勧めします。

  • データソースから図面全体を作成する場合は、タイムライン、組織図、予定表などの図を生成します。

  • visio でデータからマスターシェイプを生成する場合は、visio でデータソースから図形を作成します。

  • データベースモデル図テンプレートを通じてアクセスできるリバースエンジニアリングウィザードを使用して、データベースを元に戻すことができます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×