スキップしてメイン コンテンツへ

Microsoft Access 2010 の新機能

Microsoft Access 2010 では、web データベースを作成し、SharePoint サイトに発行することができます。 SharePoint の閲覧者は、web ブラウザーでデータベースアプリケーションを使用し、SharePoint の権限を使用して、他のユーザーを表示できるユーザーを特定することができます。 テンプレートから始めることができるので、すぐに共同作業を開始できます。

Access のユーザーインターフェイスも変更されています。 新しくなった Access 2010、Backstage ビューでは、データベース全体に適用されるすべてのコマンド (最適化/修復など)、または [ファイル] メニューから取得したコマンドへのアクセスが許可されます。

この記事では、 Access 2010で導入された機能について説明します。 Access の一般的な概要については、「 access 2010 の使用を開始する」の記事を参照してください。

この記事の内容

概要

新しいユーザー インターフェイス

より強力なオブジェクト作成ツール

新しいデータ型とコントロール

強化されたデータのプレゼンテーション

セキュリティの強化

問題を解決するための優れた方法

スペルチェックの改善

概要

Access Services が構成されている SharePoint サイトへのアクセス権を持っている場合は、 Access 2010を使って web データベースを作成することができます。 SharePoint サイトのアカウントを持っているユーザーは、web ブラウザーでデータベースを使用できますが、デザインを変更するには Access 2010 を使用する必要があります。 一部のデスクトップデータベース機能は Web に変換されませんが、集計フィールドやデータマクロなどの新機能を使用すると、同じことを行うことができます。

Web 上でデータベースを共有する

  • テンプレートを使用する    5つのテンプレートには、[連絡先]、[資産]、[プロジェクト]、[イベント]、および [寄付] の各機能が含まれます。 Access 2010 また、公開の前後にテンプレートを変更することもできます。

  • 最初から手続きを行う場合    新しい空のデータベースを作成する場合は、通常のデータベースと web データベースのいずれかを選択します。 この選択肢は、表示されるデザインの機能とコマンドに影響を与えるため、アプリケーションが Web に対応していることを簡単に確認できます。

  • 既存のデータベースを web データベースに変換する    既存のアプリケーションを Web に公開することができます。 Web ではデスクトップデータベース機能の一部がサポートされていないため、アプリケーションの一部の機能を調整しなければならない場合があります。

    新しい Web 互換性チェックを実行すると、互換性の問題を特定して修正することができます。

  • イントラネットやインターネット    自分の SharePoint server に発行するか、ホストされている SharePoint ソリューションを使うことができます。

    注: Web データベースを使うには、ユーザー アカウントが必要です。 匿名アクセスはサポートされません。

Web データベースの詳細については、「 web で共有するデータベースを作成する」を参照してください。

新しいマクロビルダー

Access 2010 には、IntelliSense と簡潔でわかりやすいインターフェイスを備えた新しいマクロビルダーが用意されています。

マクロ ビルダー

1. 一覧から操作を選択します...

2...または、アクションカタログでアクションをダブルクリックして、マクロに追加します。

3. マクロで作業しているときに [デザイン] タブが表示されます。

アクションを追加すると、マクロビルダーに [その他のオプション] が表示されます。 たとえば、"If" アクションを追加すると、次のように表示されます。

If 操作が含まれるマクロ

新しいマクロビルダーの動作については、次のビデオをご覧ください。

お使いのブラウザーではビデオがサポートされていません。 Microsoft Silverlight、Adobe Flash Player、Internet Explorer 9 のいずれかをインストールしてください。

従来のマクロに加えて、新しいマクロビルダーを使用して、新しい機能であるデータマクロを作成できます。

データマクロ: イベントに基づいてデータを変更する

データマクロは、web データベースでの集計をサポートし、任意の Access 2010 データベースに "triggers" を実装するための手段を提供します。

たとえば、[達成率] フィールドと [進捗状況] フィールドがあるとします。 データマクロを使用して、状態を完了に設定したときに [達成] を100に設定することができます。また、状態を [開始] に設定した場合は0になります。

次のビデオでは、データマクロの動作を確認できます。

お使いのブラウザーではビデオがサポートされていません。 Microsoft Silverlight、Adobe Flash Player、Internet Explorer 9 のいずれかをインストールしてください。

拡張式ビルダー

これで、式ビルダーで IntelliSense 機能を使用できるようになりました。入力中にオプションを表示できます。 また、[式ビルダー] ウィンドウで現在選択されている式の値のヘルプも表示されます。 たとえば、Trim 関数を選択すると、次のような式ビルダーが表示されます。

Trim (文字列) 指定した文字列の先頭と末尾にスペースが含まれていない場合は、文字列のバリアント型 (Variant) の値を返します。

詳細については、記事「式ビルダーを使用する」を参照してください。

集計フィールド

計算の結果を表示するフィールドを作成できます。 計算は、同じテーブル内の他のフィールドを参照する必要があります。 計算を作成するには、式ビルダーを使用します。

新しいデータベーステンプレート

Access 2010 には、連絡先、タスク、イベント、学生、資産など、さまざまな種類のデータを管理する本格的なデザインのデータベーステンプレートが含まれています。 それらをすぐに使用したり、調整したり、調整して必要な方法で情報を追跡したりすることができます。

Backstage ビューで使用できるテンプレート

各テンプレートは、定義済みのテーブル、フォーム、レポート、クエリ、マクロ、リレーションシップを含む完全な追跡アプリケーションです。 テンプレートはすぐに利用できるように設計されているため、すぐに起動して実行することができます。 テンプレートの設計がニーズを満たしている場合は、準備は完了です。 それ以外の場合は、テンプレートを使用して、特定のニーズを満たすデータベースの作成を開始できます。

資産管理 Web データベース

Access 2010に含まれているテンプレートに加えて、 Office.com に接続して、その他のテンプレートをダウンロードすることもできます。

既存のデータベースに機能を追加するためのアプリケーションパーツ

アプリケーションパーツを使用すると、既存のデータベースに機能を簡単に追加できます。 Access 2010 では、アプリケーションパーツとは、データベースの一部で構成されるテンプレート (事前に書式設定された表、または関連付けられたフォームとレポートを含むテーブルなど) です。 たとえば、データベースにタスクアプリケーションパーツを追加すると、タスクテーブル、タスクフォーム、および Tasks テーブルをデータベースの別のテーブルに関連付けるオプションが表示されます。

[作成] タブのアプリケーション パーツ

詳細については、「データベースデザイン要素を保存して再利用する」を参照してください。

データシートビューの改善

テーブルを作成して使用を開始するには、事前にフィールドを定義しておく必要があります。そのためには、[作成] タブの [テーブル] をクリックし、表示される新しいデータシートでデータの入力を開始します。 Access 2010 では、各フィールドの最適なデータ型が自動的に決定されるので、いつでも実行できます。 [クリックして追加] 列には、新しいフィールドを追加する場所が表示されます。また、新規または既存のフィールドのデータ型または表示形式を変更する必要がある場合は、リボンのコマンドを [フィールド] タブで使用できます。 また、Microsoft Excel テーブルから新しいデータシートにデータを貼り付けることもできます。 Access 2010 すべてのフィールドが作成され、データ型が自動的に認識されます。

データシート ビューで追加するためにクリック

[フィールド リスト] ウィンドウ

[フィールドリスト] ウィンドウでは、他のテーブルのフィールドを追加できます。 レコードソースのテーブル、関連テーブル、またはデータベース内の関連のないテーブルからフィールドをドラッグできます。 テーブル間のリレーションシップが必要な場合は、自動的に作成されるか、またはプロセスを通じてメッセージが表示されます。

[フィールド リスト] ウィンドウ

レイアウトビューでは、フォームやレポートのデザインを高速化できます。

レイアウトビューを使用して、フォームまたはレポートでデータを表示するときにデザインを変更します。

レイアウトビューにはいくつかの拡張機能があり、Web 用のフォームまたはレポートをデザインする場合に必要です。

[レイアウト] ビューのフォームにライブ データが表示される

コントロールのレイアウトを使用して作業を整理する

レイアウトは、単位として移動したりサイズを変更したりできるコントロールのグループです。 Access 2010では、レイアウトが強化され、フォームやレポート上のコントロールをより柔軟に配置できるようになりました。 セルを水平方向または垂直方向に分割または結合して、フィールド、列、行を簡単に再配置することができます。

Web データベースをデザインするときはレイアウトビューを使用する必要がありますが、デスクトップデータベースのデザイン作業では引き続きデザインビューを使用できます。

新しいユーザー インターフェイス

Access 2010で強化された新しいユーザーインターフェイスは、複雑なメニューやツールバーに埋め込まれることが多いコマンドと機能を簡単に見つけられるように設計されています。

リボン

リボンは、機能ごとに整理されたコマンドのグループを含むタブのコレクションです。 リボンは、以前のバージョンの Access で使用されていたメニューやツールバーのレイヤーに置き換わるものです。 次の画像は、[ホーム] タブが選択されたリボンを示しています。

Access 2010 のリボン

リボンの主な機能は次のとおりです。

  • コマンドタブ—通常は一緒に使用されるコマンドが表示され、必要なときに必要なコマンドを見つけることができます。

  • コンテキストコマンドタブ: コンテキストに応じて表示されるコマンドタブ (作業しているオブジェクトまたは実行しているタスクのいずれか)。 コンテキストコマンドタブには、実行している操作に最も適しているコマンドが含まれています。

  • ギャラリー: スタイルまたはオプションのプレビューを表示する新しいコントロールで、選択した内容をコミットする前に結果を確認できるようにします。

Backstage ビュー

新しくなった Access 2010、Backstage ビューには、データベース全体に適用するコマンド (最適化/修復など)、または新しいデータベースを開くコマンドが含まれています。 コマンドは画面左側のタブ上に配置され、各タブには関連するコマンドまたはリンクのグループが含まれています。 たとえば、[新規作成] をクリックすると、新しいデータベースを最初から作成したり、本格的なデザインのデータベーステンプレートのライブラリから選択したりするための一連のボタンが表示されます。

Access の Backstage ビュー

Backstage ビューで見つけたコマンドの多くは、以前のバージョンの Access で [ファイル] メニューに表示されていましたが、最近開いたデータベースや、(インターネットに接続している場合は) office.com の記事へのリンクもあります。

Backstage ビューにアクセスするには、[ファイル] タブをクリックします。

ナビゲーション ウィンドウ

ナビゲーションウィンドウには、現在開いているデータベース内のすべてのオブジェクトが一覧表示され、簡単にアクセスできます。

ナビゲーション ウィンドウのオブジェクト

ナビゲーションウィンドウを使用して、オブジェクトの種類、作成日、更新日、関連テーブル (オブジェクトの依存関係に基づく)、または作成したユーザー設定のグループによってオブジェクトを整理します。 フォームデザインの作業にスペースが必要な場合 ナビゲーションウィンドウは、わずかなスペースしか使用できますが、そのまま使うことができます。

タブ付きオブジェクト

既定では、テーブル、クエリ、フォーム、レポート、およびマクロは、Access ウィンドウのタブオブジェクトとして表示されます。

この設定はデータベースごとに変更できます。また、タブの代わりにオブジェクトウィンドウを使うこともできます。

Access 2007 のタブ付きオブジェクト オブジェクトのタブをクリックして、さまざまなオブジェクトを簡単に切り替えることができます。

[ヘルプ] ウィンドウ

Access 2010 は Access のヘルプと Access の開発者の両方が同じヘルプウィンドウに表示されます。 2つのシステムには、さまざまな種類のサポートコンテンツが含まれています。 ヘルプビューアーでは、表示するコンテンツを選ぶことができます。 検索の範囲を Access 開発者用参照コンテンツのみに変更できます。 ヘルプウィンドウで行った設定にかかわらず、Access のすべてのヘルプと Access の開発者向け参照コンテンツは、常にオンライン、Office.com、または MSDN で利用できます。

より強力なオブジェクト作成ツール

Access 2010 は、データベースオブジェクトを作成するための直感的な環境を提供します。

[作成] タブ

[作成] タブを使用して、新しいフォーム、レポート、テーブル、クエリ、その他のデータベースオブジェクトをすばやく作成します。 ナビゲーションウィンドウでテーブルまたはクエリを選択した場合、フォームまたはレポートコマンドを使用して、そのオブジェクトに基づいて新しいフォームまたはレポートを1回のクリックで作成することができます。

Access のリボンの [作成] タブ

この1回のクリックによって作成される新しいフォームやレポートでは、視覚的に魅力を高め、すぐに使えるように、更新されたデザインを使用します。 自動生成されたフォームとレポートには、ロゴとタイトルを含む、見出しを含む本格的なデザインのデザインが用意されています。 また、自動的に生成されたレポートには、日付と時刻に加えて、情報のフッターと合計も含まれます。

レポートビューとレイアウトビュー

Access 2010で強化されたこれらのビューを使用して、フォームやレポートを対話形式で操作できます。 レポートビューを使用すると、レポートを印刷したり、印刷プレビューで表示したりすることなく、正確な表示を参照できます。 特定のレコードにフォーカスするには、フィルター機能を使用するか、検索操作を使って、一致するテキストを検索します。 [コピー ] コマンドを使って、テキストをクリップボードにコピーするか、または、レポートに表示されているアクティブなハイパーリンクをクリックして、ブラウザー内のリンクに移動することができます。

レイアウトビューでは、データの参照中にデザインを変更できます。 レイアウトビューを使用して、フォームまたはレポートでデータを表示しながら、一般的なデザインの変更を数多く行うことができます。 たとえば、[新しいフィールドリスト] ウィンドウからフィールド名をドラッグしてフィールドを追加するか、プロパティシートを使用してプロパティを変更します。

レイアウトビューでは、強化されたデザインレイアウト (コントロールのグループ) を使用して、フィールド、列、行、またはレイアウト全体を簡単に再配置できるようになりました。 レイアウトビューでは、フィールドの削除や書式の追加を簡単に行うこともできます。 レイアウト ビューのレポート

レポートでのグループ化と並べ替えの簡略化された作成

Access には、レポート内のデータのグループ化や並べ替えを行う新しい方法、合計を追加する方法が用意されています。 このインターフェイスは簡単に移動したり理解したりすることができます。また、新しいレイアウトビューで使用すると、変更がすぐに反映されます。

[グループ化、並べ替え、集計] ウィンドウ

レポートの地域ごとの売上合計を表示するとします。 レイアウトビューと [グループ化、並べ替え、集計] ウィンドウを使用して、グループレベルを追加し、合計を要求し、変更内容をレポートに表示します。 [集計] 行を使用すると、レポートのヘッダーまたはフッターに合計、平均、カウント、最大値、または最小値を簡単に追加できます。 単純な集計では、集計フィールドを手動で作成する必要がなくなりました。 これで、ポイントしてクリックします。

レポートに合計を作成する

洗練されたフォームやレポートの作成に役立つコントロールレイアウトの向上

フォームとレポートには、顧客名を含む列や顧客のすべてのフィールドが含まれる行など、表形式の情報が含まれていることがよくあります。 これらのコントロールは、ラベルを含む1つの単位として簡単に操作できるレイアウトにグループ化することができます。

[整列] タブの [レイアウトの調整] グループのコマンド

セクションヘッダーまたはフッターのラベルなど、さまざまなセクションのコントロールを選ぶことができるため、非常に柔軟性があります。 次の操作を簡単に行うことができます。

  • レイアウトを移動またはサイズ変更します。 たとえば、列を左または右に移動します。

  • レイアウトの書式を設定する。 たとえば、顧客名の列を太字で設定して、目立つようにします。

  • 列 (フィールド) をレイアウトに追加します。

  • レイアウトから列 (フィールド) を削除します。

  • セルを結合または分割する

レイアウト ビューで列を移動する

レイアウトは、デザインと共に保存されるため、そのまま使用できます。 次のビデオでは、フォームやレポートでのレイアウトの動作について説明します。

お使いのブラウザーではビデオがサポートされていません。 Microsoft Silverlight、Adobe Flash Player、Internet Explorer 9 のいずれかをインストールしてください。

フォームを分割してデータをすばやく参照する

分割フォームを使用して、データシートビューとフォームビューを組み合わせたフォームを作成します。 プロパティを設定して、データシートを上、下、左、または右に配置するように Access に指示することができます。

分割フォーム

注: 分割フォームは、web データベースでは使用できません。

フォームとレポートに埋め込まれたマクロ

埋め込みマクロを使って、コードを記述する必要がないようにします。 埋め込みマクロは、プロパティに格納され、それが属しているオブジェクトの一部です。 埋め込みマクロのデザインを変更するには、マクロを使う可能性のある他のコントロールについて心配する必要はありません。埋め込みマクロはそれぞれ独立しています。 埋め込みマクロは、安全でない可能性のある操作を実行できないため、信頼されています。

[ダブルクリック時] イベントに埋め込みマクロを割り当てる

新しいデータ型とコントロール

[新規] Access 2010計算フィールドを使用すると、計算の結果を格納できます。

  • 複数値を持つフィールド

  • 添付ファイルデータ型

  • 強化されたメモ型フィールド

  • 日付/時刻フィールドの組み込みカレンダーコントロール

集計フィールド

同じテーブル内の他のデータから計算された値を表示するフィールドを作成できます。 式ビルダーを使用して計算を作成すると、IntelliSense から、式の値のヘルプに簡単にアクセスできるようになります。

他のテーブル内のデータは、集計データのソースとして使うことはできません。 一部の式は、集計フィールドではサポートされていません。

複数値を持つフィールド

複数値フィールドでは、レコードごとに複数の値を格納できます。 1人の従業員または請負業者にタスクを割り当て、複数のユーザーに割り当てる必要があるとします。 ほとんどのデータベース管理システムおよび Office Access 2007より前の Access のバージョンでは、これを正しく実行するために多対多のリレーションシップを作成する必要がありました。

注: Access では、複数値を持つフィールドごとに、必要な多対多リレーションシップを維持するために、非表示のテーブルが作成されます。

複数値を持つフィールドは、 Windows SharePoint Servicesで使用される複数値を持つフィールドの種類のいずれかを含む SharePoint リストを操作するときに特に適しています。 Access 2010 は、これらのデータ型と互換性があります。

複数値フィールド

ファイルの添付ファイルフィールド

添付ファイルデータ型を使用すると、データベースサイズで不必要に増加することなく、すべての種類のドキュメントやバイナリファイルを簡単にデータベースに保存できます。 Access では、可能な場合に、スペースの使用を最小限に抑えるために、添付ファイルが自動的に圧縮されます。 Word 文書をレコードに添付するか、またはデータベースに一連のデジタル画像を保存しますか? 添付ファイルを使うと、これらのタスクをより簡単に行うことができます。 1つのレコードに複数の添付ファイルを追加することもできます。

[添付ファイル] ダイアログ ボックス

注: Web データベースでは添付ファイルフィールドを使用できますが、各 web テーブルには、添付ファイルフィールドを1つだけ含めることができます。

メモ型フィールドにリッチテキストとサポートの改訂履歴が保存されるようになりました

リッチテキストのメモ型フィールドは、レコード内のテキスト形式に制限されなくなったことを意味します。 オプション (太字、斜体、さまざまなフォントと色、その他の一般的な書式設定オプション) を使用してテキストの書式を設定し、テキストをデータベースに保存することができます。 リッチテキスト形式のテキストは、 Windows SharePoint Servicesのリッチテキストデータ型と互換性のある、HTML ベースの形式のメモ型フィールドに格納されます。 新しいTextFormatプロパティをリッチテキスト形式またはプレーンテキストに設定すると、テキストボックスコントロールとデータシートビューで情報が正しく書式設定されます。

メモ型フィールドは、大量の情報を格納するのに役立ちます。 "追加のみ" プロパティを構成して、メモ型フィールドに対するすべての変更の履歴を保持することができます。 その変更履歴を表示することもできます。 この機能は、 Windows SharePoint Services の追跡機能もサポートしているため、Access を使用して SharePoint リストのコンテンツ履歴を表示することもできます。

ピッキング日の予定表

日付/時刻データ型を使うフィールドとコントロールは、組み込みの対話形式の予定表を自動的にサポートします。 [予定表] ボタンは、日付の右側に自動的に表示されます。 今週の金曜日の日付を知りたいですか? ボタンをクリックすると、予定表が自動的に表示され、日付を見つけて選ぶことができます。 プロパティを使用して、フィールドまたはコントロールの予定表をオフにすることができます。

強化されたデータのプレゼンテーション

新しいデータのプレゼンテーション機能を使用すると、データベースオブジェクトをより迅速に作成し、データをより簡単に分析することができます。

強化された並べ替えとフィルター処理ツール

一致する値をすばやく見つけたり、列のデータを並べ替えたりする必要があるとします。 オートフィルター機能により、必要なデータにすばやくフォーカスできるように、既に強力なフィルター機能が強化されています。 列内の一意の値を簡単に選ぶことができます。これは、必要な名前を取り消すことができない場合に便利です。また、[昇順] または [降順] などの単純な言語のコンテキストメニューオプションを使用して値を並べ替えることもできます。

オートフィルター

最も一般的なフィルターオプションはメニューコマンドで簡単に表示できます。また、クイックフィルターを使用して、入力したデータに基づいて情報を制限することもできます。 クイックフィルターオプションは、データ型に基づいて自動的に変更されるため、テキスト、日付、数値などの情報を簡単に選択できます。

[日付フィルター] メニュー

データシートの合計と交互の背景色

データシートビューには、合計、個数、平均、最大値、最小値、標準偏差、または分散を表示できる [集計] 行が用意されています。 集計行を追加した後で、列のセルの矢印をポイントし、目的の計算を選択します。

データシートの合計行

データシート、レポート、帳票フォームでは、行の代替背景色がサポートされています。これは、既定の背景色とは別に構成できます。 1行おきに網掛けを行うのは簡単で、任意の色を選ぶことができます。

代替の行の色を使用したデータシート

条件付き書式

Access 2010 には、新しい条件付き書式設定機能が追加されているため、Excel で使用できるのと同じ書式設定スタイルを実現できます。 たとえば、次の図に示すように、データバーを追加して、数値の列を読みやすくすることができます。

Access レポートの条件付き書式設定

注: 条件付き書式は、web データベースでは使用できません。

セキュリティの強化

強化されたセキュリティ機能と Windows SharePoint Services との統合により、より効果的に管理し、情報管理アプリケーションの安全性を高めることができます。 追跡アプリケーションデータを Windows SharePoint Servicesのリストに保存することで、変更履歴の監査、削除された情報の復元、データアクセス権限の構成を行うことができます。

Office Access 2007 は、 Access 2010で前進および改善された新しいセキュリティモデルを導入しました。 統合された信頼の決定は、Microsoft Office セキュリティセンターに統合されています。 信頼できる場所を使用すると、セキュリティで保護されたフォルダー内のすべてのデータベースを簡単に信頼できます。 セキュリティで保護された、セキュリティで保護された (つまり、安全でないコマンドを実行できない) エクスペリエンスを提供するために、無効になっているコードまたはマクロを含む Office Access 2007 アプリケーションを読み込むことができます。 信頼されたマクロは、サンドボックスモードで実行されます。

InfoPath フォームと Outlook を使用してデータを収集する

データ収集機能は、Outlook と (必要に応じて) InfoPath を使用してフィードバックを収集するのに役立ちます。 InfoPath フォームまたは HTML フォームを自動的に生成し、メールメッセージの本文に埋め込むことができます。 その後、Outlook の連絡先から選択した受信者にフォームを送信したり、Access データベースのフィールドに保存されている受信者に送信したりすることができます。

メール メッセージを使ってデータを集める

新しい情報を収集するか、既存の情報を更新するかを選択します。 受信者はフォームに入力して返信します。 Outlook では、入力したフォームが認識され、自動的にデータが Access データベースに保存されます。このとき、再入力する必要はありません。

PDF および XPS にエクスポートする

Access 2010では、pdf または XPS アドインとして発行する場合に備えて、データを PDF (ポータブルドキュメント形式) または XPS (XML 用紙仕様) のファイル形式にエクスポートできます。 フォーム、レポート、またはデータシートを .pdf または .xps ファイルにエクスポートすると、すべての書式設定の特性を保持する、他のユーザーが自分のコンピューターに Access をインストールして出力を印刷または確認する必要がないため、情報を簡単に取り込むことができます。

  • Portable Document Format    PDF は、文書の書式設定を維持し、ファイルの共有に役立てることができる、固定レイアウトの電子ファイル形式です。 PDF 形式では、ファイルがオンラインまたは印刷されたときに、意図した形式を維持したままで、ファイル内のデータを簡単にコピーまたは変更することはできません。 PDF 形式は、業務用印刷でドキュメントを複製する場合にも適しています。

  • XML Paper Specification    XPS は、ドキュメントの書式設定を維持し、ファイルの共有に役立てることができる電子ファイル形式です。 XPS 形式では、ファイルをオンラインで表示したり、印刷したりするときに、意図した形式を維持したままで、ファイル内のデータを簡単にコピーまたは変更することはできません。

外部データの操作がさらに簡単に

外部データソースとして Web サービスに接続できるようになりました。 Web サービス管理者から提供された Web サービス定義ファイルが必要です。 定義ファイルをインストールした後は、Web サービスデータへのリンクをリンクテーブルとして設定できます。

新機能により、データのインポートとエクスポートが簡単になります。 インポート操作またはエクスポート操作を保存し、次回同じタスクを実行するときに保存した操作を再利用することができます。 スプレッドシートのインポートウィザードを使用すると、Access によって選択されたデータ型を上書きすることができ、少なくとも Office Excel 2007 ファイル形式のファイルをインポート、エクスポート、およびリンクすることができます。

問題を解決するための優れた方法

Microsoft Office Diagnostics は、コンピューターがクラッシュしている理由を見つけるのに役立つ一連の診断テストです。 診断テストでは、一部の問題を直接解決し、他の問題を解決する方法を特定できます。 Microsoft Office Diagnostics では、次の Microsoft Office 2003 機能が検出および修復され、Microsoft Office アプリケーションの回復が置き換えられました。

スペルチェックの改善

スペルチェック機能には、次のような新機能があります。

  • スペルチェック機能は、Office プログラム全体でより一貫して動作します。 この変更の例を次に示します。

    • いくつかのスペルチェックオプションがグローバルになりました。 いずれかの Office プログラムでこれらのオプションのいずれかを変更すると、他のすべての Office プログラムでもそのオプションが変更されます。

    • 同じユーザー辞書を共有するだけでなく、同じダイアログボックスを使ってすべてのプログラムでそれらの辞書を管理できます。 詳細については、「ユーザー辞書を使用してスペルチェックに単語を追加する」を参照してください。

  • スペルチェックには、新正書法のフランス語辞書が含まれています。 Microsoft Office 2003 では、このアドインを個別にインストールする必要がありました。

  • 言語を初めて使用するときに、その言語の例外辞書が自動的に作成されます。 例外辞書を使用して、スペルチェックで使用したくない単語にフラグを設定することができます。 除外辞書は、性的な単語やスタイルガイドに一致しない単語を回避するのに役立ちます。 詳細については、「除外辞書を使用して単語に対して優先するスペルを指定する」を参照してください。

注:  このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 情報が役に立ったかどうか、ご意見をお寄せください。 参考までに、こちらから英語の記事をお読みいただけます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×