Microsoft Access データベースへのフォーム データの送信

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

この記事の内容

概要

手順 1: データの送信接続を有効にします。

手順 2: 送信オプションを構成します。

概要

データ接続ウィザードがデータベースへの送信データ接続を作成、Microsoft Office Access (.mdb) または Microsoft Office Access 2007 (.accdb) のデータベースに基づく Microsoft Office InfoPath フォーム テンプレートをデザインする際に場合は、次の条件一致したとします。

  • フォーム テンプレートでは、ユーザーする必要があります入力 InfoPath を使用したように設計されています。Web ブラウザーを使って、フォームに入力するが、フォームはデータベースに直接データを送信することはできません。データベースにデータを送信するにはブラウザー互換フォーム テンプレートを設定するのには、データベースで動作する Web サービスにデータを送信するデータ接続を使用します。

  • メイン データ接続で使用されるプライマリ データベース テーブルには、主キー、一意の制約、または固有インデックスが含まれています。

  • このメイン データ接続に使用される他のデータベース テーブルは、プライマリ データベース テーブルに、簡単な階層関係を持っています。

  • データベースには、画像、画像、OLE オブジェクト、添付ファイル、Office Access メモ データ型、または SQL データ型など、大きなバイナリ データ型に格納できるフィールドはありません。

データベースは、これらの要件を満たしている場合、InfoPath は送信データ接続を作成し、[標準] ツールバーとフォームの [ファイル] メニューに [送信] コマンドを送信] ボタンを追加します。

注: セカンダリ データ接続には、データベースにデータを送信できません。セカンダリ データ接続としてデータベースへの送信データ接続を使用する場合は、データベースで動作する Web サービスを特定し、Web サービスへの送信データ接続を追加します。

データの送信接続を有効にした後は、次の方法でフォーム テンプレートの送信オプションをカスタマイズできます。

  • [標準] ツールバーの [送信] ボタンと [ファイル] メニューには、[送信] に表示されているテキストを変更します。

  • [標準] ツールバーの [送信] ボタンと[ファイル] メニューの [送信] コマンドのキーボード ショートカットを変更します。

  • そのフォームを送信したときに、ユーザーに表示するユーザー設定のメッセージを作成します。

  • フォームを開いたまま、フォームを閉じるかどうかを指定するか、フォームの送信後、新しい空白のフォームを開きます。

ページの先頭へ

手順 1: データの送信接続を有効にします。

  1. [ツール] メニューで、データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、メインのデータ接続をクリックし、[変更] をクリックします。

  3. データ接続ウィザードで [次へ] をクリックします。

  4. ウィザードの次のページで、[この接続の送信を許可する] チェック ボックスを選択し、[完了] をクリックします。

ページの先頭へ

手順 2: 送信オプションを構成します。

送信データ接続を有効にした後、[標準] ツールバーと送信] コマンド、[ファイル] メニューに[送信] ボタンが追加されます。また、完成したフォームを送信した後、ユーザーにメッセージを表示するには、このフォーム テンプレートに基づくフォームが構成されます。このメッセージは、フォームが正常に送信されたかどうかを示しています。既定では、InfoPath もフォームを開いたまま、ユーザーが送信した後です。[送信] ボタン、およびユーザーのフォームを送信した後に発生する動作に表示されるテキストを変更するには、次の操作を行います。

  1. [ツール] メニューで、 [送信オプション] をクリックします。

    1. [標準] ツールバーで、ユーザーがフォームに入力するときに、[ファイル] メニューに表示されている [送信] コマンドが表示される [送信] ボタンの名前を変更するには、送信で図表番号] ボックスに新しい名前を入力します。オプション] ダイアログ ボックス。

      ヒント: このボタンおよびコマンドにキーボード ショートカットを割り当てる場合は、入力のアンパサンド (&) は、キーボード ショートカットとして使用する文字の前にします。たとえば、として送信] ボタンとコマンドのキーボード ショートカットは、alt キーを押しながら B を割り当てる、 Su と送を入力します。

  2. ユーザーがフォームに入力するときに、[標準] ツールバーに [送信] コマンド、または [送信] ボタンを使用したくない場合、送信メニューおよびツールバーの [送信] ボタンを表示する] チェック ボックスをオフにします。

    1. 既定では、ユーザーが、フォームを送信した後、InfoPath がフォームを開いたままにして、フォームが正常に送信されたかどうかを示すメッセージが表示されます。この既定の動作を変更するには、するには、[詳細設定] をクリックして、次のいずれかの操作を行います。

      • フォームを閉じるか、ユーザーが完成したフォームを送信した後、新しい空白のフォームを作成するするには、後の送信] ボックスの一覧で必要なオプションをクリックします。

      • 示すフォームが正常に送信されたかどうかのユーザー設定のメッセージを作成するには、[ユーザー設定のメッセージを使用する] チェック ボックスを選択し、成功失敗した場合のボックスに、メッセージを入力します。

        ヒント: [失敗] ボックスにメッセージを使用して、ユーザーに通知がフォームを送信することができない場合。たとえば、ユーザーがそのフォームを保存して、詳しい情報について問い合わせてを提案することができます。

      • ユーザーがフォームを送信した後にメッセージを表示したくない成功メッセージとエラー メッセージを表示する] チェック ボックスをオフにします。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×