Excel でヒストグラムを作成する

Excel でヒストグラムを作成する

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

ヒストグラムは、頻度のデータを表示する縦棒グラフです。

注: このトピックでは、ヒストグラムの作成についてのみ説明します。パレート図 (並べ替えられたヒストグラム) の詳細については、「パレート図を作成する」を参照してください。

  1. 分析ツールが読み込まれていることを確認します。詳細については、「Excel で分析ツールを読み込む」参照してください。

  2. ワークシートで、入力データを 1 つの列に入力し、必要に応じて最初のセルにラベルを追加します。

    項目の合計値、テストの点数など、必ず定量的な数値データを使用します。ヒストグラム ツールには、文字列として入力された識別番号などの定性的な数値データは使用できません。

  3. 次の列に、境界値を昇順で入力し、必要に応じて最初のセルにラベルを追加します。

    独自の境界値を使用すると、分析に役立つ可能性があります。境界値を入力しなかった場合は、ヒストグラム ツールが入力範囲の最小値と最大値を開始点および終了点として使用し、境界値の間隔を均等に分散させます。

  4. [データ] > [データ分析] をクリックします。

    [データ分析] と [ソルバー]

  5. [ヒストグラム]、[OK] の順にクリックします。

    [データ分析] ダイアログ ボックス

  6. [入力] で、次の操作を行います。

    1. [入力範囲] ボックスに、入力番号が設定されているデータ範囲のセル参照を入力します。

    2. [データ区間] ボックスに、境界値が設定されている範囲のセル参照を入力します。

      ワークシートに列見出しを使用した場合は、見出しもセル参照に含めることができます。

      ヒント: 参照を手動で入力する代わりに、 [折りたたみ] ボタン をクリックしてダイアログ ボックスを一時的に縮小し、ワークシート上で範囲を選択することができます。このボタンを再びクリックすると、ダイアログ ボックスが表示されます。

  7. セル参照に列ラベルを含めている場合は、[ラベル] ボックスをオンにします。

  8. [出力オプション] で、出力先を選びます。

    ヒストグラムは、同じワークシート上、現在のブックの新しいワークシート上、または新しいブックに出力することができます。

  9. 次のボックスを 1 つ以上オンにします。

    パレート図 (並べ替えられたヒストグラム) 頻度で降順に並べ替えたデータが表示されます。

    累積比率    累積比率が表示され、ヒストグラムに累積比率のラインが追加されます。

    グラフ出力    埋め込みヒストグラムが表示されます。

  10. [OK] をクリックします。

    ヒストグラムをカスタマイズする場合は、テキストのラベルを変更し、任意の場所をクリックすると、グラフの右側で、グラフ要素グラフのスタイル、およびグラフ フィルター ] ボタンを使用するヒストグラムにすることができます。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[統計グラフの挿入]、[ヒストグラム] の順にクリックします。

    [統計グラフの挿入] ボタンからアクセスしたヒストグラム コマンド

    [おすすめグラフ] の [すべてのグラフ] タブを使用して、ヒストグラムを作成することもできます。

ヒント: 

  • グラフの外観をカスタマイズするには、[デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これは、ヒストグラムの既定の設定です。ビンの幅は、スコットの正規化基準ルールを使用して計算されます。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

[自動] オプション (スコットの正規化基準ルール)   

自動化の数式オプション

スコットの正規化基準ルール (Scott’s normal reference rule) では、データ セットと比較した場合のヒストグラムの分散の偏りを最小化します。通常は分散データを想定しています。

[ビンのオーバーフロー] オプション   

オーバーフロー ビンの数式オプション

[ビンのアンダーフロー] オプション   

ビンのアンダーフローの数式オプション

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[グラフ] の順にクリックします。

    Word の [挿入] タブの [図] グループの [グラフ]
  3. [グラフの挿入] ダイアログ ボックスの [すべてのグラフ] で、[ヒストグラム] をクリックして、[OK] をクリックします。

ヒント: 

  • グラフの外観をカスタマイズするには、リボンにある [デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これはヒストグラムの既定の設定です。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

Excel 2016 for Mac でヒストグラムを作成するには、次の手順に従います。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. リボンで、[挿入] タブをクリックし、 統計グラフ アイコン ([統計] アイコン) をクリックして、[ヒストグラム] の下で [ヒストグラム] を選択します。

ヒント: 

  • グラフの外観をカスタマイズするには、[グラフのデザイン] タブと [書式] タブを使用します。

  • [グラフのデザイン] タブおよび [書式] タブが表示されない場合は、ヒストグラムの任意の場所をクリックして、それらをリボンに追加します。

Excel 2011 for Mac でヒストグラムを作成するには、サードパーティ製のアドインをダウンロードする必要があります。参照:詳細については、「Excel 2011 for Mac で分析ツールが見つからない」を参照してください。

Excel Online] で (縦棒グラフ頻度のデータが表示されている)、ヒストグラムを表示することができますが、 Excel OnlineでサポートされていないExcelアドイン、分析ツールが必要になるために作成することはできません。

Excelデスクトップ アプリケーションを使っている場合、デスクトップやヒストグラムを作成するExcelを開くにExcel で編集] ボタンを使用することができます。

[Excel で編集] ボタン

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 携帯電話を使用している場合は、編集アイコン [編集] アイコン をタップしてリボンを表示し、[ホーム] をタップします。

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

    必要に応じて、グラフの要素をカスタマイズできます。

    注: この機能は、Office 365 サブスクリプションを購入しているユーザーのみが使用できます。Office 365 のサブスクリプションを使用している場合は、最新バージョンの Office をインストールしているかどうかを確認してください

    Office 365 または Excel の最新バージョンを試してみる

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 携帯電話を使用している場合は、編集アイコン [編集] アイコン をタップしてリボンを表示し、[ホーム] をタップします。

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

2 種類のデータを提供するExcelでヒストグラムを作成するにはデータを分析して、頻度を測定する間隔を表す境界値。ワークシート上の 2 つの列のデータを整理する必要があります。これらの列には、次のデータが含まれる必要があります。

  • 入力データ    これは、ヒストグラム ツールを使用して分析するデータです。

  • 区間番号    これらの番号は、データ分析で入力データを測定するためにヒストグラム ツールで使用する間隔を示します。

ヒストグラム ツールを使用するときに、 Excelは、各データ バックアップ内のデータ ポイントの数をカウントします。数値が負の最大数は、データ バックアップのバインドされているまたは連結し等しくの最小値よりも大きい場合、特定のビンにデータ ポイントが含まれます。Bin 範囲を省略すると、 Excelは、入力データの最小値および最大値の間に均等に分散ビンのセットを作成します。

ヒストグラム分析の出力は、新規ワークシート (または新規ブック) に表示され、ヒストグラム テーブルおよびヒストグラム テーブル内のデータを反映する縦棒グラフが表示されます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×