Excel、SQL Server、SharePoint、および他の外部ソースからデータをインポートする

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

Microsoft Office Visio Professional 2007を使用して、図形に直接データをすばやくインポートして表示することができます。最初の手順は、データソースに接続し、図面にデータをインポートすることです。2番目の手順は、インポートしたデータを図形にリンクすることです。

この記事の内容

手順 1: データをインポートする

手順 2: 行のデータを図面内の図形にリンクする

手順 1: データをインポートする

最初の手順では、データ選択ウィザードを使用して、データを [外部データ] ウィンドウにインポートします。

[外部データ] ウィンドウに表示されるデータは、インポート時のソースデータのスナップショットです。ソースデータの変更に合わせて、図面のデータを更新することができます。ただし、図面内のデータを変更しても、データソースを更新することはできません。「インポートしたデータを更新する」をご覧ください。

  1. [データ] メニューの [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初の画面で、使用するデータ ソースの種類を選択します。

    • Microsoft Office Excel ブック

    • Microsoft Office Access データベース

    • Microsoft Windows SharePoint Services リスト

    • Microsoft SQL Server データベース

    • 他の OLEDB または ODBC データ ソース

    • [以前作成した接続]

  3. ウィザードの指示に従って残りの作業を行います。

    注: 最初の画面で Excel ブック、Access データベース、SharePoint リスト以外のオプションを選択した場合、データ選択ウィザードに従って操作している途中、一時的にデータ接続ウィザードに迂回することがあります。

    ほとんどのウィザードにはヘルプが用意されています。ヘルプを参照するには、F1 キーを押すか、[ヘルプ] ボタンをクリックしてください。

データ接続ウィザードの最後の画面で [完了] をクリックすると、[外部データ] ウィンドウが表示され、インポートしたデータがグリッドに表示されます。

ページの先頭へ

手順 2: 行のデータを図面内の図形にリンクする

行のデータを図面内の図形にリンクするには 3 とおりの方法があります。それは、行を既存の図形に 1 つずつリンクする方法、行を図形に自動的にリンクする方法、そして、データに基づいて図形を作成する方法です。

行を既存の図形に 1 つずつリンクする

この方法は、図形の数が比較的少ない既存の図面に最適です。

  • [外部データ] ウィンドウから行を図面内の図形にドラッグします。

    データが図形に表示され、[外部データ] ウィンドウの行の左横にはリンク アイコンが表示されます。

    行を図形にドラッグする

    注: 

    • 1 つの行を複数の図形にリンクすることはできますが、複数の行を 1 つの図形にリンクすることはできません。

    • 図形およびデータの体裁を変更したり、視覚効果を高めたりする方法については、「データ グラフィックを使用してデータの視覚効果を高める」を参照してください。

    • [外部データ] ウィンドウを表示するには、[表示] メニューの [外部データ ウィンドウ] をクリックします。

行を既存の図形に自動的にリンクする

このアプローチは、図形の数が多い既存の図面に最適です。これは、図形に既にデータが含まれている場合にのみ機能します。データソースのデータに一致させることができます。

  1. [データ] メニューの [自動的にリンク] をクリックします。

  2. 自動リンク ウィザードの指示に従います。

    データは図形に表示されます。図形とデータの外観を変更または強化するには、「データグラフィックを使用してデータを拡張する」を参照してください。

ほとんどのウィザードにはヘルプが用意されています。ヘルプを参照するには、F1 ボタンを押すか、[ヘルプ] アイコンを参照してください。

データに基づいて図形を作成する

この方法は、図面に図形が 1 つも作成されておらず、特定の図形を使用する必要がない場合に最適です。

  1. [図形] ウィンドウの図形をクリックします。

  2. [外部データ] ウィンドウの行 (1 つまたは複数) を図面の空白スペースにドラッグします。

    図面にドラッグした行ごとに、手順 1 でクリックした図形のインスタンスが 1 つ表示されます。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×