Excel、Access、SharePoint サイト、SQL Server、その他の外部ソースからデータをインポートする

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。簡単に参照できるように、こちらに英語の記事があります。

Visio では、図形に直接データをすばやくインポートして表示することができます。最初の手順は、データソースに接続し、図面にデータをインポートすることです。2番目の手順は、インポートしたデータを図形にリンクすることです。

手順 1: データをインポートする

この最初の手順では、データセレクターウィザードを使用してデータをインポートします。

[外部データ] ウィンドウに表示されるデータは、インポート時のソースデータのスナップショットです。ソースデータの変更に合わせて、図面のデータを更新することができます。ただし、図面内のデータを変更しても、データソースを更新することはできません。「インポートしたデータを更新する」をご覧ください。

  1. [データ] タブの [外部データ] グループで [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初のページで、使用する次の種類のデータソースを選択します。

    • Microsoft Excel ブック

    • Microsoft Access データベース

    • Microsoft SharePoint Foundation リスト

    • Microsoft SQL Server データベース

    • 他の OLEDB または ODBC データ ソース

    • 以前に作成した接続

  3. ウィザードの残りの部分を完了します。

    注: ウィザードの最初のページで Excel ブック、Access データベース、または SharePoint リスト以外のオプションを選択した場合は、データセレクターウィザードの実行中に、データ接続ウィザードに一時的に流用されることがあります。

データ接続ウィザードの最後のページで [完了] をクリックすると、インポートしたデータがグリッドに表示された [外部データ] ウィンドウが開きます。

手順 2: データ行を図面内の図形にリンクする

データ行を図面内の図形にリンクするには、次の3つの方法があります。行を既存の図形にリンクさせることができます。行を図形に自動的にリンクすることも、データから図形を作成することもできます。

方法 1: 既存の図形に行を一度に1つずつリンクする

このアプローチは、比較的少ない図形を持つ既存の図面に最適です。

  • [外部データ] ウィンドウから図面内の図形に行をドラッグします。

    注: [外部データ] ウィンドウが表示されない場合は、[データ] タブに移動し、[表示/非表示] グループの [外部データ] ウィンドウの横にあるチェックボックスをオンにします。

    図形にデータが表示され、[外部データ] ウィンドウの行の左側にリンクアイコンが表示されます。

    行を図形にドラッグする

    注: 

    • 1つの行を複数の図形にリンクすることはできますが、複数の行を1つの図形にリンクすることはありません。

    • 図形とデータの外観を変更または強化するには、「データグラフィックを使用してデータを拡張する」を参照してください。

    • [外部データ] ウィンドウを表示するには、[表示] メニューの [外部データウィンドウ] をクリックします。

方法 2: 行を既存の図形に自動的にリンクする

このアプローチは、図形の数が多い既存の図面に最適です。これは、図形に既にデータが含まれている場合にのみ機能します。データソースのデータに一致させることができます。

  1. Visio 2016と新しいバージョンの場合: [データ] メニューの [すべて更新] をクリックし、[更新後に挿入] を選択します (まだ表示されていない場合)。

    Visio 2013およびそれ以前のバージョンの場合: [データ] メニューの [自動的にリンク] をクリックします。

  2. 自動リンクウィザードの手順に従います。

    データは図形に表示されます。図形とデータの外観を変更または強化するには、「データグラフィックを使用してデータを拡張する」を参照してください。

方法 3: データから図形を作成する

この方法は、図面に図形が含まれておらず、特定の図形を使用する必要がない場合に最適です。

  1. [図形] ウィンドウで図形をクリックします。

  2. [外部データ] ウィンドウから行または一連の行を図面の空白スペースにドラッグします。

    クリックした図形の1つのインスタンスが、図面上にドラッグした行ごとに表示されます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×