Access 2010 の基本的な作業

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

ここでは、Microsoft z0z_の使用方法を学習するのに役立つ基本的なデータベースタスクを紹介します。

 

この記事の内容

Access とは

Access のリレーショナルデータベース

Access を開くと

テンプレートを検索して適用する

データベースを一から作成する

既存の Access データベースを開く

新しいデータベースを使い始める

表を追加する

Access テーブルに別のソースからデータを貼り付ける

別のソースのデータをインポートまたはリンクする

次のステップ

スプレッドシートまたは他のプログラムからデータをインポートする

Access に Excel ワークシートをインポートする

新しいデータベースのテーブルとして Excel ワークシートをインポートする

テーブル正規化ウィザードを使用してデータを整理する

他のプログラムのデータを操作する

いくつかのバージョンの Access で以前のバージョンのデータベースを使用する

access の複数のバージョンで access データベースファイルを使用する

手順 1: 既存のデータベースのコピーを作成し、新しい形式で保存する

手順 2: コピーデータベースを分割し、元のファイルをバックエンドデータベースとして使用する

手順 3: 新しいフロントエンドを元のデータベースに接続する

Access の複数のバージョンでフロントエンド/バックエンドアプリケーションを使用する

Access とは

Access 2010 は、重要な情報を追跡するために使用できる、 データベースアプリケーションの設計と展開ツールです。 自分のコンピューター上でデータを保持したり、web に公開したりすることができます。そのため、他のユーザーが web ブラウザーでデータベースを使えるようになります。

多くのユーザーは、自分で使用しているプログラムがタスクに徐々に適合するようになると、Access を使い始めます。 たとえば、イベントプランナーで、イベントを正常に処理するために管理する必要があるすべての詳細情報を把握しておく必要があるとします。 ワープロまたはスプレッドシートプログラムを使用してこの操作を実行すると、データが重複している場合や矛盾がある場合に、問題が簡単に発生する可能性があります。 予定表ソフトウェアを使用することはできますが、予定表で財務情報を管理することは適切ではありません。

Access のリレーショナルデータベース

場合によっては、このような情報を追跡するリレーショナルデータベースが必要になることがあります。たとえば、データの小さなコレクションに分割されているデータの格納 (テーブルと呼ばれる) によって、重複を排除し、共通の情報 (フィールドと呼ばれます) に基づいて互いに関連付けられます。. たとえば、イベントを計画するリレーショナルデータベースには、顧客情報を含むテーブル、ベンダー情報を含むテーブル、イベント情報を含むテーブルが含まれていることがあります。 イベント情報を含むテーブルには、顧客テーブルに関連付けるためのフィールドと、そのテーブルを仕入先テーブルに関連付けるためのフィールドが含まれている場合があります。 この方法では、たとえば、仕入先の電話番号が変更された場合、その情報は、ベンダーが関係するすべてのイベントではなく、仕入先テーブルで一度変更できます。

Access は、情報の管理に役立つリレーショナルデータベースアプリケーションをすばやく簡単に開発するために使用できるツールです。 データベースを作成すると、在庫、プロフェッショナルな連絡先、ビジネスプロセスなど、あらゆる種類の情報を常に把握することができます。 Access には、さまざまな情報を管理するためにすぐに使用できるテンプレートが用意されており、初心者にとっても簡単に作成できます。

Access を開くと

_ z0z_ _を開始すると、Microsoft Office Backstage ビューが表示されます。ここでは、現在のデータベースに関する情報の取得、新しいデータベースの作成、既存のデータベースのオープン、および_ z1z_のおすすめコンテンツの表示を行うことができます。

Access 2010 の Backstage ビュー

Backstage ビューには、データベースを調整、維持、または共有するために使用できるその他の多くのコマンドも含まれています。 Backstage ビューのコマンドは、通常はデータベース全体に適用されますが、データベース内のオブジェクトには適用されません。

注: [ファイル] タブをクリックすると、いつでも Backstage ビューを表示できます。

ページの先頭へ

テンプレートを検索して適用する

Access には、データベースの作成プロセスを高速化するために使用できるさまざまなテンプレートが用意されています。 テンプレートは、特定のタスクを実行するために必要なすべてのテーブル、クエリ、フォーム、およびレポートを含む、すぐに使用できるデータベースです。 たとえば、問題の管理、連絡先の管理、または経費の記録に使用できるテンプレートがあります。 一部のテンプレートには、使用方法を示すのに役立つサンプルレコードがいくつか含まれています。 テンプレートデータベースは、そのまま使用することも、ニーズに合わせてカスタマイズすることもできます。

データベースにテンプレートを検索して適用するには、次の操作を行います。

  1. [ファイル] タブの [新規] をクリックします。

  2. [使用できるテンプレート] で、次のいずれかの操作を行います。

    • 最近使用したテンプレートを再利用するには、[最近使用したテンプレート] をクリックし、目的のテンプレートを選択します。

    • 既にインストールされているテンプレートを使用するには、[マイテンプレート] をクリックし、目的のテンプレートを選択します。

    • _ z0z_でテンプレートを検索するには、[ Office.com Templates] の [テンプレート] カテゴリをクリックし、目的のテンプレートを選び、[ダウンロード] をクリックして、Office からコンピューターにテンプレートをダウンロードします。

      Access 内から Office.com のテンプレートを検索することもできます。 [ Office.com 用検索] ボックスに1つ以上の検索語句を入力し、矢印ボタンをクリックして検索します。

  3. 必要に応じて、[ファイル名] ボックスの横にあるフォルダーアイコンをクリックして、データベースを作成する場所を参照します。 特定の場所を指定しない場合は、[ファイル名] ボックスの下に表示される既定の場所にデータベースが作成されます。

  4. [作成] をクリックします。

Access によってデータベースが作成され、使用できるように開かれます。

ページの先頭へ

データベースを一から作成する

Access を使用してデータベースを作成するための概念について詳しく説明したい場合は、「データベース設計の基本」をご覧ください。

ニーズに合ったテンプレートがない場合、または Access で使用するデータが別のプログラムにある場合は、データベースを最初から作成した方がよいかもしれません。 Access 2010 では、標準のデスクトップデータベース、または web データベースのいずれかを選ぶことができます。

web データベースの詳細については、「 web で共有するデータベースを作成する」を参照してください。

新しいデータベースを作成するには、次の操作を行います。

  1. Access を起動します。

  2. Backstage ビューの [新規作成] タブで、[空のデータベース] または [空の Web データベース] をクリックします。

    重要: ここで行う選択によって、データベースで使用できる機能が決まります。 デスクトップデータベースを web に発行することはできません。また、web データベースでは、集計クエリなど、一部のデスクトップ機能がサポートされていません。

  3. 右側で、[ファイル名] ボックスにデータベースの名前を入力します。

    ファイルを作成する場所を変更するには、[ファイル名] ボックスの横にある [参照/z0z_] をクリックし、新しい場所を参照して選び、[ OK]をクリックします。

  4. [作成] をクリックします。

    Access によってデータベースが作成され、" z0z_" という空のテーブル (Table1 という名前) が開かれます。

  5. 新しいテーブルの[クリックして追加]列の最初の空のセルにカーソルが配置されます。

    データを追加するには、入力を開始します。または、この記事の後半の「 Access のテーブルに別のソースのデータを貼り付ける」の説明に従って、別のソースからデータを貼り付けることもできます。

    注: 

    • データシートビューにデータを入力する方法は、Excel ワークシートにデータを入力する方法とよく似ています。 主な制限事項は、データシートの左上隅から、連続した行と列にデータを入力する必要があることです。 Excel ワークシートの場合と同じように、空白の行または列を含めることによってデータを書式設定することは避けてください。これにより、テーブル内の領域が無駄になります。 テーブルにはデータが含まれているだけです。 このデータのすべてのビジュアルなプレゼンテーションは、後でデザインするフォームとレポートで実行されます。

    • データの入力中にテーブル構造が作成されます。 データシートに新しい列を追加すると、テーブルに新しいフィールドが定義されます。 入力したデータの種類に基づいて、フィールドの_ _ z0z_が設定されます。 たとえば、日付値のみを入力した列がある場合、Access はそのフィールドのデータ型を [日付/時刻] に設定します。 後でそのフィールドに日付以外の値 (名前や電話番号など) を入力しようとすると、その値が列のデータ型と一致しないことを通知するメッセージが表示されます。 可能であれば、各列に同じ種類のデータ (テキスト、日付、数値、その他の種類が含まれているかどうか) を含めるようにテーブルを設計する必要があります。 これにより、必要なデータだけを選択するクエリ、フォーム、レポートを簡単に作成できます。

まだデータを入力しない場合は、[_ 0z_を閉じる] をクリックします。

注: Access では、保存せずに閉じると、Table1 が削除されます。

ページの先頭へ

既存の Access データベースを開く

ヒント: 開いている最後のいくつかのデータベースの1つをすばやく開くには、[ファイル] タブで [最近使用したファイル] をクリックし、ファイル名をクリックします。

  1. [ファイル] タブの [開く] をクリックします。

  2. [ファイルを開く] ダイアログボックスでショートカットをクリックするか、[ファイルの場所] ボックスで、目的のデータベースが含まれているドライブまたはフォルダーをクリックします。

  3. フォルダー一覧で、データベースが含まれているフォルダーを開くまで、フォルダーをダブルクリックします。

  4. データベースが見つかったら、次のいずれかの操作を行います。

    • 既定の [開く] モードでデータベースを開くには、そのデータベースをダブルクリックします。

    • マルチユーザー環境で、共有アクセスのためにデータベースを開き、同時にデータベースの読み取りと書き込みを行うことができるようにするには、[開く] をクリックします。

    • 読み取り専用のアクセスでデータベースを開いて編集できないようにするには、[開く] ボタンの横にある矢印をクリックし、[読み取り専用として開く] をクリックします。

    • 排他アクセスのためにデータベースを開いているときに、他のユーザーがそれを開けないようにするには、[開く] ボタンの横にある矢印をクリックし、[排他モードで開く] をクリックします。

    • 読み取り専用アクセスでデータベースを開くには、[開く] ボタンの横にある矢印をクリックし、[排他読み取り専用として開く] をクリックします。ただし、他のユーザーはデータベースを開くことはできますが、読み取り専用アクセスのみが許可されます。

開こうとしているデータベースが見つからない場合    

  1. [ファイルを開く] ダイアログボックスで、[マイコンピューター ] のショートカットをクリックするか、[探す場所] ボックスで [マイコンピューター] をクリックします。

  2. ドライブの一覧で、データベースが含まれていると思われるドライブを右クリックし、[検索] をクリックします。

  3. 検索条件を入力し、enter キーを押してデータベースを検索します。

  4. データベースが見つかった場合は、[検索結果] ダイアログボックスでそのデータベースをダブルクリックして開きます。

    [開く] ダイアログボックスから検索を開始したため、データベースを開く前に、そのダイアログボックスで [キャンセル] をクリックする必要があります。

データファイルは、外部ファイル形式 (dBASE、Paradox、Microsoft Exchange、Excel など) で直接開くことができます。 microsoft SQL Server や microsoft FoxPro など、任意のz0z_を直接開くこともできます。 access では、データファイルと同じフォルダーに新しい access データベースが自動的に作成され、外部データベースの各テーブルにリンクが追加されます。

ページの先頭へ

新しいデータベースを使い始める

使用したテンプレートによっては、新しいデータベースの使用を開始するために、次の1つ以上の操作を実行する必要がある場合があります。

  • 空のユーザーリストが表示された [ログイン] ダイアログボックスが表示されたら、次の手順に従って作業を開始します。

    1. [新しいユーザー] をクリックします。

    2. "ユーザーの詳細" フォームに入力します。

    3. [保存して閉じる] をクリックします。

    4. 先ほど入力したユーザー名を選択し、[ログイン] をクリックします。

  • Access によって空のデータシートが表示される場合は、データシートに直接データを入力するか、[その他のボタンとタブ] をクリックしてデータベースを調べます。

  • [はじめに] ページが表示された場合は、そのページの [リンク] をクリックしてデータベースの詳細を確認したり、他のボタンやタブをクリックしてデータベースを調べたりすることができます。

  • メッセージバーにセキュリティ警告メッセージが表示され、テンプレートの発行元が信頼できる場合は、[コンテンツを有効にする] をクリックします。 データベースにログインが必要な場合は、ログインする必要があります。

デスクトップと web データベースの場合は、次のいずれかの手順で作業を開始することもできます。

ページの先頭へ

表を追加する

新しいテーブルを既存のデータベースに追加するには、[作成] タブの [テーブル] グループのツールを使用します。

[作成] タブの [テーブル] グループ

注: web データベースでは、[テーブル] グループで [テーブル] コマンドのみを使用できます。

どのビューから開始するかに関係なく、Access ウィンドウのステータスバーにある [表示] ボタンを使うと、いつでも他のビューに切り替えることができます。

データシートビューで空のテーブルを作成する    データシートビューでは、データをすぐに入力できます。また、Access では、背後のテーブル構造を自動的に作成できます。 フィールド名には数値 (Field1、Field2 など) が割り当てられ、フィールドのデータ型は入力したデータの種類に基づいて設定されます。

  1. [作成] タブの [テーブル] グループで、[テーブル] をクリックします(z0z_)

  2. Access によってテーブルが作成され、 [クリックして追加]列の最初の空のセルにカーソルが置かれます。

  3. データを追加するには、最初の空のセルに入力を開始するか、この記事の後半で説明するように、別のソースからデータを貼り付けます。

    • 列の名前を変更するには (フィールド)、列見出しをダブルクリックして、新しい名前を入力します。

      ヒント: 各フィールドにわかりやすい名前を付けると、データを確認しなくても、データに含まれている内容がわかります。

    • 列を移動するには、列見出しをクリックして目的の場所にドラッグします。 複数の連続した列を選んで、すべての列を新しい場所にドラッグすることもできます。

      テーブルにフィールドを追加するには、データシートビューで[クリックして追加]列で入力を開始するか、[フィールド] タブの [ add & Delete ] グループのコマンドを使用して新しいフィールドを追加することができます。

デザインビューからテーブルを作成する    デザインビューで、最初に新しいテーブルの構造を作成します。 データシートビューに切り替えてデータを入力するか、フォームなどの別の方法を使用してデータを入力します。

デザインビューは、web データベースのテーブルでは使用できません。

  1. [作成] タブで、[テーブル] グループの [テーブル デザイン] をクリックします。 ボタンの画像

  2. テーブルの各フィールドについて、[フィールド名] 列に名前を入力し、[データ型] ボックスの一覧からデータ型を選びます。

  3. [説明] 列には、各フィールドの追加情報を入力できます。 入力した説明は、挿入ポイントがそのフィールドにあるときにステータスバーに表示され、[フィールドリスト] ウィンドウからフォームまたはレポートにフィールドをドラッグして作成したコントロールのステータスバーのテキストとして使用されます。、フォームウィザードまたはレポートウィザードでそのフィールドに対して作成されたすべてのコントロールの場合。

  4. すべてのフィールドを追加したら、次のようにテーブルを保存します。

    • [ファイル] タブで [保存] をクリックします。

  5. データシートビューに切り替えて、最初の空のセルをクリックし、入力すると、いつでもデータをテーブルに入力することができます。 また、次のセクションで説明するように、別のソースからデータを貼り付けることもできます。

SharePoint リストに基づいてテーブルを作成する    SharePoint リストを使用すると、アクセス権を持たないユーザーがデータを使用できます。 また、リストデータはサーバーに保存されるので、通常は、デスクトップコンピューターに保存されているファイルよりもデータ損失に対する保護が強化されます。 新しいリストで開始するか、既存のリストにリンクすることができます。 リストを作成する SharePoint サイトに対して十分な権限を持っている必要があります。これは、SharePoint 管理者に問い合わせてオプションの詳細を確認できるように、サイトによって異なります。

この機能は、Web データベースでは使用できません。

  1. [作成] タブの [テーブル] で、[SharePoint リスト] をクリックします。

  2. リストテンプレートの1つを使用して、[連絡先] や [イベント] などの標準の SharePoint リストを作成できます。

    また、カスタムリストを作成したり、既存のリストにリンクしたり、既存のリストをインポートしたりすることもできます。 必要なオプションをクリックします。

  3. リストテンプレートを選ぶか、カスタムリストを作成する場合、[新しいリストの作成] ダイアログボックスが開き、手順に従って作業します。 既存のリストを使用する場合は、[外部データの取り込み] ダイアログボックスが表示され、ヘルプを参照できます。

テーブルの詳細については、「テーブルの概要」を参照してください。

ページの先頭へ

Access テーブルに別のソースからデータを貼り付ける

データが Excel などの別のプログラムに保存されている場合は、データをコピーして、Access テーブルに貼り付けることができます。 一般的に、データが既に列に分割されている場合は、Excel ワークシート内にある場合に最も適しています。 データが word 処理プログラムに含まれている場合は、最初にタブを使用してデータの列を分離するか、word 処理プログラムでデータをテーブルに変換してから、データをコピーする必要があります。 データの編集や操作が必要な場合 (フルネームを姓と名に分割する場合など) は、データをコピーする前に行うことをお勧めします。特に Access を使い慣れていない場合は、このようにしてください。

空のテーブルにデータを貼り付けると、各フィールドのデータ型は、そこにあるデータの種類に応じて設定されます。 たとえば、貼り付けフィールドに日付値が含まれていない場合、日付/時刻データ型がそのフィールドに適用されます。 貼り付けられたフィールドに "はい" と "いいえ" の単語のみが含まれている場合、Access では、yes/no データ型がフィールドに適用されます。

Access では、貼り付けられたデータの1行目に表示される内容に応じて、フィールドに名前が付けられます。 貼り付けられたデータの1行目がその後の行に似ている場合は、最初の行がデータの一部であり、フィールドの汎用名 (Field1、Field2 など) が割り当てられていることが Access によって決定されます。 貼り付けられたデータの1行目が後続の行と似ていない場合、Access では最初の行がフィールド名として使用され、実際のデータの最初の行は除外されます。

Access によって一般的なフィールド名が割り当てられている場合は、混乱を避けるために、できるだけ早くフィールドの名前を変更する必要があります。 次の手順で行います。

  1. [ファイル] タブで [保存] をクリックしてテーブルを保存します。

  2. データシートビューで、各列見出しをダブルクリックし、列の名前を入力します。

  3. もう一度テーブルを保存します。

ページの先頭へ

別のソースのデータをインポートまたはリンクする

別のプログラムで収集したデータを Access で使用したい場合があります。 他のプログラムでデータを保存しているユーザーと共同作業を行い、Access でデータを操作することが必要になる場合があります。 また、データの分散ソースが複数ある場合は、"ランディングパッド" が必要になります。これにより、さらに詳しく分析できます。

Access では、他のプログラムのデータを簡単にインポートまたはリンクすることができます。 Excel ワークシート、別の Access データベース内のテーブル、SharePoint リスト、その他のさまざまなソースからデータを取り込むことができます。 プロセスはデータソースによって少し異なりますが、次の手順に従って作業を開始します。

  1. [外部データ] タブの [インポート & のリンク] グループで、インポートするファイルの種類のコマンドをクリックします。

    たとえば、excel ワークシートからデータをインポートする場合は、[ excel] をクリックします。 適切なプログラムの種類が表示されない場合は、[その他] をクリックします。

    注: [ & のインポート] リンクグループで正しい形式の種類が見つからない場合は、最初にデータを作成したプログラムを起動し、そのプログラムを使用して Access がサポートするファイル形式 (たとえば、 z0z_など) にデータを保存する必要があります。を選択し、データのインポートまたはリンクを設定します。

  2. [外部データの取り込み] ダイアログボックスで、[参照] をクリックしてソースデータファイルを参照するか、ソースデータファイルの完全なパスを [ファイル名] ボックスに入力します。

  3. [現在のデータベースのデータを保存する方法と場所を指定してください] で目的のオプションをクリックします。 インポートされたデータを使用して新しいテーブルを作成したり、データソースへのリンクを維持するリンクテーブルを作成したりできます。

  4. [OK] をクリックします。

    選択に応じて、[オブジェクトのリンク] ダイアログボックスまたは [オブジェクトのインポート] ダイアログボックスが開きます。

  5. ダイアログボックスを使用して、プロセスを完了します。 実際に実行する手順は、選択したインポートオプションまたはリンクオプションによって異なります。

  6. ウィザードの最後のページで、[完了] をクリックします。

    インポートを選択した場合は、完了したインポート操作の詳細を保存するかどうかを確認するメッセージが表示されます。

  7. 同じインポート操作をもう一度実行する場合は、[インポート手順の保存] をクリックし、詳細情報を入力します。

    [外部データ] タブの [インポート] グループで [保存済みのインポート] をクリックし、[インポート定義] をクリックして、[実行] をクリックすると、インポート操作を簡単に再現できます。

  8. 操作の詳細を保存しない場合は、[閉じる] をクリックします。

データが新しいテーブルにインポートされ、そのテーブルがナビゲーションウィンドウの [テーブル] の下に表示されます。

Access にデータをインポートする方法の詳細については、この記事の [参照] セクションのリンク先を参照してください。

ページの先頭へ

次のステップ

設計プロセスの残りの部分は、目的によって異なりますが、クエリ、フォーム、レポート、マクロの作成を検討することをお勧めします。 この記事では、追加のデータベースオブジェクトを作成する方法については説明しません。

詳細については、次の記事を参照してください。

ページの先頭へ

スプレッドシートまたは他のプログラムからデータをインポートする

その他のデータベースまたはスプレッドシートプログラムに精通している場合は、これらのアプリケーションの動作や使用しているデータベースについての基本事項を理解している場合があります。 Access は、リレーショナルデータベースを作成できるため、他の多くのデータベースアプリケーションとは異なります。また、高度なクエリ、フォーム、レポートを開発するためのツールを提供することで、ほとんどのスプレッドシートプログラムとは、さらに異なります。 また、Access には、SQL Server など、他のデータベースプログラムを操作するための多くのオプションが用意されています。

Access に Excel ワークシートをインポートする

Excel で最初にリストを作成した後、多くのユーザーが Access の使用を試してみます。 Excel はリストを始めるのに最適な場所ですが、リストが拡大されるにつれて整理して更新を維持するのが難しくなります。 通常、リストを Access に移動するのは、次の論理的な手順です。

データベーステーブルはワークシートの構造に似ていますが、データは行と列に格納されます。 そのため、通常はワークシートをデータベーステーブルにインポートするのは簡単です。 データをワークシートに格納してデータベースに保存する主な違いは、データの整理方法です。 ワークシート全体を新しいテーブルとしてデータベースにインポートするだけでは、データの整理や更新に関連する問題が解決されません。特に、ワークシートに冗長なデータが含まれている場合。 これらの問題を解決するには、スプレッドシートのデータを個別のテーブルに分割する必要があります。各テーブルには、関連するデータが含まれています。 テーブルにデータを配置する方法の詳細については、「データベース設計の基本」を参照してください。

Access には、このプロセスを完了するのに役立つテーブル正規化ウィザードが用意されています。 テーブルにデータをインポートした後、ウィザードを使用すると、テーブルを個別のテーブルに分割することができます。各テーブルには、他のテーブルで重複しないデータが含まれています。 ウィザードでは、テーブル間に必要なリレーションシップも作成されます。

ページの先頭へ

新しいデータベースのテーブルとして Excel ワークシートをインポートする

  1. [ファイル] タブの [新規作成] をクリックし、[空のデータベース] をクリックします。

  2. [ファイル名] ボックスに新しいデータベースの名前を入力し、[作成] をクリックします。

    新しいデータベースが開き、Access によって新しい空のテーブル Table1 が作成されます。

  3. Table1 を閉じます。

    テーブル1のデザインの変更を保存するかどうかをたずねるメッセージが表示されたら、[いいえ] をクリックします。

  4. [外部データ] タブの [ & リンクのインポート] グループで、[ Excel] をクリックします。 ボタン イメージ

  5. [外部データの取り込み] ダイアログボックスで、[参照] をクリックします。

  6. [ファイルを開く] ダイアログボックスを使用して、ファイルを見つけます。

  7. ファイルを選び、[開く] をクリックします。

  8. [外部データの取り込み] ダイアログボックスで、[現在のデータベースの新しいテーブルにソースデータをインポートする] オプションが選択されていることを確認します。

  9. [OK] をクリックします。

    [スプレッドシートのインポート] ウィザードが起動し、データについていくつかの質問を求められます。

  10. 指示に従って、[次へ] または [戻る] をクリックしてページ間を移動します。 ウィザードの最後のページで、[完了] をクリックします。

    注: 完了したインポート操作の詳細を保存するかどうかを確認するメッセージが表示されます。 同じインポート操作をもう一度実行する場合は、[はい] をクリックして、詳細を入力します。 [外部データ] タブの [インポート] で [保存済みのインポート] をクリックすると、後で簡単に操作を再現できます。 操作の詳細を保存しない場合は、[閉じる] をクリックします。

Access によって新しいテーブルにデータがインポートされ、ナビゲーションウィンドウの [すべてのテーブル] に表示されます。

ページの先頭へ

テーブル正規化ウィザードを使用してデータを整理する

データが Access テーブルにインポートされたら、テーブル正規化ウィザードを使用して、冗長なデータをすばやく識別できます。 このウィザードでは、データを効率的な方法で保存できるように、データを個別のテーブルに整理することができます。 Access では、元のテーブルがバックアップとして保持され、データベースアプリケーションの基礎として使用できる新しいテーブルが作成されます。

  1. 分析するテーブルが含まれている Access データベースを開きます。

  2. [データベースツール] タブの [分析] グループで [テーブルの分析] をクリックします。

    テーブル正規化ウィザードが起動します。

    ウィザードの最初の2ページには、簡単なチュートリアルが含まれています。ボタンをクリックすると、例が表示されます。 序文ページが表示されずに、[導入ページを表示] というチェックボックスが表示される場合は、このチェックボックスをオンにし、[戻る] を2回クリックして、導入を確認します。 概要ページを表示した後で、導入ページをもう一度表示したくない場合は、[導入ページを表示]チェックボックスをオフにします。

  3. [次のテーブルに多数のレコードで繰り返されている値が含まれていますか] ページで、分析するテーブルを選択し、[次へ] をクリックします。

  4. ウィザードでは、どのフィールドをどのテーブルに設定するかを決めることができます。または、自分で決定することもできます。 ウィザードの提案に従っている場合は、ウィザードの次のページでテーブルのレイアウトを変更することもできます。

    注: ウィザードでどのフィールドをどのテーブルに配置するかを決定する場合、特に操作するデータが少ない場合は、データに適しているとは限りません。 ウィザードの結果を慎重に確認する必要があります。 また、ウィザードでは、考えている組織よりも効率的な組織が提案されている可能性があるため、少なくともウィザードの決定を1回試してみることをお勧めします。 候補が気に入らない場合でも、フィールドを手動で並べ替えることができます。また、いつでも [戻る] をクリックして、すべてのフィールドを自分で並べ替えることができます。

  5. [次へ] をクリックします。 このページでは、どのテーブルにどのフィールドが含まれているかを指定します。 ウィザードを使用することにした場合、リレーションシップの線で接続されている複数のテーブルが表示されます。 それ以外の場合、Access では、すべてのフィールドを含むテーブルが1つだけ作成されます。 いずれの場合も、このページで変更を行うことができます。

    • テーブルからページの空白領域にフィールドをドラッグして、これらのフィールドを含む新しいテーブルを作成できます。 テーブル名を入力するように求めるメッセージが表示されます。

    • あるテーブルから別のテーブルにフィールドをドラッグすることができます。これらのフィールドは、より効率的に格納されると考えられます。

    • ほとんどのテーブルには、 idまたは生成される一意の idフィールドが指定されます。 ID フィールドの詳細については、ウィザードの右上隅にある [ヒント] をクリックしてください。

    • 変更を元に戻すには、[元に戻す] ボタンをクリックします。

    • テーブルの名前を変更するには、テーブルのタイトルバーをダブルクリックし、新しい名前を入力して、[ OK]をクリックします。

  6. フィールドを希望どおりに配置したら、[次へ] をクリックします。

  7. ウィザードで、非常に類似した値を持つレコードが見つかった場合は、その値を入力ミスとして特定し、その処理内容を確認できる画面を表示することができます。 リストをスクロールして、修正列に値が含まれているものを見つけ、ドロップダウンリストで適切なアイテムをクリックします。 値をウィザードで変更しないようにするには、(そのままにしておく)を選びます。 完了したら、[次へ] をクリックします。

  8. ウィザードでは、元のテーブルに似たクエリを作成するかどうかを確認します。 元のテーブルに基づくフォームやレポートを既に作成している場合は、このようなクエリを作成することをお勧めします。 [はい、クエリを作成します] を選択した場合、ウィザードは元のテーブルの名前をテーブル名に "_ OLD" を付加して変更し、元のテーブルの名前を使用して新しいクエリの名前を変更します。 テーブルに基づくフォームとレポートでは、データのクエリが使用されるようになりました。これで、以前と同じように処理を続けることができます。

  9. [完了] をクリックします。

    ウィザードによって新しいテーブルが指定されて作成され、開かれます。 結果の調査が完了したら、それらを閉じます。

ページの先頭へ

他のプログラムのデータを操作する

Access 2010 には、他のプログラムに格納されているデータを操作するための機能が用意されています。

別のファイル形式のデータにリンクする新しい Access データベースを作成する    Access を使用すると、テキスト、dBASE、スプレッドシートなどの別のファイル形式のファイルを開くことができます。 access によって自動的に access データベースが作成され、ファイルがリンクされます。

  1. Access を起動します。

  2. [ファイル] タブの [開く] をクリックします。

  3. [ファイルを開く] ダイアログボックスで、一覧で開くファイルの種類をクリックします。 ファイルの種類がわからない場合は、[すべてのファイル (*.*)] をクリックします。

  4. 必要に応じて、開くファイルが保存されているフォルダーを参照します。 ファイルが見つかったら、それをダブルクリックして開きます。

  5. ウィザードに表示される手順に沿って操作します。 ウィザードの最後のページで、[完了] をクリックします。

既存の Access データベースにデータをインポートまたはリンクする    access ファイル内にデータが含まれるように、他のソースやプログラムからデータを access テーブルにインポートするか、access からデータにリンクして、データが元のファイル (access ファイルの外部) に残るようにすることができます。

  1. [外部データ] タブの [インポート & のリンク] グループで、データの保存形式をクリックします。

    次のソースからデータをインポートまたはリンクすることができます。

    • Excel    Excel ブックのワークシートまたは名前付き範囲からデータを取り込むことができます。 各ワークシートまたは名前付き範囲は、個別にインポートまたはリンクする必要があります。

    • Access    これは、分割されたデータベースを作成して、プロセスをデータから分離する場合に非常に便利です。 つまり、1つのデータベースを使用して、すべてのフォーム、レポート、マクロを格納し、別のデータベースにデータを保持することができます。 これにより、他のユーザーの作業を中断することなく、改善を開発できます。 また、さまざまな Access データベースのデータを結合して、複数の部署またはビジネスパートナー間でデータを簡単に要約することができます。

    • ODBC データベース    多くのプログラムは、多くのデータベースサーバー製品など、この形式をサポートしています。 これにより、さまざまなシステムからデータを結合する "ランディングパッド" データベースを作成することができます。

    • テキスト ファイル    単純なテキストファイルに接続することもできます。また、Access を使用して、そのファイルの内容を変更することもできます。 これにより、さまざまなプログラムで Access データを簡単に利用できるようになります。

    • XML ファイル    この形式では、web サーバーなど、他のさまざまなプログラムとの互換性も提供されます。

    • SharePoint リスト    これにより、SharePoint リストを使用する標準的な方法である web ブラウザーでデータを使用できるようになります。

    • データ サービス    企業内の web データサービスに接続できます。

    • HTML ドキュメント    

    • Outlook フォルダー    Outlook フォルダーに接続すると、連絡先情報とその他のデータを簡単に統合することができます。

    • dBase ファイル    dBase は Access でサポートされている一般的な代替データベースシステムです

      [外部データの取り込み] ダイアログボックスが表示されます。

  2. ダイアログボックスの指示に従います。

    Access によってデータがインポートされ、データベースにリンクされます。 ほとんどの形式では、データの場所を指定し、そのデータをデータベースに格納する方法を選択する必要があります。

ページの先頭へ

いくつかのバージョンの Access で以前のバージョンのデータベースを使用する

access データベースまたは access プロジェクトを access 2000 以降で作成した場合、ファイルのセキュリティが有効になっている場合でも、データベースまたはプロジェクトは、それを作成した access のバージョンまたはそれ以降のバージョンで使用できます。 たとえば、access 2000、access 2002、access 2003、access 2007、access 2010 では、access 2000 ファイルを使用できます。

以前のバージョンの access でデータを維持したい場合がありますが、そのデータへのリンクを必要としているが新しいバージョンの access を使用しているが、それ以降のバージョンの機能の一部を利用することもできます。 解決策として、新しい "フロントエンド" データベース (フォーム、レポート、クエリ、マクロを含みますが、テーブルは含まれません) を新しいバージョンで作成し、以前のバージョンのファイルのテーブルにリンクします。 データベースが1つのファイルに含まれているかどうか、または既にz0z_に分割されているかどうかに応じて、次のいずれかの手順を使用します。

access の複数のバージョンで access データベースファイルを使用する

以前のバージョンの access データベースのすべてのテーブル、フォーム、その他のオブジェクトが1つのファイルに格納されていて、複数のバージョンの access でデータベースを使用する場合は、新しいバージョンで新しいフロントエンドデータベースを作成し、元のファイルにリンクすることができます。 以前のバージョンの Access を使用しているユーザーは、引き続き元のデータベースを使用できます。 新しいバージョンのユーザーは、新しいフロントエンドデータベースを使用して、同じデータにリンクすることができます。 複数のバージョンの Access に対応する必要がある場合は、複数のフロントエンドバージョンを作成できます。

ページの先頭へ

手順 1: 既存のデータベースのコピーを作成し、新しい形式で保存する

access 2000、access 2002-2003、または access 2007 の3つの最新の形式のいずれかにデータベースを変換するには、次の手順に従います。 このコマンドを実行すると、元のデータベースが元の形式で保存され、指定した形式でコピーが作成されます。

  1. Access ファイルを閉じます。 ファイルがサーバーまたは共有フォルダーに置かれているマルチユーザー Access データベースの場合は、他のユーザーがそのデータベースを開いていないことを確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. 変換するファイルの場所を参照してダブルクリックし、ファイルを開きます。

    [データベースの拡張] ダイアログボックスが表示され、データベースを拡張するかどうかをたずねるメッセージが表示されたら、[いいえ] をクリックします。

  5. データベースの起動時にフォームが開く場合は、フォームを閉じます。

  6. [ファイル] タブで、[データベースに名前を付けて保存] をクリックします。

  7. [名前を付けて保存] ダイアログボックスで、新しいデータベースの名前を入力します。

    注: 新しいデータベースを別の場所に保存する場合以外は、元のデータベースとは別の名前にする必要があります。 いずれの場合も、フロントエンドデータベースとバックエンドデータベースを簡単に区別できるように、別の名前を使用することをお勧めします。 ただし、Access 2007 形式に変換する場合は、ファイル名拡張子が .mdb から .accdb に変更され、同じファイル名を使用できるようになります。

  8. [保存] をクリックします。

ページの先頭へ

手順 2: コピーデータベースを分割し、元のファイルをバックエンドデータベースとして使用する

変換済みのデータベースを分割するには、次の手順を実行します。

  • [データベースツール] タブの [データの移動] グループで、[ Access データベース] をクリックします。 ボタン イメージ

  • [データベース分割ツール] ダイアログボックスで、[データベースの分割] をクリックします。

    必要に応じてバックアップを作成することもできますが、元のデータベースを使用してコピーを再作成することもできます。

  • バックエンドデータベースの名前を入力し、[分割] をクリックします。

ページの先頭へ

手順 3: 新しいフロントエンドを元のデータベースに接続する

  1. データベース分割ツールによって作成されたバックエンドデータベースを削除します。元のデータベースを削除しないように注意してください。

  2. 新しいフロントエンドデータベースを元のデータベースのテーブルにリンクします。 [外部データ] タブの [ & リンクのインポート] グループで、[リンクテーブルマネージャー] をクリックします。 ボタンの画像

  3. [すべて選択] をクリックし、[常に新しい場所を確認する] チェックボックスをオンにします。

  4. [ OK] をクリックし、以前のバージョンのデータベースを参照して、それをダブルクリックします。

    すべてうまくいくと、選択したすべてのリンクテーブルが正常に更新されたことを示すメッセージが表示されます。

新しいバージョンの Access を使用しているユーザーに対して新しい機能をサポートするために、新しいフロントエンドデータベースを強化できるようになりました。 以前のバージョンのユーザーは、以前のバージョンのデータベースを引き続き使うことができます。

ページの先頭へ

Access の複数のバージョンでフロントエンド/バックエンドアプリケーションを使用する

Access データベースが既にz0z_ _ z0z_に設定されている場合は、フロントエンドを新しいファイル形式に変換することができます。 バックエンドデータベースには変更は必要ありません。

次の手順では、[データベースに名前を付けて保存] コマンドを使用して、フロントエンドデータベースを、access 2000、access 2002-2003、または access 2007 のいずれかの最新形式のいずれかに変換します。 このコマンドを実行すると、元のデータベースが元の形式で保存され、指定した形式でコピーが作成されます。

  1. フロントエンドデータベースを閉じます。 ファイルがサーバーまたは共有フォルダーに置かれているマルチユーザー Access データベースの場合は、他のユーザーがそのデータベースを開いていないことを確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. フロントエンドデータベースの場所を参照し、ダブルクリックして開きます。

    [データベースの拡張] ダイアログボックスが表示され、データベースを拡張するかどうかをたずねるメッセージが表示されたら、[いいえ] をクリックします。

  5. データベースを開いたときにフォームが表示されたら、フォームを閉じます。

  6. [ファイル] タブで、[データベースに名前を付けて保存] をクリックします。

  7. [名前を付けて保存] ダイアログボックスで、新しいデータベースの名前を入力します。

  8. [保存] をクリックします。

新しい機能をサポートするために、新しいフロントエンドデータベースを強化できるようになりました。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×