Access 2007 のテンプレートを選択して使用する

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

この記事の内容

概要

手順 1: テンプレートを選択します。

手順 2: テンプレートをカスタマイズします。

手順 3: 新しいデータベースにデータを追加します。

手順 4: レコードを検索します。


概要

簡単に、効率的なデータベースの使用を開始するのには、Microsoft Office Access は、本格的なデザインのデータベース テンプレートのさまざまなを提供します。各テンプレートは、何も変更せずに使用するか、ニーズに合わせてカスタマイズを完全なエンドのソリューションを作成します。各テンプレートには、あらかじめ定義されたテーブル、フォーム、レポート、クエリ、マクロ、および独自のデータベースをカスタマイズするため、アイデアを提供できるリレーションシップが含まれています。

さらに、簡単にダウンロードできます他の Access データベース テンプレート Microsoft Office Online Web サイトから Access でリンクをクリックします。テンプレートを選択して、ニーズに合わせてカスタマイズして後、は、データを追加して、開始レコード間を移動します。

手順 1: テンプレートを選択します。

Access では、インストールされているテンプレートのいずれかを選択するか、オンラインでテンプレートを参照します。

インストール済みのテンプレートを選択します。

  1. Microsoft Access の概要ウィンドウで、[テンプレートのカテゴリ、[ローカルのテンプレートをクリックします。

    使用可能なテンプレートの一覧   

テンプレート

用途

資産管理

保持の資産詳細や所有者を含む、資産を記録します。カテゴリで資産を配置し、条件、取得日、場所、および所有者を記録できます。

連絡先

顧客やパートナーなど、チームの業務に関連する複数のユーザーに関する情報を管理します。名前と住所、電話番号、電子メール アドレスを追跡し、図を添付できます。

[イベント]

今後の会議、締め切り、その他の重要なイベントを追跡します。タイトル、場所、開始時刻、終了時刻] と説明を記録し、画像を添付します。

教職員名簿

電話番号、住所、緊急連絡先情報、雇用データなど、教職員に関する重要な情報を管理します。

案件管理

管理や問題のセットを管理します。割り当て、優先順位付け、および開始から完了までの問題の進捗状況を把握できます。

マーケティング プロジェクト

マーケティング プロジェクトとプロジェクトの成果物のスケジュールおよび監視の詳細を管理します。

プロジェクト

タスクを管理し、1 つまたは複数のプロジェクトの予算を追跡します。

商談管理

営業担当者の小さいグループ内の見込みの売上の進捗状況を監視します。

生徒名簿

緊急連絡先、医療情報、および保護者の情報を含む、生徒に関する情報を管理します。

タスク管理

個人またはチームで行う作業項目を管理するためのタスク データベースを作成します。

Northwind 2007

システムを追跡する順序を作成します。サンプルとして含まれているデータを削除する必要があります。

  1. データベースをモデル化テンプレートをクリックします。

  2. ファイル名] ボックスに、データベースの名前を入力します。

  3. 新しいデータベースの特定の場所を選択するには、ファイル名] ボックスの横にある [ファイル] アイコンをクリックします。

    ヒント: データベースは、Windows SharePoint Services サイトにリンクするには、選択、を作成するデータベースの Windows SharePoint Services サイトへのリンクとチェック ボックスをオンします。

  4. [作成] をクリックします。

新しいデータベースこれで、使用する準備し、すると、それをカスタマイズすることができます。

オンライン テンプレートを選択します。

  1. [Microsoft access はじめに] ウィンドウで、次のいずれかの操作を行います。

    • テンプレート カテゴリ] で、おすすめオンライン テンプレートを参照するのには、 Featuring] をクリックし、[テンプレートを指定します。

    • テーマに基づくオンライン テンプレートを選択するにはから Microsoft Onlineテーマをクリックし、[テンプレートを指定します。

  2. ファイル名] ボックスでは、テンプレートの新しい名前を入力し、新しいデータベースの特定の場所を選択するテキスト ボックスの横にあるファイル アイコンをクリックします。

  3. [ダウンロード] をクリックします。

ヒント: データベースは、Microsoft Windows SharePoint Services サイトにリンクするには、選択、を作成するデータベースの Windows SharePoint Services サイトへのリンクとチェック ボックスをオンします。

新しいデータベースこれで、使用する準備し、すると、それをカスタマイズすることができます。

ページの先頭へ

手順 2: テンプレートをカスタマイズします。

データベース テンプレートを選択した後、ニーズに合わせてカスタマイズできます。テンプレートから作成されたデータベースには、組み込み、デザイン済みのテーブル、フォーム、レポートをすぐに使用できるの数値が含まれています。テンプレートからデータベースを作成するときに作成されますテーブルとその他のオブジェクトのテンプレートをデザインする対象の目的をサポートするため。場合によっては、データベース構造のテンプレートは複雑であり、その構造の一部をカスタマイズする必要があります。指定されたテーブルにデザインを変更する場合は、無効にする、既存のリレーションシップが考慮する必要があります。テンプレートの構造を大幅に変更する必要があることを検出する場合は、簡単に空のデータベースで最初に必要があります。

テンプレートをカスタマイズする任意のフィールドまたはテーブルの名前を変更しないようにすることをお試しください。フォームやレポートなどの他のデータベース オブジェクトでは、これらのフィールドとテーブルを使用する可能性があり、参照するか、期待どおりに作業からこれらのフィールドおよびテーブルの名前に依存する他のデータベース オブジェクトを妨げる可能性が名前を変更します。ナビゲーション ウィンドウ内のテーブルの名前を変更した場合、またはデータシート ビューまたはデザイン ビューでフィールドの名前を変更する前に、名前の自動修正機能が有効になっていることを確認してください。名前の自動修正機能には、フィールド、テーブル、フォーム、またはその他のオブジェクトをデータベース全体にレポートを [名前の変更が自動的に反映されます。すべての新規データベースの既定の名前の自動修正の設定が有効では、通常。

フォームまたはレポートをカスタマイズします。

テンプレートのフォームまたはレポートは、いくつかの方法でカスタマイズできます。たとえば、レイアウト ビューで開き、([書式] タブ) のオート フォーマットグループから新しい形式を選択してフォームの書式設定を変更できます。新しいフィールドを追加して、フォームまたはレポートをカスタマイズすることもできます。フォームまたはレポートにフィールドを追加する場合は、そのフォームまたはレポート上のコントロールを作成します。テンプレート内の既存のコントロールをカスタマイズする場合は、これらのコントロールのプロパティを変更することができます。

フォームまたはレポートに新しいコントロールを追加します。

  1. ナビゲーション ウィンドウでは、フォームまたはレポートのコントロールを追加するを右クリックし、[デザイン ビュー] をクリックします。

  2. [デザイン] タブをクリックします。

  3. コントロール] グループで、追加するコントロールをクリックし、[コントロール ウィザードの使用] をクリックします。

    [コントロール] グループの [コントロール ウィザード] コマンドの使用

  4. 作成し、新しいコントロールをカスタマイズするには、ウィザードの手順に従います。

フォームおよびレポートの作成の詳細については、「参照」セクションのリンクを参照してください。

コントロールを変更します。

既存のコントロールをフォームまたはレポートに表示する方法をカスタマイズすることができます。表示形式を変更するには、フィールドの [書式] プロパティを変更します。フィールドの [書式] プロパティは、新規フォームまたはレポートを作成するには、そのフィールドに基づくコントロールによって自動的に継承します。

データシート ビューで表示形式を設定する

  1. Microsoft Office ボタン Office ボタンの画像 をクリックして、[開く] をクリックします。

  2. [開く] ダイアログ ボックスで、変更するコントロールを含むデータベースを開きます。

  3. ナビゲーション ウィンドウでは、[形式を設定するフィールドが含まれているテーブルをダブルクリックします。

    テーブルがデータシート ビューで開きます。

  4. 表示形式を設定するフィールドをクリックします。

  5. [データシート] タブの [データの型と書式設定] で、書式設定] の横にあるドロップダウン リストにある矢印をクリックし、[形式を選択します。 [データ型と書式設定] グループの Access のリボンの画像

    新しい表示形式が適用されたフィールドが表示されます。

デザイン ビューで表示形式を設定する

  1. Microsoft Office ボタン Office ボタンの画像 をクリックして、[開く] をクリックします。

  2. [開く] ダイアログ ボックスを変更するコントロールを含むデータベースを開きます。

  3. ナビゲーション ウィンドウでは、表示形式を変更するには、フィールドが含まれているテーブルを右クリックし、[デザイン ビュー] をクリックします。

    デザイン ビューでテーブルが開きます。

  4. 表示形式を設定するフィールドをクリックします。

  5. [フィールド プロパティ] で [全般] タブで、書式設定] ボックスの一覧から表示形式を選択します。

  6. 変更内容を保存するには、クイック アクセス ツールバーの [上書き保存] をクリックします。

ページの先頭へ

手順 3: 新しいデータベースにデータを追加します。

テンプレートを選択してから、必要なカスタマイズを作成して後、は、インポートするか、外部データへのリンクをデータベースにデータを追加できます。

データをインポートする

Excel ブック、 Windows SharePoint Services 3.0リスト、Outlook アドレス帳、またはその他の Access データベースなど、いくつかの形式でデータをインポートすることができます。

  • [外部データ] タブの [インポート] で、データをインポートするには、がインポートするファイルの種類] ボックスをオンにします。

    [インポート] グループのコマンド ボタン

    注: 

    • をインポートするデータの種類のアイコンが表示されない場合は、その他] をクリックし、[外部データの取り込み] ダイアログ ボックスの指示に従って操作します。

    • 外部データをインポートするためのコマンドが見つからない場合は、(たい Access 以外)、データを作成した元のプログラムを起動し、そのプログラム ( 区切りテキスト ファイル) などの一般的なファイル形式でデータを保存する必要があります。Access に戻りし、外部データのコマンドのいずれかを使用してデータをインポートします。

  • ウィザードの最後のページ上には、インポート操作の詳細については、次の保存を求められる可能性があります。詳細情報を保存すると、可能性がありますがデータをインポートする、同じデータ ソースから今後場合に便利だことができます。インポート手順の保存] チェック ボックスをオンに、詳細についてを入力し、[インポートの保存] をクリックします。[外部データ] タブで [インポート] グループで保存済みのインポート] をクリックしていつでも今すぐに同じインポートを繰り返してできます。インポート操作の詳細を保存したくない場合は、[閉じる] をクリックします。

データにリンクするには

データにリンクするときにデータは引き続き元の場所に保存して、新しいデータベースにリンクをテーブルとして表示されます。ほとんどのファイル形式は、表示し、これらは、同じ物理データを操作するために、アクセス、またはデータを作成した元のプログラムを使用してデータを変更できます。ただし、データは Excel ブックに格納されている場合できますのみデータを表示するリンクにアクセスします。変更することはできません。リンク先のブック内のデータを変更するには、Excel を使用する必要があります。

    1. Office ボタンの画像 (Microsoft Office ボタン) をクリックしてから、[開く] をクリックします。

    2. [ファイルを開く] ダイアログ ボックスで、データベースを選んで開きます。

    3. 外部データ] タブの [インポート] で、[リンクするファイルの種類] ボックスをオンにします。たとえば、Excel ブックのデータにリンクする場合は、 Excelをクリックします。リンク先のデータの種類のアイコンが表示されない場合は、その他の] をクリックします。

      [外部データの取り込み] ダイアログ ボックスが表示されます。

      注: 外部データにリンクするためのコマンドが見つからない場合は、(たい Access 以外)、データの作成元のプログラムを起動し、そのプログラムを使用して、( 区切りテキスト ファイル) などの一般的なファイル形式でデータを保存する必要があります。 Access に戻りし、そのデータにリンクする外部データのコマンドのいずれかを使用します。

    4. [外部データの取り込み] ダイアログ ボックスで、[参照] をクリックしてソース データ ファイルを参照するか、ソース データ ファイルの完全なパスを [ファイル名] ボックスに入力します。

    5. 現在のデータベース内のデータを保存する方法と場所を指定するには、希望するオプションをクリックします。

      ほとんどのファイル形式のウィザードが起動します。ただし、Access データベース内のデータにリンクする場合、[オブジェクトのインポート] ダイアログ ボックスが表示されます。テーブルのリンク] ダイアログ ボックスで、選択した内容を行い、手順 7 に進みます。手順 6 に進んでください。

    6. ウィザードの手順を実行します。フォローしている正確なプロセスは、選択したオプションによって異なります。

ページの先頭へ

手順 4: レコードを検索します。

データベースにデータをインポートした後は効率的に特定のレコードを検索する必要があります。データベースの下部にあるツールバーを使用すると、レコードを検索します。

移動ボタン

ナビゲーション ボタンを使用してテーブルまたはビューでレコードを検索します。。

ナビゲーション ボタン

使って、

1.

先頭レコード

2.

前のレコード

3.

特定のレコード-クリックしてでテキスト ボックスに、レコード番号を入力し、enter キーを押してそのレコードを表示します。レコード番号は、フォームまたはデータシートの先頭から順番にカウントされます。

4.

次のレコード

5.

最終レコード

6.

新しい (空の) レコード

7.

フィルター-このインジケーターは、フィルターが適用されているかどうかが表示されます。フィルターが適用されていない、またはすべてのフィルターをクリアされている、[フィルターなしのインジケーターが表示されます。

8 します。

[検索] ボックス、各文字を入力すると、リアルタイムでテキストを入力して、検索ボックスで最初に一致する値が強調表示されました。レコードをすばやく検索するには、この機能を使用します。

レコードを検索するための他のオプション

次のいずれかを使用してレコードを検索することもできます。

特定のレコードに移動します。

特定のレコードの検索

特定のレコードのみを表示するフィルター

クエリを使用してカスタマイズされた検索を実行します。

特定のレコードに移動する

一部のテンプレートには、] ボックスの一覧を使用して特定のレコードを表示する] オプションのあるフォームが含まれます。たとえば、連絡先管理テンプレートで、連絡先詳細] フォームとマーケティング プロジェクト テンプレートのプロジェクトとタスク フォームには、このオプションがあります。ドロップダウン リストから特定のレコードを表示するのには、このオプションを使用できます。利用可能な場合は、移動先] ボックスはフォームの左上隅のセクションにあります。

  1. [移動先] ボックスの一覧の横の矢印をクリックします。

    [移動先] ボックス

  2. レコードを表示する] をクリックします。

特定のレコードを検索する

特定のレコードを検索する検索し、置換] ダイアログ ボックスで、[検索] タブを使用します。特定のフィールドを検索したり、表全体またはビューを検索することができます。

注: テーブルまたはビューは、データを表示されている場合にのみ、[検索し、置換] ダイアログ ボックスを使用することができます。

  1. 検索するテーブルを開き、フィールドを含むレコードを検索する] をクリックします。

  2. [ホーム] タブの [検索] グループで、[検索] をクリックします。

    [検索] コマンドボタン

  3. [検索し、置換] ダイアログ ボックスで、 [検索] ボックスに検索条件を入力します。

  4. [検索方向] ボックスの一覧の [すべて] をクリックし、[次を検索] をクリックします。

詳細については、 [検索し、置換] ダイアログ ボックスを使用して、「参照」セクションのリンクを参照してください。

特定のレコードのみを表示するフィルター

簡単に、同じデータのフィルターとフィルター処理なし] のビューを切り替えることができるように、オンまたはオフにするフィルターにすることができます。

条件に一致するもののみに表示されているレコードを制限するフィルターを適用することができます。フィルターを適用すると、必要なレコードを検索しやすきます。たとえば、表示されるレコードをすばやく絞りを右クリックしてフィールドの値と一致すると、し、[と等しい等しくない含むまたはが含まれていない選択範囲] メニューの [オプション] のいずれかを選択します。

  • テーブルまたはするフィルターを追加するフォームを開きます。

  • いるテーブルまたはフォームいないフィルターが適用されて、[ホーム] タブの [並べ替えとフィルター ] で、ことを確認するのには、詳細設定] をクリックし、[すべてのフィルターのクリア] をクリックします。そのコマンドが使用できない場合 (淡色表示されている)、フィルターが適用されていません。

    グループの並べ替えとフィルター

  • フィルターを適用するには、フィルターを適用し、[ホーム] タブの [並べ替えとフィルター ] で、[フィルター ] をクリックしてフィルター オプションを選択するフィールドをクリックします。

  • 選択範囲を基にしたフィルターを適用するには、テーブルまたはフォームを開くし、フィルターの一部として使用する値が含まれているレコードに移動します。[フィールド] をクリックします。[ホーム] タブの [並べ替えとフィルター ] で、選択範囲] をクリックし、フィルターを適用する] をクリックします。

  • されているフィルターを適用するには、選択部分をに基づいて、目的の文字だけを選択します。[ホーム] タブの [並べ替えとフィルター ] で、選択範囲] をクリックし、フィルターを適用する] をクリックします。

フィルターの適用方法の詳細については、「参照」セクションのリンクを参照してください。

クエリを使用してカスタマイズされた検索を実行します。

カスタマイズされた検索を実行して、カスタマイズされたフィルターの適用、レコードを並べ替えるには、クエリを使用することができます。クエリを保存し、再利用すると、およびフォームとレポートを作成できます。興味のあるテーブルのレコードのみを検索するのにクエリを使用することもできます。作成したクエリの種類は、返されるようにして処理をしなくても、結果にアクセスしたいかどうかは、レコードとは異なります。

  1. [作成] タブの [その他] で、[クエリ ウィザード] をクリックします。

    [その他] グループの [クエリ ウィザード] コマンド

  2. クエリ ウィザードの手順に従います。

クエリの作成の詳細については、「参照」セクションのリンクを参照してください。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×