Visio で図形間にコネクタを追加する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Visio では図面の図形を簡単に接続できます。 オートコネクトを使って、図形を追加するときに接続したり、コネクタ ツールを使って既存の図形を接続したりすることができます。

接続の種類

ポイント接続と動的接続という 2 種類の接続により、コネクタで図形を接続できます。 ポイント接続では、図形の特定のポイントにコネクタが接着され、図形を移動したり回転したりしても接着されたままになります。 動的接続では、図形上でのコネクタの位置変化が可能であるため、図形を移動したり回転したりすると、コネクタは、図形上でコネクタの原点に最も近い接続ポイントに移動します。

次の図では、図形 A に図形 C へのポイント接続があり、図形 C を移動するたびに、図形 A からのコネクタは図形 C の同じポイントに接続されたままになります。 それとは対照的に、図形 B には図形 C への動的接続があり、図形 B からのコネクタは、図形 C で最も近い接続ポイントに移動します。

A には C へのポイント接続がありますが、B には C への動的接続があります。

コネクタの両端に接続の種類のいずれかを指定することができます。オートコネクトを使用して図形を接続する場合、両端に動的接続があります。手動でコネクタを図形に接続する場所を選択する場合は、接続の種類を指定できます。

図形を追加したときに自動的に接続する

図形を接続する 1 つの方法として、図形を図面に追加したときに、Visio に自動的に接続させることを挙げることができます。 フローチャートを作成するときは特に便利です。

図形を図面に追加して、Visio に既存の図形に自動的に接続させる手順は次のとおりです。

注: 次の手順に従うには、オートコネクトをアクティブにしてください。 [表示] タブの [視覚補助] グループで [オートコネクト] が選択されていることを確認します。

図形を追加して、既存の図形に自動的に接続するには

  1. ページにまだ図形が追加されていない場合は、[図形] ウィンドウからページに図形をドラッグします。

  2. 最初の図形をポイントして、図形の周囲にオートコネクト矢印が表示されるまでそのままにします。

    [オートコネクト] がアクティブの場合、図形をポイントすると、接続矢印が表示されます。

    オートコネクトの矢印が表示されない場合は、[表示] タブで [オートコネクト] が選択されていることを確認します。

  3. 図形を追加する方向の矢印をポイントします。

    [オートコネクト] 矢印をポイントすると、追加する図形のツール バーが表示されます。

    現在、[クイック図形] ステンシルにある最初の 4 個のクイック図形を含むミニツール バーが表示されます。 ツールバーの図形をポイントすると、ページにその図形のプレビューが表示されます。

  4. 追加する図形をクリックします。

  5. 続ける場合は、新しく追加した図形のオートコネクトの矢印をポイントし、別の図形を追加します。その図形は自動的に接続されます。

    新しく追加された図形をポイントすると、別の図形を追加するための [オートコネクト] 矢印が表示されます。

注: ミニ ツールバーに表示される図形から別の図形が必要な場合、[図形] ウィンドウから必要な図形をページ上の位置にドラッグします。図形を接続するには、次のセクションで説明する方法を使用します。

ページ上の既存の図形を接続する

もちろん、すでに図面に含まれている図形は、オートコネクトかコネクタ ツールを使って接続できます。

図形を接続する場合、ポイント接続動的接続という 2 種類の接続を使用して接続することができます。接続の種類の詳細については、上述の「接続の種類」を参照してください。

ポイント接続を作成して、コネクタを図形上の特定の位置に接着したままにするには、最初の図形の接続ポイントから、2 番目の図形の接続ポイントにドラッグします。図形が接続されると、コネクタの端点が緑に変わります。

コネクタを図形の特定のポイントに接着して、コネクタをそのポイントに固定します。
コネクタを図形の特定のポイントに接着して、コネクタをそのポイントに固定します。

動的接続を作成して、図形の移動に伴ってコネクタを移動させるには、図形の周囲に緑のボックスが表示されるまで、コネクタ ツールを最初の図形の中央に合わせます。マウス ボタンを押したまま、2 番目の図形の中心にドラッグします。2 番目の図形の周囲に緑のボックスが表示されたら、マウス ボタンを離します。

コネクタを図形に接着して、コネクタを図形のポイントに動的に移動できるようにします。
コネクタを図形に接着して、コネクタを図形のポイントに動的に移動できるようにします。

オートコネクトを使用して既存の図形を接続します。

  1. 図形をポイントして、図形の周囲にオートコネクト矢印が表示されるまでそのままにします。

    [オートコネクト] がアクティブの場合、図形をポイントすると、接続矢印が表示されます。
  2. オートコネクト矢印をクリックして別の図形にドラッグし、動的接続の場合は図形の中央、ポイント接続の場合は図形の特定の接続ポイントにコネクタの端点をドロップします。

    オートコネクト矢印をポイントすると、図形のプレビューが表示されますが、この図形は無視できます。コネクタを目的の場所にドラッグすると、この図形は消えます。

コネクタ ツールを使用して図形を接続します。

  1. [ホーム] タブの [ツール] グループで [コネクタ] をクリックします。

    コネクタ ツールは、各端点にポイント接続がある図形に接続します。
  2. 図形をクリックし、コネクタを別の図形にドラッグします。

  3. 終了したら、[ホーム] タブの [ツール] グループで [オブジェクト選択ツール] をクリックします。

クイック タスク

タスク

操作

コネクタの種類を直角、直線、または曲線にする。

コネクタをマウスの右ボタンでクリックし、ショートカット メニューのコネクタの種類 (直角、直線、曲線) をクリックします。

コネクタが整理されるように図形を整列して間隔を調整する。

整列するすべての図形を選んでから、[ホーム] タブの [配置] グループで、[整列] > [自動整列] または [位置] > [自動間隔調整] の順にクリックします。 Ctrl キーを押しながら複数の図形をクリックするか、[ホーム] タブの [編集] グループの [選択] オプションの 1 つを使用し、複数の図形を選択できます。

動的接続からポイント接続、またはポイント接続から動的接続に変更する。

コネクタを選択し、コネクタの終点を図形からドラッグして離します。ポイント接続の場合は、コネクタを特定のポイントにドロップし、動的接続の場合は、図形の真ん中にドロップします。

オートコネクトを有効または無効にする

オートコネクト機能は、すべての Visio 図面またはアクティブな図面のみで有効または無効にできます。

アクティブな図でオートコネクトのオンとオフを有効にします。

  • [表示] タブの [視覚補助] グループで [オートコネクト] をオンまたはオフにします。

    [表示] タブの [オートコネクト] をオンまたはオフにして、オートコネクトをアクティブまたは非アクティブにします。

注: [オートコネクト] チェック ボックスを使用できない場合は、次の手順どおりに行って、すべての図についてオートコネクトが無効になっているかどうかを確認します。

すべての図でオートコネクトのオンとオフを有効にします。

  1. [ファイル] タブをクリックし、[オプション] をクリックします。

  2. [Visio のオプション] で [詳細設定] をクリックします。

  3. [編集オプション] で、[オートコネクトを有効にする] をオンにし、オートコネクトを有効にします。オートコネクトを無効にするには、[オートコネクト] チェック ボックスをオフにします。

    [オートコネクトを有効にする] をオンまたはオフにして、すべての図または図面に対してオートコネクトをアクティブまたは非アクティブにします。
  4. [OK] をクリックします。

関連項目

矢印やポイントなどの線の端点をコネクタに追加する

接続ポイント ツールを使って接続ポイントを追加、移動、または削除する

図形を追加したときに自動的に接続する

図形を接続する 1 つの方法として、図形を図面に追加したときに、Visio に自動的に接続させることを挙げることができます。 フローチャートを作成するときは特に便利です。

図形を図面に追加して、Visio に既存の図形に自動的に接続させる手順は次のとおりです。

  1. ページにまだ図形が追加されていない場合は、[図形] ウィンドウからページに最初の図形をドラッグします。

  2. 最初の図形をポイントして、図形の周囲に青いオートコネクト矢印が表示されるまでそのままにします。

  3. 図形を追加する方向の矢印をポイントします。

    現在、[クイック図形] ステンシルにある最初の 4 個のクイック図形を含むミニツール バーが表示されます。ステンシルで選択された図形のリアルタイムのプレビューがページ上に表示されます。

  4. ミニ ツール バー内の 4 個の図形をポイントして、各図形のリアルタイムのプレビューをページに表示します。

  5. 追加する図形をクリックします。

別の図形を追加する場合、ポインターをオートコネクト矢印から外側へ移動すると、プレビューが消えます。そうすると、目的の図形を [図形] ウィンドウからドラッグできます。

クイック タスク

タスク

アクション

ステンシルのクイック図形を変更する。

ステンシルを開き、クイック図形をご希望の順序にドラッグします。クイック図形領域の中または外に図形をドラッグできます。

ミニ ツール バーに表示される図形を変更する。

[クイック図形] ステンシルで、クイック図形のグループの中からミニ ツール バーに表示する図形を選択します。選択された図形を含むグループがツール バーに表示されます。

また、最初に表示する図形を含むステンシルをドラッグし、[クイック図形] タイトル バーの真下にドロップします。[図形] ウィンドウ内で他のステンシルを上下にドラッグすることで、そのステンシルの順序を変更できます。それらは、[クイック図形] ステンシル内でそれと同じ順序で表示されます。

ページ上の既存の図形を接続する

既に図面に含まれている図形は、オートコネクトまたはコネクタ ツールのいずれかを使って接続できます。

オートコネクトを使用して図形を接続する

  1. 図形をポイントして、図形の周囲に青いオートコネクト矢印が表示されるまでそのままにします。

  2. オートコネクト矢印をクリックして別の図形にドラッグし、動的接続の場合は図形の中央、ポイント接続の場合は特定の接続ポイントにコネクタの端点をドロップします。

    青い矢印をポイントすると、図形のリアルタイムのプレビューが表示されますが、この図形は無視できます。ポインターを遠ざけると、この図形は消えます。

コネクタ ツールを使用して図形を接続する

  1. [ホーム] タブの [ツール] グループで [コネクタ] をクリックします。

  2. 図形をクリックし、コネクタを別の図形にドラッグします。

コネクタを図形上の特定の位置に接着したままにするには、最初の図形の接続ポイントから、2 番目の図形の接続ポイントにドラッグします。図形同士が接続されると、コネクタの端点が赤に変わります。これをポイント接続といいます。

図形の移動に伴ってコネクタを移動させるには、図形の周囲に赤いボックスが表示されるまで、コネクタ ツールを最初の図形の中央に合わせます。マウス ボタンを押したまま、2 番目の図形の中心にドラッグします。2 番目の図形の周囲に赤いボックスが表示されたら、マウス ボタンを離します。これを動的接続といいます。

クイック タスク

タスク

操作

コネクタの種類を直角、直線、または曲線にする。

コネクタをマウスの右ボタンでクリックし、ショートカット メニューのコネクタの種類をクリックします。

コネクタが整理されるように図形を整列して間隔を調整する。

整列させる図形をすべて選んでから、[ホーム] タブの [自動整列と自動間隔調整] をクリックします。 Ctrl キーを押しながらすべての図形をクリックするか、[選択] オプションの 1 つを使用し、複数の図形を選択することができます。

動的接続からポイント接続、またはポイント接続から動的接続に変更する。

コネクタを選択し、コネクタの終点を図形からドラッグして離します。ポイント接続の場合は、コネクタを特定のポイントにドロップし、動的接続の場合は、図形の真ん中にドロップします。

オートコネクトを有効または無効にする

オートコネクト機能は、すべての Visio 図面で有効または無効にしたり、アクティブな図面でのみ有効または無効にしたりできます。

アクティブな図でオートコネクトを有効または無効にする

  • [表示] タブの [視覚補助] グループで [オートコネクト] チェック ボックスをオンまたはオフにします。

[オートコネクト] チェック ボックスを使用できない場合は、次の手順を実行して、すべての図についてオートコネクトが無効になっているかどうかを確認します。

すべての図でオートコネクトを有効または無効にする

  1. [ファイル] メニューの [オプション]をクリックします。

  2. [詳細設定] カテゴリをクリックします。

  3. [編集オプション] で、[オートコネクトを有効にする] チェック ボックスをオにし、オートコネクトを有効にします。オートコネクトを無効にするには、チェック ボックスをオフにします。

関連項目

矢印やポイントなどの線の端点をコネクタに追加する

接続ポイントを追加、移動、または削除する

オートコネクトを使用して図形を接続する

図形を接続する 1 つの方法として、図形を図面に追加したときに、Visio に自動的に接続させることを挙げることができます。 フローチャートを作成するときは特に便利です。

図形を図面に追加して、Visio に既存の図形に自動的に接続させる手順は次のとおりです。

図形をページにドラッグするときにオートコネクトを使用する

  1. ステンシルから図面ページに図形をドラッグし、別の図形の近くに配置します。

    別の図形付近に配置した図形

  2. マウス ボタンを押したまま、ポインターを青い三角形のいずれかの上に移動します。三角形が濃い青色になります。

    青い三角形の 1 つの上にポインターがあり、三角形が濃い青色になります。

  3. マウス ボタンを放します。図形を図面ページに配置し、コネクタを追加して両方の図形に接着します。

    図形を図面ページに配置し、コネクタを追加して両方の図形に接着します。

ヒント: 図形をドラッグしない場合は、最初にステンシルで図形を選択して、図面の図形にポインターを置き、その図形の近くに表示された青い三角形のいずれかをクリックすると、同じ結果を得ることができます。

ページ上の既存の図形にオートコネクトを使用する

  1. 接続の図形の上にポインターを置きます。

    接続元の図形上にあるポインター

  2. 接続の図形に最も近い青い三角形の上にポインターを置きます。

    接続先の図形に最も近い青い三角形の上にポインターが置かれている。

    三角形が濃い青色になり、赤いボックスが接続先の図形の周囲に表示されます。

    注: 赤いボックスが接続先の図形の周囲に表示されない場合、図形が離れすぎている可能性があります。図形を近くに移動して、もう一度試すか、コネクタ ツールを使用します

  3. 青い三角形をクリックします。コネクタが追加され、両方の図形に接着されます。

    図形を図面ページに配置し、コネクタを追加して両方の図形に接着します。

オートコネクトを有効または無効にする

オートコネクト機能は、すべての Visio 図面で有効または無効にしたり、現在の図面でのみ有効または無効にしたりできます。すべての図面の場合

  1. [ツール] メニューの [オプション] をクリックします。

  2. [全般] タブをクリックします。

  3. [図面ウィンドウ] オプションで、[オートコネクトを有効にする] チェック ボックスをオンにします。

現在の図面のみの場合

  • [標準] ツールバーで、[オートコネクト] ツールをクリックします。

    注: [オートコネクト] ツールをクリックしてもオートコネクトが有効にならない場合は、[オプション] ダイアログ ボックスで [オートコネクトを有効にする] チェック ボックスがオンになっていることを確認します。

コネクタ ツールを使用して図形を接続する

コネクタを追加および接着するために最も柔軟な方法の 1 つは、標準ツールバーのコネクタ ツール ボタンの画像 を使用して描画します。

  1. [標準] ツールバーでコネクタ ツール ボタンの画像 をクリックします。

  2. 次のいずれかの操作を行います。

    • コネクタを図形の特定の点に接着されたままにするには、最初の図形の接続ポイント ( 接続ポイントの画像 - 青い X ) を 2 番目の図形の接続ポイントにドラッグします。図形が接続されると、コネクタの端点が赤色になります。これは、ポイント間接続と呼ばれます。ポイント間接続では、図形の 1 つを移動する場合、コネクタは同じ接続ポイントに接着され続けます。

    • コネクタを最も近い利用可能な接続ポイントに移動できるようにするには、コネクタ ツールを赤いボックスが図形の周囲に表示されるまで、最初の図形の中央に置きます。マウス ボタンを押しながら、2 番目の図形の中央にドラッグします。赤いボックスが 2 番目の図形の周囲に表示されたら、マウス ボタンを放します。これは、図形間接続と呼ばれます。図形間接続では、図形のいずれかを移動する場合、最も近い利用可能な接続ポイントに移動することで、コネクタがそれぞれの図形に接着されたままになります。接続ポイントが表示されない場合、コネクタは最も近い側面に移動されます。

      注: また、コネクタの一方の端が接続ポイントに接続されている図形と、コネクタのもう一方の端が図形に接続されている図形間 (逆の場合も同様です) で、接続を作成することもできます。

  3. [標準] ツールバーのポインター ツール [ポインター] ボタン をクリックして、通常編集に戻ります。

    注記: 

    • 1 つの図形から複数の図形にコネクタを追加するには、複数のコネクタを追加する必要があります。"分岐" のコネクタ図形はありません。

    • ポイント間接続を作成しようとして、目的の場所に正確にコネクタを接着するのが難しい場合は、別のスナップと接着の設定を試してください。

    • [ツール] メニューの [スナップと接着] をクリックして、[全般] タブで目的のオプションを選択します。

      図形座標、図形ハンドル、または図形の頂点に接着する場合は、いずれかの接続ポイントが既に存在していなければ、自動的に追加されます。

関連項目

矢印やポイントなどの線の端点をコネクタに追加する

接続ポイントを追加、移動、または削除する

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×