Visio で図形のサイズまたは寸法を表示する

Visio で図形のサイズまたは寸法を表示する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

図形の寸法は、図形を選択すると [図形] ウィンドウの下に表示されるステータス バーで確認できます。幅、高さ、角度が自動的に一覧表示されます。あるいは、この記事で紹介する他の方法で寸法を表示できます。

[図形サイズ/​​位置/回転] を利用して図形の寸法または角度を変更する方法については、「[図形サイズ/位置/回転] ウィンドウで寸法を指定する」を参照してください。

図面ページの単位を表示する

Visio Standard をご使用の場合は、図形の高さと幅のプロパティにリンクされたフィールドを使用して図形の寸法を表示できます。 フィールドの使用の詳細については、「フィールドを使用して表示される情報を最新の状態に保つ」を参照してください。

Visio Professional をご使用の場合は、寸法図形を使用してサイズを表示できます。寸法図形は、それが接着されている図形のサイズを表示し、元の図形のサイズが変更されると、寸法が自動的に更新されます。

寸法図形は一部のテンプレートに含まれており、すべてのテンプレートで [寸法] ステンシルを開くことができます。

[寸法のステンシルを開く

  1. [図形] ウィンドウで [その他の図形] をクリックします。

  2. [Visio エキストラ] をポイントし、[寸法 - 建築系] または [寸法 - 工学系] をクリックします。

  3. 寸法を測定する図形に寸法図形をドラッグし、測定するポイントに寸法図形の端点を接着します。

注: 寸法の単位を変更するには、寸法図形を右クリックし、ショートカット メニューの [精度と単位] をクリックします。

寸法を示す寸法図形が表示されたブース図形

Visio Professional をご使用の場合、次の使用手順で、寸法図形の使用方法の一例を次に示します。

寸法図形 (例) を使用するには

  1. [ファイル] タブの [新規作成] をクリックします。[カテゴリ]、[地図とフロア プラン] の順にクリックし、[住宅設計] をダブルクリックします。

  2. [庭園設備] ステンシルのタイトル バーをクリックし、[コンクリート道] 図形を図面ページにドラッグします。

    このステンシルや別のステンシルを見つけるには、[ステンシル] のリストをスクロールする必要がある場合があります。

  3. [コンクリート道] 図形のハンドルをドラッグして、拡大します。

  4. [寸法 - 建築系] ステンシルのタイトル バーをクリックし、[水平] 図形を図面ページの道図形上にドラッグします。

    リスト内のこのステンシルが表示されない場合は、前述の手順「寸法ステンシルを開くには」に従ってください。

  5. [水平] 寸法図形の右側にある図形ハンドルを道図形の右端にドラッグし、図形が接続されたことを示す緑色の四角が表示されることを確認します。

  6. [水平] 図形の左側にある図形ハンドルを道図形の左端にドラッグします。

  7. 寸法図形の右側にある黄色のひし形 ( コントロール ハンドルの画像 - 黄色い菱形 ) を道図形上にドラッグし、寸法線の下に道図形が隠れないようにします。

目的に合ったトピックをクリックしてください

図形の全体的な幅、高さ、角度を表示する

図形内の図形の幅、高さ、角度を表示する

図形の隣にある図形の幅、高さ、角度を表示する

図形の一部のサイズを表示する

図形の全体的な幅、高さ、角度を表示する

  1. 描画内の図形を選択します。

  2. 図形の幅、高さ、角度は、ステータス バーで確認できます。

図形内の図形の幅、高さ、角度を表示する

数個の図形の全体的寸法は、テキスト ボックスのある図形に寸法フィールドを追加するだけで簡単に表示できます。

  1. フィールドを追加する図形をクリックします。

  2. [挿入] タブの [テキスト] グループで [フィールド] をクリックします。

  3. [フィールド] ダイアログ ボックスの [カテゴリ] ボックスの一覧で [図形座標] をクリックします。

  4. [フィールド名] 一覧で、表示する寸法をクリックします。

    ヒント: フィートなどの単位を数値に追加するには、[データ形式] をクリックし、[データ形式] ダイアログ ボックスで新しい単位を選択します。

  5. [OK] をクリックします。

  6. 追加するフィールドごとに手順を繰り返します。

    ヒント: 高さと幅を表示し、その間に x を表示するには、図形のテキスト ボックスに最初のフィールドを挿入し、スペースを入力し、「x」と入力し、もう一度スペースを入力し、それから 2 つ目のフィールドを挿入します。

ページの先頭へ

図形の隣にある図形の幅、高さ、角度を表示する

注: データ グラフィック機能は、Visio の Professional 版と Premium 版でのみご利用いただけます。

データ グラフィックでは、図形の高さ、幅、角度、他の図形データを簡単に表示できます。この記事では、寸法の表示方法について説明します。

  1. [データ] タブの [データの​​表示] グループで、[データ グラフィック] をクリックします。

  2. [データ グラフィックの新規作成] をクリックします。

  3. [新しいデータ グラフィック] ダイアログ ボックスで、[新しいアイテム] をクリックします。

  4. [新しいアイテム] ダイアログ ボックスの [データ フィールド] 一覧で、[その他のフィールド] をクリックします。

  5. [フィールド] ダイアログ ボックスの [カテゴリ] ボックスの一覧で [図形座標] をクリックします。

  6. [フィールド名] 一覧で、表示する寸法をクリックし、[OK] をクリックします。

  7. [新しいアイテム] ダイアログ ボックスの [表示形式] 一覧で、[テキスト] をクリックします。

  8. [詳細] の [ラベル] ボックスに寸法の名前を入力し (幅や高さなど)、[OK] をクリックします。

  9. 表示する寸法ごとに手順を繰り返します。

  10. [新しいデータ グラフィック] ダイアログ ボックスで、[OK] をクリックします。

    [データ グラフィック] ギャラリーの [利用可能なデータ グラフィック] に新しいデータ グラフィックが表示されます。

  11. 描画の中から寸法を表示する図形を選択します。それから、[データ グラフィック] ギャラリーで、作成したデータ グラフィックをクリックします。

選択した図形に新しいデータ グラフィックが適用されます。

ページの先頭へ

図形の一部のサイズを表示する

寸法を示す寸法図形が表示されたブース図形

注: 寸法図形は、Visio の Professional 版と Premium 版でのみご利用いただけます。

寸法図形を利用し、他の図形を測定できます。測定する図形に寸法図形を接着すると、図形の寸法が寸法図形に表示されます。元の図形のサイズを変更すると、寸法が自動的に更新されます。

さまざまな寸法図形があります。寸法図形ごとに測定されるアスペクトが異なります。[寸法 - 工学系] ステンシルなど、ステンシルを観察すると、それぞれの寸法図形が測定できるアスペクトを理解できます。

次の手順は、寸法図形の 1 つを利用して住宅設計内の道を測定する方法です。寸法図形の動作を理解するのに役立ちます。

  1. [ファイル] タブの [新規作成] をクリックします。[地図とフロア プラン] の順にクリックし、[住宅設計] をダブルクリックします。

  2. [庭園設備] ステンシルのタイトル バーをクリックし、[コンクリート道] 図形を図面ページにドラッグします。

  3. [寸法 - 建築系] ステンシルのタイトル バーをクリックし、[水平] 寸法図形を図面ページの道図形上にドラッグします。

  4. [水平] 寸法図形の右側にある図形ハンドルを道図形の右端にドラッグし、図形が接続されたことを示す赤色の四角が表示されることを確認します。

  5. [水平] 図形の左側にある図形ハンドルを道図形の左端にドラッグします。

  6. 寸法図形の右側にある黄色のひし形を道図形上にドラッグし、寸法線の下に道図形が隠れないようにします。

注: 寸法の単位を変更するには、寸法図形を右クリックし、ショートカット メニューの [精度と単位] をクリックします。

ページの先頭へ

目的に合ったトピックをクリックしてください

図形の全体的な幅、高さ、角度を表示する

図形の面積または外周を表示する

図形内の図形の幅、高さ、角度を表示する

図形の隣にある図形の幅、高さ、角度を表示する

図形の一部のサイズを表示する

図形の全体的な幅、高さ、角度を表示する

選んだ図形の幅、高さ、角度を表示するステータス バー。

  1. 描画内の図形を選択します。

  2. 図形の幅、高さ、角度は、ステータス バーで確認できます。

図形の面積または外周を表示する

選んだ図形の測定値を示す [面積と外周の長さ] ダイアログ ボックス。

注: [図形の面積と外周の長さ] ダイアログ ボックスは、Microsoft Office Visio Professional でのみご利用いただけます。

  1. 描画内の図形を選択します。

  2. [ツール] メニューで [アドオン] をクリックし、[Visio エキストラ] をクリックし、[図形の面積と外周の長さ] をクリックします。

    [図形の面積と外周の長さ] ダイアログ ボックスが開き、図形の寸法が表示されます。

  3. さまざまな単位で寸法を表示するには、[総面積] ボックスまたは [周囲の全長] ボックスで単位を選択します。

ページの先頭へ

図形内の図形の幅、高さ、角度を表示する

図形の高さと幅がテキスト ボックスに表示されている四角形。

数個の図形の全体的寸法は、図形のテキスト ボックスに寸法フィールドを追加するだけで簡単に表示できます。Office Visio Professional 2007 を利用しているとき、さまざまな図形の寸法を表示する場合、データ グラフィックスを利用することで時間を短縮できます。詳細は、「図形の隣にある図形の幅、高さ、角度を表示する」セクションにあります。

  1. フィールドを追加する図形をクリックします。

  2. [挿入] メニューの [フィールド] をクリックします。

  3. [フィールド] ダイアログ ボックスの [カテゴリ] ボックスの一覧で [図形座標] をクリックします。

    図形のテキスト ボックスへの入力が可能なフィールドが表示された [フィールド] ダイアログ ボックス

  4. [フィールド名] 一覧で、表示する寸法をクリックします。

    ヒント: フィートなどの単位を数値に追加するには、[データ形式] をクリックし、[データ形式] ダイアログ ボックスで新しい単位を選択します。

  5. [OK] をクリックします。

  6. 追加するフィールドごとに手順 2 ~ 5 を繰り返します。

    ヒント: 高さと幅を表示し、その間に x を表示するには、図形のテキスト ボックスに最初のフィールドを挿入し、スペースを入力し、「x」と入力し、もう一度スペースを入力し、それから 2 つ目のフィールドを挿入します。

注: 図形のサイズを変更すると、フィールドの寸法が自動的に更新されます。

ページの先頭へ

図形の隣にある図形の幅、高さ、角度を表示する

データ グラフィックの幅、高さ、角度を表示する低木図形。

注: データ グラフィック機能は、Office Visio Professional 2007 のみでご利用いただけます。

データ グラフィックでは、図形の高さ、幅、角度、他の図形データを簡単に表示できます。この記事では、寸法の表示方法について説明します。データ グラフィックの活用方法については、「データ グラフィックを使用してデータの視覚効果を高める」を参照してください。

  1. [データ] メニューで [図形にデータを表示] をクリックします。

  2. [データ グラフィック] 作業ウィンドウの [新しいデータ グラフィックの作成] で、[新しいデータ グラフィック] をクリックします。

  3. [新しいデータ グラフィック] ダイアログ ボックスで、[新しいアイテム] をクリックし、[テキスト] をクリックします。

    データ グラフィック作業ウィンドウおよび [新しいデータ グラフィック] ダイアログ ボックス。

    1.[データ グラフィック] 作業ウィンドウ

    2.[新しいデータ グラフィック] コマンド

    3.[新しいデータ グラフィック] ダイアログ ボックス、[新しいアイテム] ボックス、[テキスト] コマンド

  4. [新しいテキスト] ダイアログ ボックスの [表示] の [データ フィールド] 一覧で、[その他のフィールド] をクリックします。

  5. [フィールド] ダイアログ ボックスの [カテゴリ] ボックスの一覧で [図形座標] をクリックします。

  6. [フィールド名] 一覧で、表示する寸法をクリックし、[OK] をクリックします。

    データ グラフィックへの入力が可能なフィールドが表示された [フィールド] ダイアログ ボックス

  7. [新しいテキスト] ダイアログ ボックスの [詳細] の [ラベル] ボックスに寸法の名前を入力し (幅、高さ、角度など)、[OK] をクリックします。

  8. 表示する寸法ごとに手順 3 ~ 7 を繰り返します。

  9. [新しいデータ グラフィック] ダイアログ ボックスで、[OK] をクリックします。

    [データ グラフィック] 作業ウィンドウの [データ グラフィックの適用] に新しいデータ グラフィックが表示されます。

  10. 描画の中から寸法を表示する図形を選択します。それから、[データ グラフィック] 作業ウィンドウで、作成したデータ グラフィックをクリックします。

選択した図形に新しいデータ グラフィックが適用されます。

新たに作成したデータ グラフィックを適用した、3 個のツリー図形。

ページの先頭へ

図形の一部のサイズを表示する

寸法を示す寸法図形が表示されたブース図形

注: 寸法図形は Office Visio Professional 2007 のみでご利用いただけます。

寸法図形を利用し、他の図形を測定できます。測定する図形に寸法図形を接着すると、図形の寸法が寸法図形に表示されます。元の図形のサイズを変更すると、寸法が自動的に更新されます。

さまざまな寸法図形があります。寸法図形ごとに測定されるアスペクトが異なります。ステンシルを観察すると、それぞれの寸法図形が測定できるアスペクトを理解できます。下の図は、[寸法 - 工学系] ステンシルの図形を示しています。

[寸法 - 工学系] ステンシル。

次の手順は、寸法図形の 1 つを利用して住宅設計内のピアノを測定する方法です。寸法図形の動作を理解するのに役立ちます。

  1. [ファイル] メニューで [新規作成] をクリックし、[地図とフロア プラン] をクリックし、[住宅設計] をクリックします。

  2. [家具] ステンシルのタイトル バーをクリックし、[グランド ピアノ] 図形を図面ページにドラッグします。

  3. [寸法 - 建築系] ステンシルのタイトル バーをクリックし、[水平] 寸法図形を図面ページのピアノ図形上にドラッグします。

    水平方向の寸法線の図形が上にあるグランド ピアノの図形

  4. [水平] 寸法図形の右側にある緑色の図形ハンドルをピアノ図形の右端にドラッグし、図形が接続されたことを示す赤色の四角が表示されることを確認します。

    ピアノの図形の 1 つの図形ハンドルに接続された寸法図形

  5. [水平] 図形の左側にある緑色の図形ハンドルをピアノ図形の左端にドラッグします。

    ピアノの図形の 2 つの図形ハンドルに接続された寸法図形

  6. 寸法図形の右側にある黄色のひし形をピアノ図形上にドラッグし、寸法線の下にピアノ図形が隠れないようにします。

    寸法補助線が延長され、ピアノ型の図形に接続された寸法付き図形。

注: 寸法の単位を変更するには、寸法図形を右クリックし、ショートカット メニューの [精度と単位] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×