Visio でマクロを記録する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

手順を実行または繰り返し行うプロセスを自動化するマクロを作成します。[開発] タブでマクロを記録するためのコマンドが表示されます。

注:  マクロは、セキュリティ警告の原因となることがあります。不正な目的でマクロが作成されて使われることもあるからです。マクロのリスクと、セキュリティ警告への対応方法の詳細については、「Office ドキュメントのマクロを有効または無効にする」をご覧ください。

  1. [開発] タブの [マクロの記録] をクリックします ([開発] タブが表示されていない場合は、後の「[開発] タブを表示する」を参照してください)。

    [マクロ] のコマンド

  2. [マクロ名] ボックスにマクロの名前を入力します。

  3. [ショートカット キー] ボックスに、このマクロを実行するために Ctrl キーと共に使うショートカット キーを入力します。

  4. [マクロの保存先] ボックスでは、このマクロを保存するドキュメントをクリックします。

  5. [説明] ボックスに、マクロの説明を入力します。

  6. [OK] をクリックすると、マクロの記録が開始します。

  7. マクロに記録したい操作を実行します。必要に応じて、[開発] タブの [記録の一時停止] を使います。

    マクロを記録するときは、マウスを使ってコマンドやオプションをクリックすることや、図面内の図形やオブジェクトの作業を行うことができます。

  8. マクロの記録を停止するには、[開発] タブの [記録終了] をクリックします。

マクロ記録の一時停止と再開は、[記録] ツール バーを使って行うこともできます。

生成されたコードを表示するには、[ツール] メニューの [マクロ] をポイントし、[マクロ] をクリックし、マクロ名をクリックしてから [編集] をクリックします。

[開発] タブを表示する

  1. [ファイル] タブをクリックし、[オプション] をクリックします。

  2. [リボンのユーザー設定] をクリックします。

  3. [リボンのユーザー設定] および [メイン タブ] の下の [開発] チェック ボックスをオンにします。

    [開発] タブは、リボンの [ファイル] タブとは反対側の端に表示されます。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×