Solver 評価の例

ソルバー は、 What-If 分析 ツールとも呼ばれるコマンド群の要素の 1 つです。ソルバー を使用して、シート上の他の数式セルの値に対する制約 (制限) 条件を指定して、1 つのセル (目的セルと呼ばれます) に入力されている数式 の最適 (最大または最小) 値を求めることができます。ソルバー は、決定変数セルまたは単に変数セルと呼ばれるセルのグループを使って動作します。これらのセルは、目的セルおよび制約条件セル内の数式の計算に関与します。ソルバー は、制約条件セルの制限を満たし、目的セルに必要な結果を生成するように、決定変数セルの値を調整します。

ソルバー を使うと、あるセルの最大値または最小値を求めるために、他のセルの値を変化させることができます。たとえば、広告予算額を変更して、利益予想額への影響を確認することができます。

次の例では、各四半期の広告費の変動が、販売台数に影響を与えているほか、売り上げ、経費、および利益にも間接的に影響しています。ソルバー では、予算合計額の上限が 20,000 ドル (セル D5) という制約の下で、合計利益 (目的セル D7) が最大となるような四半期ごとの広告予算 (決定変数セルは B5:C5) を計算することができます。変数させるセルの値は、四半期ごとの利益の計算で使用されるため、目的セルの数式 D7 (=SUM(第 1 四半期の利益:第 2 四半期の利益) と関係しています。

ソルバーの実行例

吹き出し 1 変数セル

吹き出し 2 制約条件セル

吹き出し 3 目的セル

ソルバー 実行結果は次のとおりです。

新しい値が含まれるサンプル ソルバー

必要に応じて、次の操作を行います。

問題を定義し、解決する

  1. データ タブの 分析 で、ソルバー をクリックします。

    [データ] タブ、[分析] グループ、ソルバー アドイン

    [データ] タブの [分析] に Solver が表示されない場合

    1. ツール メニューの アドイン をクリックします。

    2. アドイン リストで、Solver.Xlam チェック ボックスをクリックし、OK をクリックします。

  2. 目的セルの設定 で、目的セルのセル参照 または名前を入力します。

    注: 目的セルには数式が含まれる必要があります。

  3. 次のいずれかの操作を行います。

目的

操作

目的セルの値をできる限り大きくする

最大値 をクリックします。

目的セルの値をできる限り小さくする

最小値 をクリックします。

目的を特定の値に設定する

指定値 をクリックし、ボックスに値を入力します。

  1. 変数セルの変更 ボックスに、各決定変数セル範囲の名前または参照を入力します。隣接しない参照はコンマで区切ります。

    変数セルは、目的セルと直接的または間接的に関連付ける必要があります。変数セルは 200 個まで指定できます。

  2. 制約条件の対象 ボックスに、適用する制約を追加します。

    制約条件を追加する方法

    1. Solver Parameters ダイアログ ボックスで、追加 をクリックします。

    2. セル参照 ボックスに、値の制約条件を設定するセル範囲のセル参照または名前を入力します。

    3. <= 関係ポップアップ メニューで、参照されるセルと制約条件の関係を選択します。<==、または >= を選択した場合は、制約条件 ボックスに、数値、セル参照または名前、あるいは数式を入力します。

      注: 決定変数セルに対する制約条件では、int、bin、および dif 関係のみを適用できます。

    4. 次のいずれかの操作を行います。

    目的

    操作

    制約条件を確定し、別の制約条件を追加する

    追加 をクリックします。

    制約条件を確定し、Solver Parameters ダイアログ ボックスに戻る

    OK をクリックします。

  3. Solve をクリックし、次のいずれかの操作を行います。

目的

操作

シートで解の値を保持する

ソルバーの結果 ダイアログ ボックスの ソルバーの解の保持 をクリックします。

元のデータを復元する

計算前の値に戻す をクリックします。

注記: 

  1. 解決処理を中断するには、ESC キーを押します。調整可能なセルに対して最後に見つかった値でシートが再計算されます。

  2. ソルバー によって解が見つかった後、その解を基にレポートを作成するには、レポート ボックスでレポートの種類をクリックし、OK をクリックします。レポートは、ブックの新しいシート上に作成されます。ソルバー で解が見つからなかった場合、レポート作成のオプションは使用できません。

  3. 調整するセルの値をシナリオとして保存して後で表示できるようにするには、ソルバーの結果 ダイアログ ボックスの シナリオの保存 をクリックし、シナリオ名 ボックスにシナリオの名前を入力します。

Solver で試行の解を求める

  1. データ タブの 分析 で、ソルバー をクリックします。

    [データ] タブ、[分析] グループ、ソルバー アドイン

    [データ] タブの [分析] に Solver が表示されない場合

    1. ツール メニューの アドイン をクリックします。

    2. アドイン リストで、Solver.Xlam チェック ボックスをクリックし、OK をクリックします。

  2. 問題を定義した後、Solver Parameters ダイアログ ボックスの オプション をクリックします。

  3. ソルバー オプション ダイアログ ボックスで、各トライアル ソリューションを表示するための 反復計算の結果を表示する チェック ボックスをオンにし、OK をクリックします。

  4. Solver Parameters ダイアログ ボックスの Solve をクリックします。

  5. 試行状況の表示 ダイアログ ボックスで、次のいずれかの操作を行います。

目的

操作

解決処理を中止し、ソルバーの結果 ダイアログ ボックスを表示する

停止 をクリックします。

解決処理を続行し、次の試行の解を表示する

続行 をクリックします。

Solver による解の探索方法を変更する

  1. データ タブの 分析 で、ソルバー をクリックします。

    [データ] タブ、[分析] グループ、ソルバー アドイン

    [データ] タブの [分析] に Solver が表示されない場合

    1. ツール メニューの アドイン をクリックします。

    2. アドイン リストで、Solver.Xlam チェック ボックスをクリックし、OK をクリックします。

  2. オプション をクリックし、ソルバー オプション ダイアログ ボックスで、1 つまたは複数のオプションを選択します。

目的

操作

解決時間および反復回数を設定する

すべての方法 タブの 解決の制限 で、制限時間 (秒) ボックスに、解決時間として許容する秒数を入力します。次に、反復回数 ボックスに、許容する最大反復回数を入力します。

注: ソルバー によって問題が解決される前に制限時間または最大反復回数に達すると、ソルバー で 試行状況の表示 ダイアログ ボックスが表示されます。

精度を設定する

すべての方法 タブの 制約条件の精度 ボックスに、必要な精度を入力します。数値が小さいほど精度は高くなります。

収束の程度を設定する

GRG 非線形 または エボリューショナリー タブの 収束 ボックスに、ソルバー によって問題が解決され、停止する直前の 5 回の反復計算で許容する相対的な変化量を入力します。数値が小さいほど、許容される相対的な変化は小さくなります。

  1. OK をクリックします。

  2. Solver Parameters ダイアログ ボックスの Solve または 閉じる をクリックします。

問題モデルを保存する、または読み込む

  1. データ タブの 分析 で、Solver をクリックします。

    [データ] タブ、[分析] グループ、ソルバー アドイン

    [データ] タブの [分析] に Solver が表示されない場合

    1. ツール メニューの アドイン をクリックします。

    2. アドイン リストで、Solver.Xlam チェック ボックスをクリックし、OK をクリックします。

  2. 読み込み/保存 をクリックし、モデル領域のセル範囲を入力し、保存 または 読み込み をクリックします。

    モデルを保存する場合は、問題モデルを配置する縦方向の空白セル範囲の先頭セルの参照を入力します。モデルを読み込む場合は、問題モデルを含むセルの範囲全体の参照を入力します。

    ヒント: ブックを保存することにより、Solver Parameters ダイアログ ボックスで最後に選択した内容を保存できます。ブックの各シートに独自の ソルバー 選択内容を含めることができ、これらはすべて保存されます。読み込み/保存 をクリックして問題を個別に保存することによって、1 つのシートに複数の問題を定義することもできます。

Solver で使用される解決方法を設定する

  1. データ タブの 分析 で、ソルバー をクリックします。

    [データ] タブ、[分析] グループ、ソルバー アドイン

    [データ] タブの [分析] に Solver が表示されない場合

    1. ツール メニューの アドイン をクリックします。

    2. アドイン リストで、Solver.Xlam チェック ボックスをクリックし、OK をクリックします。

  2. 解決方法の選択 ポップアップ メニューで、次のいずれかを選択します。

解決方法

説明

GRG 非線形

既定で選択されています。IF、CHOOSE、LOOKUP、およびその他の "ステップ" 関数以外のほとんどの Excel 関数を使用するモデル用。

シンプレックス LP

この方法は、線形計画問題に使用します。モデルでは、変数セルに応じて SUM、SUMPRODUCT、+ -、および * を数式で使用する必要があります。

エボリューショナリー

この方法は、遺伝的アルゴリズムを基にしており、モデルで変数セルに応じて IF、CHOOSE、または LOOKUP を引数と共に使用する場合に最適です。

ソルバー のプログラム コード部分の著作権は、1990 ~ 2010 年は Frontline Systems, Inc.、1989 年は Optimal Methods, Inc. にあります。

ソルバー の詳細情報について

連絡先:

Frontline Systems, Inc.

P.O. Box 4288

Incline Village, NV 89450-4288

電話番号: (775) 831-0300

電子メール: info@solver.com

または Frontline Systems Web サイト を参照してください。

Frontline Systems が提供する ソルバー についての詳しいヘルプは、 Solver Help on the Frontline Systems Web サイト (英語) を参照してください。

関連項目

ピボットテーブルを作成する

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×