SharePoint ライブラリでファイルをチェックインまたはチェックアウトする

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Windows SharePoint Services サイト上のライブラリからファイルをチェックアウトすると、チェックアウトしたユーザーがファイルを編集している間、他のユーザーはそのファイルに変更を加えることができません。ファイルがチェックアウトされた状態である間は、ファイルを編集して閉じ、再度開くことができ、ハード ディスク上で操作することもできます。ファイルがチェックインされるまで、他のユーザーは、そのファイルに変更を加えることも、変更内容を閲覧することもできません。

このトピックの内容

概要

SharePoint ライブラリからファイルをチェック アウト

SharePoint ライブラリにファイルをチェックインします。

チェック アウトしたファイルを操作する場所を変更します。

概要

複数のユーザーが同じ一連のファイルを使用して作業している場合、ファイルを操作する前にチェックアウトすると、競合や混乱の回避に役立ちます。ファイルがチェックアウトされているときは、チェックアウトしたユーザーだけがそのファイルを変更できます。アクセス許可を持つファイルであれば、SharePoint サイト上のどのファイルでもチェックアウトでき、Word、Excel、PowerPoint、および Visio の 2007 Microsoft Office system プログラムから直接ファイルをチェックアウトできます。

ファイルをチェックインするときに、ファイルに加えた変更についてコメントを入力できます。これは、他のユーザーがファイルのバージョンごとの変更点を理解するために役立ちます。複数のユーザーがファイルを使用して作業している場合や、ファイルの改訂が複数回発生する可能性がある場合は、特に便利です。ライブラリでファイルのバージョンを管理している場合、コメントはファイルのバージョン履歴の一部となるので、以前のバージョンを表示または復元する必要があるときに役立ちます。

編集するファイルは必ずチェックアウトするという決まりを組織内で設けることができます。チェックアウトすることを決まりにした場合、ライブラリに新しいファイルを作成したとき、またはライブラリに新しいファイルをアップロードしたときは、ファイルをチェックインする必要があります。

ファイルをチェックアウトした状態で行った変更は、ファイルをチェックインしない限り他のユーザーには表示されません。変更内容が他のユーザーに表示されるようにファイルをチェックインしつつも、引き続き作業できるようにファイルをチェックアウトしたままにしておきたい場合があります。ファイルをチェックインする際、引き続きファイルを操作することもできます。ただし、ライブラリでメジャー バージョンとマイナー バージョンの両方が追跡管理されていて、メジャー バージョンをチェックインする場合を除きます。メジャー バージョンは通常、前のメジャー バージョンから大きく変更されています。これに対してマイナー バージョンは通常、前のバージョンからの変更はわずかです。たとえば、メジャー バージョンには大量の新しいコンテンツの追加などが含まれ、マイナー バージョンにはスペル ミスのみの修正などが含まれます。

Office プログラムを使用して Windows SharePoint Services 3.0 サイト上のファイルをチェックアウトすると、ファイルは既定でハード ディスクの [マイ ドキュメント] フォルダにある下書きフォルダに格納されます。この場所をハード ディスクまたはネットワーク上の別の場所に変更することや、チェックアウトしたファイルを操作するときにファイルが Web サーバーに格納されるように指定することができます。組織の必要に応じて、管理者が特定の場所を指定したり、場所を変更できないように設定したりすることがあります。

Microsoft Windows SharePoint Services 2.0 サイトからファイルをチェックアウトすると、ファイルは操作している間サーバーに格納されていますが、変更内容はファイルをチェックインしない限り他のユーザーに表示されません。ほとんどの場合、Windows SharePoint Services 3.0 サイトからファイルをチェックアウトするときは、チェックアウト中にファイルが格納される場所を知らせるメッセージが表示されます。SharePoint Services 2.0 サイトからファイルをチェックアウトするときは、このようなメッセージは表示されません。

ドキュメントをチェックアウトすると、Office プログラムの [ドキュメント管理] 作業ウィンドウに、ファイルをチェックインするためのコマンドが表示されます。

ファイルのメジャー バージョンとマイナー バージョンの両方が追跡管理されている場合は、メジャー バージョンまたはマイナー バージョンのどちらをチェックインするかを選択するように求められることがあります。

ページの先頭へ

SharePoint ライブラリからファイルをチェックアウトする

この手順は、Office プログラムで既に開いているファイルをチェックアウトするときに使用します。SharePoint サイトのライブラリからファイルをチェックアウトすることもできます。

2007 Office リリース プログラムで次の操作を行います。

Word、Excel、または PowerPoint の場合

  1. Office ボタンの画像Microsoft Office ボタンをクリックして、サーバー] をクリックし、[チェック アウト] をクリックします。

    多くの場合、Word 文書は既定で全画面閲覧表示で開きます。その場合は、この手順を実行する前に、[印刷レイアウト] をクリックして印刷レイアウト表示に切り替える必要があります。

  2. チェックアウト時のファイルの格納先を示すメッセージが表示されたら、[OK] をクリックします。

    ほとんどの場合、このメッセージは、Windows SharePoint Services 3.0 サイトからファイルをチェックアウトするときに表示されます。

    ヒント: チェックアウト時のファイルの格納先を示すメッセージで、チェックアウトしたファイルの操作に関するオプションを変更できます。

Visio の場合

  1. [ファイル] メニューの [チェックアウト] をクリックします。

  2. チェックアウト時のファイルの格納先を示すメッセージが表示されたら、[OK] をクリックします。

    ほとんどの場合、このメッセージは、Windows SharePoint Services 3.0 サイトからファイルをチェックアウトするときに表示されます。

    ヒント: チェックアウト時のファイルの格納先を示すメッセージで、チェックアウトしたファイルの操作に関するオプションを変更できます。

ページの先頭へ

SharePoint ライブラリにファイルをチェックインする

この手順は、Office プログラムで開いているファイルをチェックインするときに使用します。SharePoint サイト上のライブラリからファイルをチェックインすることもできます。

2007 Office リリース プログラムで次の操作を行います。

Word、Excel、または PowerPoint の場合

  1. Office ボタンの画像Microsoft Office ボタンをクリックして、サーバー] をクリックし、[チェックイン] をクリックします。

    多くの場合、Word 文書は既定で全画面閲覧表示で開きます。その場合は、この手順を実行する前に、[印刷レイアウト] をクリックして印刷レイアウト表示に切り替える必要があります。

  2. メジャー バージョンとマイナー バージョンのどちらをチェックインするかを確認するメッセージが表示された場合、行った変更が少量の場合は [マイナー バージョン] をクリックし、大きな変更を行った場合は [メジャー バージョン] をクリックします。

  3. [バージョンに関するコメント] ボックスに、変更に関するコメントを必要に応じて入力します。

    入力したコメントは、SharePoint ライブラリでファイルのバージョン履歴の一部として表示され、コメントを入力したユーザーまたは他のユーザーが以前のバージョンに関する情報を表示する必要がある場合に役立ちます。

  4. [このバージョンをチェックインした後も、ドキュメントをチェックアウトしたままにする] チェック ボックスが使用できる場合、引き続きファイルを操作するときは、このチェック ボックスをオンにします。

    このオプションは、ライブラリでバージョンの追跡管理を行っていないか、すべてのバージョンを同じ方法で追跡管理しているか、マイナー バージョンをチェックインする場合に使用できます。メジャー バージョンをチェックインするとき、またはファイルを発行するときには、このオプションは使用できません。

Visio の場合

  1. [ファイル] メニューの [チェックイン] をクリックします。

  2. メジャー バージョンとマイナー バージョンのどちらをチェックインするかを確認するメッセージが表示された場合、行った変更が少量の場合は [マイナー バージョン] をクリックし、大きな変更を行った場合は [メジャー バージョン] をクリックします。

  3. [バージョンに関するコメント] ボックスに、変更に関するコメントを必要に応じて入力します。

    入力したコメントは、SharePoint ライブラリでファイルのバージョン履歴の一部として表示され、コメントを入力したユーザーまたは他のユーザーが以前のバージョンに関する情報を表示する必要がある場合に役立ちます。

  4. [このバージョンをチェックインした後も、ドキュメントをチェックアウトしたままにする] チェック ボックスが使用できる場合、引き続きファイルを操作するときは、このチェック ボックスをオンにします。

    このオプションは、ライブラリでバージョンの追跡管理を行っていないか、すべてのバージョンを同じ方法で追跡管理しているか、マイナー バージョンをチェックインする場合に使用できます。メジャー バージョンをチェックインするとき、またはファイルを発行するときには、このオプションは使用できません。

ページの先頭へ

チェックアウトしたファイルを操作する場所を変更する

この設定によって、次にチェックアウトするファイルを操作する場所を変更します。チェックアウトしたファイルが現在作業中の場合は、この手順を実行しても、そのファイルの場所は変更されません。

2007 Office リリース プログラムで次の操作を行います。

Word、Excel、または PowerPoint の場合

  1. Microsoft Office ボタン Office ボタンの画像 ] をクリックし、[プログラムのオプション] をクリックします。 Word のオプション][Excel のオプション]、またはPowerPoint のオプション

  2. 表示されたダイアログ ボックスで、[保存] をクリックします。

  3. [ドキュメント管理サーバー ファイル用のオフライン編集オプション] セクションで、次のいずれかの操作を行います。

    • 次の手順は、チェックアウトしたファイルをハード ディスクまたはネットワーク上の場所で操作するときに使用します。

      1. [チェックアウトしたファイルの保存先] で、[このコンピュータ上の、サーバーのファイルの下書きの場所] をクリックします。

      2. [サーバーのファイルの下書きの場所] ボックスに、チェックアウトしたファイルを操作するハード ディスク上の場所を入力するか、[参照] をクリックして目的の場所を検索します。

    • チェックアウトしたファイルを Web サーバー上で操作するには、[チェックアウトしたファイルの保存先] で [Web サーバー] をクリックします。

      このオプションを選択した場合、チェックアウトしたファイルが格納されている Web サーバーまたはサイト上でファイルを操作することになります。特定の場所をカスタマイズすることはできません。

  4. [OK] をクリックします。

Visio

  1. [ツール] メニューの [オプション] をクリックします。

  2. [オプション] ダイアログ ボックスで、[全般] タブをクリックし、[サービス オプション] をクリックします。

  3. 表示されるダイアログ ボックスで、[オフライン編集オプション] をクリックします。

  4. [ドキュメント管理サーバー ファイル用のオフライン編集オプション] セクションで、次のいずれかの操作を行います。

    • 次の手順は、チェックアウトしたファイルをハード ディスクまたはネットワーク上の場所で操作するときに使用します。

      1. チェックアウトしたファイルをハード ディスク上で操作するには、[チェックアウトしたファイルの保存先] で [このコンピュータ上の、サーバーのファイルの下書きの場所] をクリックします。

      2. [サーバーのファイルの下書きの場所] ボックスに、チェックアウトしたファイルを操作するハード ディスク上の場所を入力するか、[参照] をクリックして目的の場所を検索します。

    • チェックアウトしたファイルをサーバー上で操作するには、[チェックアウトしたファイルの保存先] で [Web サーバー] をクリックします。

      このオプションを選択した場合、チェックアウトしたファイルが格納されている Web サーバーまたはサイト上でファイルを操作することになります。特定の場所をカスタマイズすることはできません。

  5. [OK] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×