SharePoint ドキュメント ライブラリまたはリストへのデータ接続を追加する

フォーム テンプレートに 1 つ以上のセカンダリ データ接続を追加して、Microsoft Windows SharePoint Services を実行しているサーバー上のドキュメント ライブラリまたはリストにデータのクエリを実行したり、ドキュメント ライブラリにデータを送信したりできるようにすることができます。

この記事の内容

概要

始める前に

クエリ データ接続を追加する

送信データ接続を追加する

概要

セカンダリ データ接続は、フォーム テンプレートに追加する外部データ ソースへのデータ接続です。このデータ接続は、データベース、Web サービス、または接続ライブラリ設定に基づいてフォーム テンプレートをデザインするときに作成するメイン データ接続とは異なります。セカンダリ データ接続は、メイン データ接続からデータのクエリまたはデータ送信を実行できない場合にのみ追加します。

データのクエリを実行するセカンダリ データ接続をフォーム テンプレートに追加すると、Microsoft Office InfoPath により、ドキュメント ライブラリまたはリストでのデータの格納方法に対応するデータ フィールドとグループを使用して、セカンダリ データ ソースが作成されます。 外部データ ソースと、フォーム テンプレート内のデータ ソースの間のリレーションシップ。

セカンダリ データ ソースのデータ構造とドキュメント ライブラリまたはリストのデータ格納方法は一致している必要があるため、セカンダリ データ ソース内の既存のフィールドまたはグループを変更することはできません。

SharePoint ドキュメント ライブラリまたはリストにデータのクエリを実行するデータ接続は自動的に、そのドキュメント ライブラリまたはリスト内のすべてのアイテムを返します。クエリ データ接続を使用してリスト ボックス、ドロップダウン リスト ボックス、またはコンボ ボックス コントロールを作成しており、作成したコントロールの項目数が多すぎるか、指定された基準を満たす項目だけを表示したい場合は、項目数を制限するフィルターをコントロールで使用することができます。コントロールで表示されるデータのフィルター処理の詳細については、[参照] セクションのリンクを参照してください。

また、各クエリ データ接続の結果を保存するように構成すると、ユーザーはフォームがネットワークに接続されていないときにデータにアクセスできるようになります。データの種類に応じて、ネットワークに接続されているときにのみクエリ結果を表示するようにすることもできます。

セキュリティに関するお知らせ : セカンダリ データ接続を使用して外部データ ソースから機密データを取得している場合、この機能を無効にすると、コンピューターが紛失または盗難にあったときのデータの不正使用を防ぐのに役立ちます。この機能を無効にした場合は、ユーザーがネットワークに接続しているときにのみデータが使用可能になります。

フォーム テンプレートにクエリ データ接続を追加すると、既定では、ユーザーがフォーム テンプレートに基づくフォーム開いたときにそのフォームでデータ接続が使用されます。以下の方法のいずれかを実行して、クエリ データ接続を使用するようにフォーム テンプレートを構成することもできます。

  • 動作規則を追加する    動作規則の条件が満たされたときにクエリ データ接続を使用するように動作規則を構成できます。

  • ボタンを追加する    ユーザーがクエリ データ接続を使用してデータを取得するときにクリックできるように、ボタンをフォーム テンプレートに追加することができます。

  • ユーザー設定コードを使用する    規則やボタンを追加できない場合、ユーザー設定コードを使用して、クエリ データ接続でデータを取得することができます。ユーザー設定コードを使用する場合、開発者がユーザー設定コードを作成する必要があります。

フォーム テンプレートに送信データ接続を追加し、ユーザーによるフォーム データの送信を許可するようにフォーム テンプレートを構成できます。また、フォーム テンプレートに基づくフォームの送信オプションを構成できます。

ページの先頭へ

始める前に

セカンダリ データ接続をフォーム テンプレートに追加するには、サイト管理者から次の情報を入手する必要があります。

  • SharePoint サイトの場所とその場所にアクセスするために必要なアクセス許可

  • ドキュメント ライブラリまたはリストからデータを取得できるようにサイトが構成されているかどうかの確認

  • オフラインで使用するためにドキュメント ライブラリまたはリストのデータをユーザーのコンピュータ上に保存できるかどうかの確認

ページの先頭へ

クエリ データ接続を追加する

Microsoft Windows SharePoint Services を実行しているサーバー上に配置されたサイトのドキュメント ライブラリまたはリストにデータのクエリを実行できるようにするには、フォーム テンプレートで次の操作を行う必要があります。

  1. セカンダリ データ接続を追加します。

  2. セカンダリ データ接続を使用するようにフォーム テンプレートを構成します。

手順 1: セカンダリ データ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[新しいデータ接続先]、[データの受信]、[次へ] の順にクリックします。

  4. ウィザードの次のページで、[SharePoint ライブラリまたはリスト]、[次へ] の順にクリックします。

    データ接続ウィザードのページで、SharePoint サイトをデータ ソースとして指定します。

  5. ウィザードの次のページで、ドキュメント ライブラリまたはリストが置かれている SharePoint サイトの URL を入力し、[次へ] をクリックします。たとえば、URL が http://www.adventureworks.com/EmployeeList の SharePoint サイトに置かれているドキュメント リストを使用するには、「http://www.adventureworks.com/EmployeeList」と入力します。

  6. ウィザードの次のページにある [リストまたはライブラリの選択] ボックスの一覧で、使用するリストまたはライブラリをクリックし、[次へ] をクリックします。

  7. ウィザードの次のページで、受信する値の横にあるチェック ボックスをオンにします。フォーム テンプレートをドキュメント ライブラリに発行する場合、このフォーム テンプレートに基づくフォームでフォームに関するメタデータが取得されるようにするには、[作業中のフォームのデータのみを含める] チェック ボックスをオンにします。

  8. [次へ] をクリックします。

  9. クエリの結果をフォーム テンプレートに保存する場合は、[フォーム テンプレートのデータのコピーを保存する] チェック ボックスをオンにします。このチェック ボックスをオンにすると、クエリ結果がフォーム テンプレートに保存されます。データがフォーム テンプレートに保存されるため、コンピュータがネットワークに接続されていない場合でも、入力するフォーム内でデータを使用できます。

    セキュリティに関するお知らせ : このチェック ボックスをオンにすると、クエリ結果がフォーム テンプレートに保存されます。データがフォーム テンプレートに保存されるため、コンピュータがネットワークに接続されていない場合でも、ユーザーが入力するフォーム内でデータを使用できます。このデータ接続から機密データを取得している場合は、コンピューターの紛失や盗難に備えて、この機能を無効にすることができます。

  10. [次へ] をクリックします。

  11. ウィザードの次のページの [このデータ接続の名前を入力してください] ボックスに、このセカンダリ データ接続のわかりやすい名前を入力します。この名前が [データ ソース] 作業ウィンドウの [データ ソース] ボックスの一覧に表示されます。フォームを開くときにこのクエリが自動的に実行されるようにするには、[フォームを開くとき自動的にデータを取得する] チェック ボックスをオンにします。

手順 2: セカンダリ データ接続を使用するようにフォーム テンプレートを構成する

このフォーム テンプレートに基づくフォームをユーザーが開いた後に、フォームでこのデータ接続が使用されるようにするには、特定の条件の下でこのデータ接続を使用する動作規則をフォーム テンプレートに追加するか、ユーザーがこのデータ接続を使用するときにクリックできるボタンをフォーム テンプレートに追加することができます。

動作規則を追加する

動作規則に関する基準が満たされた場合はクエリ データ接続からデータを取得するように、フォーム テンプレートの動作規則を追加できます。次の手順では、フォーム テンプレートにクエリ データ接続を作成し、そのデータ接続のデータを表示するコントロールをフォーム テンプレートに構成したと想定しています。

  1. 複数のビューを持つフォーム テンプレートの場合、[表示] メニューの [ビュー名] をクリックして、セカンダリ データ ソースのデータを表示するコントロールがあるビューに移動します。

  2. クエリ結果を表示するコントロールをダブルクリックします。

  3. [データ] タブをクリックします。

  4. [入力規則と動作規則] の [動作規則] をクリックします。

  5. [動作規則] ダイアログ ボックスで、[追加] をクリックします。

  6. [名前] ボックスに動作規則の名前を入力します。

  7. 動作規則を実行する条件を指定するには、[条件の設定] をクリックして条件を入力します。条件が満たされると、動作規則が実行されます。条件を設定しない場合は、ユーザーがコントロールの値を変更した後、そのコントロール以外へカーソルを移動するたびに動作規則が実行されます。

  8. [動作の追加] をクリックします。

  9. [動作] ボックスの一覧で、[データ接続を使用してクエリを送信する] をクリックします。

  10. [データ接続] ボックスの一覧で、使用するクエリ データ接続をクリックし、[OK] をクリックして開いている各ダイアログ ボックスを閉じます。

  11. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

ボタンを追加する

ユーザーがボタンをクリックしてこのクエリ データ接続を使用できるように、フォーム テンプレートにボタン コントロールを追加できます。次の手順では、フォーム テンプレートにクエリ データ接続を作成したと想定しています。

  1. 複数のビューを持つフォーム テンプレートの場合、[表示] メニューの [ビュー名] をクリックして、セカンダリ データ ソースのデータを表示するコントロールがあるビューに移動します。

  2. [コントロール] 作業ウィンドウが表示されていない場合は、[挿入] メニューの [コントロールの選択] をクリックするか、Alt キーを押しながら I キー、C キーの順に押します。

  3. ボタン コントロールをフォーム テンプレートにドラッグします。

  4. フォーム テンプレートに追加したボタン コントロールをダブルクリックします。

  5. [全般] タブをクリックします。

  6. [操作] ボックスの一覧で、[更新] をクリックします。

  7. [ラベル] ボックスに、フォーム テンプレートのボタンに表示するボタンの名前を入力します。

  8. [設定] をクリックします。

  9. [更新] ダイアログ ボックスで、[1 つのセカンダリ データ ソース] をクリックします。

  10. [セカンダリ データ ソースを選択してください] ボックスの一覧で、クエリ データ接続に関連付けられたセカンダリ データ ソースをクリックし、[OK] をクリックして開いている各ダイアログ ボックスを閉じます。

  11. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

ページの先頭へ

送信データ接続を追加する

フォーム テンプレートに基づくフォームをユーザーがドキュメント ライブラリに送信することを許可するには、次の操作を行う必要があります。

  1. フォーム テンプレートにデータを送信するセカンダリ データ接続を追加します。

  2. ユーザーによるフォーム データのドキュメント ライブラリへの送信を許可するようにフォーム テンプレートを構成します。

手順 1: セカンダリ データ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[新しいデータ接続先] をクリックし、[データの送信] をクリックします。次に、[次へ] をクリックします。

  4. [どのようにデータを送信しますか?] の [SharePoint サイトのドキュメント ライブラリに送信] をクリックし、[次へ] をクリックします。

  5. データ接続ウィザードで、[ドキュメント ライブラリ] ボックスに SharePoint ドキュメント ライブラリの URL を入力します。

  6. [ファイル名] ボックスに、ドキュメント ライブラリ内でフォームの識別に使用する名前を入力します。

    ヒント: 各フォーム名が一意になるように数式を使用することもできます。

    操作方法

    1. [数式の挿入] 数式ボタン をクリックします。

    2. [数式の挿入] ダイアログ ボックスで、次のいずれかの操作を実行します。

      • 数式内でフィールドを使用する場合は、[フィールドまたはグループの挿入] をクリックし、[フィールドまたはグループの選択] ダイアログ ボックスで使用するフィールドをクリックして、[OK] をクリックします。

      • 数式内で関数を使用する場合は、[関数の挿入] をクリックし、[関数の挿入] ダイアログ ボックスで使用する関数をクリックして、[OK] をクリックします。

        ヒント: 関数にパラメーターが必要な場合は、[関数の挿入] ダイアログ ボックスで関数を選択して [OK] をクリックした後、[数式の挿入] ダイアログ ボックスの [数式] ボックスで、追加した関数をダブルクリックし、フィールドまたはグループをクリックします。関数の詳細については、[参照] セクションのリンクを参照してください。

      • 数式に値または算術演算子を挿入するには、その値または演算子を表す記号を [数式] ボックスに入力します。

    演算

    記号

    加算

    +

    減算

    -

    乗算

    *

    除算

    /

    • 注: 数式に除算 (/) 演算子を使用する場合は、必ず除算演算子の前後にスペースを挿入します。除算演算子の前後にスペースがない場合、InfoPath では "/" を除算演算子ではなく XPath の場所の段階を表す区切りとして解釈します。

    • 関数の構文が正しいかどうかを確認するには、[数式の挿入] ダイアログ ボックスの [数式の確認] をクリックします。

      数式の詳細については、[参照] セクションのリンクを参照してください。

  7. ドキュメント ライブラリ内の同じ名前を持つ既存のフォームを上書きするには、[既存のファイルに上書きする] チェック ボックスをオンにします。

  8. [次へ] をクリックします。

  9. ウィザードの次のページで、[このデータ接続の名前を入力してください] ボックスに、この送信データ接続のわかりやすい名前を入力します。

セカンダリ送信データ接続を追加した後は、ユーザーがこの送信データ接続を使用してフォーム データを送信できるようにフォーム テンプレートを構成する必要があります。

手順 2: フォーム テンプレートで送信を有効にする

ユーザーによるフォーム データの送信を許可するようにフォーム テンプレートを構成すると、[標準] ツールバーに [送信] ボタンが追加され、フォームの [ファイル] メニューに [送信] コマンドが追加されます。また、次のようにフォーム テンプレートの送信オプションをカスタマイズすることもできます。

  • [送信] ボタンに表示するテキストを変更します。

  • [送信] ボタンのショートカット キーを変更します。

  • ユーザーがフォームを送信したときに表示される、ユーザー設定のメッセージを作成します。

  • フォームが送信された後、フォームを開いたままにしておくか、フォームを閉じるか、または新しい空のフォームを開くかを指定します。

  • [ツール] メニューの [送信オプション] をクリックします。

  • [送信オプション] ダイアログ ボックスで、[ユーザーによるこのフォームの送信を許可する] チェック ボックスをオンにし、[フォームのデータを単一の宛先に送信する] をクリックします。次に、一覧の [SharePoint ドキュメント ライブラリ] をクリックします。

  • [送信用のデータ接続を選択する] ボックスの一覧で、SharePoint ライブラリへの送信データ接続の名前をクリックします。

    1. ユーザーがフォームに入力する時に [標準] ツールバーに表示される [送信] ボタンの名前と、[ファイル] メニューに表示される [送信] コマンドの名前を変更するには、[送信オプション] ダイアログ ボックスの [キャプション] ボックスに新しい名前を入力します。

      ヒント: このボタンとコマンドにショートカット キーを割り当てる場合は、キーボード ショートカットとして使用する文字の前にアンパサンド (&) を入力します。たとえば、[送信] ボタンのキーボード ショートカットとして ALT+B を割り当てるには、「Su&bmit」と入力します。

  • ユーザーがフォームに入力する時に [送信] コマンドまたは [標準] ツールバーの [送信] ボタンを使用できないようにする場合は、[送信メニューおよび送信ツール バーを表示する] チェック ボックスをオフにします。

    1. 既定では、ユーザーがフォームを送信した後もそのフォームは開いたままになり、フォームの送信が正常に終了したかどうかを示すメッセージが表示されます。この既定の動作を変更するには、[詳細設定] をクリックし、次のいずれかの操作を行います。

      • ユーザーが入力済みのフォームを送信した後で、そのフォームを閉じるか新しい空のフォームを作成する場合は、[送信後] ボックスの一覧で目的のオプションをクリックします。

      • フォームが正常に送信されたかどうかを示すメッセージを独自に作成する場合は、[ユーザー設定のメッセージを使用する] チェック ボックスをオンにし、[成功時] と [失敗時] の両方のボックスにそれぞれメッセージを入力します。

        ヒント: [失敗時] ボックスのメッセージには、フォームを送信できなかった場合の対処法を含めます。たとえば、フォームを保存したうえで関係者に問い合わせるようにユーザーに促すメッセージを入力できます。

      • ユーザーがフォームを送信した後に確認メッセージを表示しない場合は、[成功時および失敗時にメッセージを表示する] チェック ボックスをオフにします。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×