Publisher で Web サイトを準備、発行、および保守する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office Publisher 2007 で Web 用の文書の企画を練って作成したら、それを Web、ネットワーク サーバー、または自分のコンピューターの共有フォルダーに発行できます。発行先がどこであっても、この Web 用の文書からフィルター後の HTML ファイルが作成されます。これらの HTML ファイルは、Windows Internet Explorer などの任意の Web ブラウザーで開いて表示できます。

Web サイトを公開する

この記事の内容

ここでは、Web 用の文書を作成し、HTML ファイルとして発行する手順と、その Web 用の文書を編集して再発行することにより、Web サイトを更新する手順について説明します。

Web サイトを準備する

Web サイトを発行する

Web サイトを保守する

Web サイトを準備する

Web サイトは、自分、事業、および事業の商標の延長線上にあるものです。Web サイトを構築する前に、企画を練ります。その詳細については、「Web サイトの企画を練る」を参照してください。

最適なツールを選択する

Web サイトおよびそこで提供する情報の企画を練るときは、ニーズに合った作成ツールについても検討します。Office Publisher 2007 は、ビジネス ブランドに合わせて、単純で静的な Web サイトをすばやく作成、発行、管理する場合に効力を発揮し、テキストとグラフィックだけを改訂するような場合に適しています。次のような場合には、Office Publisher 2007 は適していません。

  • サイト利用者が Web ログ (ブログ) にコメントを付けたり、ショッピング カートを使用して物品を購入したりできるように、Web サイトに対話機能やデータベース駆動型のコンテンツが必要な場合

  • Web サイトに、クレジット カードの番号を確認するなどのデータ検証が必要な場合

  • Office Publisher 2007 を使用して、HTML、拡張マークアップ言語 (XML)、および Vector Markup Language (VML) コードを組み合わせた Web サイトを作成した後に、HTML エディタで生の HTML コードを変更する予定がある場合

基本的な Web ホスティングやオンライン サイトの作成には、Microsoft Office Live をご利用いただけます。詳細については、Microsoft Office Live の Web サイトを参照してください。

対話機能のある Web サイトについては、データを豊富に持つ標準ベースの Web サイトのためのツールが、Microsoft Expression Web に用意されています。詳細については、Microsoft Expression Web のサイトを参照してください。

Web サイトを作成する

Office Publisher 2007 で新しい Web 用の文書を作成できます。Web 用の文書を持たない既存の Web サイトに対して作業する場合は、発行済みの Web ページからコンテンツをコピーし、新しい Web 用の文書に貼り付けることによって、Web サイトを Web 用の文書として再作成できます。または、HTML 編集ツールを使用することもできます。

  1. [ファイル] メニューの [新規作成] をクリックします。

  2. [文書の種類] 一覧で、[Web サイト] をクリックします。

  3. 次のいずれかの操作を行います。

    • サイトの目的に基づいてカスタム Web サイトを作成するには、[オプション] 作業ウィンドウの [Web サイト簡易作成ウィザードを使用する] がオンになっていることを確認し、適用するデザインをクリックします。

    • 新規に Web サイトを作成するには、[Web サイト] の下の [白紙のページ] をクリックし、適用するサイズをクリックします。

  4. [作成] をクリックします。

  5. Web サイト簡易作成ウィザードを使用するように指定した場合は、[Web サイト ビルダー] ダイアログ ボックスで使用するオプションを選択し、[OK] をクリックします。

  6. 文書内にコンテンツを追加し、必要な変更を加えます。

    ヒント: Web 用の文書のマスター ページにオブジェクトを配置することは避けてください。Office Publisher 2007 のマスター ページに配置されたオブジェクトは、一部の Web ブラウザーでは正しく表示されません。

Web 用の文書をチェックする

Web サイトを発行する前に、サイトが期待どおりに動作し、発生し得る問題のすべてに対処したことを確認します。

デザイン チェックを使用したり、サイトのプレビューを表示したりすると、問題を発見することができます。

デザイン チェックを使用して問題を発見し、修正する

デザイン チェックは、潜在的な問題を発見するための強力なツールです。チェック内容の多くは、基本的な書式の問題です。ただし、Web 用の文書に影響する問題に特化したチェックもあります。デザイン チェックを実行するには、次の操作を行います。

  1. [ツール] メニューの [デザイン チェック] をクリックします。

  2. [デザイン チェック] 作業ウィンドウで、[一般的なデザイン チェックを実行する] チェック ボックスおよび [Web サイト用チェックを実行する] チェック ボックスをオンにします。

    注: [業者印刷用チェックを実行する] チェック ボックスがオフになっていることを確認します。

  3. [デザイン チェック] 作業ウィンドウの [修正する項目の選択] で、修正する項目の横にある矢印をクリックし、次のいずれかの操作を行います。

    • 項目の問題を自動的に修正するには、[修正: <自動修正の内容>] をクリックします。

      自動修正の内容は、問題によって異なります。ほとんどの場合、自動修正を利用することはできません。

    • 選択した問題の項目があるページに移動するには、[このアイテムへ移動する] をクリックします。

      そこで必要な変更を行い、問題を修正することができます。

    • [説明を表示] をクリックして、問題とその修正方法をより詳細に示すヘルプ トピックを表示します。

    • [今後、このチェックを実行しない] をクリックして、このチェックをオフにします。

      このオプションをクリックすると、同じ問題が見つかったすべての項目に反映されます。

Web サイトをプレビュー表示する

  • [ファイル] メニューの [ブラウザーでプレビュー] をクリックします。

既定のブラウザーで Web サイトがプレビュー表示されます。プレビューで次の点をチェックします。

  • サイトが開き、すべてのページにアクセスできること。

  • すべてのハイパーリンクが期待どおりに動作すること。

  • ナビゲーション コントロールが期待どおりに動作すること。

  • 欠落している要素がないこと。

  • すべての BGM が期待どおりに再生されること。

Web ホスティング サービスを見つける

Web サイトを Web 上に発行するには、インターネット サービス プロバイダー (ISP) によって提供される Web ホスティング サービスに加入する必要があります。このサービスにより、インターネットへのアクセス、Web サーバー上の格納スペース、および URL (Uniform Resource Locator) が提供され、自分の Web サイトに他のユーザーがアクセスできるようになります。Web サイトを発行する前に、ISP またはシステム管理者に連絡して、必要な情報と、ファイルを保存できる Web サイトの URL または FTP サイトのアドレスを入手してください。

ほとんどの地域では複数の ISP を利用できます。加入する ISP で、必要なサポートを提供しているかどうかを確認してください。Web への発行経験が少ない場合は、なんらかの問題が発生したときに、ISP による支援が必要になる可能性があります。

ページの先頭へ

Web サイトを発行する

Web 用の文書のチェックとプレビューを実行し、Web ホスティング サービスに加入したら、Web サイトの発行準備は完了です。

Web サイトは、Web サーバー、ネットワーク サーバー、FTP サーバー、または自分のコンピューターのフォルダーに対して発行できます。

自分のコンピューター上の場所にサイトを発行する目的は、いくつかあります。

  • 各ファイルを Web 上で公開する前に、発行されたファイルを使用して Web サイトをテストできます。

  • 自分のコンピューター上の場所から FTP ユーティリティを使用してファイルをアップロードすることにより、ファイルを Web に発行できます。

  • Web 用の文書だけでなく、HTML ファイルのローカル コピーを保持できます。

自分に最適な発行方法を決定するには、ISP からの情報が役に立ちます。

Web に発行するか、自分のコンピューターに発行するかに関係なく、Office Publisher 2007 では、作成されるすべての関連ファイルが単一のフォルダーにまとめられます。Office Publisher 2007 によって作成されるファイルには、サイトを構成する他の HTML ページ、ページで使用される GIF 画像と JPEG 画像、埋め込みサウンド用のファイルなどがあります。

Office Publisher 2007 を設定すると、Web サイトの発行先となるフォルダーに対し、次の 2 とおりの方法のどちらかでファイルを編成するように指定できます。既定では、Office Publisher 2007 は、単一のホーム ページと、Web サイトに必要なすべての関連ファイルを格納する 1 つのサブフォルダーを作成します。もう一方の方法では、Web サイトのすべての関連ファイルを含むホーム ページを単一のフォルダーに編成します。

Office Publisher 2007 によって発行される Web サイト ファイルの編成場所の制御方法

[ツール] メニューの [オプション] をクリックし、[Web] タブをクリックして、次のいずれかの操作を実行します。

  • ホーム ページを関連ファイルと分けるには、[関連ファイルを 1 つのフォルダーに保存する] チェック ボックスをオンにします。

  • ホーム ページとすべての関連ファイルを同じフォルダー内にまとめるには、[関連ファイルを 1 つのフォルダーに保存する] チェック ボックスをオフにします。

文書を Web に発行すると、Office Publisher 2007 によってフィルター後の HTML ファイルが作成され、フィルター処理されていない HTML ファイルよりもすばやく Web に反映されます。Office Publisher 2007 で作成されるフィルター後の HTML ファイルには、Microsoft Office に固有のタグが含まれていないため、その HTML ファイルを Office Publisher 2007 で開いて編集することはできません。Web サイトに対する変更は Web 用の文書で行い、そのサイトを Web に再発行する必要があります。

インターネット上またはネットワーク上の場所に Web サイトを発行する

この手順を実行する前に、ISP またはシステム管理者に連絡して、サイトを発行するために必要な情報と、ファイルを保存できる Web サイトの URL を入手してください。

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [Web サイトの作成] ダイアログ ボックスの [ファイル名] ボックスに、Web サイトを保存する Web サーバーまたはネットワーク サーバーの URL を入力します。たとえば、「http://www.northwindtraders.com」と入力します。

  3. [保存] をクリックします。

  4. プロンプトが表示されたら、ユーザー名とパスワードを入力して [OK] をクリックします。

    [Web ページの作成] ダイアログ ボックスに、URL と関連付けられているディレクトリが表示されます。

  5. Web サイトを保存するフォルダーをダブルクリックします。

  6. [ファイル名] ボックスで、ホーム ページの既定の名前として [index] をクリックし、[保存] をクリックします。

    既定では "index.htm" が選択されます。ホーム ページの名前として "index" を使用すると、Web サイトにアクセスしやすくなり、Web サイトを構成しているファイルの一覧がユーザーに閲覧されるのを防止できます。

  7. プロンプトが表示されたら、[OK] をクリックします。

FTP を使用して Web サイトを発行する

この手順を実行する前に、ISP またはシステム管理者に連絡して、FTP サイトに発行するために必要な情報を入手してください。[FTP ロケーション] に FTP サイトを作成しておくことも必要です。

操作方法

[FTP ロケーション] の一覧に FTP サイトを追加するには、インターネットまたはイントラネットにアクセスできる必要があります。

Windows Vista の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [Web サイトの作成] ダイアログ ボックスで [ツール] をクリックし、[ネットワーク ドライブの割り当て] をクリックします。

  3. [ネットワーク ドライブの割り当て] ダイアログ ボックスで、次の操作を行います。

    • [ドライブ] の一覧で、ドライブ文字をクリックします。使用できるどの文字を選択してもかまいません。

    • コンピュータにログオンするたびに接続するには、[ログオン時に再接続する] チェック ボックスをオンにします。

    • [ドキュメントと画像の保存に使用する Web サイトに接続します。] をクリックします。

  4. ネットワークの場所の追加ウィザードで、[次へ] をクリックし、[カスタムのネットワークの場所を選択] をクリックして、[次へ] をクリックします。

  5. [インターネットまたはネットワークのアドレス] ボックスに FTP サイトのアドレスを入力し (たとえば「ftp://ftp.microsoft.com」と入力します)、[次へ] をクリックします。

    注: ネットワーク ドライブまたはネットワーク フォルダーに接続できない場合は、コンピューターの電源がオフになっているか、自分が正しいアクセス許可を持っていない場合があります。接続できない場合は、ネットワーク管理者または ISP に連絡してください。

  6. 匿名でログオンしない場合は、[匿名でログオンする] チェック ボックスをオフにし、[ユーザー名] ボックスにユーザー名を入力して、[次へ] をクリックします。

  7. このネットワークの場所に付ける名前を入力し、[次へ] をクリックします。

  8. [完了] をクリックします。

Microsoft Windows XP の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [保存先] ボックスの横にある矢印をクリックし、[FTP ロケーション] をクリックします。

  3. [FTP パスの追加/変更] をダブルクリックします。

  4. [FTP サイト名] ボックスに FTP サイト名を入力します。たとえば「ftp.microsoft.com」と入力します。

  5. 次のいずれかの操作を行います。

    • 匿名でログオンできる FTP サイトにログオンする場合は、[ログオン オプション] の [匿名] をクリックします。

    • アクセス許可を持っている FTP サイトにログオンする場合は、[ログオン オプション] の [ユーザー] をクリックし、[パスワード] ボックスにパスワードを入力します。

  6. [追加] をクリックします。

  7. [OK] をクリックします。

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [保存先] ボックスの一覧の [FTP ロケーション] をクリックします。

  3. FTP サイトの一覧で、目的のサイトをダブルクリックし、Web サイトを発行するフォルダーをダブルクリックします。

    注: 特定のプログラムを使用して Web サイトをアップロードするように ISP から要求されている場合、または会社のイントラネットに Web サイトを発行する場合は、Web サイトを特定の HTML ファイル形式で保存したバージョンを用意し、別の手順に従って Web サイトを発行しなければならないことがあります。Web サイトの保存方法と発行方法については、ISP またはシステム管理者に問い合わせてください。

コンピューター上のフォルダーに Web サイトを発行する

Windows Vista の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [アドレス バー] で Web サイトを発行するドライブまたはフォルダー (Documents フォルダーなど) をクリックします。

    Web サイトを新しいフォルダに追加する場合は、ツールバーの [新しいフォルダ] をクリックして新しいフォルダを作成し、新しいフォルダの名前を入力して、Enter キーを押します。

  3. [ファイル名] ボックスで、ホーム ページの既定の名前として [index] をクリックし、[保存] をクリックします。

    既定では "index.htm" が選択されます。ホーム ページの名前として "index" を使用すると、Web サイトにアクセスしやすくなり、Web サイトを構成しているファイルの一覧がユーザーに閲覧されるのを防止できます。

Windows XP の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [保存先] ボックスの一覧で、Web サイトを発行するドライブまたはフォルダー ("マイ ドキュメント" フォルダーなど) をクリックします。

    Web サイトを新しいフォルダーに追加する場合は、新しいフォルダーを追加する場所を右クリックし、[新規作成] をポイントし、[フォルダー] をクリックして新しいフォルダーを作成します。[ファイル名] ボックスに新しいフォルダーの名前を入力し、[開く] をクリックします。

  3. [ファイル名] ボックスで、ホーム ページの既定の名前として [index] をクリックし、[保存] をクリックします。

    既定では "index.htm" が選択されます。ホーム ページの名前として "index" を使用すると、Web サイトにアクセスしやすくなり、Web サイトを構成しているファイルの一覧がユーザーに閲覧されるのを防止できます。

ページの先頭へ

Web サイトを保守する

Web サイトを発行したら、新しい情報を反映するために必要に応じて更新できます。ただし、フィルター後の HTML ファイルを Publisher で開くことはできません。元の Web 用の文書を開いて必要な変更を加えた後に、サイトを Web に再発行する必要があります。

注: Microsoft メモ帳や Microsoft ワードパッドなどのテキスト エディターで、フィルター後の HTML ファイルを更新しないでください。これを行うことは可能ですが、Publisher で生成された HTML は複雑で、手動で編集するのは容易ではありません。最良の結果を得るには、常に Web 用の文書を使用して Publisher の Web サイトを更新し、Web に再発行します。

変更したコンテンツのみを発行する

Office Publisher 2007 では、更新したページだけを発行する差分のみの発行機能を使用することにより、以前に発行した Web サイトに更新をすばやく発行できます。たびたび Web サイトを更新する予定がある場合、または Web サイトが大きくて複雑な場合は、Web に差分のみを発行することで、Web サイトの更新作業にかかる時間を短縮できます。

ただし、Web への差分のみの発行を有効にした場合、Office Publisher 2007 を使用せずに Web サーバー上で直接 Web サイトを変更すると、その Web サイトに対する以降の更新を [Web サイトの作成] コマンドで発行できなくなる可能性があります。Web サイトのファイルを Web サーバー上で直接管理する予定がある場合 (別の FTP プログラムを使用する場合など) は、Web への差分のみの発行を無効にする必要があります。

注: Publisher では、既定で差分のみの発行が有効になっています。

Web への差分のみの発行を有効または無効にする

  1. [ツール] メニューの [オプション] をクリックし、[Web] タブをクリックします。

  2. [保存] で、次のいずれかの操作を行います。

    • Web への差分のみの発行を無効にするには、[Web に差分のみを発行する] チェック ボックスをオフにします。

    • Web への差分のみの発行を有効にするには、[Web に差分のみを発行する] チェック ボックスをオンにします。

Web サイトへの変更を発行する

Web サイトへの更新の発行は、最初の Web サイトの発行とは少し異なります。Web 上またはネットワーク上の場所に Web サイトを発行すると、その Web サーバーまたはネットワーク サーバーへのショートカットがマイ ネットワークに表示されるようになります。

Windows Vista の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [Web サイトの作成] ダイアログ ボックスのナビゲーション ウィンドウで、[Computer] をクリックします。

  3. ファイルの一覧で、Web サイトの発行先の Web サーバーまたはネットワーク サーバーへのショートカットをダブルクリックします。

  4. ファイルを保存するフォルダーをダブルクリックします。

  5. [ファイル名] ボックスに更新するファイルの名前を入力し、[保存] をクリックします。

Windows XP の場合

  1. [ファイル] メニューの [Web サイトの作成] をクリックします。

  2. [Web サイトの作成] ダイアログ ボックスで、[マイ ネットワーク] をクリックします。

  3. Web サイトの発行先の Web サーバーまたはネットワーク サーバーへのショートカットをダブルクリックします。

  4. ファイルを保存するフォルダーをダブルクリックします。

  5. [ファイル名] ボックスに更新するファイルの名前を入力し、[保存] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×