Microsoft Visual C++ 6.0 ソース コードのリバース エンジニアリング

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

  1. Visual C++ をカスタマイズします。

    方法

    1. Visual C++ で、[ツール] メニューの [カスタマイズ] をクリックします。

    2. [カスタマイズ] ダイアログ ボックスで、[アドインおよびマクロ ファイル] タブをクリックします。

    3. [アドインおよびマクロ ファイル] ボックスで、[Microsoft Visio UML アドイン] をクリックします。

      [Microsoft Visio UML アドイン] の横にチェック マークが表示されます。

    4. [閉じる] をクリックします。

      5 つのボタンから成る [Microsoft Visio UML アドイン] ツールバーが浮動表示されます。

    5. Visual C++ を開いたときにこのツールバーが必ず表示されるようにするには、ツールバーをツールバー領域にドラッグして固定します。

      ヒント: [Visio UML Add-in] ツールバーの各ボタンに対してキーボード ショートカットを作成するには、[ツール] メニューの [カスタマイズ] をクリックし、[キーボード] タブをクリックして [アドイン] カテゴリをクリックします。

      さらに、システムを指定するのには、ファイルをリバース エンジニア リング (MFC、ATL、または含める) は、 Visio UML オプションボタン UML オプション ボタンの画像 をクリックします。

  2. 参照情報ファイルを作成します。

    方法

    1. Visual C++ で、[プロジェクト] メニューの [設定] をクリックします。

    2. [プロジェクトの設定] ダイアログ ボックスで、ビルド設定の種類を選択します。次に [C/C++] タブをクリックして、[ブラウザ情報を生成する] チェック ボックスをオンにします。

    3. [ブラウザ情報] タブをクリックして、参照情報ファイルの名前と場所を指定します。次に [ブラウザ情報ファイルの生成] チェック ボックスをオンにして [OK] をクリックします。

  3. Visual C++ でプロジェクトを作成します。

    注: プロジェクトをリバース エンジニアリングした後で Visual C++ プロジェクトに変更を加えた場合、プロジェクトを再構築し、Visio プログラムに対してそのプロジェクトをリバース エンジニアリングして、変更内容を反映する必要があります。

  4. Visual C では、ツールバーのVisio UML アドインUML モデルのリバース エンジニア リングのツールバー ボタン UML の [リバース エンジニアリング] ボタンの画像 をクリックします。

    Visual C++ のワークスペースに複数のプロジェクトが存在する場合、[プロジェクトを選択] ダイアログ ボックスでリバース エンジニアリングするプロジェクトをクリックして、[OK] をクリックします。

    プロジェクト階層に複数の参照ファイルが存在する場合、[参照ファイルを選択する] ダイアログ ボックスで参照ファイルをクリックして、[OK] をクリックします。

    参照情報ファイルからクラス情報を抽出するには数秒かかることがあります。抽出が完了すると、Visio の [UML モデル図] が開き、空白の静的構造図の図面ページが表示されます。また [モデル エクスプローラ] のツリー ビューには、ソース コードのクラス定義を表すアイコンが表示されます。

  5. Visio の [UML モデル図] で、ツリー ビューから図面ページにアイコンをドラッグして、モデルのビューを表す静的構造図を作成します。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×