Microsoft SQL Server データベースへのデータ接続を追加する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft SQL Server データベースにクエリを実行するセカンダリ データ接続をフォーム テンプレートに追加できます。フォーム データをデータベースに送信するセカンダリ データ接続をフォーム テンプレートに追加することはできません。フォーム データをデータベースに送信するセカンダリ データ接続を使用する必要がある場合は、そのデータベースに対応した Web サービスへのセカンダリ データ接続を使用します。Web サービスとのセカンダリ データ接続を追加する方法の詳細については、[参照] セクションのリンクを参照してください。

データベースにセカンダリ データ接続を追加するには、次の操作を行う必要があります。

手順 1: セカンダリ データ接続をフォーム テンプレートに追加する    この手順では、データベースのデータ格納方法に基づいて、適切なフィールドとグループを持つセカンダリ データ ソースが作成されます。フォームが最初に開かれたときにこのデータ接続を使用することをフォームに許可するように、フォーム テンプレートを構成することもできます。

手順 2: データ接続を使用するようにフォーム テンプレートを構成する    ユーザーがフォームを開いた後にこのデータ接続が使用されるようにするには、ユーザーがこのデータ接続からデータを取得できるように、動作規則またはボタンをフォーム テンプレートに追加します。

このトピックの内容

概要

始める前に

手順 1: セカンダリ データ接続を追加します。

手順 2: データ接続を使用するフォーム テンプレートを構成します。

概要

外部データ ソースに基づくフォーム テンプレートを作成すると、その外部データ ソースへのデータ接続が Microsoft Office InfoPath によって作成されます。その後、InfoPath では、外部データ ソースのデータ格納方法に基づいて、フォーム テンプレートのメイン データ ソースが作成されます。ただし、メイン データ接続に使用する外部データ ソースに、フォーム テンプレートのコントロールに保存する目的の値がない場合があります。そのような値は、別の SQL Server データベースなどの別の外部データ ソースに存在する場合があります。別の外部データ ソースから値を取得するには、フォーム テンプレートにセカンダリ データ接続を追加します。

セカンダリ データ接続は、フォーム テンプレートに追加するデータ接続です。このデータ接続には、クエリ データ接続と送信データ接続があります。クエリ データ接続は、SQL Server データベースへのセカンダリ データ接続としてのみ、フォーム テンプレートに追加できます。このデータ接続を追加するのは、メイン データ接続のデータ ソース以外の外部データ ソースのデータを使用する必要がある場合のみです。SQL Server データベースへの送信データ接続はセカンダリ データ接続として追加できません。

データベースにクエリのデータ接続を追加する方法、データベースのデータが保存されていることに対応するデータ フィールドとグループの第 2 データ ソースが作成されます。セカンダリ データ ソース内のデータ構造のデータベース テーブルにデータを保存する方法が一致しているためのフィールドまたはグループのセカンダリ データ ソースを変更することはできません。アクセスできるようにユーザーにデータがフォームがネットワークに接続していないときに、結果を保存する各クエリのデータ接続を構成することができます。データの種類、によってユーザーがネットワークに接続されている場合にのみ、クエリの結果を表示します。

セキュリティに関するお知らせ : セカンダリ データ接続を使用して外部データ ソースから機密データを取得している場合、この機能を無効にすると、コンピューターが紛失または盗難にあったときのデータの不正使用を防ぐのに役立ちます。この機能を無効にした場合は、ユーザーがネットワークに接続しているときにのみデータが使用可能になります。

フォーム テンプレートにクエリ データ接続を追加すると、既定では、ユーザーがフォーム テンプレートに基づくフォーム開いたときにそのフォームでデータ接続が使用されます。以下の方法のいずれかを実行して、クエリ データ接続を使用するようにフォーム テンプレートを構成することもできます。

  • 動作規則を追加する    動作規則の条件が満たされたときにクエリ データ接続を使用するように動作規則を構成できます。

  • ボタンを追加する    ユーザーがクエリ データ接続を使用してデータを取得するときにクリックできるように、ボタンをフォーム テンプレートに追加することができます。

  • ユーザー設定コードを使用する    規則やボタンを追加できない場合、ユーザー設定コードを使用して、クエリ データ接続でデータを取得することができます。ユーザー設定コードを使用する場合、開発者がユーザー設定コードを作成する必要があります。

ページの先頭へ

始める前に

SQL Server データベースへのセカンダリ データ接続をフォーム テンプレートに追加するには、データベース管理者から次の情報を入手する必要があります。

  • このフォーム テンプレートで使用するデータベースが格納されているサーバーの名前。

  • このフォーム テンプレートで使用するデータベースの名前。

  • データベースで要求される認証。データベースでは、Microsoft Windows 認証または SQL Server 認証を使用して、ユーザーがデータベースにどのようにアクセスできるかを判断できます。

  • フォームに送信するデータが格納されているテーブルの名前。これは主テーブルです。データベース内の複数のテーブルを使用する場合は、他の子テーブルの名前が必要です。また、主テーブルのフィールドとの間にリレーションシップが確立されている子テーブルのフィールドの名前も必要です。

  • オフラインで使用するためにクエリ結果をフォームに安全に保存できるかどうか。

ページの先頭へ

手順 1: セカンダリ データ接続を追加する

  1. [ツール] メニューの [データ接続] をクリックします。

  2. [データ接続] ダイアログ ボックスで、[追加] をクリックします。

  3. データ接続ウィザードで、[新しいデータ接続先]、[データの受信]、[次へ] の順にクリックします。

  4. ウィザードの次のページで、[データベース (Microsoft SQL Server または Microsoft Office Access のみ)] をクリックし、[次へ] をクリックします。

  5. ウィザードの次のページで、[データベースの選択] をクリックします。

  6. [データ ソースの選択] ダイアログ ボックスで、[新しいソース] をクリックします。

  7. [接続するデータ ソースの種類を指定してください] ボックスの一覧で [Microsoft SQL Server] をクリックし、[次へ] をクリックします。

  8. [サーバー名] ボックスに、データベースが配置されているサーバーの名前を入力します。

  9. [ログイン時の証明] で、次のいずれかの操作を行います。

    • データベースで、Microsoft Windows ネットワークで使用される証明に基づいてアクセス権があるユーザーを確認する場合は、[Windows 認証を使用する] をクリックします。

    • データベースで、データベース管理者から入手する指定のユーザー名とパスワードに基づいてアクセス権があるユーザーを確認する場合は、[以下のユーザー名とパスワードを使用する] をクリックし、[ユーザー名] ボックスと [パスワード] ボックスにユーザー名とパスワードを入力します。

  10. [次へ] をクリックします。

  11. ウィザードの次のページの [使用するデータが含まれているデータベースを選択] ボックスの一覧で、使用するデータベースをクリックし、[指定したテーブルに接続] チェック ボックスをオンにして、主テーブルの名前をクリックし、[次へ] をクリックします。

  12. ウィザードの次のページの [ファイル名] ボックスに、データ接続情報を保存するファイルの名前を入力します。

  13. これらの設定を保存するには、[完了] をクリックします。

  14. クエリ データ接続で使用する他のテーブルを追加します。

    方法

    1. [追加] をクリックします。

    2. 追加のテーブルまたはクエリ] ダイアログ ボックスで、子のテーブルの名前をクリックし、[次へ] をクリックします。InfoPath では、両方のテーブルのフィールド名と一致する、リレーションシップを設定を試みます。お勧めのリレーションシップを使用しない場合は、リレーションシップを選択し、[リレーションシップの削除] をクリックします。リレーションシップを追加するには、リレーションシップの追加] をクリックします。リレーションシップの追加] ダイアログ ボックスでは、[それぞれの列では、関連する各フィールドの名前をクリックし、[ OK] をクリックします。

    3. [完了] をクリックします。

    4. 子テーブルを追加するには、これらの手順を繰り返してください。

  15. [次へ] をクリックします。

  16. フォームがネットワークに接続されていないときにクエリ データ接続の結果を使用できるようにするには、[フォーム テンプレートのデータのコピーを保存する] チェック ボックスをオンにします。

    セキュリティに関するお知らせ : このチェック ボックスをオンにすると、フォームでこのデータ接続が使用された場合は、ユーザーのコンピュータにデータが保存されます。このデータ接続からフォームに機密性の高いデータを取得する場合は、コンピュータが紛失したり盗まれたりしたときにデータを保護できるよう、この機能を無効にします。

  17. [次へ] をクリックします。

  18. ウィザードの次のページで、このセカンダリ データ接続のわかりやすい名前を入力します。フォームを開いたときにデータを自動的に受信するようにするには、[フォームを開くとき自動的にデータを取得する] チェック ボックスをオンにします。

ページの先頭へ

手順 2: データ接続を使用するようにフォーム テンプレートを構成する

このフォーム テンプレートに基づくフォームをユーザーが開いた後に、フォームでこのデータ接続が使用されるようにするには、特定の条件の下でこのデータ接続を使用する動作規則をフォーム テンプレートに追加するか、ユーザーがクリックしてこのデータ接続を使用できるボタンをフォーム テンプレートに追加します。

動作規則を追加する

動作規則に関する基準が満たされた場合はクエリ データ接続からデータを取得するように、フォーム テンプレートの動作規則を追加できます。次の手順では、フォーム テンプレートにクエリ データ接続を作成し、そのデータ接続のデータを表示するコントロールをフォーム テンプレートに構成したと想定しています。

  1. 複数のビューを持つフォーム テンプレートの場合、[表示] メニューの [ビュー名] をクリックして、セカンダリ データ ソースのデータを表示するコントロールがあるビューに移動します。

  2. 動作規則を追加する対象のコントロールをダブルクリックします。

  3. [データ] タブをクリックします。

  4. [入力規則と動作規則] の [動作規則] をクリックします。

  5. [動作規則] ダイアログ ボックスで、[追加] をクリックします。

  6. [名前] ボックスに動作規則の名前を入力します。

  7. 動作規則を実行する条件を指定するには、[条件の設定] をクリックして条件を入力します。条件が満たされると、動作規則が実行されます。条件を設定しない場合は、ユーザーがコントロールの値を変更した後、そのコントロール以外へカーソルを移動するたびに動作規則が実行されます。

  8. [動作の追加] をクリックします。

  9. [動作] ボックスの一覧で、[データ接続を使用してクエリを送信する] をクリックします。

  10. [データ接続] ボックスの一覧で、使用するクエリ データ接続をクリックし、[OK] をクリックして開いている各ダイアログ ボックスを閉じます。

  11. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

ボタンを追加する

ユーザーがボタンをクリックしてクエリ データ接続からデータを取得できるように、フォーム テンプレートにボタン コントロールを追加できます。

  1. 複数のビューを持つフォーム テンプレートの場合、[表示] メニューの [ビュー名] をクリックして、セカンダリ データ ソースのデータを表示するコントロールがあるビューに移動します。

  2. [コントロール] 作業ウィンドウが表示されていない場合は、[挿入] メニューの [コントロールの選択] をクリックするか、Alt キーを押しながら I キー、C キーの順に押します。

  3. ボタン コントロールをフォーム テンプレートにドラッグします。

  4. フォーム テンプレートに追加したボタン コントロールをダブルクリックします。

  5. [全般] タブをクリックします。

  6. [操作] ボックスの一覧で、[更新] をクリックします。

  7. [ラベル] ボックスに、フォーム テンプレートのボタンに表示するボタンの名前を入力します。

  8. [設定] をクリックします。

  9. [更新] ダイアログ ボックスで、[1 つのセカンダリ データ ソース] をクリックします。

  10. [セカンダリ データ ソースを選択してください] ボックスの一覧で、クエリ データ接続に関連付けられたセカンダリ データ ソースをクリックします。

  11. [OK] をクリックして、開いている各ダイアログ ボックスを閉じます。

  12. 変更内容をテストするには、[標準] ツール バーの [プレビュー] をクリックするか、Ctrl キーと Shift キーを押しながら B キーを押します。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×