Microsoft Query を使用して外部データを取得する

Microsoft Query を使用すると、外部ソースからのデータを取り込むことができます。Microsoft Query を使用してデータベースやファイルからデータを取り出すと、Excel でデータを分析するときに、同じデータを再入力する必要がなくなります。また、元のデータベースが新しい情報で更新されるたびに、そのデータベースから Excel のレポートや集計データを自動的に更新することもできます。

目的に合ったトピックをクリックしてください

Microsoft Query について

データ ソースに接続する

クエリ ウィザードを使用してクエリを定義する

Excel でデータを操作する

Microsoft Query について

Microsoft Query を使用すると、外部データ ソースに接続し、それらの外部ソースからデータを選択し、選択したデータをワークシートにインポートし、必要に応じてデータを更新して、ワークシート データを外部ソースのデータに同期させることができます。

アクセス可能なデータベース    Microsoft Office Access、Microsoft SQL Server、Microsoft SQL Server OLAP Services をはじめとする数種類のデータベースから、データを取得することができます。また、Excel ブックやテキスト ファイルからもデータを取得することができます。

Microsoft Office では、次のデータ ソースからデータを取得するためのドライバが用意されています。

  • Microsoft SQL Server Analysis Services (OLAP プロバイダー)

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • テキスト ファイル データベース

また、他の製造元が提供する ODBC ドライバーやデータ ソース ドライバーを使用して、別の種類の OLAP データベースなど、このトピックに示されていないデータ ソースから情報を取得することもできます。ここに示されていない ODBC ドライバーやデータ ソース ドライバーのインストール方法については、対応するデータベースのマニュアルを参照するか、データベースのベンダーにお問い合わせください。

データベースからデータを選択する    データベースからデータを取得するには、クエリを作成します。クエリとは、外部データベースに保存されているデータに関する質問のことです。たとえば、データが Access データベースに保存されていて、特定の製品の売上高を地域別に調べる必要があるとします。この場合、分析の対象となる製品および地域のデータのみを選択することで、一部の必要なデータだけを取り出すことができます。

Microsoft Query を使用すると、必要なデータの列を選択し、そのデータのみを Excel にインポートすることができます。

1 回の操作でワークシートを更新する    Excel ブックに外部データを取り込むと、データベースを変更するたびに、データを最新の情報に更新して分析結果に反映させることができます。集計レポートやグラフを作成し直す必要はありません。たとえば、月間売上集計レポートを作成した場合、毎月、新しい売上高が入力されるとレポートが更新されます。

Microsoft Query でのデータ ソースの処理方法    特定のデータベースに対してデータ ソースをセットアップした後は、いつでもそのデータ ソースを使用してクエリを作成し、データベースからデータを選択して取り出すことができます。このとき、接続情報を入力し直す必要はありません。Microsoft Query は、データ ソースを使用して外部データベースに接続し、利用可能なデータを表示します。クエリを作成し、データが Excel に返されると、データの更新時にデータベースに再接続できるように、Microsoft Query から Excel ブックにクエリおよびデータ ソースに関する情報の両方が提供されます。

Query でのデータ ソースの処理方法

Microsoft Query を使用してデータをインポートする    Microsoft Query を使用して Excel に外部データをインポートするには、次の基本的な手順を行います。各手順の詳細については、それぞれのセクションで説明します。

  1. データ ソースに接続します。

  2. クエリを定義するクエリ ウィザードを使用します。

  3. Excel でデータを操作します。

ページの先頭へ

データ ソースに接続する

データ ソースとは    データ ソースとは、Excel および Microsoft Query から外部データベースに接続するための一連の保存情報です。Microsoft Query を使用してデータ ソースをセットアップする場合、データ ソースに名前を付け、次にデータベースまたはサーバーの場所、データベースの種類、ログオンとパスワードに関する情報を指定します。この情報には、ODBC ドライバーまたはデータ ソース ドライバーの名前も含まれます。これは、特定の種類のデータベースに接続するためのプログラムです。

Microsoft Query を使用してデータ ソースをセットアップするには、次の手順を行います。

  1. [データ] タブの [外部データの取り込み] で [その他のデータ ソース] をクリックし、[Microsoft Query] をクリックします。

  2. 次のいずれかの操作を行います。

    • データベース、テキスト ファイル、Excel ブックに対するデータ ソースを指定するには、[データベース] タブをクリックします。

    • OLAP キューブのデータ ソースを指定するには、[OLAP キューブ] タブをクリックします。このタブは、Excel から Microsoft Query を実行している場合にのみ、表示されます。

  3. [<新規データ ソース>] をダブルクリックします。

    または

    [<新規データ ソース>] をクリックし、[OK] をクリックします。

    [新規データ ソースの作成] ダイアログ ボックスが表示されます。

  4. 1 という番号が付けられているボックスで、データ ソースを特定する名前を入力します。

  5. 2 という番号が付けられているボックスで、データ ソースとして使用するデータベースの種類に対応するドライバをクリックします。

    アクセスする外部データベースが Microsoft Query に付属の ODBC ドライバでサポートされていない場合は、データベースの製造元などのサードパーティから、Microsoft Office と互換性のある ODBC ドライバを入手してインストールする必要があります。インストールの手順については、ドライバの製造元に問い合わせてください。

    注: OLAP データベースでは、ODBC ドライバは必要ありません。Microsoft Query をインストールすると、Microsoft SQL Server Analysis Services で作成されたデータベース用のドライバがインストールされます。他の OLAP データベースに接続するには、データ ソース ドライバとクライアント ソフトウェアをインストールする必要があります。

  6. [接続] をクリックし、データ ソースへの接続に必要な情報を入力します。データベース、Excel ブック、テキスト ファイルの場合、入力する情報は選択したデータ ソースの種類によって異なります。ログオン名、パスワード、使用しているデータベースのバージョン、データベースの保存場所など、データベース固有の情報を入力するように求められることがあります。

    パスワードには、大文字、小文字、数字、記号を組み合わせた複雑なものを使用してください。これらの文字を混在させたものになっていないパスワードは強力とは言えません。たとえば、House27 は Y6dh!et5 に比べ、推測されやすいパスワードと言えます。長さは 8 文字以上にする必要があり、理想は 14 文字以上のパス フレーズです。

    パスワードは忘れないようにしてください。パスワードを忘れた場合、マイクロソフトでパスワードを回復することはできません。紙に記録したパスワードを、保護する必要がある情報から離れた安全な場所に保管してください。

  7. 必要な情報を入力した後、[OK] または [完了] をクリックして、[新規データ ソースの作成] ダイアログ ボックスに戻ります。

  8. 使用するデータベースに複数のテーブルがあり、特定のテーブルが自動的にクエリ ウィザードに表示されるように設定する場合は、4 という番号の付いたボックスをクリックし、目的のテーブルをクリックします。

  9. データ ソースを使用するときに、ログオン名とパスワードを入力しなくても済むようにする場合は、[データ ソースの定義にユーザー ID とパスワードを保存する] チェック ボックスをオンにします。保存されるパスワードは暗号化されていません。チェック ボックスが使用できない場合は、このオプションを使用可能にできるかどうかをデータベースの管理者に問い合わせてください。

    セキュリティに関するお知らせ : Avoid saving logon information when connecting to data sources. This information may be stored as plain text, and a malicious user could access the information to compromise the security of the data source.

これらの手順を完了すると、データ ソース名が [データ ソースの選択] ダイアログ ボックスに表示されます。

ページの先頭へ

クエリ ウィザードを使用してクエリを定義する

クエリ ウィザードを使用して一般的なクエリを作成する    クエリ ウィザードにより、データベース内のさまざまなテーブルやフィールドからデータを選択して、まとめる作業を簡単に行うことができます。クエリ ウィザードを使用すると、クエリに含めるテーブルとフィールドを選択できます。1 つのテーブルの主キー フィールドがウィザードによって認識され、そのフィールドと同じ名前のフィールドが 2 つ目のテーブルに見つかると、内部結合 (一致するフィールド値に基づいて 2 つのテーブルの行を結合するクエリ処理) が自動的に作成されます。

ウィザードを使用して、結果セットを並べ替えたり、簡単なフィルタを実行したりすることもできます。ウィザードの最後の手順では、データを Excel に返すか、Microsoft Query を使用してより詳細にクエリを定義するかを選択できます。作成したクエリは、Excel または Microsoft Query で実行できます。

クエリ ウィザードを開始するには、次の操作を行います。

  1. [データ] タブの [外部データの取り込み] で [その他のデータ ソース] をクリックし、[Microsoft Query] をクリックします。

  2. [データ ソースの選択] ダイアログ ボックスで、[クエリ ウィザードを使ってクエリを作成/編集する] チェック ボックスがオンになっていることを確認します。

  3. 使用するデータ ソースをダブルクリックします。

    または

    使用するデータ ソースをクリックし、[OK] をクリックします。

他の種類のクエリは直接 Microsoft Query を使用して作業する    クエリ ウィザードで作成できるクエリよりも複雑なクエリを作成する必要がある場合は、Microsoft Query を直接使用して作業できます。Microsoft Query を使用すると、クエリ ウィザードで途中まで作成したクエリを表示して変更したり、ウィザードを使わずに新しいクエリを作成したりできます。次のような処理を行うクエリを作成するには、Microsoft Query を直接使用します。

  • フィールドから特定のデータを選択する    大規模なデータベースのフィールドから特定のデータだけを選択し、不要なデータを除外する場合。たとえば、多数の製品に関する情報が含まれているフィールドで、2 つの製品に関するデータのみが必要な場合は、抽出条件を使用して、必要な 2 つの製品に関するデータのみを選ぶことができます。

  • クエリを実行するたびに異なる検索条件に基づいてデータを取り出す    地域ごとに売上レポートを作成する場合など、1 つの外部データの別々の項目について、同じ Excel レポートや集計を作成する必要がある場合。この場合はパラメーター クエリを作成できます。パラメーター クエリを実行すると、クエリでレコードを選択するときに、抽出条件として使用する値の入力を求められます。たとえば、特定の地域を入力するように求めるパラメーター クエリを作成すると、そのクエリを再利用して地域ごとの売上レポートを作成できます。

  • さまざまな方法でデータを結合する    クエリ ウィザードで作成される内部結合は、クエリの作成において最もよく使用される結合の種類です。ただし、場合によっては他の種類の結合を使用する方が適していることもあります。たとえば、製品の売上情報のテーブルと顧客情報のテーブルがある場合、内部結合 (クエリ ウィザードで作成される種類) では、製品を購入しなかった顧客のレコードは取り出されません。Microsoft Query を使用すると、これらのテーブルを結合して、すべての顧客レコードと、製品を購入したことのある顧客についてはその売上データを取得することができます。

Microsoft Query を起動するには、次の手順を行います。

  1. [データ] タブの [外部データの取り込み] で [その他のデータ ソース] をクリックし、[Microsoft Query] をクリックします。

  2. [データ ソースの選択] ダイアログ ボックスで、[クエリ ウィザードを使ってクエリを作成/編集する] チェック ボックスがオフになっていることを確認します。

  3. 使用するデータ ソースをダブルクリックします。

    または

    使用するデータ ソースをクリックし、[OK] をクリックします。

クエリを再利用および共有する    クエリ ウィザードと Microsoft Query のどちらでも、作成したクエリを .dqy ファイルとして保存して、変更、再利用、および共有することができます。Excel では .dqy ファイルを直接開くことができるため、ファイルの作成者や他のユーザーが、同じクエリを使用して追加の外部データ範囲を作成できます。

保存されたクエリを Excel で開くには、次の操作を行います。

  1. [データ] タブの [外部データの取り込み] グループで [その他のデータ ソース] をクリックし、[Microsoft Query] をクリックします。[データ ソースの選択] ダイアログ ボックスが表示されます。

  2. [データ ソースの選択] ダイアログ ボックスで、[クエリ] タブをクリックします。

  3. 保存された目的のクエリをダブルクリックします。クエリが Microsoft Query に表示されます。

保存されたクエリを開くとき、既に Microsoft Query が開かれている場合は、Microsoft Query の [ファイル] メニューをクリックし、[開く] をクリックします。

.dqy ファイルをダブルクリックすると、Excel が起動し、クエリが実行されて、その結果が新しいワークシートに挿入されます。

外部データに基づいて作成された Excel の集計やレポートを共有する場合は、外部データ範囲が含まれているブックを他のユーザーに提供するか、またはテンプレートを作成することができます。テンプレートを使用すると、外部データを保存せずに集計やレポートを保存できるため、ファイルのサイズが小さくなります。外部データは、ユーザーがレポート テンプレートを開いたときに取得されます。

ページの先頭へ

Excel でデータを操作する

クエリ ウィザードまたは Microsoft Query でクエリを作成したら、データを Excel ワークシートに返すことができます。返されたデータは、外部データ範囲になるか、またはデータの書式設定および更新を行うことができるピボットテーブル レポートになります。

取得したデータに書式を設定する    Excel では、グラフや自動集計などのツールを使用して、Microsoft Query により取得されたデータを表示したり集計したりできます。データには書式を設定でき、その書式は外部データを更新しても保持されます。列ラベルには、フィールド名の代わりにご自分で作成したラベルを使用でき、行番号を自動的に付けることもできます。

Excel では、範囲の最後に追加したデータに対し、前の行と一致するように自動的に書式を設定できます。また、追加した行に対し、前の行に繰り返し設定されていた数式を自動的に適用することもできます。

注: 範囲内の新しい行に書式や数式が継承されるようにするためには、直前の 5 行のうちの少なくとも 3 行に、その書式や数式が設定されている必要があります。

このオプションは、いつでも有効に (または再度無効に) できます。

  1. [Microsoft Office ボタン] Office ボタンの画像 をクリックし、[Excel のオプション] をクリックします。次に、[詳細設定] カテゴリをクリックします。

  2. このオプションを無効にするには、[編集] セクションの [データ範囲の形式および数式を拡張する] チェック ボックスをオンにします。データ範囲に対する自動書式設定を再び無効にするには、このチェック ボックスをオフにします。

外部データを更新する    外部データを更新するときは、クエリを実行して、条件を満たす新しいデータや変更されたデータを取得します。クエリの更新は、Microsoft Query と Excel のどちらでも実行できます。Excel では、ブックを開くたびにクエリを更新する機能や、設定した間隔で自動的にクエリを更新する機能など、いくつかのオプションが用意されています。データの更新中に Excel での作業を続行したり、更新状況を確認することもできます。詳細については、「接続 (インポート) されたデータを更新する」を参照してください。

ページの先頭へ

注記: 

  • 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

  • この記事の英語版を参照するには、ここ をクリックしてください。Microsoft コミュニティの他のメンバーと一緒に、Community Translation Framework (CTF) を使ったこの記事の改善にご協力ください。記事内の文章にマウス ポインターを合わせて、CTF ウィジェットの [翻訳を改善します] をクリックしてください。CTF の詳細については、ここ をクリックしてください。CTF を使用すると弊社の サービス利用規約 に同意したことになります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×