Microsoft Office Visio 2007 のデータ接続機能の概要

Microsoft Office Visio 2007 は、図や図面を作成するだけでなく、データを視覚化、整理、理解、および提示するのにも役立ちます。

Visio 図面の各図形には、異なるデータ セットを表示できます。次の図では、各図形に異なる地域の売り上げデータが表示されているため、地域ごとの過年度と本年度の販売実績を簡単に比較できます。

フラグで状態を表示する

使用するデータが既にブックやデータベース テーブルに格納されている場合は、個々の情報を手動で入力せずに Office Visio の図形に直接インポートできます。

このトピックの内容

データを図面に接続する場合に推奨される方法

以前のバージョンの Visio で使用されていた方法でデータに接続する

データ リンク以外の機能を使用してデータを図面に接続する

データを図面に接続する場合に推奨される方法

Visio にはいくつかのデータ接続機能がありますが、通常は、データ選択ウィザードを使用してデータ ソースを図面に接続するのが最適な方法です。データ選択ウィザードは、[データ] メニューの [図形にデータをインポート] をクリックすると表示されます。このウィザードを完了すると、データが [外部データ] ウィンドウに表示されます。接続された図形を図面に追加すると、データが図形に表示されます。また、Office Visio 2007 には一連のデータ グラフィックが含まれており、それを選択したり変更したりすることもできます。

データ リンク機能とデータ グラフィック機能の詳細については、次のトピックを参照してください。

ページの先頭へ

以前のバージョンの Visio で使用されていた方法でデータに接続する

Office Visio 2007 のデータ リンク機能は、以前のバージョンの Visio の機能を置き換えるものではないため、以前のバージョンで使用されていた方法でもデータに接続できます。データに接続するための特殊機能を持つソリューションや、2 つのデータベース接続アドオンを引き続き使用できます。

2 つのデータベース接続アドオンとは、データベース ウィザードと [ODBC データベースにリンク] コマンドを指します。これらの機能にアクセスするには、[ツール] メニューの [アドオン] をポイントし、[Visio エキストラ] をポイントして、[データベース ウィザード] または [ODBC データベースにリンク] をクリックします。

一部のテンプレートには、次に示すように、特定の種類のデータを図面に接続したり、データから図面を生成したりするための特別なツールが用意されています。

  • 組織図テンプレート     組織図ウィザードを使用すると、Microsoft Exchange Server のデータ、Microsoft Office Excel のデータ、テキスト ファイル、およびその他の ODBC 準拠のデータ ソースに接続して組織図を生成できます。これを行うには、組織図で [組織図] メニューの [組織データのインポート] をクリックします。組織図を生成した後は、データ選択ウィザードを使用して他の外部データにリンクできます。詳細については、「Visio 組織図を作成する」を参照してください。

  • タイムライン テンプレート     タイムライン インポート ウィザードを使用して、Microsoft Office Project のデータに接続できます。これを行うには、[データ] メニューの [データ ソリューションの挿入] をポイントし、[タイムライン] をクリックします。詳細については、「Project から Visio タイムラインにデータをインポートする」を参照してください。

  • カレンダー テンプレート     Outlook データのインポート ウィザードを使用して、Microsoft Office Outlook のデータに接続できます。これを行うには、[データ] メニューの [データ ソリューションの挿入] をポイントし、[カレンダー] をクリックします。詳細については、「Outlook から Visio カレンダーに予定をインポートする」を参照してください。

  • ブレーンストーミング図テンプレート     ブレーンストーミング図では、[ブレーンストーミング] メニューの [データのインポート] を使用して XML ファイルに接続できます。詳細については、「ブレーンストーミング図を作成する」を参照してください。

  • ガント チャート テンプレート     プロジェクト データ インポート ウィザードを使用して、Office Project のデータに接続できます。これを行うには、ガント チャートで [ガント チャート] メニューの [インポート] をクリックします。詳細については、「Project から Visio ガント チャートにデータをインポートする」を参照してください。

  • データベース モデル図テンプレート     リバース エンジニアリング ウィザードを使用して、ODBC 準拠のデータベースをリバース エンジニアリングできます。これを行うには、データベース モデル図で [データベース] メニューの [リバース エンジニアリング] をクリックします。それらの図に追加のデータをインポートしたりデータを表示したりするには、テンプレートに含まれている他のウィザードに加えて、データ選択ウィザードを使用できます。詳細については、「既存のデータベースからデータベース モデルへのリバース エンジニアリングを行う」を参照してください。

ページの先頭へ

データ リンク以外の機能を使用してデータを図面に接続する

次のような特殊な場合には、データ選択ウィザード以外の方法で図面のデータを操作します。

  • 以前にデータベース ウィザードを使用して作成された図面を操作する場合。

  • Visio の図面でデータ ソースに影響を及ぼすデータ変更を行う場合など、データベース ウィザードを使用して双方向のデータ接続を操作する場合。

  • Visio を使用してデータ ソースから図面全体を作成する際に、タイムライン、組織図、カレンダーなどの図面をデータから生成する場合。

  • Visio を使用してデータ ソースから図形を作成する際に、Visio でマスタ シェイプを生成する場合。

  • データベース モデル図テンプレートからアクセスできるリバース エンジニアリング ウィザードを使用して、データベースをリバース エンジニアリングする場合。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×