Microsoft Office Access の新機能

Microsoft Access 2010 では、Web データベースを構築し、SharePoint サイトに発行できます。

“共同作業をすぐに開始可能。”

SharePoint の閲覧者は、Web ブラウザーでデータベース アプリケーションを使用できます。だれに何を表示するかを決定するには、SharePoint のアクセス許可を使用します。また、テンプレートを利用すると、すぐに共同作業を開始できます。その他の多くの機能拡張でこの新しい Web 発行機能がサポートされており、従来のデスクトップ データベースの利点も得られます。

Access 2010 のユーザー インターフェイスも変更されています。Office Access 2007 を使ったことがなければ、リボンやナビゲーション ウィンドウに初めて触れることになります。旧来のバージョンのメニューとツールバーは、リボンに置き換えられました。データベース ウィンドウはナビゲーション ウィンドウに置き換えられ、機能が強化されています。また、Access 2010 で導入された Backstage ビューでは、最適化や修復など、データベース全体に適用されるすべてのコマンドや、[ファイル] メニューに用意されていたコマンドを使用できます。

この記事では、Office Access 2007 と Access 2010 で導入された機能について説明します。Access の全般的な概要については、「Access 2010 の使用を開始する」を参照してください。

この記事の内容

概要

新しいユーザー インターフェイス

より強力なオブジェクト作成ツール

新しいデータ型とコントロール

強化されたデータ表示機能

強化されたセキュリティ

より効果的なトラブルシューティング

校正ツールの強化

概要

Access Services が設定されている SharePoint サイトにアクセスできる場合は、Access 2010 を使用して Web データベースを作成できます。ユーザーはそのデータベースを Web ブラウザー ウィンドウで使用できますが、デザインを変更するには、Access 2010 を使用する必要があります。一部のデスクトップ データベース機能は Web 用に変換されませんが、演算フィールドやデータ マクロなどの新しい機能を使用すれば、同じ処理の多くを実行できます。

Web 上でデータベースを共有する

  • テンプレートを使用する     Access 2010 には、連絡先、資産、プロジェクト、イベント、および慈善活動を管理するための 5 つのテンプレートが用意されています。発行する前後に、テンプレートを変更することもできます。

  • ゼロから開始する    新しい空のデータベースを作成する際に、通常のデータベースと Web データベースのどちらかを選択できます。この選択によって、表示されるデザイン機能とコマンドが変わってくるため、アプリケーションが Web 対応かどうかを簡単に確認できます。

  • 既存のデータベースを Web データベースに変換する    既存のアプリケーションを Web に発行できます。すべてのデスクトップ データベース機能が Web 上でサポートされるわけではないため、場合によっては、アプリケーションの一部の機能を調整する必要があります。

    注: 新しい Web 互換性チェックを実行すると、互換性の問題を特定し、修正できます。

  • イントラネットまたはインターネット    データベースを独自の SharePoint サーバーに発行できるほか、ホストされた SharePoint ソリューションを使用できます。

Web データベースの詳細については、「Web で共有するデータベースを作成する」を参照してください。

新しいマクロ ビルダー

Access 2010 には、わかりやすくシンプルなインターフェイスと IntelliSense を備えた新しいマクロ ビルダーが用意されています。

マクロ ビルダー

1. 一覧からアクションを選択します。

2. または、アクション カタログでアクションをダブルクリックし、マクロに追加します。

3. マクロの編集中に、[デザイン] タブが表示されます。

アクションを追加すると、マクロ ビルダーにさらにオプションが表示されます。たとえば、"If" アクションを追加した場合は、次のように表示されます。

If 操作が含まれるマクロ

新しいマクロ ビルダーを使用すると、従来のマクロに加えて、新たに導入されたデータ マクロを作成できます。

データ マクロ: イベントに基づいてデータを変更する

データ マクロを使用すると、Web データベースで集計を実行できるほか、任意の Access 2010 データベースで "トリガー" を実装できます。

たとえば、PercentComplete フィールドと Status フィールドがあるとします。データ マクロを使用すると、Status を Complete に設定したときに PercentComplete を 100 に、Status を Not Started に設定したときに PercentComplete を 0 に設定できます。

機能強化された式ビルダー

式ビルダーで IntelliSense がサポートされたため、入力中にオプションを確認できるようになりました。また、式ビルダー ウィンドウで選択されている式の値に対応するヘルプも表示されます。たとえば、Trim 関数を選択すると、式ビルダーに次のヘルプが表示されます。

Trim(文字列) 指定した文字列から先頭と末尾のスペースを削除した文字列を示すバリアント型 (内部処理形式は文字列型) の値を返します。

演算フィールド

計算の結果を表示するフィールドを作成できます。計算では、同じテーブルの他のフィールドを参照する必要があります。計算を作成するには、式ビルダーを使用します。

テーブルの入力規則

注: これは Access 2007 で導入された機能です。

変更したレコードで指定の規則が検証される場合に、データ入力を禁止する規則を作成することができます。フィールドの入力規則とは異なり、テーブルの入力規則では複数のフィールドの値をチェックできます。入力規則の作成には式ビルダーを使用します。

必要な機能を完備したアプリケーションを実現するデータベース テンプレート

Access 2010 には、連絡先、タスク、イベント、生徒名簿、資産をはじめとする、さまざまな種類のデータを管理するための本格的なデータベース テンプレートが用意されています。テンプレートはそのまま使用できるほか、より目的に沿った形で情報を追跡できるようにカスタマイズすることもできます。

Backstage ビューで使用できるテンプレート

テンプレートは、その一つひとつが定義済みのテーブル、フォーム、レポート、クエリ、マクロ、リレーションシップなど、必要な機能を完備した追跡管理アプリケーションです。テンプレートは、起動するだけですぐに使い始めることができるように設計されています。テンプレートのデザインが目的にかなうものであれば、そのまま利用することも可能です。そのままでは利用できない場合でも、テンプレートを基に、特定のニーズを満たすデータベースを作成できます。

資産管理 Web データベース

Access 2010 に付属のテンプレートだけでなく、Office.com に接続することで、さまざまなテンプレートをダウンロードできます。

既存のデータベースに機能を追加するアプリケーション パーツ

アプリケーション パーツを使用すると、既存のデータベースに機能を簡単に追加できます。Access 2010 の新機能では、アプリケーション パーツはデータベースの一部を構成するテンプレートです。たとえば、Tasks アプリケーション パーツをデータベースに追加すると、Tasks テーブルと Tasks フォームを利用できるようになり、さらにテーブルをデータベース内の別のテーブルに関連付けることができるようになります。

[作成] タブのアプリケーション パーツ

データシート ビューの強化

フィールドを定義しなくても、テーブルを作成して使用を開始できます。[作成] タブの [テーブル] をクリックするだけで新しいデータシートが表示され、データを入力し始めることができます。すぐに作業を開始できるように、Access 2010 によって各フィールドの最適なデータ型が自動的に決定されます。新しいフィールドの追加先は、[クリックして追加] 列によって示されます。新しいフィールドまたは既存のフィールドのデータ型や表示形式を変更する場合も、リボンの [フィールド] タブにあるコマンドを使って行うことができます。Microsoft Office Excel のテーブルから新しいデータシートにデータを貼り付けることもできます。その場合、Access 2010 によって自動的にすべてのフィールドが作成され、データ型が認識されます。

データシート ビューで追加するためにクリック

[フィールド リスト] 作業ウィンドウ

Access 2007 で導入された [フィールド リスト] 作業ウィンドウで、他のテーブルのフィールドを追加できます。レコード ソース内のテーブルや、関連テーブルからフィールドをドラッグできるほか、データベース内の関連付けられていないテーブルからもフィールドをドラッグすることができます。テーブル間のリレーションシップが必要な場合は、自動的に作成されるか、必要な手順を案内する画面が表示されます。

[フィールド リスト] ウィンドウ

フォームとレポートをすばやくデザインできるレイアウト ビュー

フォームまたはレポートでデータを閲覧しながらデザインを変更する場合は、レイアウト ビューを使用します。

レイアウト ビューには、Access 2007 と比べていくつかの点で機能強化が行われています。Web 用のフォームやレポートをデザインする場合は、レイアウト ビューを使用する必要があります。

[レイアウト] ビューのフォームにライブ データが表示される

たとえば、[フィールド リスト] 作業ウィンドウからドラッグしてデザイン グリッドにフィールドを追加したり、プロパティ シートを使ってプロパティを変更したりできます。

コントロール レイアウトを使用して要素を整理する

Office Access 2007 で導入されたレイアウトは、まとめて移動およびサイズ変更できるコントロールのグループです。Access 2010 では、レイアウトの機能が強化され、フォームやレポート上にコントロールをより柔軟に配置できるようになりました。セルを水平または垂直に分割、結合できるため、フィールド、列、または行を簡単に再配置できます。

Web データベースをデザインする場合はレイアウト ビューを使用する必要がありますが、デスクトップ データベースのデザイン作業には、引き続きデザイン ビューを使用できます。

ページの先頭へ

新しいユーザー インターフェイス

Office Access 2007 で導入され、Access 2010 で機能強化された新しいユーザー インターフェイスは、以前は複雑なメニューやツールバーに埋もれがちだったコマンドや機能を簡単に見つけられるようにデザインされています。

リボン

リボンとは、機能別に分類された一連のコマンドが含まれたタブを集約したものです。以前のバージョンの Access で採用されていたメニュー階層やツールバーに代わるインターフェイスです。

リボンの主な特長を次に示します。

  • コマンド タブ: 必要なときに必要なコマンドを見つけることができるように、使用頻度の高いコマンドがグループ化されて表示されます。

  • コンテキスト コマンド タブ: 作業中のオブジェクトや実行中のタスクなど、状況に応じて表示されるコマンド タブです。コンテキスト コマンド タブには、実行中の作業に最も適したコマンドが表示されます。

  • ギャラリー: スタイルやオプションのプレビューを表示する新しいコントロールで、選択内容を確定する前に結果を確認できます。

Backstage ビュー

Access 2010 で新たに導入された Backstage ビューには、最適化や修復など、データベース全体に適用されるコマンドや、新しいデータベースを開くコマンドがあります。コマンドは画面左側のタブに配置され、各タブには関連性のある一連のコマンドやリンクが表示されます。たとえば、[新規作成] をクリックすると、新しいデータベースをゼロから、または本格的なデータベース テンプレートのライブラリから選択して作成できる一連のボタンが表示されます。

Backstage ビューにあるコマンドの多くは、以前のバージョンの Access では、最近開いたデータベースや、(インターネットに接続している場合は) 一般的な office.com の記事へのリンクとともに、[ファイル] メニューに用意されていました。

Access の Backstage ビュー

ナビゲーション ウィンドウ

Access 2007 で導入されたナビゲーション ウィンドウには、現在開いているデータベースに存在するすべてのオブジェクトが一覧表示され、ここから目的のオブジェクトに簡単にアクセスできます。ナビゲーション ウィンドウを使用すると、オブジェクトの種類、作成日、更新日、関連テーブル (オブジェクトの依存関係)、独自に作成したユーザー設定のグループなどの基準で、オブジェクトを整理できます。フォームのデザイン領域を広くしたい場合、ナビゲーション ウィンドウは簡単に縮小できます。再び必要になった場合でも、すぐにアクセスできます。ナビゲーション ウィンドウは、Access 2007 より前のバージョンの Access で使用されていたデータベース ウィンドウに代わるものです。

ナビゲーション ウィンドウのオブジェクト

タブ付きオブジェクト

既定では、Access のウィンドウには、テーブル、クエリ、フォーム、レポート、およびマクロがタブ付きオブジェクトとして表示されます。

注: データベースごとにこの設定を変更し、タブの代わりにオブジェクト ウィンドウを使用することができます。

Access 2007 のタブ付きオブジェクト

オブジェクト タブをクリックすることにより、各種のオブジェクトを簡単に切り替えることができます。

ヘルプ ウィンドウ

Access 2010 では、Access ヘルプと開発者用リファレンスの両方のコンテンツに、同じヘルプ ウィンドウから簡単にアクセスできます。たとえば、検索範囲を開発者用リファレンスのコンテンツのみに絞り込むことも簡単にできます。Office.com または MSDN では、ヘルプ ウィンドウで行った設定に関係なく、常に Access ヘルプと開発者用リファレンスのコンテンツをすべてオンラインで閲覧できます。

ページの先頭へ

より強力なオブジェクト作成ツール

Access 2010 は、データベース オブジェクトを作成するための直感的な環境を提供します。

[作成] タブ

[作成] タブを使用すると、新しいフォーム、レポート、テーブル、クエリなどのデータベース オブジェクトをすばやく作成できます。ナビゲーション ウィンドウでテーブルまたはクエリを選択した場合、[フォーム] コマンドまたは [レポート] コマンドを 1 回クリックするだけで、そのオブジェクトを基にした新しいフォームやレポートを作成できます。

この 1 回のクリックで作成される新しいフォームやレポートは、デザインが一新されているため、見た目にも美しく、そのまま使用することもできます。自動的に生成されたフォームやレポートのヘッダーには、ロゴやタイトルが挿入され、洗練された外観に仕上がります。自動的に生成されたレポートには、さらに、日付と時刻の情報のほか、有用な情報が入ったフッターや集計も挿入されます。

レポート ビューとレイアウト ビュー

Office Access 2007 で導入され、Access 2010 で機能強化されたこれらのビューでは、フォームやレポートを対話形式で操作できます。レポート ビューを使用すると、[印刷プレビュー] で表示したり、実際に印刷したりしなくても、レポートの正確な表示結果を確認できます。特定のレコードに焦点を当てるには、フィルター機能を使用するか、検索を実行して条件に一致するテキストを探します。[コピー] コマンドを使ってテキストをクリップボードにコピーできるほか、レポートに表示されるアクティブ ハイパーリンクをクリックすることによって、ブラウザーでリンク先を表示こともできます。

レイアウト ビューでは、データを閲覧しながらデザインを変更できます。レイアウト ビューを使用すると、フォームやレポートのデータを確認しながら、デザイン上の一般的な変更の多くを行うことができます。たとえば、新しい [フィールド リスト] 作業ウィンドウからフィールド名をドラッグしてフィールドを追加したり、プロパティ シートを使ってプロパティを変更したりできます。

レイアウト ビューは、機能が強化されたデザイン レイアウトをサポートしています。まとめて調整できるようにコントロールがグループ化されているため、フィールド、列、行のほか、レイアウト全体の配置を簡単に変更できます。フィールドの削除や書式の追加も、レイアウト ビューで簡単に行うことができます。

レイアウト ビューのレポート

グループ化と並べ替えの機能をレポートにすばやく追加

Office Access 2007 では、レポートのグループ化と並べ替えの機能や、集計の追加機能が強化され、アクセスしやすくなりました。インターフェイスは理解しやすく、簡単に操作できます。これらの機能を新しいレイアウト ビューで使用すると、即座に処理結果が表示されます。

[グループ化、並べ替え、集計] ウィンドウ

たとえば、レポートに地域別の売り上げ合計を表示することになったとします。レイアウト ビューと [グループ化、並べ替え、集計] 作業ウィンドウを使用して、グループ レベルを追加し、集計すると、その結果がすぐにレポートに反映されます。集計行によって、レポートのヘッダーやフッターに対し、合計、平均、カウント、最大値、最小値などを簡単に追加できるようになりました。単純な合計であれば、演算フィールドを手動で作成する必要はありません。ただポイントして、クリックするだけです。

レポートに合計を作成する

洗練されたフォームとレポートを作成するための機能強化されたコントロール レイアウト

1 つの列に得意先名を表示し、対応する各行にそれぞれの得意先のすべてのフィールドを配置する表などのように、フォームやレポートでは表形式の情報が多く使用されます。これらのコントロールは、ラベルなども含め、まとめて操作できるようにグループ化してレイアウトできます。

[整列] タブの [レイアウトの調整] グループのコマンド

セクション ヘッダーやセクション フッター内のラベルなど、セクションをまたいでコントロールを選択できるので、柔軟性も備えています。これにより、次のことを簡単に行うことができます。

  • レイアウトを移動したり、サイズを変更したりする。たとえば、列を左側または右側へ移動する。

  • レイアウトに書式を設定する。たとえば、得意先名の列に太字を設定して、目立たせる。

  • 列 (フィールド) をレイアウトに追加する。

  • 列 (フィールド) をレイアウトから削除する。

  • セルを結合または分割する (Access 2010 のみ)。

レイアウト ビューで列を移動する

レイアウトはデザインと共に保存されます。

データをすばやく閲覧できる分割フォーム

注: これは Access 2007 で導入された機能です。

データシート ビューとフォーム ビューを組み合わせたフォームを作成するには、分割フォームを使用します。データシートを上部、下部、左側、または右側のどこに配置するかは、プロパティで設定できます。

分割フォーム

注: Web データベースでは分割フォームは使用できません。

フォームとレポートの埋め込みマクロ

埋め込みマクロは Office Access 2007 で導入されました。

埋め込みマクロを使用すると、コードを記述せずに済みます。埋め込みマクロは、プロパティとして保存され、それが属しているオブジェクトの一部として組み込まれます。それぞれの埋め込みマクロは独立しているため、同じマクロが他のコントロールで使用されている可能性を考慮することなく、マクロの設計を自由に変更できます。安全でない可能性のある特定の操作は実行できないようになっているため、埋め込みマクロは信頼済みとして扱われます。

[ダブルクリック時] イベントに埋め込みマクロを割り当てる

ページの先頭へ

新しいデータ型とコントロール

Access 2010 で新たに導入された演算フィールドを使用すると、計算の結果を保存できます。Office Access 2007 では、次のデータ型とコントロールが導入または機能強化されました。

  • 複数値を持つフィールド

  • 添付ファイル データ型

  • 機能強化されたメモ型フィールド

  • 日付/時刻フィールドに対応した組み込みのカレンダー コントロール

演算フィールド

同じテーブル内の他のデータから計算される値を表示するフィールドを作成できます。計算を作成するには、式ビルダーを使用します。式ビルダーを使用すると、IntelliSense を活用でき、式の値のヘルプに簡単にアクセスできます。

他のテーブル内のデータは、演算データのソースとして使用できません。一部の式は、演算フィールドではサポートされていません。

複数値を持つフィールド

Office Access 2007 で導入された複数値を持つフィールドでは、レコードごとに複数の値を保持できます。たとえば、1 つのタスクを複数の社員または請負業者に割り当てるとします。Office Access 2007 より前のバージョンの Access を含め、ほとんどのデータベース管理システムでこれを正しく行うには、多対多のリレーションシップを作成する必要がありました。

注: Access では、複数値を持つフィールドごとに必要な多対多のリレーションシップを保持するために、隠しテーブルを作成します。

複数値を持つフィールドは、Windows SharePoint Services で使用されている、いずれかの種類の複数値フィールドを含む SharePoint リストを操作する場合に最適です。Access 2010 はこれらのデータ型に対応しています。

複数値フィールド

添付ファイル フィールド

添付ファイル データ型を使用すると、不必要にデータベース サイズを増加させることなく、あらゆる種類のドキュメントやバイナリ ファイルをデータベースに簡単に保存できます。使用領域を最小限に抑えるため、Access では、添付ファイルが自動的に圧縮されます。Word 文書をレコードに添付する必要がある場合や、データベース内に一連のデジタル画像を保存する必要がある場合には、添付ファイルを使用するとこれらの作業を簡単に行うことができます。また、複数の添付ファイルを単一のレコードに添付することもできます。

[添付ファイル] ダイアログ ボックス

注: Web データベースで添付ファイル型フィールドを使用できますが、各 Web テーブルで使用できる添付ファイル型フィールドは最大で 1 つです。

リッチ テキストや変更履歴に対応したメモ型フィールド

Office Access 2007 でリッチ テキスト メモ型フィールドが導入されたため、書式付きのテキストをレコードに保存できるようになりました。テキストに太字、斜体、各種のフォント、色など、一般的な書式を適用してデータベースに格納できます。書式の適用されたテキストは、Windows SharePoint Services のリッチ テキスト データ型と互換性のある HTML ベースの形式でメモ型フィールドに格納されます。新しい "文字書式" プロパティを、"リッチ テキスト形式" または "テキスト形式" に設定すると、テキスト ボックス コントロール内の情報に適切な書式が適用されてデータシート ビューに表示されます。

メモ型フィールドは大量の情報を保存する際に便利です。"追加のみ" プロパティを設定することで、すべての変更履歴をメモ型フィールドに保存できます。保存した変更履歴は表示することもできます。この機能では、Windows SharePoint Services の履歴管理機能もサポートされているため、Access を使用して SharePoint リストのコンテンツの履歴を表示することもできます。

日付選択カレンダー

注: これは Access 2007 で導入された機能です。

日付/時刻データ型を使用するフィールドやコントロールでは、Access 2007 で導入された対話形式の組み込みカレンダーが自動的にサポートされます。カレンダーのボタンは、日付の右側に自動的に表示されます。たとえば、今週の金曜日の日付を知りたい場合、ボタンをクリックすると、カレンダーが自動的に表示され、目的の日付を探して選択できます。プロパティを使用して、フィールドやコントロールのカレンダーを表示しないようにすることもできます。

ページの先頭へ

強化されたデータ表示機能

新しいデータ表示機能により、データベース オブジェクトをすばやく作成し、データをより簡単に分析できます。

並べ替えツールとフィルター ツールの強化

Office Access 2007 で導入されたオートフィルター機能は、従来のフィルター機能からさらに強化されており、条件に一致する値を見つけたり、データの列を並べ替えたりする作業をできるだけ短時間で済ませる必要がある状況で、必要なデータにすばやく焦点を当てることができるようになっています。たとえば、列内の一意の値を使って簡単に条件を選択できるので、必要な条件を思い出すことができないときに便利です。また、[昇順で並べ替え] など、わかりやすい言葉を使ったショートカット メニューのオプションで値を並べ替えることができます。

オートフィルター

最も一般的なフィルター オプションはメニュー コマンドで簡単に表示できますが、クイック フィルターを使用すると、入力したデータを基に情報を絞り込むことができます。クイック フィルターのオプションはデータ型に基づいて自動的に変化するため、テキスト、日付、数値の各情報に適した選択肢が表示されます。

[日付フィルター] メニュー

データシートの集計と 1 行おきの背景色

データシート ビューの集計行には、合計、カウント、平均、最大、最小、標準偏差、分散などを表示できます。集計行を追加した後、列のセルに表示される矢印をポイントし、必要な計算を選択します。

データシートの合計行

データシート、レポート、および帳票フォームでは、既定の背景色とは別に、1 行おきに行の背景色を構成することができます。1 行おきの背景色は簡単に設定でき、好きな色を選択できます。

代替の行の色を使用したデータシート

条件付き書式

Access 2010 には、新しい条件付き書式機能が追加されており、Excel で提供されているものと同じ書式の一部を使用できます。たとえば、次の図に示すように、データ バーを追加して数値の列を見やすくすることができます。

Access レポートの条件付き書式設定

注: 条件付き書式は、Web データベースでは使用できません。

ページの先頭へ

強化されたセキュリティ

強化されたセキュリティ機能と Windows SharePoint Services との統合強化によって、情報追跡管理アプリケーションをより効果的に管理し、より安全に保護できます。追跡管理アプリケーションのデータを Windows SharePoint Services のリストに保存すると、リビジョン履歴を監査したり、削除した情報を復元したりできるほか、データのアクセス許可を構成することもできます。

Office Access 2007 で導入された新しいセキュリティ モデルは、Access 2010 でさらに強化されています。信頼性に関する判断は Microsoft Office セキュリティ センターに統合されています。信頼された場所を使用すると、セキュリティ保護されたフォルダーにあるすべてのデータベースを容易に信頼できます。コードやマクロが無効になっている Office Access 2007 アプリケーションを読み込むことによって、安全性の高い、サンドボックス化された (つまり、安全でないコマンドは実行できない) 操作性が提供されます。信頼されたマクロはサンドボックス モードでも実行されます。

ページの先頭へ

InfoPath フォームと Outlook を使用してデータを収集する

Office Access 2007 で導入されたデータ収集機能を使用すると、Outlook (および必要に応じて InfoPath) を使って、フィードバックを収集できます。InfoPath フォームまたは HTML フォームを自動的に生成し、それを電子メール メッセージの本文に埋め込むことができます。ユーザーは、Outlook の連絡先、または Access データベースのフィールドに格納された受信者名から宛先を選択して、フォームを送信することができます。

メール メッセージを使ってデータを集める

新しい情報を収集するか、既存の情報を更新するかを選択します。受信者はフォームに入力し終えたら、それを返信します。返信されたフォームは Outlook によって認識され、データが Access データベースに自動的に保存されるため、データを入力し直す必要はありません。

PDF と XPS へのエクスポート

Access 2010 では、"PDF または XPS 形式で発行" アドインをインストールしておくと、データを PDF (Portable Document Format) ファイル形式または XPS (XML Paper Specification) ファイル形式にエクスポートして、印刷、投稿、電子メールによる配布を行うことができます。フォーム、レポート、またはデータシートを .pdf ファイルまたは .xps ファイルにエクスポートすることによって、書式設定がすべて保たれた、配布に適した形態で情報を出力できます。また、その出力結果を受け取った相手が内容を印刷または表示する際、そのコンピューターに Access がインストールされている必要はありません。

  • Portable Document Format    PDF は、ドキュメントの書式を保持したまま、ファイルの共有を可能にする固定レイアウトの電子ファイル形式です。PDF 形式では、ファイルをオンラインで表示したり、印刷したりするときに、作成者の意図したとおりの書式が保持され、ファイルのデータを簡単にコピーまたは変更することはできません。PDF 形式は、業務用印刷でドキュメントを再現する場合にも適しています。

  • XML Paper Specification    XPS は、ドキュメントの書式を保持したまま、ファイルの共有を可能にする電子ファイル形式です。XPS 形式では、ファイルをオンラインで表示したり、印刷したりするときに、作成者の意図したとおりの書式が保持され、ファイルのデータを簡単にコピーまたは変更することはできません。

外部データの扱いがより簡単に

外部データ ソースとしての Web サービスに接続できるようになりました。その場合、Web サービス管理者が提供する Web サービス定義ファイルが必要です。定義ファイルのインストール後、リンク テーブルとして Web サービス データにリンクできます。

Office Access 2007 で新たに導入された機能によって、データのインポートとエクスポートが容易になりました。インポートやエクスポートの操作を保存し、次に同じ作業が必要になったときに保存した操作を再利用できます。ワークシート インポート ウィザードを使用すると、Access によって選択されたデータ型を無視でき、Office Excel 2007 以降のファイル形式のファイルに対してインポート、エクスポート、およびリンクすることができます。

ページの先頭へ

より効果的なトラブルシューティング

Office Access 2007 で導入された Microsoft Office 診断プログラムは、コンピューターの異常終了の原因を調べることができる一連の診断テストです。診断テストによって、直接問題を解決できる場合と、問題の解決方法が示される場合があります。Microsoft Office 診断プログラムは、Microsoft Office 2003 のアプリケーションの自動修復機能および Microsoft Office アプリケーションの回復機能に代わる機能です。

ページの先頭へ

校正ツールの強化

スペル チェックの新機能の一部を次に示します。

  • Office アプリケーション間で、スペル チェック機能の一貫性が向上しました。次のような点が変更されました。

    • 一部のスペル チェック オプションは Office アプリケーションで共通になりました。ある Office アプリケーションでこれらのオプションを変更すると、そのオプションは他のすべての Office アプリケーションでも変更されます。詳細については、「スペル チェックと文章校正の方法を選択する」を参照してください。

    • 同じユーザー辞書を共有するだけでなく、すべてのアプリケーションで同じダイアログ ボックスを使用してユーザー辞書を管理できます。詳細については、「ユーザー辞書を使用して単語をスペル チェック機能に追加する」を参照してください。

  • スペル チェック機能には、フランス語新正書法の辞書が含まれています。Microsoft Office 2003 では、これをアドインとして別途インストールする必要がありました。詳細については、「スペル チェックと文章校正の方法を選択する」を参照してください。

  • ある言語を最初に使用したときに、その言語の例外辞書が自動的に作成されます。例外辞書を使用すると、スペル チェックで、使用したくない単語にマークを付けることができます。例外辞書によって、好ましくない単語やスタイル ガイドに一致しない単語を簡単に除外することができます。詳細については、「例外辞書を使用して使用するスペルを指定する」を参照してください。

    ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×