Excel 2016 の Get & Transform の開始

Excel 2016 の Get & Transform の開始

Excel 2016 の Get & Transform を使うと、データ ソースの検索、データへの接続を行い、そのデータを目的に合った方法で整理 (列の削除、データ型の変更、テーブルの結合など) できます。データを整理したら、得られた情報を共有できるほか、クエリを使用してレポートを作成できます。

Power Query の一般的な手順

これらのステップを順に見ていくと、多くの場合、次のような処理が行われます。

  • 接続 – クラウド内、サービス内、またはローカルに存在するデータに接続する

  • 変換 – 目的に応じてデータを整理する。元のソースは変更されない

  • 結合 - 複数のデータ ソースからデータ モデルを作って、データに対する独自のビューを作成する

  • 共有 – クエリが完了したら、それを保存、共有、またはレポートに使用できる

データに接続したり、データを変換したり、データを他のデータ ソースと結合する場合は、クエリ エディターという Get & Transform の機能が各手順を記録し、ユーザーは必要に応じて各手順を変更することができます。 またクエリ エディターでは、あらゆる操作を元に戻す、やり直す、変更する、または順序を変更することができるため、これらを活用して、接続しているデータのビューを思いどおりに作成できます。

Get & Transform を使うと、クエリを必要に応じてシンプルにも複雑にも作成できます。 クエリに手順を追加すると、クエリ エディターがバックグラウンドで動作し、コマンドを実行する個別の命令セットを作成します。 この命令は M 言語で作成されます。 データ スクリプトの機能と柔軟性を活用するユーザーは、詳細エディターを使用して、M 言語を作成し、手動でクエリを作成 (調整) することができます。 このすべての機能と柔軟性は、手順が自動的に作成されるか手動で作成されるかにかかわらず、Excel 2016 の一連の Get & Transform 機能の一部です。 クエリ エディター詳細エディターについては、この記事の後半で詳しく説明します。

Excel 2016 の [Get & Transform] リボンから [新しいクエリ] を選んで、新しいクエリを開始することができます。

Excel 2016 の新しいクエリ

注: この技術は、旧バージョンの Excel で Power Query Add-In を使用して利用することができます。これは、ダウンロードするか Power BI から利用することができます。 旧バージョンの Excel での Power Query の実際の使用例については、「Power Query を使い始める」を参照してください。

接続

クエリを使用して、Access データベースなどの 1 つのデータ ソースや、複数のファイル、データベース、OData フィード、またはインターネットに散在している Web サイトに接続することができます。Get & Transform を使用すると、独自の組み合わせでそれらすべてのソースを統合して、クエリがなければわからなかった新しい考察を得ることができます。

[データ] タブの [Get & Transform] リボン セクションから [新しいクエリ] を選ぶと、利用可能なデータ ソースがメニューに表示されます。 選択可能なデータ ソースには、Excel ブックや CSV ファイルなどのファイル、AccessSQL ServerOracleMySQL などのデータベース、HDInsightBlob ストレージなどの Azure サービス、また、WebSharePoint リストHadoop ファイルFacebookSalesforce など、その他のあらゆるソースがあります。

注: 一部のデータ ソースは、Professional ライセンスと Professional Plus ライセンスでのみ利用可能です。

クエリのデータ ソース

データ ソースに接続すると、Get & Transform は [ナビゲーター] ウィンドウを表示します。このウィンドウでは、ソースからデータを編集することができます。 [ナビゲーター] ウィンドウから [編集] を選ぶと、Get & Transform は、クエリ エディターを起動します。これは、データ接続および適用する変換を表示して操作しやすくする専用ウィンドウです。 この後の変換セクションで、クエリ エディターの詳細について説明します。

変換

Get & Transform を使うと、データ ソースからのデータを、分析しやすいように変換できます。データの変換とは、目的に合うようにデータを何らかの方法で変更することです。たとえば、列の削除、データ型の変更、テーブルの結合などがデータの変換に該当します。データを変換すると、分析を進めるうえで必要な形にデータをまとめて変えることができます。1 つ以上のデータセットに変換を適用するプロセスは、通常、データの整理と呼ばれます。

Excel では、データの変換を表示して操作しやすくするクエリ エディターという専用ウィンドウを使用します。 [データ] タブの [Get & Transform] リボン セクションから [新しいクエリ] を選んでから、データ ソース (ブック、データベースなど) を選ぶと、[ナビゲーター] ウィンドウが表示されて、クエリで使用する表 (複数も可) を選ぶことができます。 表を選ぶと、そのデータのプレビューが [ナビゲーター] ウィンドウの右側のウィンドウに表示されます。

クエリ ナビゲーター

[ロード] を選ぶと、データ ソースが Excel に直接取り込まれます。 この場合、[編集] を選んで [クエリ エディター] を起動します。

クエリ エディター

クエリ エディターでは、データに対するすべての操作が追跡されます。クエリ エディターでは、データに適用される各変換やステップが記録されて、ラベル付けされます。変換がデータ接続 (データ ソース)、列の削除、結合、データ型の変更のいずれであっても、クエリ エディターでは、各操作が [クエリの設定] ウィンドウの [適用したステップ] セクションに記録されます。

データ接続に適用する変換をまとめてクエリが形成されます。

クエリ エディターで定義するアクションは、元のソース データを変更しないことを知っておくことは重要 (有用) です。Excel では、元のデータを変更するのではなく、データの接続または変換のときに実行される各ステップを記録して、データの整理が完了した後で、改良されたデータ セットのスナップショットを取得してブックに読み込みます。

データに適用できる変換には、非常に多くの種類があります。また、クエリ エディターの詳細エディターを使用して、M 言語 (クエリ エディターがバックグラウンドでステップを記録するときに使われる言語) で独自の変換を記述することもできます。詳細エディターは、クエリ エディターの [表示] リボンから表示します。このエディターで、既存のクエリに関連する M 言語で記述されたステップを変更できます。また、詳細エディターを使用して、クエリをゼロから作成することもできます。

クエリの詳細エディター

クエリの作成が完了したら、[ホーム] リボン タブから [Close & Load] を選ぶことができます。クエリ結果が Excel にロードされて新しいブック タブで使用可能になります。

変換の詳細については、以下を参照してください。

共有する

クエリを含む Excel ブックを保存すると、クエリも自動的に保存されます。[データ] タブの [Get & Transform] リボン セクションで [クエリの表示] を選ぶと、Excel ブック内のすべてのクエリを表示できます。

クエリの表示

[ブック クエリ] ウィンドウにブック内のすべてのクエリが表示されます。

Excel 2016 のブックのクエリ

さらに便利な機能もあります。Power BI データ カタログを使用して、クエリを組織内のだれとでも共有できます。または、頻繁に使用するクエリを作成しておき、複数のブックで使用して、作業の手間を省くことができます。Excel ブックを保存してメール送信する (および元のバージョン、変更内容、データが古くなっていないかどうかを把握しようとする) 代わりに、クエリをデータ カタログに保存すれば、追跡されない無数のブック バージョンが受信ボックスに蓄積されるという問題をなくすことができます。[ブック クエリ] ウィンドウでクエリを右クリックするだけで、[データ カタログに送信] などのあらゆるオプションがメニューに表示されます。

データ カタログに送信

右クリック メニューの他のオプションも見ていきましょう。 クエリを複製すると、元のクエリを変更せずに、クエリの特定の要素 (またはすべての要素) を変更できます。これは、後から変更してカスタマイズ データセットを作成できるクエリ テンプレートを作成するようなものです。たとえば、小売用に 1 つ、卸売用に 1 つ、在庫用に 1 つのデータセットを同じデータ接続に基づいて作成できるようになります。

また、クエリを結合または追加すると、クエリを再利用可能な構成要素に変えることができます。

また、Power BI にブックを公開して、グループで共有したり、自動的に更新したり、改良したりすることができるオンライン レポートを作成することができます。 Excel ブックを Power BI に公開するには、[ファイル > 公開 > Power BI への公開] の順に選びます。 Power BI への公開

注: ブックを Power BI に公開するには、ブックを OneDrive for Business に保存する必要があります。

クエリが完了したら、そのクエリを使って Excel または Power BI でレポートを作成できます。Get & Transform 機能を使用してデータを思いどおりに整理して仕上げたすべての作業を活用できるレポート リソースの詳細については、次の各セクションを参照してください。

保存の詳細:

注記: 

  • 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

  • この記事の英語版を参照するには、ここ をクリックしてください。Microsoft コミュニティの他のメンバーと一緒に、Community Translation Framework (CTF) を使ったこの記事の改善にご協力ください。記事内の文章にマウス ポインターを合わせて、CTF ウィジェットの [翻訳を改善します] をクリックしてください。CTF の詳細については、ここ をクリックしてください。CTF を使用すると弊社の サービス利用規約 に同意したことになります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×