Excel スプレッドシートでオブジェクトを挿入します。

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Word や Excel などの他のプログラムからのコンテンツを追加するのには、オブジェクトのリンクと埋め込み (OLE) を使用することができます。

OLE は多数のアプリケーションでサポートされており、OLE を使用すると、あるアプリケーションで作成されたオブジェクトを別のアプリケーションで利用できます。たとえば、Office Word 文書を Office Excel ブックに挿入することができます。挿入できるコンテンツの種類を確認するには、[挿入] タブの [テキスト] で [オブジェクト] をクリックします。使用するコンピュータにインストール済みで、OLE オブジェクトをサポートしているアプリケーションだけが、[オブジェクトの種類] ボックスに表示されます。

Excel または OLE がサポートされている任意のアプリケーション (Word など) の間でデータをコピーする場合は、情報をリンク オブジェクトまたは埋め込みオブジェクトとしてデータをコピーできます。リンク オブジェクトと埋め込みオブジェクトとの主な違いは、データの保存場所と、転送先ファイルに配置した後のオブジェクトの更新方法にあります。埋め込みオブジェクトは、その挿入先のブックに保存され、更新されません。リンク オブジェクトは、別のファイルとして保存され、更新することができます。

文書内のリンク オブジェクトと埋め込みオブジェクト

Office for Windows ドキュメントのリンク オブジェクトと埋め込みオブジェクト

1. ソース ファイルへの接続がない埋め込みオブジェクト

2. ソース ファイルにリンクされているリンク オブジェクト

3. ソース ファイルがリンク オブジェクトを更新

リンク オブジェクトを使用します。

ソース ファイルのデータが変更されたときに転送先ファイルの情報を更新する場合は、リンク オブジェクトを使用します。

リンク オブジェクトでは、元のデータはソース ファイルに保存されます。リンク先ファイルにはリンクされたデータが表示されますが、元のデータの場所だけが保存されます。Excel のグラフ オブジェクトをリンクした場合は、そのサイズも保存されます。オブジェクトのリンクを維持するためには、コンピュータ上またはネットワーク上のリンク元ファイルにアクセスできる必要があります。

リンクされたデータは、ソース ファイル内の元のデータを変更したときに自動的に更新できます。たとえば、Word 文書の段落を選択し、その段落を Excel ブックにリンク オブジェクトとして貼り付けた場合は、Word 文書で段落のデータを変更すると Excel のデータも更新されます。

埋め込みオブジェクトを使用する場合

ソース ファイルのデータが変更されても、コピーされたデータを更新する必要がない場合は、埋め込みオブジェクトを使用します。オブジェクトを埋め込んだときのソースのデータが、そのままブックに埋め込まれます。データを埋め込みオブジェクトとしてコピーする場合は、リンク オブジェクトとしてコピーするときよりも多くのディスク容量がデスティネーション ファイル用に必要となります。

別のコンピュータでファイルを開いた場合でも、元のファイルにアクセスせずに埋め込みオブジェクトを表示できます。埋め込みオブジェクトにはソース ファイルへのリンクが設定されていないため、元のファイルを変更しても、オブジェクトは変更されません。埋め込みオブジェクトを変更するには、オブジェクトをダブルクリックし、作成元アプリケーションでオブジェクトを開いて編集します。作成元アプリケーション (またはそのオブジェクトを編集できる他のアプリケーション) がコンピュータにインストールされている必要があります。

OLE オブジェクトを表示する方法を変更します。

リンク オブジェクトや埋め込みオブジェクトは、ソース プログラムと同じ状態で、またはアイコンとしてブックに表示できます。ブックを印刷せずにオンラインで表示するだけの場合は、オブジェクトをアイコンとして表示できます。これにより、オブジェクトが占める画面上のスペースを最小化できます。データを表示するには、アイコンをダブルクリックします。

ワークシートにオブジェクトを埋め込む

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] グループで、[オブジェクト リボンの [オブジェクトのアイコン ] をクリックします。
    [オブジェクトの挿入]

  3. [オブジェクト] ダイアログ ボックスでは、ファイルから作成] タブをクリックします。

  4. [参照] をクリックし、挿入するファイルを選択します。

  5. アイコンのスプレッドシートを挿入する場合は、代わりに、ファイルの内容を表示、アイコンとして表示] チェック ボックスをオンにします。] のチェック ボックスを選択しない場合は、ファイルの最初のページが表示されます。どちらの場合も、完全なファイルをダブルクリックで開きます。[Ok]をクリックします。

    注: アイコンまたはファイルを追加した後は、ドラッグし、ワークシート上の任意の場所にドロップします。サイズ変更ハンドルを使用してアイコンまたはファイルを変更することもできます。ハンドルを検索するには、ファイルまたはアイコンをクリックして 1 回だけです。

ファイルにリンクを挿入する

だけ完全に埋め込むのではなく、オブジェクトへのリンクを追加することがあります。ブックとオブジェクトは、SharePoint サイト、共有ネットワーク ドライブ、または類似の場所に保存された両方を追加する場合と同じで、ファイルの場所が残っている場合を行うことができます。これは、リンクは常に最新のドキュメントを開くために、リンクされたオブジェクトを加えた場合に便利です。

注: リンクされたファイルを別の場所に移動すると、そのリンクは機能しなくなります。

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] グループで、[オブジェクト リボンの [オブジェクトのアイコン ] をクリックします。
    [オブジェクトの挿入]

  3. [ファイルから作成] タブをクリックします。

  4. [参照] をクリックし、[リンク先のファイルを選択します。

  5. [ファイルへのリンク] チェック ボックスをオンにして、[OK] をクリックします。

Excel 内から新しいオブジェクトを作成する

ブックを離れずに別のプログラムに基づくまったく新しいオブジェクトを作成することができます。たとえば、テーブル、グラフに詳細な説明を追加する場合は、 ExcelでWordまたはPowerPointファイルなど、埋め込みドキュメントを作成できます。表示するオブジェクトを設定するか、ワークシート内で右またはファイルを開くアイコンを追加します。

この埋め込まれたオブジェクトは、Word 文書です。
  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] グループで、[オブジェクト リボンの [オブジェクトのアイコン ] をクリックします。
    [オブジェクトの挿入]

  3. [新規作成] タブで、表示されるリストから挿入するオブジェクトの種類を選択します。オブジェクト自体ではなく、スプレッドシートにアイコンを挿入する場合は、[アイコンで表示] チェック ボックスをオンにします。

  4. [OK] をクリックします。挿入しているファイルの種類によって、新しいプログラム ウィンドウが開くか、Excel 内に編集ウィンドウが表示されるかのいずれかになります。

  5. 挿入する新しいオブジェクトを作成します。

    完了したときに、Excel でオブジェクトを作成した新しいプログラム ウィンドウが開かれた場合、そのウィンドウ内で直接操作を行うことができます。

    Excel で、埋め込まれた Word 文書を直接編集できます。

    ウィンドウでの作業を完了したら、埋め込みオブジェクトを保存せずにその他のタスクを行うことができます。ブックを閉じるときに、新しいオブジェクトが自動的に保存されます。

    注: オブジェクトを追加した後は、Excel ワークシート上の任意の場所にドラッグ アンド ドロップすることができます。サイズ変更ハンドルを使用して、オブジェクトのサイズを変更することもできます。ハンドルを見つけるには、オブジェクトを一度クリックします。

ワークシートにオブジェクトを埋め込む

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    [オブジェクト] オプションは、[挿入] タブにあります。
  3. [ファイルから] タブをクリックします。

    [オブジェクト] ダイアログ ボックスの [ファイルから作成] タブ。
  4. [参照] をクリックし、挿入するファイルを選択します。

  5. アイコンのスプレッドシートを挿入する場合は、代わりに、ファイルの内容を表示、アイコンとして表示] チェック ボックスをオンにします。] のチェック ボックスを選択しない場合は、ファイルの最初のページが表示されます。どちらの場合も、完全なファイルをダブルクリックで開きます。[Ok]をクリックします。

    注: アイコンまたはファイルを追加した後は、ドラッグし、ワークシート上の任意の場所にドロップします。サイズ変更ハンドルを使用してアイコンまたはファイルを変更することもできます。ハンドルを検索するには、ファイルまたはアイコンをクリックして 1 回だけです。

ファイルにリンクを挿入する

だけ完全に埋め込むのではなく、オブジェクトへのリンクを追加することがあります。ブックとオブジェクトは、SharePoint サイト、共有ネットワーク ドライブ、または類似の場所に保存された両方を追加する場合と同じで、ファイルの場所が残っている場合を行うことができます。これは、リンクは常に最新のドキュメントを開くために、リンクされたオブジェクトを加えた場合に便利です。

注: リンクされたファイルを別の場所に移動すると、そのリンクは機能しなくなります。

  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    [オブジェクト] オプションは、[挿入] タブにあります。
  3. [ファイルから作成] タブをクリックします。

  4. [参照] をクリックし、[リンク先のファイルを選択します。

  5. [ファイルへのリンク] チェック ボックスをオンにして、[OK] をクリックします。

    [ファイルから作成] タブで、[ファイルにリンク] を選択します。

Excel 内から新しいオブジェクトを作成する

ブックを離れずに別のプログラムに基づくまったく新しいオブジェクトを作成することができます。たとえば、テーブル、グラフに詳細な説明を追加する場合は、 ExcelでWordまたはPowerPointファイルなど、埋め込みドキュメントを作成できます。表示するオブジェクトを設定するか、ワークシート内で右またはファイルを開くアイコンを追加します。

この埋め込まれたオブジェクトは、Word 文書です。
  1. オブジェクトを挿入するスプレッドシートのセルの内側をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    [オブジェクト] オプションは、[挿入] タブにあります。
  3. [新規作成] タブで、表示されるリストから挿入するオブジェクトの種類を選択します。オブジェクト自体ではなく、スプレッドシートにアイコンを挿入する場合は、[アイコンで表示] チェック ボックスをオンにします。

    [オブジェクト] ダイアログ ボックスの [新規作成] タブ
  4. [OK] をクリックします。挿入しているファイルの種類によって、新しいプログラム ウィンドウが開くか、Excel 内に編集ウィンドウが表示されるかのいずれかになります。

  5. 挿入する新しいオブジェクトを作成します。

    完了したときに、Excel でオブジェクトを作成した新しいプログラム ウィンドウが開かれた場合、そのウィンドウ内で直接操作を行うことができます。

    Excel で、埋め込まれた Word 文書を直接編集できます。

    ウィンドウでの作業を完了したら、埋め込みオブジェクトを保存せずにその他のタスクを行うことができます。ブックを閉じるときに、新しいオブジェクトが自動的に保存されます。

    注: オブジェクトを追加した後は、Excel ワークシート上の任意の場所にドラッグ アンド ドロップすることができます。サイズ変更ハンドルを使用して、オブジェクトのサイズを変更することもできます。ハンドルを見つけるには、オブジェクトを一度クリックします。

OLE を使用して別のプログラムのコンテンツをリンクするか埋め込む

別のプログラムのコンテンツのすべてまたは一部を、リンクまたは埋め込むことができます。

別のプログラムからのコンテンツへのリンクを作成します。

  1. ワークシートのリンク オブジェクトを挿入する位置をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Excel のリボンのイメージ

  3. [ファイルから] タブをクリックします。

  4. [ファイル名] ボックスにファイル名を入力するか、[参照] をクリックして一覧から選択します。

  5. [リンク] チェック ボックスをオンにします。

  6. 次のいずれかを実行します。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、アイコンとして表示する] チェック ボックスを選択します。必要に応じて、既定のアイコンの画像またはラベルを変更するにの変更] アイコンをクリックし、アイコンの一覧から必要なアイコンをクリックしてや図表番号] ボックスにラベルを入力します。

    注: グラフィックおよび特定の種類のファイルは、[オブジェクト] コマンドでは挿入できません。グラフィックまたはファイルを挿入するには、[挿入] タブの [] で [] をクリックします。

別のプログラムからコンテンツを埋め込む

  1. ワークシートの埋め込みオブジェクトを挿入する位置をクリックします。

  2. [挿入] タブの [テキスト] で [オブジェクト] をクリックします。

    Excel のリボンのイメージ

  3. ドキュメントが未作成の場合は、[新規作成] タブをクリックし、[オブジェクトの種類] ボックスの一覧で、作成するオブジェクトの種類をクリックします。

    ドキュメントが既に存在している場合は、[ファイルから] タブをクリックし、[ファイル名] ボックスにファイルの名前を入力するか、[参照] をクリックして一覧からファイルを選択します。

  4. [リンク] チェック ボックスをオフにします。

  5. 次のいずれかを実行します。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、アイコンとして表示する] チェック ボックスを選択します。既定のアイコンの画像またはラベルを変更するには、アイコンの変更] をクリックしてに、[アイコン] ボックスの一覧から必要なアイコンをクリックするかを [図表番号] ボックスにラベルを入力します。

リンクする、または別のプログラムから部分的なコンテンツを埋め込む

  1. Excel 以外のプログラムから情報をリンクとしてコピーまたは埋め込みオブジェクトを選択します。

  2. [ホーム] タブの [クリップボード] で、[コピー] をクリックします。

    [ホーム] タブの [クリップボード]

  3. データを配置するワークシートに切り替え、データを表示する位置をクリックします。

  4. [ホーム] タブの [クリップボード] で、[貼り付け] の下にある矢印をクリックし、[形式を選択して貼り付け] をクリックします。

  5. 次のいずれかを実行します。

    • リンク オブジェクトとしてデータを貼り付ける場合は、[リンク貼り付け] をクリックします。

    • データを埋め込みオブジェクトとして貼り付けるには、[貼り付け] をクリックします。[貼り付ける形式] ボックスで、"オブジェクト" という単語が含まれるエントリをクリックします。たとえば、データを Word 文書からコピーした場合は、[Microsoft Office Word 文書オブジェクト] をクリックします。

OLE オブジェクトの表示方法を変更する

  1. アイコンまたはオブジェクトを右クリックし、[<オブジェクトの種類> オブジェクト] ([文書オブジェクト] など) をポイントし、[変換] をクリックします。

  2. 次のいずれかを実行します。

    • コンテンツを表示するには、[アイコンで表示] チェック ボックスをオフにします。

    • アイコンを表示するには、アイコンとして表示する] チェック ボックスを選択します。必要に応じて、[既定のアイコンの画像またはラベルを変更できます。そのための変更] アイコンをクリックし、[アイコン] ボックスの一覧から必要なアイコンをクリックするか、 [標題] ボックスにラベルを入力します。

リンク オブジェクトの更新を制御する

他のアプリケーションへのリンクは、転送先ファイルを開いたときに自動で更新されるように設定するか、ソース ファイルから新しいデータに更新する前に以前のデータを確認したい場合に、手動で更新するように設定できます。または、自動更新と手動更新のどちらが有効になっているかに関係なく、更新を明示的に要求することもできます。

他のアプリケーションへのリンクを手動更新に設定する

  1. [データ] タブの [接続] で [リンクの編集] をクリックします。

    Excel のリボンのイメージ

    注: 作業中のファイルに他のファイルへのリンクがない場合、[リンクの編集] コマンドは使用できません。

  2. [リンク元] ボックスの一覧で、更新するリンク オブジェクトをクリックします。[更新] 列に [A] と表示されているオブジェクトは自動更新、[更新] 列に [M] と表示されているオブジェクトは手動更新を表します。

    ヒント: 複数のリンク オブジェクトを選択するには、ctrl キーを押しキーを押しながら各オブジェクトをクリックします。すべてのリンク オブジェクトを選ぶには、ctrl キーを押しながら A キーを押します。

  3. [値の更新] をクリックしたときにだけリンク オブジェクトを更新するには、[手動] をクリックします。

他のアプリケーションへのリンクを自動更新に設定する

  1. [データ] タブの [接続] で [リンクの編集] をクリックします。

    Excel のリボンのイメージ

    注: 作業中のファイルに他のファイルへのリンクがない場合、[リンクの編集] コマンドは使用できません。

  2. [リンク元] ボックスの一覧で、更新するリンク オブジェクトをクリックします。[更新] 列に [A] と表示されているオブジェクトは自動的に更新され、[更新] 列に [M] と表示されているオブジェクトは手動で更新する必要があります。

    ヒント: 複数のリンク オブジェクトを選択するには、ctrl キーを押しキーを押しながら各オブジェクトをクリックします。すべてのリンク オブジェクトを選ぶには、ctrl キーを押しながら A キーを押します。

  3. [OK] をクリックします。

問題: ワークシートのリンクの自動設定を更新できません。

Excel の [他のドキュメントへのリンクを更新する] オプションは、[自動] オプションよりも優先されます。

OLE オブジェクトへの自動リンクが自動的に更新されるようにするには、次の操作を行います。

  1. Office ボタンの画像Microsoft Office ボタンをクリックして、 Excel のオプション] をクリックし、[詳細設定] カテゴリ] をクリックします。

  2. [次のブックを計算するとき] で、[他のドキュメントへのリンクを更新する] チェック ボックスがオンになっていることを確認します。

他のアプリケーションへのリンクを直ちに更新する

  1. [データ] タブの [接続] で [リンクの編集] をクリックします。

    Excel のリボンのイメージ

    注: リンクされたデータが作業中のファイルにない場合、[リンクの編集] コマンドは使用できません。

  2. [リンク元] ボックスの一覧で、更新するリンク オブジェクトをクリックします。

    ヒント: 複数のリンク オブジェクトを選択するには、ctrl キーを押しキーを押しながら各オブジェクトをクリックします。すべてのリンク オブジェクトを選ぶには、ctrl キーを押しながら A キーを押します。

  3. [値の更新] をクリックします。

OLE アプリケーションのコンテンツを編集する

Excel の使用中に、他のアプリケーションからリンクされたコンテンツ、または埋め込まれたコンテンツを変更できます。

ソース プログラムでリンクされたオブジェクトを編集します。

  1. [データ] タブの [接続] で [リンクの編集] をクリックします。

    Excel のリボンのイメージ

    注: リンクされたデータが作業中のファイルにない場合、[リンクの編集] コマンドは使用できません。

  2. [リンク元] ボックスの一覧で、編集するリンク オブジェクトのソースをクリックし、[リンク元を開く] をクリックします。

  3. リンク オブジェクトを変更します。

  4. ソース プログラムを終了して、デスティネーション ファイルに戻ります。

ソース プログラムで埋め込みオブジェクトを編集します。

  1. 埋め込みオブジェクトをダブルクリックして開きます。

  2. オブジェクトに必要な変更を加えます。

  3. 同一ウィンドウのプログラムでオブジェクトを編集している場合は、オブジェクトの外側の任意の場所をクリックすると転送先ファイルに戻ります。

    作成元のアプリケーションの独立したウィンドウでオブジェクトを編集した場合は、作成元アプリケーションを終了して、デスティネーション ファイルに戻ります。

注: ビデオ クリップやサウンド クリップなど、一部の埋め込みオブジェクトでは、オブジェクトをダブルクリックするとビデオやサウンドが再生され、アプリケーションは起動されません。これらの埋め込みオブジェクトを編集するには、アイコンまたはオブジェクトを右クリックし、[<オブジェクトの種類> オブジェクト] ([メディア クリップ オブジェクト] など) をポイントして、[編集] をクリックします。

ソース プログラム以外のプログラムで埋め込みオブジェクトを編集します。

  1. 編集する埋め込みオブジェクトを選択します。

  2. アイコンまたはオブジェクトを右クリックして [<オブジェクトの種類> オブジェクト] ([文書 オブジェクト] など) をポイントし、[変換] をクリックします。

  3. 次のいずれかを実行します。

    • 埋め込みオブジェクトを他のファイル形式に変換するには、[変換形式] をクリックします。

    • 埋め込みオブジェクトの種類を変換しないで他のファイル形式で開くには、[再生方法] をクリックします。

キーボードを使用して OLE オブジェクトを選択する

  1. Ctrl キーを押しながら G キーを押して、[ジャンプ] ダイアログ ボックスを表示します。

  2. [セル選択] をクリックし、[オブジェクト] をクリックして、[OK] をクリックします。

  3. 目的のオブジェクトが選択されるまで、TAB キーを押します。

  4. Shift + F10 を押します。

  5. [<オブジェクトの種類> オブジェクト] をポイントし、[編集] をクリックします。

問題: リンク オブジェクトまたは埋め込みオブジェクトをダブルクリックすると、"編集できない" というメッセージが表示される

このメッセージは、ソース ファイルまたはソース プログラムを開くことができない場合に表示されます。

ソース プログラムが使用できることを確認する     ソース プログラムがコンピュータにインストールされていない場合は、オブジェクトのファイル形式を、インストール済みのプログラムのファイル形式に変換します。

メモリに十分な空き領域があることを確認する     ソース プログラムを実行するのに十分なメモリの空き領域があることを確認します。必要に応じて、他のプログラムを閉じてメモリの空き領域を増やします。

すべてのダイアログ ボックスを閉じる     ソース プログラムが実行中の場合は、開いているダイアログ ボックスがないことを確認します。ソース プログラムに切り替え、開いているダイアログ ボックスをすべて閉じます。

ソース ファイルを閉じる     ソース ファイルがリンク オブジェクトである場合は、別のユーザーがそのファイルを開いていないことを確認します。

ソース ファイルの名前が変更されていないかどうかを確認する     編集するソース ファイルがリンク オブジェクトの場合は、そのソース ファイルの名前がリンクの作成時から変更されていないことと、ソース ファイルが移動されていないことを確認してください。ソース ファイルの名前を確認するには、リンク オブジェクトを選択し、[データ] タブの [接続] で [リンクの編集] をクリックします。ソース ファイルの名前が変更されているか、ファイルが移動されている場合は、[リンクの編集] ダイアログ ボックスの [リンク元の変更] を使用してソース ファイルの位置を指定し、リンクを設定し直します。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×