Excel で分析ツールを読み込む

複雑な統計学的分析や工学的分析を行わなければならない場合も、分析ツールを使用すれば、すばやく簡単に結果を得ることができます。分析に必要なデータとパラメータを指定すると、各ツールが統計用または工学用の適切なマクロ関数を使ってデータを分析し、計算結果を出力テーブルに表示します。出力テーブルだけでなく、グラフを出力するツールもあります。

データ分析ツールは、一度に 1 つのワークシートでのみ使用できます。グループ化したワークシートでデータ分析を実行すると、分析結果は先頭のワークシートに表示され、残りのワークシートには空のテーブルが表示されます。残りのワークシートでもデータ分析を実行するには、グループを解除し、各ワークシートで分析ツールを実行します。

  1. [ファイル] タブをクリックし、[オプション] をクリックして、[アドイン] カテゴリをクリックします。

    Excel 2007 を使用している場合は、[Microsoft Office ボタン] Office ボタンの画像 をクリックしてから、[Excel のオプション] をクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

    Excel for Mac を使用している場合は、[ファイル] メニューから [ツール]、[Excel アドイン] を順にクリックします。

  3. [アドイン] ボックスで、[分析ツール] チェック ボックスをオンにし、[OK] をクリックします。

    • [有効なアドイン] ボックスの一覧に [分析ツール] が表示されない場合は、[参照] をクリックしてアドイン ファイルを見つけます。

    • 分析ツールが現在コンピューターにインストールされていないというメッセージが表示されたら、[はい] をクリックして分析ツールをインストールします。

注: 分析ツールの Visual Basic for Application (VBA) 関数を含める場合は、分析ツールを読み込むときと同じ方法で "分析ツール - VBA" アドインを読み込むことができます。[有効なアドイン] ボックスで、[分析ツール - VBA] チェック ボックスをオンにします。

注: Excel for Mac 2011 では分析ツールは使用できません。詳細については、「Excel for Mac 2011 で分析ツールが見つからない」を参照してください。

Excel 2016 for Mac で分析ツールを読み込むには、次の手順を実行します。

  1. [ツール] メニューの [Excel アドイン] をクリックします。

  2. [有効なアドイン] ボックスの一覧で、[分析ツール] チェック ボックスをオンにし、[OK] をクリックします。

    1. [有効なアドイン] ボックスの一覧に [分析ツール] が表示されない場合は、[参照] をクリックしてアドイン ファイルを見つけます。

    2. 分析ツールが現在コンピューターにインストールされていないというメッセージが表示されたら、[はい] をクリックして分析ツールをインストールします。

    3. Excel を終了して再び起動します。

      これで [データ分析] が [データ] タブに表示されます。

Excel for Mac 2011 で分析ツールが見つからない

Excel 2011 用の分析ツール機能を提供するサードパーティ製のアドインがいくつかあります。

オプション 1:     Mac 用の XLSTAT アドオン統計ソフトウェアをダウンロードし、Excel 2011 で使用します。XLSTAT には、すべての分析ツール機能を含む、200 を超える基本的な統計ツールと高度な統計ツールが含まれています。

  1. XLSTAT のダウンロード ページに移動します。

  2. Mac OS に対応する XLSTAT バージョンを選択してダウンロードします。

  3. MAC OS でのインストール手順を実行します。

  4. データを含む Excel ファイルを開き、XLSTAT アイコンをクリックして XLSTAT ツール バーを起動します。

  5. 30 日間は、すべての XLSTAT 関数にアクセスできます。30 日後に、分析ツールの関数を含む無料版を使用することができます。また、XLSTAT のより完全なソリューションのいずれかを注文することもできます。

オプション 2:     AnalystSoft から StatPlus:mac LE を無料でダウンロードし、Excel 2011 で StatPlus:mac LE を使用します。

StatPlus:mac LE を使用すれば、回帰、ヒストグラム、分散分析 (ANOVA)、および t 検定など、分析ツールで以前に使用できていた多くの関数を実行できます。

  1. AnalystSoft Web サイトにアクセスし、ダウンロード ページの手順を実行します。

  2. StatPlus:mac LE をダウンロードしてインストールしたら、分析するデータを含むブックを開きます。

  3. StatPlus:mac LE を開きます。関数は StatPlus:mac LE メニューにあります。

    重要: 

    • Excel 2011 には、XLStat や StatPlus:mac LE のヘルプは含まれていません。XLStat のヘルプは XLSTAT によって提供されています。StatPlus:mac LE のヘルプは、AnalystSoft によって提供されています。

    • Microsoft ではいずれの製品もサポートしていません。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

分析ツールを使用して統計学的および工学的分析を行う

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×