Excel でヒストグラムを作成する

Excel でヒストグラムを作成する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ヒストグラムは、頻度のデータを表示する縦棒グラフです。

注: このトピックは、のみヒストグラムの作成について説明します。グラフのパレート図 (並べ替えられたヒストグラム) については、パレート図を作成するを参照してください。

  1. 分析ツールが読み込まれていることを確認します。詳細については、「Excel で分析ツールを読み込む」参照してください。

  2. ワークシートで、入力データを 1 つの列に入力し、必要に応じて最初のセルにラベルを追加します。

    項目の合計値、テストの点数など、必ず定量的な数値データを使用します。ヒストグラム ツールには、文字列として入力された識別番号などの定性的な数値データは使用できません。

  3. 次の列に、境界値を昇順で入力し、必要に応じて最初のセルにラベルを追加します。

    独自の境界値を使用すると、分析に役立つ可能性があります。境界値を入力しなかった場合は、ヒストグラム ツールが入力範囲の最小値と最大値を開始点および終了点として使用し、境界値の間隔を均等に分散させます。

  4. [データ] > [データ分析] をクリックします。

    [データ分析] と [ソルバー]

  5. [ヒストグラム]、[OK] の順にクリックします。

    [データ分析] ダイアログ ボックス

  6. [入力] で、次の操作を行います。

    1. [入力範囲] ボックスに、入力番号が設定されているデータ範囲のセル参照を入力します。

    2. [データ区間] ボックスに、境界値が設定されている範囲のセル参照を入力します。

      ワークシートに列見出しを使用した場合は、見出しもセル参照に含めることができます。

      ヒント: 参照を手動で入力する代わりに、ワークシートで範囲を選択するには、ダイアログ ボックスを一時的に閉じに [折りたたみ] ボタン をクリックします。ダイアログ ボックスを展開する] をもう一度クリックします。

  7. セル参照に列ラベルを含めている場合は、[ラベル] ボックスをオンにします。

  8. [出力オプション] で、出力先を選びます。

    ヒストグラムは、同じワークシート上、現在のブックの新しいワークシート上、または新しいブックに出力することができます。

  9. 次のボックスを 1 つ以上オンにします。

    パレート図 (並べ替えられたヒストグラム) 頻度で降順に並べ替えたデータが表示されます。

    累積比率    累積比率が表示され、ヒストグラムに累積比率のラインが追加されます。

    グラフ出力    埋め込みヒストグラムが表示されます。

  10. [OK] をクリックします。

    ヒストグラムをカスタマイズする場合、テキスト ラベルを変更することができ、ヒストグラム内の任意の場所をクリックして、グラフの右にある [グラフ要素]、[グラフ スタイル]、[グラフ フィルター] ボタンを使用できます。

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[統計グラフの挿入]、[ヒストグラム] の順にクリックします。

    [統計グラフの挿入] ボタンからアクセスしたヒストグラム コマンド

    [おすすめグラフ] の [すべてのグラフ] タブを使用して、ヒストグラムを作成することもできます。

ヒント: 

  • グラフの外観をカスタマイズするのには、デザインおよび [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (水平軸) が数値の代わりにテキスト ベースの場合は、このオプションを選択します。ヒストグラムは同じカテゴリのグループ化し、数値軸の値を合計します。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これは、ヒストグラムの既定の設定です。スコットの正規化基準ルールを使用して、ビンの幅が計算されます。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    (ビンのオーバーフローとアンダー フローを含む) のヒストグラムのビンの数を入力します。

    ビンのオーバーフロー

    右側のボックスに値の上にあるすべての値のビンを作成するには、このチェック ボックスを選択します。値を変更するには、ボックスに別の 10 進数を入力します。

    ビンのアンダーフロー

    右側のボックスの下または値のすべての値のビンを作成するには、このチェック ボックスを選択します。値を変更するには、ボックスに別の 10 進数を入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: 読むには、ヒストグラムの詳細方法とをその統計データをビジュアル化する、Excel チームがこのヒストグラム、パレート、箱ひげ図にブログの投稿を参照してください。目的の詳細については、その他の新しい種類のグラフこのブログで説明する投稿場合もあります。

[自動] オプション (スコットの正規化基準ルール)   

自動化の数式オプション

スコットの正規化基準ルールは分散データを通常と仮定して、データ セットと比較した場合のヒストグラムの分散の偏りを最小化しようとします。

[ビンのオーバーフロー] オプション   

オーバーフロー ビンの数式オプション

[ビンのアンダーフロー] オプション   

ビンのアンダーフローの数式オプション

  1. データを選択します。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[グラフ] の順にクリックします。

    Word の [挿入] タブの [図] グループの [グラフ]
  3. [グラフの挿入] ダイアログ ボックスの [すべてのグラフ] で、[ヒストグラム] をクリックして、[OK] をクリックします。

ヒント: 

  • グラフの外観をカスタマイズするのには、リボンのデザインおよび [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (水平軸) が数値の代わりにテキスト ベースの場合は、このオプションを選択します。ヒストグラムは同じカテゴリのグループ化し、数値軸の値を合計します。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これはヒストグラムの既定の設定です。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    (ビンのオーバーフローとアンダー フローを含む) のヒストグラムのビンの数を入力します。

    ビンのオーバーフロー

    右側のボックスに値の上にあるすべての値のビンを作成するには、このチェック ボックスを選択します。値を変更するには、ボックスに別の 10 進数を入力します。

    ビンのアンダーフロー

    右側のボックスの下または値のすべての値のビンを作成するには、このチェック ボックスを選択します。値を変更するには、ボックスに別の 10 進数を入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: 読むには、ヒストグラムの詳細方法とをその統計データをビジュアル化する、Excel チームがこのヒストグラム、パレート、箱ひげ図にブログの投稿を参照してください。目的の詳細については、その他の新しい種類のグラフこのブログで説明する投稿場合もあります。

注: Excel for Mac 2011 のヒストグラムを作成することはできません。

Excel 2016 for Mac でヒストグラムを作成するには、次の手順に従います。

  1. データを選びます。

    (これは、ヒストグラムのデータの一例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. リボンの挿入] タブをクリックして 統計グラフ] アイコン (統計アイコン) をクリックし、ヒストグラム] で [ヒストグラムを選択します。

ヒント: 

  • グラフの外観をカスタマイズするのには、グラフのデザイン書式設定] タブを使用します。

  • ]、 [グラフのデザイン書式設定タブが表示されない場合は、リボンに追加するヒストグラムで任意の場所] クリックします。

Excel Online ではヒストグラム (頻度データを表示する縦棒グラフ) を表示できますが、作成はできません。作成には Excel のアドインである分析ツールを使用してください。これは Excel Online ではサポートされていません。

Excel デスクトップ アプリケーションをお持ちの場合は、[Excel で開く] ボタンを使用して、デスクトップで Excel を開いてヒストグラムを作成することができます。

[Excel で開く] ボタン

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 携帯電話を使用している場合は、編集アイコン [編集] アイコン をタップしてリボンを表示し、[ホーム] をタップします。

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

    必要に応じて、グラフの要素をカスタマイズできます。

    注: この機能は、Office 365 サブスクリプションを購入しているユーザーのみが使用できます。Office 365 のサブスクリプションを使用している場合は、最新バージョンの Office をインストールしているかどうかを確認してください

    Office 365 または Excel の最新バージョンを試してみる

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 携帯電話を使用している場合は、編集アイコン [編集] アイコン をタップしてリボンを表示し、[ホーム] をタップします。

  3. [挿入]、[グラフ]、[ヒストグラム] の順にタップします。

Excel でヒストグラムを作成するには、2 種類のデータを提供: データを分析して、頻度を測定する間隔を表す境界値。ワークシート上の 2 つの列のデータを整理する必要があります。これらの列には、次のデータが含まれる必要があります。

  • 入力データ    これは、ヒストグラム ツールを使用して分析するデータです。

  • 区間番号    これらの番号は、データ分析で入力データを測定するためにヒストグラム ツールで使用する間隔を示します。

ヒストグラム ツールを使用すると、Excel で各データ区間のデータ ポイント数をカウントします。データ ポイントは、その数値がデータ区間の最小の境界値よりも大きく、最大の境界値以下である場合、特定の区間に含まれます。区間の範囲を省略すると、Excel により入力データの最小値と最大値の間に均等に割り付けられた区間のセットが作成されます。

ヒストグラム分析の出力は、新規ワークシート (または新規ブック) に表示され、ヒストグラム テーブルおよびヒストグラム テーブル内のデータを反映する縦棒グラフが表示されます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×