Excel でヒストグラムを作成します。

Excel でヒストグラムを作成します。

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

ヒストグラムまたはパレート図 (並べ替えられたヒストグラム) は、頻度データを表示する縦棒グラフです。

  1. 分析ツールを読み込むことを確認します。詳細については、 Excel で分析ツールの読み込みを参照してください。

  2. ワークシートで、入力データを 1 つの列に入力し、必要に応じて最初のセルにラベルを追加します。

    項目の合計値、テストの点数など、必ず定量的な数値データを使用します。ヒストグラム ツールには、文字列として入力された識別番号などの定性的な数値データは使用できません。

  3. 次の列に、境界値を昇順で入力し、必要に応じて最初のセルにラベルを追加します。

    独自の境界値を使用すると、分析に役立つ可能性があります。境界値を入力しなかった場合は、ヒストグラム ツールが入力範囲の最小値と最大値を開始点および終了点として使用し、境界値の間隔を均等に分散させます。

  4. [データ] > [データ分析] をクリックします。

    [データ分析] と [ソルバー]

  5. [ヒストグラム]、[OK] の順にクリックします。

    [データ分析] ダイアログ ボックス

  6. [入力] で、次の操作を行います。

    1. [入力範囲] ボックスに、入力番号が設定されているデータ範囲のセル参照を入力します。

    2. [データ区間] ボックスに、境界値が設定されている範囲のセル参照を入力します。

      ワークシートに列見出しを使用した場合は、見出しもセル参照に含めることができます。

      ヒント: 参照を手動で入力する代わりに、 [折りたたみ] をクリックしてダイアログ ボックスを一時的に縮小し、ワークシート上で範囲を選択することができます。このボタンを再びクリックすると、ダイアログ ボックスが表示されます。

  7. セル参照に列ラベルを含めている場合は、[ラベル] ボックスをオンにします。

  8. [出力オプション] で、出力先を選びます。

    ヒストグラムは、同じワークシート上、現在のブックの新しいワークシート上、または新しいブックに出力することができます。

  9. 次のボックスを 1 つ以上オンにします。

    パレート図 (並べ替えられたヒストグラム) 頻度で降順に並べ替えたデータが表示されます。

    累積比率    累積比率が表示され、ヒストグラムに累積比率のラインが追加されます。

    グラフ出力    埋め込みヒストグラムが表示されます。

  10. [OK] をクリックします。

    ヒストグラムをカスタマイズする場合、テキスト ラベルを変更することができ、ヒストグラム内の任意の場所をクリックして、グラフの右にある [グラフ要素]、[グラフ スタイル]、[グラフ フィルター] ボタンを使用できます。

  1. データを選択します。

    (これは、ヒストグラムにデータの一般的な例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[統計グラフの挿入]、[ヒストグラム] の順にクリックします。

    [統計グラフの挿入] ボタンからアクセスしたヒストグラム コマンド

    [おすすめグラフ] の [すべてのグラフ] タブを使用して、ヒストグラムを作成することもできます。

ヒント: 

  • グラフの外観をカスタマイズするには、[デザイン] タブと [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。 ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これは、ヒストグラムの既定の設定です。 ビンの幅は、スコットの正規化基準ルールを使用して計算されます。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

[自動] オプション (スコットの正規化基準ルール)   

自動化の数式オプション

スコットの正規化基準ルール (Scott’s normal reference rule) では、データ セットと比較した場合のヒストグラムの分散の偏りを最小化します。通常は分散データを想定しています。

[ビンのオーバーフロー] オプション   

オーバーフロー ビンの数式オプション

[ビンのアンダーフロー] オプション   

アンダーフロー ビンの数式オプション

  1. データを選択します。

    (これは、ヒストグラムにデータの一般的な例です)。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. [挿入]、[グラフ] の順にクリックします。

    Word の [挿入] タブの [図] グループの [グラフ]
  3. グラフの挿入] ダイアログ ボックスの [すべてのグラフでは、[、ヒストグラムをクリックし、[ OK] をクリックします。

ヒント: 

  • グラフの外観をカスタマイズするのには、リボンのデザインおよび [書式] タブを使用します。

  • これらのタブが表示されない場合は、ヒストグラムの好きな場所をクリックして、[グラフ ツール] をリボンに追加します。

[グラフ ツール] の [デザイン] タブと [書式設定] タブ

  1. グラフの水平軸を右クリックして、[軸の書式設定]、[軸のオプション] の順にクリックします。

    ショートカット メニューの [軸の書式設定] コマンド
  2. 以下の表の情報を使って、[軸の書式設定] 作業ウィンドウで設定するオプションを選びます。

    オプション

    説明

    カテゴリ別

    カテゴリ (横軸) がテキストベースで、数値でない場合に、このオプションを選びます。 ヒストグラムによって同じカテゴリがグループ化され、数値軸の値が合計されます。

    ヒント: テキスト文字列の数を数えるには、列を追加して、「1」の値を入力し、ヒストグラムをプロットして、ビンを [項目別] に設定します。

    自動

    これは、ヒストグラムの既定の設定です。

    ビンの幅

    各範囲のデータ ポイントの数に正の 10 進数を入力します。

    ビンの数

    ヒストグラムのビンの数を入力します (ビンのオーバーフローとアンダーフローを含む)。

    ビンのオーバーフロー

    右側のボックスの値を上回るすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    ビンのアンダーフロー

    右側のボックスの値以下のすべての値にビンを作成する場合にオンにします。 値を変更するには、別の 10 進数をボックスに入力します。

    [軸の書式設定] 作業ウィンドウ

ヒント: ヒストグラム図と、統計データの視覚化の方法については、Excel チームによるヒストグラム図、パレート図、箱ひげ図に関するブログ投稿を参照してください。また、このブログ投稿で説明されているその他の新しいグラフの種類も参照してください。

注: 分析ツールでは利用できませんバージョンと、Excel for Mac 2011 のヒストグラムを作成できません。

Excel 2016 for Mac ヒストグラムを作成するのには、次の手順に従います。

  1. 分析ツールを読み込むことを確認します。詳細については、 Excel で分析ツールの読み込みを参照してください。

  2. ワークシートで、入力データを 1 つの列に入力し、必要に応じて最初のセルにラベルを追加します。項目の合計値、テストの点数など、必ず定量的な数値データを使用します。ヒストグラム ツールには、文字列として入力された識別番号などの定性的な数値データは使用できません。

  3. 次の列に、境界値を昇順で入力し、必要に応じて最初のセルにラベルを追加します。 "Bins" の数値にどのような情報を入力すればよいか不明である場合は、データを調べ、自然な間隔を認識できるかどうかを確認します。 これらの間隔の名称は "Bins" でもあり、ヒストグラム ツールではこれらの "Bins" でデータをプロットします。

    独自の境界値を使用すると、分析に役立つ可能性があります。境界値を入力しなかった場合は、ヒストグラム ツールが入力範囲の最小値と最大値を開始点および終了点として使用し、境界値の間隔を均等に分散させます。

    以下に、ヒストグラムに使用できる 2 つの列の例を示します。

    2 つの列の例

  4. [データ] タブで、[データ分析] をクリックします。

    [データ分析] ボタン

  5. [ヒストグラム]、[OK] の順にクリックします。

  6. [入力] で、次の操作を行います。

    1. [入力範囲] ボックス内をクリックし、データの最初の列のセルを選びます。

    2. [Bin 範囲] ボックス内をクリックし、データの 2 番目の列のセルを選びます。

      ワークシートに列見出しを使用した場合は、見出しもセル参照に含めることができます。

      ヒント: また、 [折りたたみ] をクリックすると、ダイアログ ボックスを一時的に縮小し、ワークシート上で範囲を選ぶこともできます。 このボタンを再びクリックすると、ダイアログ ボックスが表示されます。

  7. セル参照に列ラベルを含めている場合は、[ラベル] ボックスをオンにします。

  8. [出力オプション] の下で、ヒストグラムの場所を指定します。

    • 同じシート上にヒストグラムを配置するには、[出力範囲] をクリックしてから [出力範囲] ボックス内をクリックします。 ヒストグラムを配置するシートをクリックします。

    • 新しいシートにヒストグラムを配置するには、[新規ワークシート] をクリックします。

    • 新しいブックにヒストグラムを配置するには、[新規ブック] をクリックします。

  9. 次のボックスを 1 つ以上オンにします。

    • パレート図 (並べ替えられたヒストグラム) 頻度で降順に並べ替えたデータが表示されます。

    • 累積比率    累積比率が表示され、ヒストグラムに累積比率のラインが追加されます。

    • グラフ出力    埋め込みヒストグラムが表示されます。

  10. [OK] をクリックします。

Excel Online ではヒストグラム (頻度データを表示する縦棒グラフ) を表示できますが、作成はできません。作成には Excel のアドインである分析ツールを使用してください。これは Excel Online ではサポートされていません。

Excel デスクトップ アプリケーションがあれば、Excel を開く、デスクトップやヒストグラムを作成するのには、 Excel で開く] ボタンを使用することができます。

[Excel で開く] ボタン

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 電話を使用している場合は、リボンを表示する編集アイコン [編集] アイコン をタップします。[ホーム] をタップします。

  3. [挿入] をタップ >グラフ>ヒストグラムします。

    必要に応じて、グラフの要素をカスタマイズできます。

    注: この機能は、Office 365 サブスクリプションを購入しているユーザーのみが使用できます。Office 365 のサブスクリプションを使用している場合は、最新バージョンの Office をインストールしているかどうかを確認してください

    Office 365 または Excel の最新バージョンを試してみる

  1. タップして、データを選択します。

    上のサンプルのヒストグラムを作成するために使用されたデータ
  2. 電話を使用している場合は、リボンを表示する編集アイコン [編集] アイコン をタップし、[ホーム] をタップします。

  3. [挿入] をタップ >グラフ>ヒストグラムします。

Excel でヒストグラムを作成するには、2 種類のデータを提供: データを分析して、頻度を測定する間隔を表す境界値。ワークシート上の 2 つの列のデータを整理する必要があります。これらの列には、次のデータが含まれる必要があります。

  • データの入力   これは、データをヒストグラム ツールを使用して分析します。

  • 境界値   これらの数値は、データ分析の入力データを測定するために使用する場合のヒストグラムは、間隔のツールを表す。

ヒストグラム ツールを使用すると、Excel は、各データ バックアップ内のデータ ポイントの数をカウントします。数値が負の最大数は、データ バックアップのバインドされているまたは連結し等しくの最小値よりも大きい場合、特定のビンにデータ ポイントが含まれます。Bin 範囲を省略すると、Excel は、入力データの最小値および最大値の間に均等に分散ビンのセットを作成します。

ヒストグラム分析の出力では、新しいワークシートに (または [新しいブック) が表示され、ヒストグラムのテーブルのデータを反映する縦棒グラフとヒストグラムのテーブルが表示されます。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×