スキップしてメイン コンテンツへ

Excel でアドインを追加または削除する

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

アドインは、Microsoft Excel のオプションのコマンドと機能を提供します。 既定では、Excel でアドインをすぐに利用できないため、最初にアドインをインストールし、(場合によっては) ライセンス認証を行って使用できるようにします。

HTML、CSS、JS に基づく Office アドインに関する情報をお探しですか? 使用している場合は、「 Excel 用 Office アドインを入手する」を参照してください。

一部のアドインは、ソルバーや分析ツールなどの Excel に組み込まれています。 他のアドインは、ダウンロードセンターから入手できます。また、最初にダウンロードしてインストールする必要があります。 最後に、組織内のプログラマやソフトウェアソリューションプロバイダーなどのサードパーティによって作成されたアドインがあります。 これらは、コンポーネントオブジェクトモデル (COM) アドイン、Visual Basic for Applications (VBA) アドイン、および DLL アドインにすることができます。 これらのアドインを使用するには、これらのアドインもインストールされている必要があります。

ほとんどのアドインは、次の 3 種類に分類できます。

  • Excel アドイン:    これらには、主に Excel アドイン (.xlam) ファイル、Excel 97-2003 アドイン (.xla) ファイル、DLL アドイン (.xll) ファイルなどで、オートメーション アドインです。 ソルバーや分析ツールなどの Excel アドインは、Excel または Microsoft Office をインストールすると使用できるようになります。 通常、これらのアドインの使用に必要なのはライセンス認証だけです。

  • ダウンロード可能なアドイン    Excel 用のその他のアドインは、 ダウンロードからダウンロードしてインストールすることができます。

  • カスタムアドイン    通常、開発者とソリューションプロバイダーは、カスタムコンポーネントオブジェクトモデル (COM) アドイン、オートメーションアドイン、VBA アドイン、XLL アドインを設計します。 これらを使用するには、これらをインストールする必要があります。

アドインをインストールまたは有効にすると、アドインとそのコマンドが次のいずれかの場所で使用できるようになります。

  • [データ] タブ。 分析ツール アドインとソルバー アドインをインストールして有効にすると、[分析] で [データ分析] と [ソルバー] を使用できます。

    [データ分析] と [ソルバー]

  • [数式] タブ。 ユーロ通貨対応ツールをインストールして有効にすると、[ソリューション] に [ユーロ換算] および [ユーロ書式設定] が表示されます。

    [ユーロ換算] と [ユーロ書式設定]

  • [アドイン] タブ。 その他のアドインは [アドイン] タブに追加できます。 [アドイン] タブに表示される最初のアドインをインストールして有効にすると、このタブがリボンに追加されます。 [アドイン] タブが表示されない場合は、Excel を終了して再起動する必要があります。

[はじめに] タブなど、その他のアドインは、Excel の他の場所 (リボンのタブなど) で使用したり、マクロやユーザー設定のメニューから使用できます。

重要: ソフトウェア開発者は、この手順を使用して、アドインのインストールプログラムや削除プログラムを設計する前に、オートメーションプログラムをインストールまたは削除することができます。

Excel アドインを有効にするには    

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

    [アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、有効にするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

有効にするアドインが [有効なアドイン] ボックスに表示されない場合は、インストールする必要があります。

Excel アドインをインストールするには    

  • ソルバーや分析ツールなど、通常は Excel と共にインストールされるアドインをインストールするには、Excel または Microsoft Office のセットアップ プログラムを実行し、[変更] オプションを選択してアドインをインストールします。 Excel を再起動した後、[有効なアドイン] ボックスにアドインが表示されます。

  • 一部の Excel アドインはコンピューターに保存されており、[アドイン] ダイアログ ボックスの [参照] をクリックしてアドインを探し、[OK] をクリックすると、インストールまたは有効にすることができます。

  • 一部の Excel アドインは、インストール パッケージの実行が必要です。 インストール パッケージをコンピューターにダウンロードまたはコピーして (インストール パッケージは通常 .msi 拡張子のファイル) 実行することが必要な場合があります。

  • コンピューターにないその他のアドインは、Web ブラウザーを使用して「ダウンロード センター」かインターネット上の他のサイトや組織内のサーバーからダウンロードしてインストールできます。 必要に応じて、ダウンロードのセットアップで表示される手順に従って操作してください。

Excel アドインを無効にするには    

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

  3. [有効なアドイン] ボックスで、無効にするアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    多くの場合、アドインを無効にすると、リボンのグループから削除されます。 別のケースでは、リボンからアドインを削除するために、Excel の再起動が必要になる場合があります。

    メモ    Inactivating アドインを使用している場合、アドインはコンピューターから削除されません。 コンピューターからアドインを削除するには、アドインをアンインストールする必要があります。

Excel アドインを削除するには    

重要: 最初にネットワークファイルサーバーまたは共有フォルダーから Excel アドインをインストールした場合は、その場所からアドインを削除する必要がある場合があります。 CD から Excel アドインをインストールして、アドインをインストールした後で、CD ドライブを新しいドライブ文字にマップした場合は、アドインを CD から再インストールする必要があります。 CD から Excel アドインを実行している場合は、Excel アドインをアンインストールしてから、CD から再インストールする必要があります。

  1. [ファイル] タブをクリックして、[終了] をクリックします。

  2. コントロール パネルの [プログラムと機能] (Windows 7 および Windows Vista の場合) または [プログラムの追加と削除] (Windows XP の場合) をクリックします。

  3. 次のいずれかの操作を行います。

    • Excel を Microsoft Office の一部としてインストールした場合は、インストールされているプログラムの一覧で [Microsoft Office] をクリックし、[変更] をクリックします。

    • Excel を個別にインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[変更] をクリックします。

    • ダウンロード センターからダウンロードしたアドインをインストールした場合は、インストールされているプログラムの一覧で目的のプログラム名をクリックし、[アンインストール] をクリックします。

  4. インストール プログラムに表示される指示に従って操作します。

重要: ソフトウェア開発者は、この手順を使用して、アドインのインストールプログラムや削除プログラムを設計する前に、オートメーションプログラムをインストールまたは削除することができます。 開発者以外の場合は、この手順を使用する必要はありません。 インストールと削除の手順が必要な場合は、アドインを提供したシステム管理者に連絡してください。

COM アドインを追加する

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。

    [COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、インストールするアドインの横のチェック ボックスをオンにして、[OK] をクリックします。

    ヒント    [有効なアドイン] ボックスの一覧に目的のアドインが表示されない場合は、[追加] をクリックしてアドインを検索します。

COM アドインを削除する

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの [COM アドイン] をクリックし、[設定] をクリックします。

    [COM アドイン] ダイアログ ボックスが表示されます。

  3. [有効なアドイン] ボックスで、削除するアドインの横のチェック ボックスをオフにして、[OK] をクリックします。

    メモ    これにより、アドインはメモリから削除されますが、使用可能なアドインの一覧にその名前は保持されます。 この方法では、アドインはコンピューターから削除されません。

  4. 有効なアドインの一覧から COM アドインを削除し、コンピューターからアドインを削除するには、[使用できるアドイン] ボックスの一覧でアドイン名をクリックし、[削除] をクリックします。

注: ソフトウェア開発者は、この手順を使用して、アドインのインストールプログラムや削除プログラムを設計する前に、オートメーションプログラムをインストールまたは削除することができます。 開発者以外の場合は、この手順を使用する必要はありません。 インストールと削除の手順が必要な場合は、アドインを提供したシステム管理者に連絡してください。

  1. [ファイル] タブをクリックします。[オプション] をクリックし、[アドイン] カテゴリをクリックします。

  2. [管理] ボックスの一覧の [Excel アドイン] をクリックし、[設定] をクリックします。

    [アドイン] ダイアログ ボックスが表示されます。

  3. オートメーション アドインをインストールするには、[オートメーション] をクリックし、[有効なオートメーション サーバー] ボックスで目的のアドインをクリックします。

    ヒント    目的のアドインが一覧に表示されていない場合は、[参照] をクリックしてアドインを探し、[ OK]をクリックします。

  4. オートメーション アドインを削除するには、レジストリから削除する必要があります。 詳細については、システム管理者にお問い合わせください。

一部のアドインは、ソルバーや分析ツールなどの Excel に組み込まれています。 他のアドインは、ダウンロードセンターから入手できます。また、最初にダウンロードしてインストールする必要があります。 最後に、組織内のプログラマやソフトウェアソリューションプロバイダーなどのサードパーティによって作成されたアドインがあります。 これらは、コンポーネントオブジェクトモデル (COM) アドイン、Visual Basic for Applications (VBA) アドイン、および DLL アドインにすることができます。 これらのアドインを使用するには、これらのアドインもインストールされている必要があります。

ほとんどのアドインは、次の 3 種類に分類できます。

  • Excel アドイン:    これらには、主に Excel アドイン (.xlam) ファイル、Excel 97-2003 アドイン (.xla) ファイル、DLL アドイン (.xll) ファイルなどで、オートメーション アドインです。 ソルバーや分析ツールなどの Excel アドインは、Excel または Microsoft Office をインストールすると使用できるようになります。 通常、これらのアドインの使用に必要なのはライセンス認証だけです。

  • ダウンロード可能なアドイン    Excel 用のその他のアドインは、 ダウンロードからダウンロードしてインストールすることができます。

  • カスタムアドイン    通常、開発者とソリューションプロバイダーは、カスタムコンポーネントオブジェクトモデル (COM) アドイン、オートメーションアドイン、VBA アドイン、XLL アドインを設計します。 これらを使用するには、これらをインストールする必要があります。

アドインをインストールまたは有効にすると、アドインとそのコマンドが次のいずれかの場所で使用できるようになります。

  • [データ] タブ。 分析ツールとソルバーアドインをインストールしてアクティブ化すると、リボンの [データ] タブでデータ分析ソルバーコマンドを使用できるようになります。

  • [ホーム] タブ。 他のアドインを [ホーム] タブに追加することもできます。

[はじめに] タブなど、その他のアドインは、Excel の他の場所 (リボンのタブなど) で使用したり、マクロやユーザー設定のメニューから使用できます。

重要: ソフトウェア開発者は、この手順を使用して、アドインのインストールプログラムや削除プログラムを設計する前に、オートメーションプログラムをインストールまたは削除することができます。

プレインストールされている Excel アドインをアクティブにするには    

  1. [ツール] メニューで、[アドイン] を選択します。

  2. [有効なアドイン] ボックスで、アクティブにするアドインのチェックボックスをオンにして、[ OK]をクリックします。

Excel アドインをインストールするには    

  • 一部の Excel アドインはコンピューターに保存されているため、[アドイン] ダイアログボックスの [参照] をクリックしてアドインを見つけ、[ OK]をクリックすると、インストールまたはライセンス認証を行うことができます。

  • 一部の Excel アドインは、インストール パッケージの実行が必要です。 インストール パッケージをコンピューターにダウンロードまたはコピーして (インストール パッケージは通常 .msi 拡張子のファイル) 実行することが必要な場合があります。

  • コンピューターで利用できないその他のアドインは、Web ブラウザーを使って、ダウンロードまたはインターネット上の他のサイト、組織内のサーバー、または Excel の組み込みストアオプションを使って、ダウンロードしてインストールすることができます。 必要に応じて、ダウンロードのセットアップで表示される手順に従って操作してください。

    ストアからアドインをインストールするには

    1. リボンの [挿入] タブをクリックします。

    2. [ストア] ボタンをクリックします。

    3. [カテゴリ] または [検索] フィールドを使ってアドインを見つけます。

    4. [追加] をクリックしてアドインをインストールします。

      注: 一部のアドインを購入する必要があります。

Excel アドインを削除するには    

  1. [挿入] タブをクリックし、[個人用アドイン] をクリックします。

  2. Office アドインで、アドインの横にある3つのドットメニューをクリックします。

  3. [削除] をクリックします。

  4. 他のデバイスについて表示される通知を読み、[削除] をクリックします。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×