Excel、SQL Server、SharePoint、および他の外部ソースからデータをインポートする

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

簡単にインポートしてMicrosoft Office Visio Professional 2007を使用して、図形に直接データを表示できます。最初には、データ ソースに接続すると、図面にデータをインポートします。2 番目の手順では、インポートされたデータを図形にリンクします。

データをインポートせずに図形にデータを追加する方法の詳細については、「図形にデータを追加する」を参照してください。

この記事の内容

手順 1: データをインポートする

手順 2: 行のデータを図面内の図形にリンクする

手順 1: データをインポートする

最初の手順では、データ選択ウィザードを使用して、データを [外部データ] ウィンドウにインポートします。

[外部データ] ウィンドウに表示されるデータのインポート時に、ソース データのスナップショットです。元のデータの変更に合わせて、図面内のデータを更新できます。ただし、図面内のデータを変更することで、データ ソースを更新することはできません。インポートしたデータを更新するを参照してください。

  1. [データ] メニューの [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初の画面で、使用するデータ ソースの種類を選択します。

    • Microsoft Office Excel ブック

    • Microsoft Office Access データベース

    • Microsoft Windows SharePoint Services リスト

    • Microsoft SQL Server データベース

    • 他の OLEDB または ODBC データ ソース

    • [以前作成した接続]

  3. ウィザードの指示に従って残りの作業を行います。

    注: 最初の画面で Excel ブック、Access データベース、SharePoint リスト以外のオプションを選択した場合、データ選択ウィザードに従って操作している途中、一時的にデータ接続ウィザードに迂回することがあります。

    ほとんどのウィザードにはヘルプが用意されています。ヘルプを参照するには、F1 ボタンを押すか、[ヘルプ] ボタンを参照してください。

データ接続ウィザードの最後の画面で [完了] をクリックすると、[外部データ] ウィンドウが表示され、インポートしたデータがグリッドに表示されます。

ページの先頭へ

手順 2: 行のデータを図面内の図形にリンクする

行のデータを図面内の図形にリンクするには 3 とおりの方法があります。それは、行を既存の図形に 1 つずつリンクする方法、行を図形に自動的にリンクする方法、そして、データに基づいて図形を作成する方法です。

行を既存の図形に 1 つずつリンクする

この方法は、図形の数が比較的少ない既存の図面に最適です。

  • [外部データ] ウィンドウから行を図面内の図形にドラッグします。

    データが図形に表示され、[外部データ] ウィンドウの行の左横にはリンク アイコンが表示されます。

    行を図形にドラッグする

    注記: 

    • 1 つの行を複数の図形にリンクすることはできますが、複数の行を 1 つの図形にリンクすることはできません。

    • 図形およびデータの体裁を変更したり、視覚効果を高めたりする方法については、「データ グラフィックを使用してデータの視覚効果を高める」を参照してください。

    • [外部データ] ウィンドウを表示するには、[表示] メニューの [外部データ ウィンドウ] をクリックします。

行を既存の図形に自動的にリンクする

この方法は、多数の図形の既存の図面に最適です。これは、図形にデータがある既にデータ ソース内のデータと照合できるようにする場合にのみ機能します。

  1. [データ] メニューの [自動的にリンク] をクリックします。

  2. 自動リンク ウィザードの指示に従います。

    図形にデータが表示されます。図形とデータの外観を向上させるを変更したり、データ グラフィックを適用するをご覧ください。

特定のヘルプでは、ほとんどのウィザード ページで利用できます。ヘルプにアクセスするには、F1 キーを押してまたはヘルプのアイコンをクリックします。

データに基づいて図形を作成する

この方法は、図面に図形が 1 つも作成されておらず、特定の図形を使用する必要がない場合に最適です。

  1. [図形] ウィンドウの図形をクリックします。

  2. [外部データ] ウィンドウの行 (1 つまたは複数) を図面の空白スペースにドラッグします。

    図面にドラッグした行ごとに、手順 1 でクリックした図形のインスタンスが 1 つ表示されます。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×