Excel、Access、SharePoint サイト、SQL Server、およびその他の外部ソースからデータをインポートします。

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

簡単にインポートし、Visio の図形に直接データを表示できます。 最初には、データ ソースに接続すると、図面にデータをインポートします。 2 番目の手順では、インポートされたデータを図形にリンクします。

手順 1: データをインポートします。

この最初の手順では、データをインポートするのにデータ選択ウィザードを使用します。

[外部データ] ウィンドウに表示されるデータのインポート時に、ソース データのスナップショットです。 元のデータの変更に合わせて、図面内のデータを更新できます。 ただし、図面内のデータを変更することで、データ ソースを更新することはできません。 インポートしたデータを更新するを参照してください。

  1. [データ] タブの [外部データ] グループで [図形にデータをリンク] をクリックします。

  2. データ選択ウィザードの最初のページで、次の種類に使いたいデータ ソースの選択します。

    • Microsoft Excel ブック

    • Microsoft Access データベース

    • Microsoft SharePoint Foundation リスト

    • Microsoft SQL Server データベース

    • 他の OLEDB または ODBC データ ソース

    • 以前に作成した接続

  3. ウィザードの残りの部分を実行します。

    注: ウィザードの最初のページで Excel ブック、Access データベース、または SharePoint リスト以外のオプションを選んだ場合することがありますが一時的に迂回データ選択ウィザードの完了の一環で、データ接続ウィザードをします。

データ接続ウィザードの最後のページで [完了] をクリックすると、インポートされたデータをグリッドに示すように外部データ] ウィンドウが表示されます。

手順 2: データの行を図面内の図形をリンクします。

行のデータを図面内の図形にリンクする 3 つの方法があります: 行を 1 つの既存の図形にリンクするには、時に、自動的に行を図形にリンクできますまたはデータの図形を作成することができます。

方法 1: 同時に行を 1 つの既存の図形にリンクします。

この方法は、少数の図形を含む既存の図面に最適です。

  • 外部データ] ウィンドウから図面内の図形に行をドラッグします。

    注: 外部データ ウィンドウ] が表示されない場合は、[データ] タブに移動し、[表示/非表示] グループで、外部データ ウィンドウ]の横にあるチェック ボックスをオンします。

    図形、データを表示して、外部データ] ウィンドウで、[行の左側にリンク アイコンが表示されます。

    行を図形にドラッグする

    注: 

    • 複数の図形に 1 つの行をリンクすることができますが、複数の行を 1 つの図形にリンクすることはできません。

    • 図形とデータの外観を向上させるを変更したり、データ グラフィックを適用するをご覧ください。

    • 外部データを表示するのには、ウィンドウで、[表示] メニューは、外部データ] ウィンドウをクリックします。

方法 2: 行既存の図形に自動的にリンクします。

この方法は、多数の図形の既存の図面に最適です。 これは、図形にデータがある既にデータ ソース内のデータと照合できるようにする場合にのみ機能します。

  1. Visio 2016および以降のバージョン: [データ] メニューをクリックしてすべて更新して、更新後に自動的にリンクする選択がオンになっていない場合。

    Visio 2013で以前のバージョン: [データ] メニューの [自動的にリンク] をクリックします。

  2. 自動リンク ウィザードの手順に従います。

    図形にデータが表示されます。 図形とデータの外観を向上させるを変更したり、データ グラフィックを適用するをご覧ください。

方法 3: データから図形を作成します。

図形、図面を持っていないし、特定の図形を使用する必要がない場合は、この方法をお勧めします。

  1. [図形] ウィンドウ内の図形] をクリックします。

  2. 図面の空白スペースに外部データ] ウィンドウから行または行のセットをドラッグします。

    図面にドラッグした行ごとに 1 つクリックすると、図形のインスタンスが表示されます。

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×