Access 2010 の基本的な作業

Microsoft Access 2010 の使用方法の学習に役立ついくつかの基本的なデータベース作業について説明します。

 

この記事の内容

Access とは

Access のリレーショナル データベース

Access を開いたときに表示されるビュー

テンプレートを検索して適用する

データベースを最初から作成する

Access の既存のデータベースを開く

新しいデータベースを使用して作業を開始する

表を追加する

外部ソースのデータを Access のテーブルに貼り付ける

別のソースからのデータのインポートまたは別のソースのデータへのリンクを行う

次のステップ

スプレッドシートまたは他のプログラムからデータをインポートする

Excel ワークシートを Access にインポートする

Excel ワークシートを新しいデータベースのテーブルとしてインポートする

テーブル正規化ウィザードを使用してデータを整理する

他のプログラムのデータを操作する

複数バージョンの Access で以前のバージョンのデータベースを使用する

複数バージョンの Access で Access データベース ファイルを使用する

手順 1: 既存のデータベースのコピーを作成して新しい形式で保存する

手順 2: コピーのデータベースを分割し、元のファイルをバックエンド データベースとして使用する

手順 3: 新しいフロントエンドを元のデータベースに接続する

複数バージョンの Access でフロントエンド/バックエンド アプリケーションを使用する

Access とは

Access 2010 は、データベース アプリケーションのデザインおよび展開ツールで、重要な情報を管理するために使用できます。データはコンピューターに保存できますが、他のユーザーが Web ブラウザーでデータベースを使用できるように、Web に公開することもできます。

多くのユーザーが Access を使い始めるのは、普段データの記録に使用しているプログラムに不便を感じるようになったときです。イベント プランナーを例に考えてみましょう。イベント プランナーは、イベントを成功に導くために、細かいデータをすべて記録して管理する必要がありますが、この作業にワード プロセッサや表計算プログラムで対応していると、たちまちデータの重複や不整合の問題が生じます。予定表ソフトウェアを使うこともできますが、財務情報を予定表に記録するのは適切とは言えません。

Access のリレーショナル データベース

このような情報を追跡するために、リレーショナル データベース (重複を避けるために、テーブルと呼ばれる小さなデータのコレクションに分割され、フィールドと呼ばれる一般的な情報の断片に基づいて相互に関連付けられた、データの倉庫) が必要になることがあります。たとえば、イベント管理用リレーショナル データベースの場合、それぞれに顧客情報、仕入先情報、イベント情報が格納されたテーブルが存在します。イベント情報が格納されたテーブルには、それ自体を顧客テーブルに関連付けるためのフィールドと、仕入先テーブルに関連付けるためのフィールドが含まれます。そのため、仕入先の電話番号が変わった場合、その仕入先が関係するすべてのイベントではなく、仕入先テーブルで情報を一度変更するだけで済みます。

Access は、情報の管理に役立つリレーショナル データベース アプリケーションをすばやく簡単に作成するためのツールです。在庫、仕事上の連絡先、ビジネス プロセスなど、ほぼすべての種類の情報を記録できるデータベースを作成できます。Access にはさまざまな情報の記録をすぐに開始できるテンプレートが用意されているため、初心者の方でも安心です。

Access を開いたときに表示されるビュー

Access 2010 を起動すると、Microsoft Office Backstage ビューが表示されます。このビューから、現在のデータベースの情報を取得、新しいデータベースを作成、既存データベースを開く、Office.com からお勧めのコンテンツを表示するなどの操作を行うことができます。

Access 2010 の Backstage ビュー

Backstage ビューには、データベースを調整、保守、共有するためのコマンドも多数用意されています。Backstage ビューのコマンドは、通常、データベース内のオブジェクトではなく、データベース全体に適用されます。

注: [ファイル] タブをクリックすると、いつでも Backstage ビューを表示できます。

ページの先頭へ

テンプレートを検索して適用する

Access には、データベースの作成処理を高速化するために使用できる、さまざまなテンプレートが用意されています。テンプレートは、すぐに使用可能なデータベースです。特定のタスクを実行するためのテーブル、クエリ、フォーム、およびレポートがすべて含まれています。たとえば、問題のトラッキング、連絡先情報の管理、支出の記録などのために使用できるテンプレートがあります。一部のテンプレートには、テンプレートの使い方をわかりやすく示したサンプル レコードが含まれています。テンプレート データベースはそのまま使用することも、ニーズに合わせてカスタマイズすることもできます。

テンプレートを検索してデータベースに適用するには、次の操作を行います。

  1. [ファイル] タブの [新規作成] をクリックします。

  2. [使用できるテンプレート] で、次のいずれかの操作を行います。

    • 最近使用したテンプレートを再利用するには、[最近使用したテンプレート] をクリックし、使用するテンプレートをクリックします。

    • 既にコンピューターにインストールされているテンプレートを使用するには、[マイ テンプレート] をクリックし、使用するテンプレートをクリックします。

    • Office.com でテンプレートを検索するには、[Office.com テンプレート] でテンプレート カテゴリをクリックし、使用するテンプレートをクリックします。次に、[ダウンロード] をクリックして、Office .com からコンピューターにテンプレートをダウンロードします。

      Access 内から Office.com のテンプレートを検索することもできます。[Office.com でテンプレートを検索] ボックスに 1 つ以上の検索語句を入力し、矢印ボタンをクリックして検索します。

  3. 必要に応じて、[ファイル名] ボックスの横にあるフォルダー アイコンをクリックし、データベースを作成する場所を参照します。特定の場所を指定しないと、[ファイル名] ボックスの下に表示されている既定の場所にデータベースが作成されます。

  4. [作成] をクリックします。

データベースが作成され、使用できるように開きます。

ページの先頭へ

データベースを最初から作成する

Access を使用したデータベースの作成の基本概念について詳しく調べる場合は、「データベース設計の基本」を参照してください。

ニーズに合ったテンプレートがない場合や、Access で使用したいデータが別のプログラムにある場合は、データベースを最初から作成した方が効果的なことがあります。Access 2010 では、標準的なデスクトップ データベースと Web データベースのどちらかを作成できます。

Web データベースの詳細については、「Web で共有するデータベースを作成する」を参照してください。

新しいデータベースを作成するには、次の操作を行います。

  1. Access を起動します。

  2. Backstage ビューの [新規作成] タブで、[空のデータベース] または [空の Web データベース] をクリックします。

    重要: ここでの選択により、データベースで使用できる機能が決まります。デスクトップ データベースは Web には発行できません。一方の Web データベースは、集計クエリなど、デスクトップ データベースの機能の一部をサポートしていません。

  3. 右側の [ファイル名] ボックスに、データベースの名前を入力します。

    ファイルを作成する場所を変更するには、[ファイル名] ボックスの横にある [参照] ボタン イメージ をクリックし、新しい場所を参照して選び、[OK] をクリックします。

  4. [作成] をクリックします。

    データベースが作成され、Table1 という名前の空のテーブルがデータシート ビューで表示されます。

  5. カーソルは新しいテーブルの [クリックして追加] 列の最初の空白セルに置かれます。

    データを追加するには、データを入力するか、この記事の後半の「外部ソースのデータを Access のテーブルに貼り付ける」セクションの説明に従って、別のデータ ソースからデータを貼り付けます。

    注記: 

    • データシート ビューは、Excel のワークシートを使用する場合とほぼ同様にデータを入力できるように設計されています。データシート ビューの主な制約は、データシートの左上隅から始めて、連続した行と列にデータを入力しなければならないことです。テーブル スペースの無駄使いになるので、Excel ワークシートの場合のように、データの体裁を整えるために空の行や列を挿入しないでください。テーブルはデータを格納するだけにすぎません。データの表示を担当するのは、後で設計するフォームとレポートです。

    • テーブル構造は、データの入力中に作成されます。データシートに新しい列を追加するたびに、新しいフィールドがテーブルに定義されます。フィールドのデータ型は、入力したデータの種類に基づいて設定されます。たとえば、列に入力されている値が日付値のみの場合、そのフィールドのデータ型は日付/時刻に設定されます。後でこのフィールドに日付以外の値 (名前や電話番号など) を入力しようとすると、値が列のデータ型と一致しないことを通知するメッセージが表示されます。可能な場合は、文字列、日付、数値など、同じデータ型のデータが各列に入力されるようなテーブルを作成します。そのようにすると、クエリ、フォーム、レポートを作成するときに、必要なデータだけを簡単に選ぶことができます。

この時点でデータを入力しない場合は、[閉じる] ボタン イメージ をクリックします。

注: Table1 を保存せずに閉じると、削除されます。

ページの先頭へ

既存の Access データベースを開く

ヒント: 最近開いたデータベースのいずれかをすばやく開くには、[ファイル] タブの [最近使用したファイル] をクリックし、ファイル名をクリックします。

  1. [ファイル] タブの [開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスのショートカットをクリックするか、[ファイルの場所] ボックスで、目的のデータベースが含まれているドライブまたはフォルダーをクリックします。

  3. フォルダー リストで、目的のデータベースが含まれるフォルダーが開くまでダブルクリックしていきます。

  4. データベースが見つかったら、次のいずれかの操作を行います。

    • 既定の開くモードでデータベースを開くには、データベースをダブルクリックします。

    • マルチユーザー環境で共有アクセス用にデータベースを開き、自分と他のユーザーが同時にデータベースを読み書きできるようにするには、[開く] をクリックします。

    • 読み取り専用アクセスでデータベースを開き、データベースの表示のみを可能にして編集は不可能にするには、[開く] ボタンの横にある下向き矢印をクリックし、[読み取り専用として開く] をクリックします。

    • 排他アクセスでデータベースを開き、開いているデータベースを他のユーザーが開けないようにするには、[開く] ボタンの横にある下向き矢印をクリックし、[排他モードで開く] をクリックします。

    • データベースを読み取り専用で開くには、[ファイルを開く] ボタンの横にある矢印をクリックし、[排他および読み取り専用で開く] をクリックします。他のユーザーは引き続きデータベースを開くことができますが、実行できるのは読み取り専用アクセスのみです。

開こうとしているデータベースが見つからない場合   

  1. [ファイルを開く] ダイアログ ボックスで [マイ コンピューター] ショートカットをクリックするか、[ファイルの場所] ボックスで [マイ コンピューター] をクリックします。

  2. ドライブの一覧で、データベースが存在すると思われるドライブを右クリックし、[検索] をクリックします。

  3. 検索条件を入力し、Enter キーを押してデータベースを検索します。

  4. データベースが見つかったら、[検索結果] ダイアログ ボックスでデータベースをダブルクリックして開きます。

    [ファイルを開く] ダイアログ ボックスから検索を行ったため、データベースを開くには、そのダイアログ ボックスの [キャンセル] をクリックする必要があります。

データ ファイルを外部ファイル形式 (dBASE、Paradox、Microsoft Exchange、Excel など) で直接開くことができます。また、Microsoft SQL Server や Microsoft FoxPro などのあらゆる ODBC データ ソースも直接開くことができます。そのデータ ファイルと同じフォルダー内に新しい Access データベースが自動的に作成され、外部データベース内の各テーブルへのリンクが追加されます。

ページの先頭へ

新しいデータベースを使用して作業を開始する

使用したテンプレートによっては、新しいデータベースを使用して作業を開始するために、次の操作の 1 つ以上が必要になる場合があります。

  • [ログイン] ダイアログ ボックスが表示され、そのユーザーの一覧が空の場合、作業を開始するには次の手順に従います。

    1. [新しいユーザー] をクリックします。

    2. [ユーザー詳細] フォームに情報を入力します。

    3. [保存して閉じる] をクリックします。

    4. 入力したユーザー名を選択し、[ログイン] をクリックします。

  • 空のデータシートが表示された場合は、すぐにそのデータシートにデータを直接入力するか、他のボタンやタブをクリックしてデータベースを探索することができます。

  • [作業の開始] ページが表示された場合は、そのページ上のリンクをクリックしてデータベースの詳細を確認するか、他のボタンやタブをクリックしてデータベースを探索することができます。

  • メッセージ バーに [セキュリティの警告] メッセージが表示され、テンプレートの発行元を信頼できる場合は、[コンテンツを有効にする] をクリックします。データベースでログインが要求される場合は、再度ログインする必要があります。

デスクトップ データベースおよび Web データベースの場合、次のいずれかの手順も始めます。

ページの先頭へ

テーブルを追加する

[作成] タブの [テーブル] にあるツールを使用すると、新しいテーブルを既存のデータベースに追加できます。

[作成] タブの [テーブル]

注: Web データベースの場合、[テーブル] で使用できるのは [テーブル] コマンドだけです。

どちらのビューを先に使用した場合でも、Access ウィンドウのステータス バーにある表示ボタンを使用して、もう一方のビューにいつでも切り替えることができます。

データシート ビューで空白のテーブルを作成する   データシート ビューでは、データの入力を開始するとすぐに、テーブル構造が自動的に作成されます。フィールド名には、番号 (フィールド 1、フィールド 2 など) が割り当てられ、各フィールドのデータ型は入力したデータの種類に基づいて自動的に設定されます。

  1. [作成] タブの [テーブル] グループで、テーブル ボタンの画像 をクリックします。

  2. テーブルが作成され、[クリックして追加] 列の最初の空のセルが選択されます。

  3. データを追加するには、先頭の空のセルに入力し始めるか、この記事の後半で説明しているように、別のデータ ソースからデータを貼り付けます。

    • 列 (フィールド) の名前を変更するには、その列見出しをダブルクリックして新しい名前を入力します。

      ヒント: データを確認しなくても内容がわかるように、各フィールドにはわかりやすい名前を付けてください。

    • 列を移動するには、列見出しをクリックして列を選択し、新しい場所までドラッグします。連続した複数の列を選択し、すべての列を一度に新しい場所までドラッグすることもできます。

      テーブルにさらにフィールドを追加するには、データシート ビューで [クリックして追加] 列に入力を開始するか、[フィールド] タブの [追加と削除] 内のコマンドを使用して新しいフィールドを追加します。

デザイン ビューからテーブルを作成する    デザイン ビューでは、最初に新しいテーブル構造を作成します。その後データシート ビューに切り替えてデータを入力するか、フォームの使用などの他の方法でデータを入力します。

デザイン ビューは、Web データベースのテーブルには使用できません。

  1. [作成] タブの [テーブル] グループで、[テーブル デザイン] をクリックします。 ボタン イメージ

  2. テーブル内の各フィールドで、[フィールド名] 列に名前を入力し、[データ型] ボックスの一覧からデータ型を選択します。

  3. [説明] 列には、各フィールドの追加情報を入力できます。入力した説明は、そのフィールドの上にカーソルを置いたときにステータス バーに表示され、[フィールド リスト] ウィンドウからフォームまたはレポートにフィールドをドラッグすることによって作成したすべてのコントロール、およびフォーム ウィザードまたはレポート ウィザードによってそのフィールド用に作成されたすべてのコントロールのステータス バー テキストとして使用されます。

  4. すべてのフィールドを追加した後、テーブルを保存します。

    • [ファイル] タブの [保存] をクリックします。

  5. データシート ビューに切り替えて、最初の空のセルをクリックしたら、テーブルにデータをいつでも入力し始めることができます。次のセクションで説明するように、外部ソースからデータを貼り付けることもできます。

SharePoint リストに基づいたテーブルを作成する    SharePoint リストを使用すると、Access をインストールしていないユーザーもデータを使用できます。さらに、リストのデータはサーバー上に保存されるため、一般に、デスクトップ コンピューターに保存されたファイルよりもデータの損失に対する保護が強化されます。新しいリストで始めることも、既存のリストにリンクすることもできます。リストを作成する SharePoint サイトで必要なアクセス許可を持っている必要があります。アクセス許可はサイトによって異なるため、選ぶことができるオプションの詳細については、SharePoint 管理者に問い合わせてください。

この機能は Web データベースでは利用できません。

  1. [作成] タブの [テーブル] で、[SharePoint リスト] をクリックします。

  2. いずれかのリスト テンプレートを使用して、連絡先リストやイベント リストなどの標準的な SharePoint リストを作成できます。

    カスタム リストの作成、既存のリストへのリンク、既存のリストのインポートなどの選択肢もあります。目的のオプションをクリックしてください。

  3. いずれかのリスト テンプレートを選択するか、カスタム リストを作成することを選んだ場合は、[新しいリストの作成] ダイアログ ボックスが開き、手順が順を追って示されます。既存のリストを使用することを選んだ場合は、[外部データの取り込み] ダイアログ ボックスが開き、手順が示されます。

テーブルの詳細については、「テーブルの概要」を参照してください。

ページの先頭へ

外部ソースのデータを Access のテーブルに貼り付ける

データが現在 Excel などの別のプログラムに保存されている場合、そのデータをコピーして、Access のテーブルに貼り付けることができます。一般に、この方法は、Excel のワークシートのようにデータが既に列に分かれている場合に最適に機能します。データが文書処理プログラムに保存されている場合は、タブを使用して先にデータの列を区切るか、データを文書処理プログラムで表に変換してからコピーする必要があります。特に Access の操作に慣れていない場合、データの編集や操作 (姓名を姓と名に分けるなど) が必要なときは、データをコピーする前に処理しておくことをお勧めします。

データを空のテーブルに貼り付けると、そのデータの種類に基づいて各フィールドのデータ型が設定されます。たとえば、貼り付けられたフィールドに日付だけが含まれる場合、そのフィールドには日付/時刻型が設定されます。貼り付けられたフィールドに "はい" と "いいえ" だけが含まれる場合、そのフィールドには Yes/No 型が設定されます。

Access では、貼り付けられたデータの最初の行の内容を使用してフィールドに名前が付けられます。貼り付けられたデータの最初の行が他の行と似た種類である場合、最初の行はデータの一部と判断され、フィールドに汎用的な名前 (Field1、Field2 など) が割り当てられます。貼り付けられた最初の行が以降の行と似ていない場合、最初の行がフィールド名として使用され、実際のデータから除外されます。

汎用的なフィールド名が割り当てられた場合、混乱を避けるためにそのフィールドの名前をできるだけ早く変更する必要があります。次の手順に従います。

  1. [ファイル] タブの [上書き保存] をクリックしてテーブルを保存します。

  2. データシート ビューで、各列見出しをダブルクリックし、列の名前を入力します。

  3. テーブルを再び保存します。

ページの先頭へ

別のソースからのデータのインポートまたは別のソースのデータへのリンクを行う

別のプログラムで収集したデータを Access で使用する必要が生じることがあります。同僚が他のプログラムで保存したデータを Access で操作しなければならない場合や、詳細な分析を目的に、種類の異なる複数のデータ ソースを集約する場所が必要になる場合もあります。

Access では、他のプログラムのデータのインポートとリンクを簡単に行うことができます。データは、Excel ワークシート、別の Access データベースのテーブル、SharePoint リストなど、さまざまな外部ソースから取り込むことができます。インポートのプロセスはデータ ソースごとに多少異なりますが、次の手順に従うと、データのインポートを開始できます。

  1. [外部データ] タブの [インポートとリンク] で、インポートするファイルの種類に対応するコマンドをクリックします。

    たとえば、Excel ワークシートからデータをインポートする場合は [Excel] をクリックします。適切なプログラムの種類が見つからない場合は、[その他] をクリックします。

    注: [インポートとリンク] グループに適切な形式の種類がない場合は、そのデータを作成した元のプログラムを起動し、そのデータを Access でサポートされているファイル形式 (区切りテキスト ファイルなど) で保存してから、インポートまたはリンクを実行します。

  2. [外部データの取り込み] ダイアログ ボックスで、[参照] をクリックしてソース データ ファイルを参照するか、ソース データ ファイルの完全なパスを [ファイル名] ボックスに入力します。

  3. [現在のデータベースのデータの保存方法と保存場所を指定してください] で、適切なオプションをクリックします。インポートしたデータを使って新しいテーブルを作成するか、データ ソースとのリンクを維持するリンク テーブルを作成できます。

  4. [OK] をクリックします。

    選択したオプションに応じて、[オブジェクトのリンク] ダイアログ ボックスか [オブジェクトのインポート] ダイアログ ボックスが開きます。

  5. ダイアログ ボックスで必要な手順を行います。実際の手順は、どのインポート オプションやリンク オプションを選択したかによって異なります。

  6. ウィザードの最後のページで、[完了] をクリックします。

    完了したインポート操作の詳細情報を保存するかどうかをたずねるメッセージが表示されます。

  7. 同じインポート操作を再び実行する可能性がある場合は、[インポート手順の保存] をクリックし、詳細情報を入力します。

    これ以降は、[外部データ] タブの [インポート] で [保存済みのインポート操作] をクリックします。次に、インポート定義をクリックし、[実行] をクリックすると、インポート操作を簡単に再現できます。

  8. インポート操作の詳細を保存しない場合は、[閉じる] をクリックします。

新しいテーブルにデータがインポートされ、テーブルがナビゲーション ウィンドウの [テーブル] に表示されます。

Access へのデータのインポートの詳細については、この記事の [参照] セクションにあるリンクを参照してください。

ページの先頭へ

次のステップ

デザイン プロセスの残りの作業は目的に応じて変わりますが、通常は、クエリ、フォーム、レポート、およびマクロの作成を検討する必要があります。この記事では、これらのデータベース オブジェクトの作成方法については説明しません。

詳細については、次の記事を参照してください。

ページの先頭へ

スプレッドシートまたは他のプログラムからデータをインポートする

他のデータベースまたは表計算プログラムを使用したことがある場合は、そのアプリケーションの動作やデータベースの用途について、基本を把握していることと思われます。Access は、リレーショナル データベースを作成できるという点で、他の多くのデータベース アプリケーションと異なります。さらに、高度なクエリ、フォーム、およびレポートを作成するツールが用意されているという点で、ほとんどの表計算プログラムとは一線を画しています。Access には、SQL Server をはじめとする他のデータベース アプリケーションを操作するためのオプションも多数用意されています。

Excel ワークシートを Access にインポートする

Excel でリストを作成してから Access を使用するというのは、ごく一般的な順序です。Excel はリストの作成に適していますが、リストのサイズが大きくなるにつれて、整理や更新がしにくくなります。このような場合は、Access にリストを移動することが必要となります。

データベース テーブルとワークシートは、どちらも行と列にデータが格納されるという点で構造的に似ています。そのため、ワークシートは簡単にデータベース テーブルにインポートできます。データをワークシートに格納する場合とデータベースに格納する場合の主な違いは、データがどのように整理されるかということです。ワークシート全体をデータベースの新しいテーブルとしてインポートするのみでは、データの整理や更新に関連した問題は解決されません。このことは、ワークシートに冗長なデータが含まれている場合に特に当てはまります。これらの問題を解決するには、スプレッドシートのデータを、関連するデータごとにまとめた別々のテーブルに分割する必要があります。テーブル内にデータを配置する方法の詳細については、「データベース設計の基本」を参照してください。

Access には、この処理を行うために使用できるテーブル正規化ウィザードが備わっています。データをテーブルにインポートしてからこのウィザードを使用すると、テーブルをそれぞれが固有のデータのみを含んだ複数のテーブルに分割できます。また、このウィザードでは、テーブル間に必要なリレーションシップも作成されます。

ページの先頭へ

Excel ワークシートを新しいデータベースのテーブルとしてインポートする

  1. [ファイル] タブの [新規作成] をクリックし、[空のデータベース] をクリックします。

  2. [ファイル名] ボックスに新しいデータベースの名前を入力し、[作成] をクリックします。

    新しいデータベースが開き、Table1 という名前の空のテーブルが新たに作成されます。

  3. Table1 を閉じます。

    Table1 のデザインに加えた変更を保存するかどうかを確認するメッセージが表示されたら、[いいえ] をクリックします。

  4. [外部データ] タブの [インポートとリンク] グループで、Excel ボタンの画像 をクリックします。

  5. [外部データの取り込み] ダイアログ ボックスで [参照] をクリックします。

  6. [ファイルを開く] ダイアログ ボックスを使用して、ファイルを検索します。

  7. ファイルを選択して、[開く] をクリックします。

  8. [外部データの取り込み] ダイアログ ボックスで、[カレント データベースの新しいテーブルにソース データをインポートする] チェック ボックスがオンになっていることを確認します。

  9. [OK] をクリックします。

    ワークシート インポート ウィザードが開き、データに関する質問がいくつか表示されます。

  10. ウィザードの指示に従って操作し、[次へ] または [戻る] をクリックしてページ間を移動します。ウィザードの最後のページで [完了] をクリックします。

    注: 完了したインポート操作に関する詳細情報を保存するかどうかを確認するメッセージが表示されます。同じインポート操作を再び実行する可能性がある場合は、[はい] をクリックし、詳細情報を入力します。[外部データ] タブの [インポート] で [保存済みのインポート操作] をクリックすると、この操作を後で簡単に再生できます。操作の詳細を保存しない場合は、[閉じる] をクリックします。

データが新しいテーブルにインポートされ、ナビゲーション ウィンドウの [すべてのテーブル] に表示されます。

ページの先頭へ

テーブル正規化ウィザードを使用してデータを整理する

データが Access テーブルにインポートされたら、テーブル正規化ウィザードを使って、重複データをすばやく識別できます。さらに、データを別々のテーブルに整理して、データが効率的に格納されるようにすることもできます。Access では、元のテーブルをバックアップとして保存してから、データベース アプリケーションの基礎として使用できる新しいテーブルが作成されます。

  1. 正規化するテーブルが含まれている Access データベースを開きます。

  2. [データベース ツール] タブの [解析] で [テーブルの正規化] をクリックします。

    テーブル正規化ウィザードが開きます。

    このウィザードの最初の 2 ページには、正規化について簡単に説明したチュートリアルが含まれています。このページのボタンをクリックすると、例が表示されます。チュートリアルのページが表示されずに [テーブル正規化ウィザードの紹介の画面を表示する] チェック ボックスが表示される場合は、チェック ボックスをオンにして [戻る] を 2 回クリックすると、チュートリアルを表示できます。チュートリアルを一度読んだ後で今後は表示しないようにするには、[テーブル正規化ウィザードの紹介の画面を表示する] チェック ボックスをオフにします。

  3. [多くの重複データを含むフィールドがあるテーブルを選択してください] ページで、正規化するテーブルを選択して [次へ] をクリックします。

  4. どのフィールドをどのテーブルに入れるかは、ウィザードに決定させることも、手動で決定することもできます。ウィザードの推奨に従った場合でも、ウィザードの次のページでテーブルのレイアウトを変更できます。

    注: どのフィールドをどのテーブルに入れるかをウィザードに決定させると、データの量が多くない場合などは特に、テーブルのレイアウトがデータに適していないことがあります。ウィザードの処理の結果は必ずよく確認してください。その一方で、ウィザードによって推奨されたレイアウトの方が自分で考えていたものより効率的な場合もあるので、ウィザードの推奨を少なくとも一度試してみることをお勧めします。ウィザードの処理の結果に満足がいかない場合は、フィールドを手動で並べ替えることができ、[戻る] をクリックすれば、いつでもすべてのフィールドを手動で配置できます。

  5. [次へ] をクリックします。このページでは、どのテーブルにどのフィールドを入れるかを指定します。ウィザードに決定させることを選択した場合は、リレーションシップ ラインで接続された複数のテーブルが作成されます。それ以外の場合は、すべてのフィールドを含んだテーブルが 1 つだけ作成されます。いずれの場合も、このページで変更を加えることができます。

    • テーブルのフィールドをこのページの空白領域にドラッグすると、それらのフィールドを含んだ新しいテーブルを作成できます。テーブル名を指定するように求めるメッセージが表示されます。

    • あるテーブルのデータを別のテーブルに移した方が効率的に格納できると考えられる場合は、テーブル間でフィールドをドラッグすることもできます。

    • ほとんどのテーブルには、[ID] フィールドまたは [固有の ID が生成されました] フィールドが含まれています。ID フィールドの詳細を表示するには、ウィザードの右上隅にある [ヒント] をクリックしてください。

    • 変更を元に戻すには、[元に戻す] ボタンをクリックします。

    • テーブルの名前を変更するには、テーブルのタイトル バーをダブルクリックして、新しい名前を入力し、[OK] をクリックします。

  6. フィールドのレイアウトが希望どおりになったら、[次へ] をクリックします。

  7. 値が非常に似ているレコードがウィザードによって見つけられると、誤入力の可能性がある値として識別され、画面に表示されます。値が表示されたら、それをどのように処理するかを確認できます。リストをスクロールして、[候補] 列に値が表示されている項目を見つけたら、ドロップダウン リストの適切な項目をクリックします。[(修正しない)] を選択して、これらの値がウィザードによって変更されないようにします。処理が完了したら、[次へ] をクリックします。

  8. 元のテーブルに似たクエリを作成するかどうかを確認するメッセージが表示されます。元のテーブルに基づいてフォームやレポートを既に作成してある場合は、このクエリを作成することをお勧めします。[作成する] を選択すると、元のテーブル名は "_OLD" を追加したものに変更され、新しいクエリに元のテーブル名が付けられます。テーブルに基づいて作成されたフォームやレポートは、このクエリを使用するようになりますが、以前と同様に機能します。

  9. [完了] をクリックします。

    指定した設定に基づいて新しいテーブルが作成され、自動的に開きます。結果の確認が終わったら、テーブルを閉じます。

ページの先頭へ

他のプログラムのデータを操作する

Access 2010 には、他のプログラムに格納されたデータを操作する機能が用意されています。

別のファイル形式のデータにリンクした新規の Access データベースを作成する    Access では、テキスト、dBASE、スプレッドシートなど、別のファイル形式のファイルを開くことができます。Access データベースの作成とファイルのリンク付けは自動的に行われます。

  1. Access を起動します。

  2. [ファイル] タブの [開く] をクリックします。

  3. [ファイルを開く] ダイアログ ボックスで、開くファイルの種類を一覧からクリックします。ファイルの種類がわからない場合は、[すべてのファイル (*.*)] をクリックします。

  4. 必要な場合は、開くファイルが含まれているフォルダーを参照します。ファイルを見つけたら、ダブルクリックして開きます。

  5. ウィザードに表示される指示に従って操作します。ウィザードの最後のページで [完了] をクリックします。

既存の Access データベースにデータをインポートするか、データベースにデータをリンクする    別のデータ ソースやプログラムのデータを Access テーブルにインポートして、Access ファイルにデータを挿入するか、Access のデータへのリンクを作成して、元のファイル (Access ファイル以外) にデータを残すことができます。

  1. [外部データ] タブの [インポートとリンク] で、データが格納されている形式をクリックします。

    インポートとリンクが可能なのは、次のソースのデータです。

    • Excel    ワークシートまたは名前付き範囲から Excel のブックにデータをインポートできます。それぞれのワークシートまたは名前付き範囲は、個別にインポートまたはリンクする必要があります。

    • Access    プロセスをデータから切り離し、分割データベースを作成するうえで非常に便利です。具体的には、一方のデータベースにすべてのフォーム、レポート、マクロを格納し、もう一方のデータベースにデータを保管できます。この場合、他のユーザーの作業を中断することなく変更を加えることができます。また、さまざまな Access データベースのデータを 1 か所にまとめ、部署やビジネス パートナー間でデータを簡単に集約することもできます。

    • ODBC データベース    この形式は、多くのデータベース サーバー製品を含め、数多くのプログラムでサポートされています。この形式を使用すると、集約用のデータベースを作成し、異なるシステムのデータをそこで結合できます。

    • テキスト ファイル    シンプルなテキスト ファイルに接続できるほか、Access を使用してそのファイルの内容を変更することもできます。テキスト ファイルを使用すると、各種プログラムで Access のデータを容易に処理できます。

    • XML ファイル    この形式は、Web サーバーを含め、他のさまざまなプログラムとの互換性を確保するうえでも役立ちます。

    • SharePoint リスト    Web ブラウザーでデータを扱いやすくなります。SharePoint リストは、通常は Web ブラウザーで使用します。

    • Data Services    企業内の Web データ サービスに接続できます。

    • HTML ドキュメント   

    • Outlook フォルダー    Outlook フォルダーに接続できるため、連絡先情報を残りのデータと簡単に統合できます。

    • dBase ファイル    dBase は、広く使用されている代替データベース システムで、Access でサポートされています。

      [外部データの取り込み] ダイアログ ボックスが表示されます。

  2. ダイアログ ボックスに表示される指示に従って操作します。

    データベースにデータがインポートまたはリンクされます。ほとんどの形式の場合、データの場所を指定して、データをデータベースに格納する方法を選択する必要があります。

ページの先頭へ

複数バージョンの Access で以前のバージョンのデータベースを使用する

Access 2000 以降で作成した Access データベースまたは Access プロジェクトは、ファイルのセキュリティが有効になっている場合でも、作成に使用したバージョンとそれ以降の任意のバージョンの Access で使用できます。たとえば、Access 2000 で作成したファイルは、Access 2000、Access 2002、Access 2003、Access 2007、Access 2010 で使用できます。

以前のバージョンの Access で作成したデータをそのまま保持しながら、それより新しいバージョンの Access を使用しているユーザーは、そのデータにリンクして新しいバージョンの一部の機能を利用したい場合があります。それには、新しいバージョンで (フォーム、レポート、クエリ、マクロが含まれるがテーブルは含まない) 新しい "フロントエンド" データベースを作成して、以前のバージョンで作成したファイルのテーブルにリンクします。データベースが 1 つのファイルに保存されている場合、またはデータベースがフロントエンド/バックエンド アプリケーションに分割されている場合のそれぞれについて、次のいずれかの手順どおりに行います。

複数バージョンの Access で Access データベース ファイルを使用する

以前のバージョンの Access データベースのテーブルやフォームなどのすべてのオブジェクトが 1 つのファイルに格納されていて、複数のバージョンの Access でそのデータベースを使用する場合は、それらのバージョンで新しいフロントエンド データベースを作成し、元のファイルにリンクします。以前のバージョンの Access を使用しているユーザーは、引き続き元のデータベースを使用できます。それより新しいバージョンを使用しているユーザーは、新しいフロントエンド データベースを介して同じデータにリンクできます。複数のバージョンの Access に対応する必要がある場合は、複数のフロントエンド バージョンを作成できます。

ページの先頭へ

手順 1: 既存のデータベースのコピーを作成して新しい形式で保存する

以下の手順に従って、データベースを最新の 3 つの形式 (Access 2000、Access 2002/2003、Access 2007) のいずれかに変換します。次に説明するコマンドを使用すると、元のデータベースは元の形式で保持され、指定した形式でコピーが作成されます。

  1. Access ファイルを閉じます。ファイルがサーバーまたは共有フォルダーに置かれたマルチユーザー Access データベースの場合は、他のユーザーがそのデータベースを開いていないことを確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. 変換するファイルの場所を参照し、ファイルをダブルクリックして開きます。

    データベースを拡張するかどうかを確認する [データベースの拡張] ダイアログ ボックスが表示されたら、[いいえ] をクリックします。

  5. データベースを起動したときにフォームが開いたら、フォームを閉じます。

  6. [ファイル] タブの [データベースに名前を付けて保存] をクリックします。

  7. [名前を付けて保存] ダイアログ ボックスに、新しいデータベースの名前を入力します。

    注: 新しいデータベースを別の場所に保存しない限り、元のデータベースとは異なる名前をデータベースに付ける必要があります。いずれの場合も、フロントエンド データベースとバックエンド データベースを簡単に区別できるように、別の名前を使用することをお勧めします。ただし、変換先の形式が Access 2007 の場合は、ファイル名の拡張子が .mdb から .accdb に変わるので、同じファイル名を使用してもかまいません。

  8. [保存] をクリックします。

ページの先頭へ

手順 2: コピーのデータベースを分割し、元のファイルをバックエンド データベースとして使用する

変換したデータベースを以下の手順に従って分割します。

  • [データベース ツール] タブの [データの移動] グループで、[Access データベース] をクリックします。 ボタンの画像

  • [データベース分割ツール] ダイアログ ボックスの [データベースの分割] をクリックします。

    必要に応じてバックアップを作成することもできますが、元のデータベースを使用してコピーを再作成するだけでもかまいません。

  • バックエンド データベースの名前を入力し、[分割] をクリックします。

ページの先頭へ

手順 3: 新しいフロントエンドを元のデータベースに接続する

  1. 元のデータベースを削除しないように注意して、データベース分割ツールによって作成されたバックエンド データベースを削除します。

  2. 新しいフロントエンド データベースを元のデータベース内のテーブルにリンクします。そのためには、[外部データ] タブの [インポートとリンク] グループで、[リンク テーブル マネージャー] ボタン イメージ をクリックします。

  3. [すべて選択] をクリックして、[リンク先を更新するためのプロンプトを毎回表示する] チェック ボックスをオンにします。

  4. [OK] をクリックして、古いバージョンのデータベースを参照し、データベースをダブルクリックします。

    すべてが正常に完了すると、選択したすべてのリンク テーブルが正しく更新されたことを示すメッセージが表示されます。

これで、新しいフロントエンド データベースを拡張して、新しいバージョンの Access を使用するユーザー向けの新しい機能をサポートできるようになりました。以前のバージョンのユーザーも、以前のバージョンのデータベースをそのまま使用できます。

ページの先頭へ

複数バージョンの Access でフロントエンド/バックエンド アプリケーションを使用する

Access データベースが既にフロントエンド/バックエンド アプリケーションとして構成されている場合は、フロントエンドを新しいファイル形式に変換できます。バックエンド データベースを変更する必要はありません。

以下の手順は、[データベースに名前を付けて保存] コマンドを使用して、フロントエンド データベースを最新の 3 つの形式 (Access 2000、Access 2002/2003、Access 2007) のいずれかに変換する方法を示します。このコマンドを使用すると、元のデータベースが元の形式で保持され、指定した形式でコピーが作成されます。

  1. フロントエンド データベースを閉じます。ファイルがサーバーまたは共有フォルダーに置かれたマルチユーザー Access データベースの場合は、他のユーザーがそのデータベースを開いていないことを確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. フロントエンド データベースの場所を参照し、データベースをダブルクリックして開きます。

    データベースを拡張するかどうかを確認する [データベースの拡張] ダイアログ ボックスが表示されたら、[いいえ] をクリックします。

  5. データベースを開いたときにフォームが表示されたら、フォームを閉じます。

  6. [ファイル] タブの [データベースに名前を付けて保存] をクリックします。

  7. [名前を付けて保存] ダイアログ ボックスに、新しいデータベースの名前を入力します。

  8. [保存] をクリックします。

これで、新しいフロントエンド データベースを拡張して、新しい機能をサポートできるようになりました。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×