Access 2010 の基本的な作業

注: 最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。 私たちの目的は、このコンテンツがお客様の役に立つようにすることです。 お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに英語の記事があります。

Microsoft Access 2010を使用する方法を学習するために実行できるいくつかのデータベースの基本的な作業を紹介します。

 

この記事の内容

Access とは

Access でのリレーショナル データベース

Access を開いたとき

テンプレートを検索して適用する

データベースを一から作成する

既存の Access データベースを開く

新しいデータベースの使用を開始します。

表を追加する

Access のテーブルに別のソースからデータを貼り付ける

インポートまたは別のソースからデータへのリンク

次のステップ

スプレッドシートまたは他のプログラムからデータをインポートします。

Excel ワークシートを Access にインポートします。

新しいデータベースのテーブルとして Excel ワークシートをインポートします。

テーブル正規化ウィザードを使用してデータを整理します。

その他のプログラムからのデータを操作します。

いくつかのバージョンの Access で以前のバージョンのデータベースを使用します。

複数のバージョンの Access で Access データベース ファイルを使用します。

手順 1: 既存のデータベースのコピーを作成して、新しい形式で保存

手順 2: コピー データベースを分割して、バックエンド データベースとして、元のファイルを使用します。

手順 3: は、新しい接続元のデータベース フロント エンド

複数のバージョンの Access でフロント エンド/バックエンド アプリケーションを使用します。

Access とは

Access 2010 では、データベース アプリケーションの設計と展開ツールの重要な情報を追跡するために使用できます。 お使いのコンピューターにデータを保存することができますか、Web に発行できます: 他のユーザーを web ブラウザーを使用してデータベースを使用できるようにします。

多数のユーザーは、タスクの管理対象段階的に使用しているプログラムが収まるが少ない場合は、Access を使用して起動します。 たとえば、イベント計画表では、しているしのイベントを成功に導くために管理する必要があるすべての詳細情報を管理します。 これを行うワード プロセッサやスプレッドシート プログラムを使用している場合に矛盾があるデータの重複している問題が簡単に実行できます。 、予定表のソフトウェアを使用することができますが、予定表での財務の情報を追跡いない最適です。

Access でのリレーショナル データベース

リレーショナル データベースなどの情報を追跡する必要がある場合があります: (フィールドと呼ばれる) についての一般的なビットに基づいて、されているデータ (テーブルと呼ばれる) の小さいコレクションに分けられている冗長を消すためにまとめて、関連データの宝庫を活用します。. たとえば、顧客の情報を含むテーブル、仕入先の情報を持つテーブルとイベント情報を含むテーブル イベント リレーショナル データベースの計画が含まれます。 イベント情報を持つテーブルには、顧客テーブルに関連付けることにフィールドとフィールドを仕入先テーブルに関連付けることがあります。 これにより、たとえば、仕入先の電話番号が変更された場合情報可能性のある 1 回仕入先テーブルでの代わりにで変更仕入先に関連するすべてのイベント。

Access では、情報の管理ツールを使用してすばやくし簡単にできるようにするリレーショナル データベース アプリケーションを作成します。 ほぼあらゆる種類の在庫、本格的な連絡先は、ビジネス プロセスなどの情報を追跡するためにデータベースを作成することができます。 実際には、Access は、テンプレートを今すぐに使えるさまざまな情報を追跡する初心者の場合でも点を簡単にできます。

Access を開いたとき

Access 2010を起動したときに、Microsoft Office Backstage ビュー、おすすめOffice.comからのコンテンツの表示、現在のデータベースに関する情報を取得、新しいデータベースを作成、既存のデータベースを開く場所を参照してください。

Access 2010 の Backstage ビュー

Backstage ビューでは、調整、維持、または、データベースを共有するのに使用できるその他の多くのコマンドも含まれます。 Backstage ビューのコマンドは、一般的に、データベース内のオブジェクトに、データベース全体に適用されます。

注: [ファイル] タブをクリックして、いつでも Backstage ビューに取得できます。

ページの先頭へ

テンプレートを検索して適用する

Access には、さまざまなデータベースの作成プロセスを迅速に使用できるテンプレートを使用します。 テンプレートは、すべてのテーブル、クエリ、フォーム、および特定のタスクを実行するために必要なレポートがすぐに使用できるデータベースです。 たとえば、この問題を追跡、連絡先の管理または経費の記録を残すに使用できるテンプレートがあります。 一部のテンプレートには、その使用をわかりやすくするためのいくつかのサンプル レコードが含まれます。 データベースのテンプレートを使用することができますか、ニーズに合わせてカスタマイズすることができます。

テンプレートを適用するには、データベースを見つけて、次の操作を行います。

  1. [ファイル] タブの [新規] をクリックします。

  2. [使用できるテンプレート] には、次のいずれかの操作を行います。

    • 、最近使用したテンプレートを再利用するには、最近使用したテンプレート] をクリックしてテンプレートを選びます。

    • 既にインストールされているテンプレートを使用するのには、マイ テンプレート] をクリックし、[テンプレートを指定します。

    • Office.com、 Office.com テンプレート] の下のテンプレートを検索テンプレート カテゴリをクリックして、必要なテンプレートを選択、ダウンロードをお使いのコンピューターに Office .com からテンプレートをダウンロードする] をクリックします。

      Access からの Office.com からテンプレートを検索することもできます。 Office.com の検索] ボックスに、1 つまたは複数の検索語句を入力し、[検索] の矢印] をクリックします。

  3. 必要に応じて、データベースを作成する場所を指定する [ファイル名] ボックスの横にある [フォルダー] アイコンをクリックします。 特定の場所を指定しない、ファイル名] ボックスの下に表示される既定の場所にデータベースが作成されます。

  4. [作成] をクリックします。

Access では、データベースを作成し、使用するために表示します。

ページの先頭へ

データベースを一から作成する

Access を使用してデータベースを作成する概念を紹介するより詳細な場合は、データベース設計の基本の記事を参照してください。

ニーズに合ったテンプレートがない、または Access で使用する別のプログラムで、データがある場合、を決定する場合は、最初からデータベースを作成することをお勧めします。 Access 2010 で、選択がある: 標準のデスクトップ データベースでは、または web データベースを作成します。

Web データベースの詳細については、「 Web で共有するデータベースを作成する」を参照してください。

新しいデータベースを作成するには、次の操作を行います。

  1. Access を起動します。

  2. Backstage ビューの [新規作成] タブでは、空のデータベースまたは空の Web データベースをクリックします。

    重要: ここで行った選択は、データベースにどのような機能を利用決定されます。 デスクトップ データベースを Web に公開することはできず、web データベースでは集計クエリなど、一部のデスクトップ機能がサポートされていません。

  3. 右側の [ファイル名] ボックスで、データベースの名前を入力します。

    ファイルを作成する場所を変更するには、ファイル名] ボックスの横にある参照 ボタンの画像 ] をクリックを参照し、新しい場所を選択して、[ OK] をクリックします。

  4. [作成] をクリックします。

    Access では、データベースを作成し、 データシート ビューで、(Table1 という名前) の空のテーブルを開きます。

  5. Access では、 [追加] をクリックして新しいテーブルの列の最初の空白のセルにカーソルを置きます。

    データを追加するには、入力を開始、または] セクションで、Access のテーブルに別のソースからデータを貼り付けるには、この記事の後半で説明するように、別のソースからデータを貼り付けることができます。

    注: 

    • データシート ビューでデータを入力するは非常に Excel ワークシートのデータを入力するように設計されています。 メインの制限は、連続した行と列を位置のデータシートの左上隅でデータを入力する必要があります。 空の行を追加して、データの書式を設定しない方法を試してそのとする列がありますを Excel ワークシートのため、テーブル内の領域が無駄する、します。 テーブルには、データだけが表示されます。 フォームとレポートを後で設計するデータの視覚的なプレゼンテーションのすべてが行われます。

    • データを入力するときに、テーブルの構造が作成されます。 データシートに新しい列を追加する、いつでも新しいフィールドは、テーブルで定義されます。 Access では、入力したデータの種類に基づいてフィールドのデータ型を設定します。 たとえば、日付の値だけを入力した列を使っている場合に、アクセスはそのフィールドのデータ型を日付/時刻に設定されます。 後でそのフィールドに、(名前または電話番号) などの日付以外の値を入力すると、値の列のデータ型に一致しないことを通知するメッセージが表示されます。 可能であれば、する必要がありますを計画する表各列は同じ種類のデータが含まれているようにテキスト、日付、数字、その他の種類であるかどうか。 これにより、簡単に作成するクエリ、フォーム、およびレポートを使用するデータだけを選択します。

まだデータを入力したくない場合は、閉じる ボタンの画像 をクリックします。

注: 保存せずに終了する場合、アクセスは Table1 を削除します。

ページの先頭へ

既存の Access データベースを開く

ヒント: 開き、[ファイル] タブが含まれている最後のいくつかのデータベースのいずれかをすばやく開くには、最近使用したファイル] をクリックし、ファイル名をクリックします。

  1. [ファイル] タブの [開く] をクリックします。

  2. [開く] ダイアログ ボックス内のショートカット] をクリックして、または、 [ファイルの場所] ボックスに、ドライブまたは使用するデータベースを含むフォルダーをクリックします。

  3. フォルダーの一覧で、データベースが含まれているフォルダーを開くまでフォルダーをダブルクリックします。

  4. データベースを確認した場合、次のいずれかの操作を行います。

    • データベースを既定の開くモードで開く] をダブルクリックします。

    • 開くには、データベースを共有マルチ ユーザー環境では、他のユーザーと両方読み書きできる、データベースを同時にできるように、[開く] をクリックします。

    • 読み取り専用のアクセスのため、データベースを開いて表示を変更することができますが、編集ができませんが、[開く] ボタンの横にある矢印をクリックし、[読み取り専用として開く] をクリックします。

    • 開くには、データベースを排他モードの場合は、他のユーザーが開けないように、[開く] ボタンの横にある矢印をクリックし、[排他モードで開く] をクリックします。

    • 読み取り専用の access でデータベースを開き、[開く] ボタンの横にある矢印をクリックし、[排他モードで読み取り専用で開く] をクリックして他のユーザーはまだ、データベースを開きますが、読み取り専用のアクセス権があるのみ。

開きたいデータベースが見つからない場合    

  1. [開く] ダイアログ ボックスで[このコンピューターショートカットをクリックして、または、 [ファイルの場所] ボックスに、[マイ コンピューター] をクリックします。

  2. ドライブの一覧でと思われるドライブを右クリック可能性がありますデータベースが存在し、[検索] をクリックします。

  3. 検索条件を入力し、enter キーを押して、データベースの検索します。

  4. データベースがある場合は、検索結果] ダイアログ ボックスでそれをダブルクリックして開きます。

    [開く] ダイアログ ボックスの検索が開始されているためには、データベースを開く前にキャンセルをその] ダイアログ ボックスでをクリックしてください。

直接 (dBASE、Paradox、Microsoft Exchange の場合は、Excel など) を外部ファイル形式でデータ ファイルを開くことができます。 直接、 ODBC データ ソース、Microsoft SQL Server または Microsoft FoxPro などを表示できます。 Access は自動的にデータ ファイルと同じフォルダーに新しい Access データベースを作成し、リンクを外部データベース内の各テーブルに追加します。

ページの先頭へ

新しいデータベースの使用を開始します。

テンプレートによっては、使用するには、新しいデータベースの使用を開始するのには、次のいずれかの操作する必要があります。

  • Access には、ユーザーの空の一覧と共に [ログイン] ダイアログ ボックスが表示されている場合は、開始するのには、次の手順を使用します。

    1. 新しいユーザー] をクリックします。

    2. ユーザー詳細]フォームに入力します。

    3. [保存して閉じる] をクリックします。

    4. 入力したユーザー名を選択し、[ログイン] をクリックします。

  • Access には、空のデータシートが表示されている場合は、データシートにデータを直接入力を開始またはその他のボタンや、データベースを操作するタブをクリックできます。

  • Access には、作業の開始ページが表示されている場合は、データベースの詳細については、そのページにリンク] をクリックしてまたはその他のボタンや、データベースを操作するタブをクリックできます。

  • 表示されますが、メッセージ バーのセキュリティの警告メッセージをテンプレートのソースが信頼できる場合は、[コンテンツの有効化] をクリックします。 データベースにログインが必要な場合は、もう一度ログインする必要があります。

デスクトップと web データベースでは、するもを開始する次のいずれかの手順します。

ページの先頭へ

表を追加する

既存のデータベースに新しいテーブルを追加するには、作成] タブの [テーブル] のツールを使用します。

[作成] タブの [テーブル]

注: Web データベースでは、 [テーブル] コマンドだけはテーブル] で [利用できます。

どのビューで起動するに関係なく常に切り替える他のビューに Access ウィンドウのステータス バーの [表示] ボタンを使用しています。

データシート ビューで空白のテーブルを作成します。    データシート ビューで、すぐにデータを入力し、アクセスが行われるテーブルの構造を作成できます。 フィールド名番号が割り当てられ (Field1、Field2 など) と入力したデータの種類に応じて、フィールドのデータ型に設定します。

  1. [作成] タブの [テーブル] グループで、テーブル ボタンの画像 ] をクリックします。

  2. テーブルが作成され、[追加] をクリックする列の最初の空白のセルにカーソルを配置します。

  3. データを追加するには、最初の空のセルの入力を開始、または、この記事の後半で説明するように、別のソースからデータを貼り付けることができます。

    • 列 (フィールド) の名前を変更するには、列見出しをダブルクリックし、[新しい名前を入力します。

      ヒント: 内容が含まれているデータを表示することがなくを指定することは、各フィールドにわかりやすい名前を付けます。

    • 列を移動するには、その列の見出しをクリックして選択し、目的の場所にドラッグします。 複数の隣接する列を選択し、化すべての新しい場所にドラッグしてやもことができます。

      テーブルには、その他のフィールドを追加するにデータシート ビューで、 [追加] をクリックして列に入力を開始するか、または新しいフィールドを追加するには、[フィールド] タブで追加 & を削除するグループのコマンドを使用します。

開始デザイン ビューでテーブルを作成します。    デザイン ビューでは、最初に、新しいテーブルの構造を作成します。 か、ビューに切り替えデータシートにデータを入力するかなど、他のメソッドを使用してフォームを使用してデータを入力します。

デザイン ビューは、web データベースのテーブルにします。

  1. [作成] タブで、[テーブル] グループの [テーブル デザイン] をクリックします。 ボタンの画像

  2. テーブルには、各フィールドのフィールド名] 列に名前を入力し、[データ型の一覧から、[データ型を選択します。

  3. [説明] 列で、各フィールドの追加情報を入力できます。 カーソル位置をそのフィールドには、[フィールド リスト] ウィンドウからフォームまたはレポートにフィールドをドラッグして作成されたすべてのコントロールのステータス バーのテキストとして使用されるときに、ステータス バーに入力した説明が表示されます。、、フォーム ウィザードまたはレポート ウィザードで、そのフィールドの作成されているすべてのコントロール。

  4. すべてのフィールドを追加した後は、テーブルを保存します。

    • [ファイル] タブで [保存] をクリックします。

  5. データシート ビューに切り替えで最初の空のセルをクリックすると、入力して、いつでもテーブルにデータを入力を開始することができます。 次のセクションで説明するように、別のソースからデータを貼り付けることもできます。

SharePoint リストに基づくテーブルを作成します。    SharePoint リストの場合は、ユーザーのアクセスを持たないによりデータを使用できます。 さらに、リストのデータは、デスクトップ コンピューターに保存されたファイルよりデータ損失の優れた保護は、一般的に、サーバーに格納されます。 新しいリストの場合は、開始するか既存のリストにリンクすることができます。 リストを作成する SharePoint サイトに十分なアクセス許可が必要これは、サイト、連絡先のオプションの詳細は、SharePoint 管理者によって異なることができます。

この機能は、Web データベースで使用できません。

  1. [作成] タブの [テーブル] で、[SharePoint リスト] をクリックします。

  2. 連絡先またはイベントなど、標準的な SharePoint リストを作成するのにには、リスト テンプレートのいずれかを使用できます。

    カスタム リストを作成するのにはまたはにリンクする、または既存のリストをインポートすることもできます。 必要なオプションをクリックします。

  3. いずれかのリスト テンプレートまたはユーザー設定リストを作成する場合は、プロセスに従って、新しいリストの作成] ダイアログ ボックスが開きます。 既存のリストを使用する場合は、できるように、[外部データの取り込み] ダイアログ ボックスが開きます。

テーブルの詳細については、「テーブルの概要」を参照してください。

ページの先頭へ

Access のテーブルに別のソースからデータを貼り付ける

Excel などの別のプログラムで、データが格納されている場合は、コピーして、Access のテーブルにデータを貼り付けます。 一般に、これが最適データが既にの列に区切られている場合 Excel ワークシートのようにします。 Word のデータが処理プログラムの場合は、最初にタブを使用してデータの列が区切ら word 処理プログラムで、[テーブルにデータを変換またはデータをコピーしてください。 データは、任意の編集または操作 (姓と名に完全な名前を区切るなど) を必要とする場合は次のデータをコピーする前に Access を使い慣れていない場合は特にする可能性があります。

空のテーブルにデータを貼り付けるときに、どのような種類のデータ検出によっては、各フィールドのデータ型が設定されます。 たとえば、貼り付けられたフィールドには、日付の値だけが含まれる、アクセスは [日付/時刻データを適用そのフィールドに入力します。 貼り付けられたフィールドでのみ単語「はい」および"no"が含まれている場合、[はい] が適用されますデータ型のフィールドにします。

Access が貼り付けたデータの最初の行の内容に応じて、フィールドを名前します。 貼り付けたデータの最初の行が行の種類のような場合は、最初の行がデータの一部であるし、汎用名前 (Field1、Field2、) フィールドを割り当てるアクセスを決定します。 貼り付けたデータの最初の行と同じ行にない場合は、アクセス、フィールド名として、最初の行を使用し、実際のデータの最初の行を除外します。

[標準] フィールドの名前の割り当て、混乱を回避するには、できるだけ早く] フィールドの名前を変更する必要があります。 次の手順で行います。

  1. [ファイル] タブで、保存テーブルを保存する] をクリックします。

  2. データシート ビューでは、各列の見出しをダブルクリックし、列の名前を入力します。

  3. テーブルをもう一度保存します。

ページの先頭へ

インポートまたは別のソースからデータへのリンク

Access で使用する別のプログラムでファイルを収集したしてデータを使用するがあります。 Access でのデータを使用するなどの他のプログラムでのデータを格納しているユーザーと作業する. または、柄、データの複数の異なるソースし、必要がある場所をまとめてにすべての詳細な分析の「ランディング パッド」します。

Access では、簡単にインポートまたはその他のプログラムからのデータをリンクします。 Excel ワークシートから、別の Access データベースのテーブルから、SharePoint リスト、またはからさまざまなその他のソースのいずれかのデータのインポートできます。 プロセスは、データ ソースによって少し異なりますが、次の手順は使い始めるときに表示されます。

  1. [外部データ] タブの [インポート & リンク] グループからインポートするファイルの種類のためのコマンドをクリックします。

    たとえば、Excel ワークシートからデータをインポートする場合は、 Excelをクリックします。 適切なプログラムの種類] が表示されない場合は、その他の] をクリックします。

    注: インポート & リンク] で適切な形式できない場合が、データの作成元のプログラムを起動し、そのプログラムを使用して、( 区切りテキスト ファイル) などのアクセスをサポートしているファイル形式でデータを保存する必要があります。、、[インポートや、データにリンクします。

  2. 外部データの取り込み] ダイアログ ボックスで、参照元のデータ ファイルを参照] をクリックするか、ファイル名] ボックスに元のデータ ファイルの完全なパスを入力します。

  3. 現在のデータベース内のデータを保存する方法と場所を指定するには、希望するオプションをクリックします。 新しいテーブルを作成、インポートしたデータを使用して、[データ ソースへのリンクを維持するリンク テーブルを作成したりできます。

  4. [OK] をクリックします。

    によっては、選択、リンク オブジェクト] ダイアログ ボックス、またはオブジェクトのインポート] ダイアログ ボックスが開きます。

  5. プロセスを完了するのにには、ダイアログ ボックスを使用します。 インポートまたはリンクのオプションを選択した正確な手順を実行するかによって決まります。

  6. ウィザードの最後のページで、[完了] をクリックします。

    インポートする場合は、アクセスが完了したインポート操作の詳細を保存するかどうかを確認します。

  7. もう一度同じインポート操作を実行している場合は、インポート手順の保存] をクリックし、[詳細情報を入力します。

    保存済みのインポートをクリックして、[外部データ] タブで [インポート] グループで、インポート定義] をクリックし、[実行] をクリックしてインポート操作を簡単に再生して、[ことができます。

  8. 操作の詳細を保存したくない場合は、[閉じる] をクリックします。

アクセスでは、新しいテーブルにデータをインポートし、ナビゲーション ウィンドウで [テーブル] でテーブルを表示します。

Access にデータをインポートする方法の詳細については、この記事の「参照」セクションのリンクに従います。

ページの先頭へ

次のステップ

上の目標は、残りのデザイン プロセスが異なりますが、クエリ、フォーム、レポート、およびマクロの作成を検討する可能性があります。 この記事では、その他のデータベース オブジェクトの作成方法についてはありません。

詳細については、以下の記事を参照してください。

ページの先頭へ

スプレッドシートまたは他のプログラムからデータをインポートします。

他のデータベースまたはスプレッドシート プログラムの場合は、おそらくについて基本が次のアプリケーションの機能と、どのようなデータベースを使用します。 リレーショナル データベースを作成することにより、その他の多くのデータベース アプリケーションからとは異なるアクセスし、[高度なクエリ、フォーム、およびレポートを作成するためのツールを提供することでほとんどのスプレッドシート プログラムから異なるさらにします。 Access では、SQL Server などの他のデータベース プログラムを操作するためのさまざまなオプションも提供します。

Excel ワークシートを Access にインポートします。

多数のユーザーは、最初に Excel のリストを作成した後、アクセスを調査を開始します。 Excel は、箇条書きを開始する優れた場所では、リストがにつれて、整理や更新がしにくくなります。 リストに移動へのアクセスには、通常、論理、次の手順です。

データベースのテーブルは、行と列のデータが保存されていることで、ワークシート構造内と同じです。 その結果は通常は簡単にデータベースのテーブルにワークシートをインポートします。 ワークシートのデータを格納して、データベースに保存することの主な違いが、データを整理する方法です。 新しいデータベースのテーブルとしてワークシート全体をインポートするだけでの整理や、データを更新すると、ワークシートには、冗長なデータが含まれている場合に特にに関連する問題は解決されません。 これらの問題を解決するは必要がありますに分割するスプレッドシートのデータ別のテーブルでは、関連するデータが含まれています。 テーブルにデータを配置する方法の詳細については、「データベース設計の基本」を参照してください。

このプロセスを完了することができるテーブル正規化ウィザードの機能にアクセスします。 ウィザードでは、テーブルにデータをインポートした後、テーブルを他のテーブルのいずれかの重複しないデータを含む別々 のテーブルに分割できます。 ウィザードでは、テーブル間のために必要なリレーションシップも作成します。

ページの先頭へ

新しいデータベースのテーブルとして Excel ワークシートをインポートします。

  1. [ファイル] タブの [新規作成] をクリックし、[空のデータベース] をクリックします。

  2. ファイル名] ボックスに、新しいデータベースの名前を入力し、[作成] をクリックします。

    新しいデータベースを開くし、新しい空のテーブル、Table1 が作成されます。

  3. Table1 を閉じます。

    Table1 のデザインに変更を保存するメッセージが表示されたら、[いいえ] をクリックします。

  4. [外部データ] タブの [インポート & リンク] グループで [ Excel] をクリックします。 ボタン イメージ

  5. 外部データの取り込み] ダイアログ ボックスで、[参照] をクリックします。

  6. ファイルを探すには、ファイルを開く] ダイアログ ボックスを使用します。

  7. ファイルを選び、[開く] をクリックします。

  8. 外部データの取り込み] ダイアログ ボックスで、[カレント データベースの新しいテーブルにソース データのインポート] オプションが選択されていることを確認します。

  9. [OK] をクリックします。

    スプレッドシートのインポート ウィザードが開始され、データに関するいくつかの質問が表示されます。

  10. 次の手順については、次へ] または [戻るページ間を移動する] をクリックします。 ウィザードの最後のページで、[完了] をクリックします。

    注: Access では、完了したインポート操作の詳細を保存するかどうかを確認します。 実行する可能性がある場合は、同じインポート操作をもう一度、 [はい] をクリックし、詳細情報を入力します。 外部データ] タブの [インポート] で保存済みのインポート] をクリックして、将来の操作を簡単に再生して、ことができます。 操作の詳細を保存したくない場合は、[閉じる] をクリックします。

Access では、新しいテーブルにデータをインポートし、ナビゲーション ウィンドウ内のすべてのテーブルの下に表示します。

ページの先頭へ

テーブル正規化ウィザードを使用してデータを整理します。

Access のテーブルにデータをインポートした後、冗長なデータをすばやく識別するのにテーブル正規化ウィザードを使用することができます。 ウィザードは、別のテーブルにデータを整理するには、最も効率的に格納されるようにするための簡単な方法を提供します。 Access では、バックアップとして元のテーブルを保持し、データベース アプリケーションの基礎として使用できる新しいテーブルが作成されます。

  1. 分析するテーブルを含む Access データベースを開きます。

  2. [データベース ツール] タブの [分析] グループで、テーブルを分析する] をクリックします。

    テーブル正規化ウィザードを開始します。

    ウィザードの最初の 2 つのページには、短いチュートリアルが含まれている、完了、ボタンの例を参照] をクリックすることができます。 代わりにする] チェック ボックスを表示、概要を説明したページが表示されない場合概要を説明したページを表示するか?、] チェック ボックスをオンにし、戻る2 倍には、概要を参照してください] をクリックします。 概要を読み上げた後に、もう一度概要を説明したページが表示されない場合は、オフにできます、概要を説明したページを表示するか?チェック ボックスをオンします。

  3. [どのテーブルには、多数のレコードの重複値を持つフィールドが含まれていますか? ] ページで、[分析するテーブルを選択して、[次へ] をクリックします。

  4. ウィザードに移動して、テーブル フィールドを決定することができますか、その意思決定を自分自身で行うことができます。 ウィザードの候補を実行すると、ウィザードの次のページで [テーブルのレイアウトに変更を行うもできます。

    注: ウィザードにどのテーブルに格納するフィールドを決定する場合は、その選択できないことがあります常に適した、データを操作する多くのデータがない場合に特にします。 ウィザードの結果を慎重に確認する必要があります。 その一方で、ウィザードが提案を検討しているものとは方が効率的な組織のため、ウィザードの決定が少なくとも一度することをお勧めします。 候補を気に入らない場合、フィールドを手動で、まだ並べ替えることができ、常に戻る] をクリックし、すべてのフィールドを配置することができます。

  5. [次へ] をクリックします。 このページでは、フィールドを含むテーブルを指定します。 ウィザードを使う場合は、リレーションシップ ラインで接続されている複数のテーブルが表示されます。 それ以外の場合、すべてのフィールドを含む 1 つだけのテーブルが作成されます。 どちらの場合は、このページで変更をことができます。

    • テーブルからフィールドをドラッグして、これらのフィールドを含む新しいテーブルを作成するのには、ページの空白領域にできます。 Access には、テーブル名が表示されます。

    • これらが保存されるより効率的にあると判断した場合、別のテーブルに 1 つのテーブルからフィールドをドラッグできます。

    • ほとんどのテーブルをIDまたは生成された一意の IDフィールドが与えられます。 [ID] フィールドの詳細については、ウィザードの右上隅にある [ヒント] をクリックします。

    • 変更を取り消すには、[元に戻す] ボタンをクリックします。

    • テーブルの名前を変更するには、のタイトル バーをダブルクリックして、新しい名前を入力し、[ OK] をクリックします。

  6. フィールドに必要なレイアウトを作成したら、[次へ] をクリックします。

  7. ウィザードでは、類似の値を持つレコードが見つかると、これらの値として入力ミスの可能性のあるエラーを特定するされ、画面の操作を確認できます。 いずれかの修正] 列に値を持つを検索し、[ドロップダウン リストで適切なアイテム] をクリックして一覧をスクロールします。 選択(としてそのまま-が)ウィザードが値に変更を加えるようにします。 完了したら、[次へ] をクリックします。

  8. ウィザードでは、元のテーブルのようなクエリを作成するかどうかを確認します。 既に作成したフォームとレポートを元のテーブルに基づく場合、このようなクエリの作成をお勧めします。 クエリを作成する場合は、テーブル名に"_OLD"を追加して元のテーブルの名前が変更され、元のテーブルの名前を使用して新しいクエリの名前を [されます。 フォームおよびレポートの基にした表のようになりましたが、それぞれのデータのクエリを使用して、以前と同様に作業を続けられますがします。

  9. [完了] をクリックします。

    ウィザードでは、として指定した場合は、新しいテーブルを作成し、開きます。 結果の確認が完了したら、それらを閉じます。

ページの先頭へ

その他のプログラムからのデータを操作します。

Access 2010 では、他のプログラムで保存されているデータを操作するための機能を提供します。

別のファイル形式でデータにリンクする新しい Access データベースを作成します。    Access を使用すると、テキスト、dBASE、スプレッドシートなどの別のファイル形式でファイルを開きます。 Access は自動的に Access データベースを作成し、ファイルのリンクします。

  1. Access を起動します。

  2. [ファイル] タブの [開く] をクリックします。

  3. [開く] ダイアログ ボックスの一覧で表示ファイルの種類] をクリックします。 ファイルの種類のことを確認していない場合は、クリックしてすべてのファイル (*. *)します。

  4. 必要な場合は、ファイルを開きたいを含むフォルダーを参照します。 ファイルが見つかったら、開くにをダブルクリックします。

  5. ウィザードに表示される手順に沿って操作します。 ウィザードの最後のページで、[完了] をクリックします。

既存の Access データベースにデータをインポートまたはリンクします。    Access のテーブルに他のデータ ソースやプログラムからは、Access ファイル内のデータが含まれているかにリンクできますデータ アクセスからできるように、データは、元のファイル (Access ファイル) の外部でできるように、データをインポートできますか。

  1. [外部データ] タブの [インポート & リンク] グループで、データが保存されている書式設定] をクリックします。

    インポートまたは次のソースからデータにリンクできます。

    • Excel    ワークシートまたは Excel ブックの名前付き範囲からデータを移動できます。 各ワークシートか名前付き範囲をインポートまたは、個別にリンクする必要があります。

    • Access    分割データベースを作成する、データから、プロセスを分離するに便利です。 つまり、1 つのデータベースを使用して、フォーム、レポート、および、マクロを含むし、別のデータベースにデータを維持できます。 他のユーザーの作業を中断することがなく、改善点を作成できます。 1 つを簡単にデータを集計する部門やビジネス パートナーの間のさまざまな Access データベースからデータを組み合わせることもできます。

    • ODBC データベース    多くのアプリケーションでは、多くのデータベース サーバー製品など、この形式をサポートします。 これにより、さまざまなシステムからのデータを結合する「ランディング パッド」データベースを作成できます。

    • テキスト ファイル    単純なテキスト ファイルに接続できるしてファイルの内容を変更するのにはアクセスを使用することもします。 Access データを簡単に使用しているプログラムのさまざまなことができます。

    • XML ファイル    この形式は、さまざまな一部の web サーバーなどの他のプログラムとの互換性も提供します。

    • SharePoint リスト    これにより、データは web ブラウザーでは、SharePoint リストを使用する標準的な方法で使用します。

    • データ サービス    組織内のデータの web サービスに接続できます。

    • HTML ドキュメント    

    • Outlook フォルダー    残りのデータをより簡単に連絡先情報と統合するために、Outlook フォルダーに接続できます。

    • dBase ファイル    dBase が Access でサポートされている一般的な代替データベース システムです。

      [外部データの取り込み] ダイアログ ボックスが表示されます。

  2. ダイアログ ボックスの指示に従います。

    Access をインポートするか、データベースにデータをリンクします。 ほとんどの形式のデータの場所を指定して、データベースに格納するデータの表示方法を選択し、ください。

ページの先頭へ

いくつかのバージョンの Access で以前のバージョンのデータベースを使用します。

データベースまたはプロジェクトを使って、バージョンの Access で作成されたまたは以降のバージョンの Access データベースまたは Access プロジェクトは、Access 2000 またはそれ以降に作成されている場合、ファイルのセキュリティが有効になっている場合でもします。 たとえば、Access 2000 ファイルは、Access 2000、Access 2002、Access 2003、Access 2007 と Access 2010 で使用できます。

解決策を以前のバージョンの Access でデータを残したいが、以降のバージョンの Access でユーザーであり、そのデータへのリンクがいくつかの以降のバージョンの機能も利用できるようにするがあります。 ソリューションでは、(は、フォーム、レポート、クエリ、マクロ、テーブルを含む)、以降のバージョンで新しい「フロント エンド」データベースを作成し、以前のバージョンのファイル内のテーブルにリンクします。 データベースが 1 つのファイルが含まれているか、 フロントエンド/バックエンド アプリケーションに分割されているかどうかによって、次の手順のいずれかを使用します。

複数のバージョンの Access で Access データベース ファイルを使用します。

1 つのファイルに含まれているすべてのテーブル、フォーム、およびその他のオブジェクトを以前のバージョンの Access データベースのいくつかのバージョンの Access でデータベースを使用する場合は、以降のバージョンで新しいフロント エンド データベースを作成し、元のファイルにリンクすることができます。 元のデータベースを使用するのには、引き続き以前のバージョンの Access を持っているユーザーです。 以降のバージョンを持っているユーザーは、新しいフロント エンド データベースを使用して、同じデータにリンクします。 複数のバージョンの Access に対応する必要がある場合は、フロント エンドの複数のバージョンを作成できます。

ページの先頭へ

手順 1: 既存のデータベースのコピーを作成して、新しい形式で保存

3 つの最新形式のいずれかにデータベースを変換するのには、次の手順を使用: Access 2000、Access 2002-2003、または Access 2007 します。 このコマンドは、元の形式で元のデータベースを保持され、指定した書式のコピーを作成します。

  1. Access ファイルを閉じます。 ファイルがある場合、サーバーまたは共有フォルダーに置かれた Access データベースをほかのユーザーが開いているであることを確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. に変換するファイルの場所を参照して、ダブルクリックして開きます。

    データベースの拡張] ダイアログ ボックスが表示されている場合は、データベースを追加するかどうかを確認いいえ] をクリックします。

  5. フォームを開いた場合、データベースを起動したときに、フォームを閉じます。

  6. [ファイル] タブで、データベースの名前を付けて保存] をクリックします。

  7. 名前を付けて保存] ダイアログ ボックスで、新しいデータベースの名前を入力します。

    注: しない限り、新しいデータベースを保存すると、別の場所には、その名前が元のデータベースと異なる場合があります。 どちらの場合、通常はお勧め別の名前を使用するフロント エンド データベースとバックエンド データベースの間を簡単に区別できるようにします。 ただし、Access 2007 形式に変換する場合、ファイル名拡張子 .mdb からに変更 .accdb、同じファイル名を使用できるようにします。

  8. [保存] をクリックします。

ページの先頭へ

手順 2: コピー データベースを分割して、バックエンド データベースとして、元のファイルを使用します。

変換されたデータベースを分割するには、次の手順を使用します。

  • [データベース ツール] タブの [データの移動] で、 Access データベース] をクリックします。 ボタン イメージ

  • [データベースの分割] ダイアログ ボックスで、データベースの分割

    可能性のあるも再コピーを作成した元のデータベースを使用して、必要な場合は、バックアップを作成することができます。

  • バックエンド データベースの名前を入力し、[分割] をクリックします。

ページの先頭へ

手順 3: は、新しい接続元のデータベース フロント エンド

  1. データベース分割ツールによって作成されたバックエンド データベースを削除する: されて、元のデータベースを削除しないように注意します。

  2. 元のデータベース内のテーブルに新しいフロント エンド データベースをリンクする: [外部データ] タブの [インポート & リンク] グループで [リンク テーブル マネージャー] をクリックします。 ボタンの画像

  3. [すべて選択] をクリックし、[常に新しい場所にメッセージを表示する] チェック ボックスを選択します。

  4. [OK] をクリックして、[以前のバージョンのデータベースを参照して、それをダブルクリックします。

    すべてうまく場合は、[選択したすべてのリンク テーブルが正しく更新されたことを示すメッセージが表示されます。

これで、新しいバージョンの Access を持つユーザーの新機能をサポートする場合は、新しいフロント エンド データベースを強化できます。 以前のバージョンを持つユーザーは、以前のバージョンのデータベースを使用する続行できます。

ページの先頭へ

複数のバージョンの Access でフロント エンド/バックエンド アプリケーションを使用します。

Access データベースが既にフロントエンド/バックエンド アプリケーションをしている場合は、フロント エンドを新しいファイル形式に変換できます。 バックエンド データベースの変更は不要です。

次の手順は、次の 3 つの最新形式のいずれかに、フロント エンド データベースを変換するデータベースに名前を付けて保存] コマンドを使用する方法を示します。 Access 2000、Access 2002-2003、または Access 2007 します。 このコマンドは、元の形式で元のデータベースを保持され、指定した書式のコピーを作成します。

  1. フロント エンド データベースを閉じます。 ファイルがある場合、サーバーまたは共有フォルダーに置かれたマルチ ユーザー データベース、そのほかのユーザーが開いていることを確認します。

  2. Access 2010 を起動します。

  3. [ファイル] タブの [開く] をクリックします。

  4. フロント エンド データベースの場所を参照して、ダブルクリックして開きます。

    データベースの拡張] ダイアログ ボックスが表示されている場合は、データベースを追加するかどうかを確認いいえ] をクリックします。

  5. フォームは、データベースを開いたときに表示されている場合は、フォームを閉じます。

  6. [ファイル] タブで、データベースの名前を付けて保存] をクリックします。

  7. 名前を付けて保存] ダイアログ ボックスで、新しいデータベースの名前を入力します。

  8. [保存] をクリックします。

これで、新しい機能をサポートする場合は、新しいフロント エンド データベースを強化できます。

ページの先頭へ

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×