Access 2007 の使用を開始する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office Access 2007 の使用方法は、Access を初めて使用する場合、別のデータベースまたは表計算プログラムから Access にデータを移動している場合、以前のバージョンの Access からアップグレードしている場合のそれぞれによって異なります。ここでは、それぞれの状況に関する質問とその対応について説明します。

目的

Access を初めて使用する

スプレッドシートまたは他のプログラムからデータをインポートする

複数バージョンの Access で以前のバージョンのデータベースを使用する

Access を初めて使用する

Office Access 2007 には、データベースを作成する処理を今まで以上に簡略化する改善点が多数加えられています。以前に Access でデータベースを作成したことがある場合は、これらの新機能と改善された機能を使って、データベースの作成処理がどれだけ高速化されたかがわかります。

Office Access 2007 を起動して最初に表示される画面は、[Microsoft Office Access - 作業の開始] ページです (ただし、特定の Access データベース ファイルをダブルクリックして Access を起動し、そのデータベースが開いている場合を除く)。[Microsoft Office Access - 作業の開始] ページは、新しいデータベースを作成する、既存のデータベースを開く、Microsoft Office Online で提供されているコンテンツを表示するなどの操作を行う場合の開始点です。

テンプレートを使用してデータベースを作成する.

Microsoft Office Online からテンプレートをダウンロードする

データベースを最初から作成する

空のデータベースを作成する

表を追加する

外部ソースのデータを Access のテーブルに貼り付ける

外部ソースからデータをインポートする

Access の既存のデータベースを開く

Access 2010 には、データの追跡や共有、レポート作成などを簡単に行うための便利なツールが用意されています。

テンプレートを使用してデータベースを作成する

Access には、データベースの作成処理を高速化するために使用できる、さまざまなテンプレートが備わっています。テンプレートとは、特定のタスクを実行するためのテーブル、クエリ、フォーム、およびレポートがすべて含まれている既定のデータベースのことです。たとえば、問題の追跡、連絡先情報の管理、支出の記録などのために使用できるテンプレートがあります。一部のテンプレートには、テンプレートの使い方をわかりやすくするためのサンプル レコードが含まれています。テンプレート データベースはそのまま使用することも、ニーズに合わせてカスタマイズすることもできます。

  1. Access をまだ実行していない場合は、起動します。

    データベースを既に開いてある場合は、次の操作を行って [Microsoft Office Access - 作業の開始] ページを表示します。

    • Microsoft Office ボタン Office ボタンの画像 をクリックして、[データベースを閉じる] をクリックします。 ボタン イメージ

      [Microsoft Office Access - 作業の開始] ページ

  2. [Microsoft Office Access - 作業の開始] ページの [お勧めのオンライン テンプレート] に複数のテンプレートが表示され、Access ウィンドウの左側にある [テンプレート カテゴリ] でカテゴリの 1 つをクリックすると、追加のテンプレートが表示されます。Microsoft Office の Web サイトからは、さらに多くのテンプレートをダウンロードできます (詳細については、次の「Microsoft Office Online からテンプレートをダウンロードする」を参照してください)。

  3. 使用するテンプレートをクリックします。

  4. Access ウィンドウの右側のウィンドウには、データベースの既定のファイル名が [ファイル名] ボックスに表示されます。ファイル名は変更でき、別のフォルダーを指定できます。作成したデータベースは、必要に応じて Windows SharePoint Services 3.0 サイトにリンクすることもできます。

  5. [作成] をクリックします (または、Office Online テンプレートの場合は [ダウンロード] をクリックします)。

    Access で作成されたデータベースが開きます。フォームが表示され、データの入力を開始できるようになります。

    テンプレートにサンプル データが含まれている場合は、次のようにして各レコードを削除できます。

    • 削除するレコードの行ヘッダーをクリックします (行ヘッダーは、レコードのすぐ左にあるボックスまたはバーです)。

    • [ホーム] タブの [レコード] グループで、[削除] をクリックします。 ボタン イメージ

  6. データの入力を開始するには、フォーム上の最初の空白のセルをクリックして、データを入力し始めます。レコードをいくつか入力したら、ナビゲーション ウィンドウを使って、使用したいフォームやレポートが他にもあるかどうかを調べることができます。

Microsoft Office Online からテンプレートをダウンロードする

ニーズに合ったテンプレートが [Microsoft Office Access - 作業の開始] ページにない場合は、より多くの選択肢が揃った Office Online の Web サイトで検索できます。

  1. Access をまだ実行していない場合は、起動します。

    データベースを既に開いてある場合は、次の操作を行って [Microsoft Office Access - 作業の開始] ページを表示します。

    • Microsoft Office ボタン Office ボタンの画像 をクリックして、[データベースを閉じる] をクリックします。 ボタン イメージ

  2. [Microsoft Office Access - 作業の開始] ページの最下部近くで、[Office Online のその他の内容] の [テンプレート] をクリックします。

    Office Online の Web サイトが、新しいブラウザー ウィンドウに表示されます。

  3. Office Online サイトの検索ツールを使用し、必要なテンプレートを見つけてダウンロードします。

  4. テンプレートをダウンロードすると、新規のデータベースが次のいずれかのフォルダーに保存されます。

    • Windows Vista    c:\Users\<ユーザー名>\Documents

    • Microsoft Windows Server 2003 または Microsoft Windows XP の場合    c:\Documents and Settings\<ユーザー名>\My Documents

      このデータベースを次回使用するときは、Access またはエクスプローラーを使って、この場所からデータベースを開いてください。

セクションの先頭へ

データベースを最初から作成する

ニーズに合ったテンプレートがない場合や、Access にインポートしたいデータが別のプログラムにある場合は、データベースを最初から作成した方が効果的なことがあります。ほとんどの場合、データベースを最初から作成するには、次のいずれかまたは両方を実行する必要があります。

  • 新規のテーブルを作成し、テーブルにデータを入力、貼り付け、またはインポートする。

  • 外部ソースからデータをインポートして、新規のテーブルが自動的に作成されるようにする。

データベースの計画と設計や、リレーションシップ、フォーム、レポート、またはクエリの作成の詳細については、この記事の [参照] セクションにあるリンクを参照してください。

空のデータベースを作成する

  1. Access を起動します。

  2. [Microsoft Office Access - 作業の開始] ページで、[空のデータベース] をクリックします。

    [空のデータベース] ボタン

  3. [空のデータベース] ウィンドウで、[ファイル名] ボックスにファイル名を入力します。ファイル名の拡張子を入力しなかった場合は、拡張子が自動的に追加されます。ファイルの既定の保存場所は次のいずれかです。

    • Windows Vista    c:\Users\<ユーザー名>\Documents

    • Microsoft Windows Server 2003 または Microsoft Windows XP の場合    c:\Documents and Settings\<ユーザー名>\My Documents

      ファイルの場所を変更するには、[ファイル名] ボックスの横の [参照] ボタン イメージ をクリックして、新しい場所を選び、[OK] をクリックします。

  4. [作成] をクリックします。

    データベースが作成され、Table1 という名前の空のテーブルがデータシート ビューで表示されます。

  5. カーソルは [新しいフィールドの追加] 列の最初の空白セルに置かれます。

    新規データベースの空白の新規テーブル

    データを追加するには、データを入力するか、この記事の後半の「外部ソースのデータを Access のテーブルに貼り付ける」セクションの説明に従って、別のデータ ソースからデータを貼り付けます。

    注記: 

    • データシート ビューは、Excel のワークシートを使用する場合とほぼ同様にデータを入力できるように設計されています。データシート ビューの主な制約は、データシートの左上隅から始めて、連続した行と列にデータを入力しなければならないことです。テーブル スペースの無駄使いになるので、データを書式設定する際は、Excel ワークシートの場合のように空の行や列を挿入しないでください。テーブルはデータを格納するだけにすぎません。データの表示を担当するのは、後で設計するフォームとレポートです。

    • テーブル構造は、データの入力中に作成されます。テーブルに新しい列を追加するたびに、新しいフィールドが定義されます。フィールドのデータ型は、入力したデータの種類に基づいて設定されます。たとえば、列に入力されている値が日付値のみの場合、そのフィールドのデータ型は日付/時刻に設定されます。後でこのフィールドに日付以外の値 (名前や電話番号など) を入力しようとすると、値が列のデータ型と一致しないことを通知するメッセージが表示されます。可能な場合は、文字列、日付、数値など、同じデータ型のデータが各列に入力されるようなテーブルを作成します。そのようにすると、クエリ、フォーム、レポートを作成するときに、必要なデータだけを簡単に選ぶことができます。

    • データシートの使用の詳細については、「空白のデータシートを開く」を参照してください。

この時点でデータを入力しない場合は、[閉じる] ボタン イメージ をクリックします。

表を追加する

[作成] タブの [テーブル] にあるツールを使用すると、新しいテーブルを既存のデータベースに追加できます。

Access リボンのイメージ

データシート ビューで空白のテーブルを作成するには、[テーブル] をクリックします。データシート ビューでデータの入力をすぐに開始して、データを入力しながらテーブル構造を自動的に作成するか、デザイン ビューで最初にテーブル構造を作成してから、データシート ビューに切り替えてデータを入力することができます。どちらのビューを先に使用した場合も、Access ウィンドウのステータス バーにある表示ボタンでビューを切り替えることができます。

テーブルの作成をデータシート ビューで開始する   データシート ビューでは、データの入力を開始すると、テーブル構造が自動的に作成されます。フィールド名には、番号 (フィールド 1、フィールド 2 など) が割り当てられ、各フィールドのデータ型は入力したデータに基づいて自動的に設定されます。

  1. [作成] タブの [テーブル] グループで、[テーブル] をクリックします。 ボタン イメージ

  2. テーブルが作成され、[新しいフィールドの追加] 列の最初の空のセルが選択されます。

    注: [新しいフィールドの追加] 列が表示されない場合は、データシート ビューではなくデザイン ビューが有効になっている可能性があります。データシート ビューに切り替えるには、ナビゲーション ウィンドウでテーブルをダブルクリックします。新しいテーブルの名前を入力するよう求めるメッセージが表示された後で、データシート ビューに切り替わります。

  3. [データシート] タブの [フィールドと列] グループで、[新しいフィールド] をクリックします。 ボタン イメージ

    [フィールド テンプレート] ウィンドウが開き、よく使用されるフィールド型が一覧表示されます。いずれかのフィールド型をデータシートにドラッグすると、そのフィールド型の名前の付いたフィールドが追加され、プロパティがフィールド型に適した値に設定されます。プロパティは後で変更できます。フィールドは、データが含まれているデータシートの領域にドラッグする必要があります。フィールドの場所を示す垂直の挿入バーが表示されます。

  4. データを追加するには、先頭の空のセルに入力し始めるか、この記事の後半で説明しているように、別のデータ ソースからデータを貼り付けます。

    • 列 (フィールド) の名前を変更するには、列見出しをダブルクリックしてから、新しい名前を入力します。[フィールド リスト] ウィンドウに表示されたときに内容がわかるように、各フィールドには、その内容と関連した名前を付けることをお勧めします。

    • 列を移動するには、列見出しをクリックして列を選択し、新しい場所までドラッグします。連続した複数の列を選択し、すべての列を一度に新しい場所までドラッグすることもできます。

デザイン ビューを先に使用してテーブルを挿入する   デザイン ビューでは、最初に新しいテーブルの構造を作成してから、データシート ビューに切り替えてデータを入力するか、貼り付けや追加などの方法でデータを入力します。

  1. [作成] タブの [テーブル] グループで、[テーブル デザイン] をクリックします。 ボタン イメージ

  2. テーブル内の各フィールドで、[フィールド名] 列に名前を入力し、[データ型] ボックスの一覧からデータ型を選択します。

    注: [フィールド名] 列と [データ型] 列が表示されない場合は、デザイン ビューではなくデータシート ビューが有効になっている可能性があります。デザイン ビューに切り替えるには、Access ウィンドウのステータス バーにある [デザイン ビュー] ボタンをクリックします。新しいテーブルの名前を入力するよう求めるメッセージが表示された後で、デザイン ビューに切り替わります。

  3. [説明] 列には、必要に応じて各フィールドの説明を入力できます。入力した説明は、そのフィールドの上にカーソルを置いたときにステータス バーに表示され、[フィールド リスト] ウィンドウからフォームまたはレポートにフィールドをドラッグすることによって作成したすべてのコントロール、およびフォーム ウィザードまたはレポート ウィザードによってそのフィールド用に作成されたすべてのコントロールのステータス バー テキストとして使用されます。

  4. すべてのフィールドを追加した後、テーブルを保存します。

    • Microsoft Office ボタン Office ボタンの画像 をクリックして [保存] をクリックするか、Ctrl キーを押しながら S キーを押します。

  5. データシート ビューに切り替えて、最初の空のセルをクリックしたら、テーブルにデータをいつでも入力し始めることができます。次のセクションで説明するように、外部ソースからデータを貼り付けることもできます。

データを入力し始めた後でテーブルにフィールドを追加するには、データシート ビューの [新しいフィールドの追加] 列で入力を開始するか、[データシート] タブの [フィールドと列] にあるコマンドを使用します。

テーブル テンプレートの使用を含め、テーブル作成の詳細については、「テーブルを作成する」を参照してください。

セクションの先頭へ

外部ソースのデータを Access のテーブルに貼り付ける

現在、Office Excel 2007 などの別のプログラムにデータが保存されている場合は、データをコピーして、Access のテーブルに貼り付けることができます。一般に、この方法は、Excel のワークシートのようにデータが既に列に分かれている場合に最適です。データがワープロ プログラムに保存されている場合は、タブでデータの列を区切るか、データを表形式に変換してからコピーすることをお勧めします。特に Access の操作に慣れていない場合に、データの編集や操作 (姓名を姓と名に分けるなど) が必要なときは、データをあらかじめ変換してからコピーしてください。

データを空のテーブルに貼り付けると、そのデータの種類に基づいて各フィールドのデータ型が設定されます。たとえば、貼り付けられたフィールドに日付だけが含まれる場合、そのフィールドには日付/時刻型が設定されます。貼り付けられたフィールドに "はい" と "いいえ" だけが含まれる場合、そのフィールドには Yes/No 型が設定されます。

Access では、貼り付けられたデータの最初の行の内容を使用してフィールドに名前が付けられます。貼り付けられたデータの最初の行が他の行と似た種類である場合、最初の行はデータの一部と判断され、フィールドに汎用的な名前 (F1、F2 など) が割り当てられます。貼り付けられた最初の行が以降の行と似ていない場合、最初の行はフィールド名で構成されると判断されます。その行に従ってフィールドの名前が付けられ、最初の行はデータには含められません。

汎用的なフィールド名が割り当てられた場合、混乱を避けるためにそのフィールドの名前をできるだけ早く変更する必要があります。次の手順どおりに行います。

  1. テーブルを保存します。

    • Microsoft Office ボタン Office ボタンの画像 をクリックして [保存] をクリックするか、Ctrl キーを押しながら S キーを押します。

  2. データシート ビューで、各列見出しをダブルクリックし、それぞれの列に有効なフィールド名を入力します。データ上に入力しているように見えますが、列見出しの行にはフィールド名が含まれ、データは含まれていません。

  3. テーブルを再び保存します。

注: フィールド名の変更は、デザイン ビューに切り替えて、そこで編集して行うこともできます。デザイン ビューに切り替えるには、ナビゲーション ウィンドウでテーブルを右クリックし、[デザイン ビュー] をクリックします。データシート ビューに戻るには、ナビゲーション ウィンドウでテーブルをダブルクリックします。

セクションの先頭へ

外部ソースからデータをインポートする

別のプログラムで収集したデータを Access にインポートしたり、他のプログラムにデータを格納している人と共同で作業する際に、この相手のデータを Access で使用したりすることが必要になる場合があります。いずれの場合も、Access を使用すると、外部プログラムからデータを簡単にインポートできます。データは、Excel ワークシート、別の Access データベースのテーブル、SharePoint リストなど、さまざまな外部ソースからインポートできます。インポートのプロセスはソースごとに多少異なりますが、次の手順に従うと、データのインポートを開始できます。

  1. [外部データ] タブの [インポート] で、インポートするファイルの種類に対応するコマンドをクリックします。

    Access リボンのイメージ

    たとえば、Excel ワークシートからデータをインポートする場合は [Excel] をクリックします。適切なプログラムの種類が見つからない場合は、[その他] をクリックします。

    注: [インポート] グループに目的の形式が表示されない場合は、データを作成した元のプログラムを起動して、そのデータを一般的なファイル形式 (区切りテキスト ファイルなど) で保存してから、Access にインポートします。

  2. [外部データの取り込み] ダイアログ ボックスで、[参照] をクリックしてソース データ ファイルを参照するか、ソース データ ファイルの完全なパスを [ファイル名] ボックスに入力します。

  3. [カレント データベースのデータの保存方法と保存場所を指定してください。] で、適切なオプションをクリックします。インポートしたデータを使って新しいテーブルを作成するか、既存のテーブルにデータを追加するか、データ ソースとのリンクを維持するリンク テーブルを作成できます。

  4. [OK] をクリックします。

    インポート ウィザードが起動します。

  5. インポート ウィザードに表示される手順に従います。実際の手順は、どのインポート オプションやリンク オプションを選んだかによって異なります。

  6. ウィザードの最後のページで、[完了] をクリックします。

    完了したインポート操作に関する詳細情報を保存するかどうかを確認するメッセージが表示されます。

    • 同じインポート操作を再び実行する可能性がある場合は、[インポート手順の保存] をクリックし、詳細情報を入力します。

      これ以降は、[外部データ] タブの [インポート] で [保存済みのインポート操作] をクリックします。次に、インポート定義をクリックし、[実行] をクリックすると、インポート操作を簡単に再現できます。

    • 操作の詳細を保存しない場合は [閉じる] をクリックします。

新しいテーブルにデータがインポートされ、テーブルがナビゲーション ウィンドウの [テーブル] に表示されます。

Access へのデータのインポートの詳細については、この記事の [参照] セクションにあるリンクを参照してください。

セクションの先頭へ

Access の既存のデータベースを開く

  1. Microsoft Office ボタン Office ボタンの画像 をクリックして、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスのショートカットをクリックするか、[ファイルの場所] ボックスで、目的のデータベースが含まれているドライブまたはフォルダーをクリックします。

  3. フォルダー リストで、目的のデータベースが含まれるフォルダーが開くまでダブルクリックしていきます。

  4. データベースが見つかったら、次のいずれかの操作を行います。

    • 既定の開くモードでデータベースを開くには、データベースをダブルクリックします。

    • マルチユーザー環境において共有アクセスでデータベースを開き、データベースの読み取りと書き込みを他のユーザーも同時に行うことができるようにするには、[ファイルを開く] をクリックします。

    • 読み取り専用アクセスでデータベースを開き、データベースの表示のみを可能にして編集は不可能にするには、[開く] ボタンの横にある下向き矢印をクリックし、[読み取り専用として開く] をクリックします。

    • 排他アクセスでデータベースを開き、開いているデータベースを他のユーザーが開けないようにするには、[開く] ボタンの横にある下向き矢印をクリックし、[排他モードで開く] をクリックします。

    • データベースを読み取り専用で開くには、[ファイルを開く] ボタンの横にある矢印をクリックし、[排他および読み取り専用で開く] をクリックします。他のユーザーは引き続きデータベースを開くことができますが、実行できるのは読み取り専用アクセスのみです。

開こうとしているデータベースが見つからない場合   

  1. [ファイルを開く] ダイアログ ボックスで [マイ コンピューター] ショートカットをクリックするか、[ファイルの場所] ボックスで [マイ コンピューター] をクリックします。

  2. ドライブの一覧で、目的のデータベースが存在すると思われるドライブを右クリックし、[検索] をクリックします。

  3. 検索条件を入力し、Enter キーを押してデータベースを検索します。

  4. データベースが見つかったら、[検索結果] ダイアログ ボックスでデータベースをダブルクリックして開きます。

  5. [ファイルを開く] ダイアログ ボックスから検索を行ったため、データベースを開くには、そのダイアログ ボックスの [キャンセル] をクリックする必要があります。

注: データ ファイルを外部ファイル形式 (dBASE、Paradox、Microsoft Exchange、Excel など) で直接開くことができます。また、Microsoft SQL Server や Microsoft FoxPro などのあらゆる ODBC データ ソースも直接開くことができます。開いたデータ ファイルと同じフォルダー内に新しい Access データベースが自動的に作成され、外部データベース内の各テーブルへのリンクが追加されます。

ヒント

  • 最後に開いたデータベースを開くには、[Microsoft Office Access - 作業の開始] ページで、[最近使用したデータベースを開く] ボックスの一覧の先頭に表示されたファイル名をクリックします。データベースが開き、前回そのデータベースを開いたときと同じオプション設定が適用されます。最近使用したファイルの一覧が表示されない場合は、Microsoft Office ボタン Office ボタンの画像 をクリックして、[Access のオプション] をクリックします。[Access のオプション] ダイアログ ボックスが表示されるので、[詳細設定] カテゴリをクリックして、[表示] セクションの [最近使用したファイルの一覧に表示するファイルの数] チェック ボックスをオンにします (一覧に表示する最近使用したファイルの数 (最大 9 ファイル) も指定できます)。

  • Microsoft Office ボタン Office ボタンの画像 をクリックして、[ファイルを開く] コマンドでデータベースを開いている場合は、[ファイルを開く] ダイアログ ボックスの [最近使ったドキュメント] をクリックして、以前に開いたデータベースへのショートカットの一覧を表示できます。

セクションの先頭へ

ページの先頭へ

スプレッドシートまたは他のプログラムからデータをインポートする

他のデータベースまたは表計算プログラムを使用したことがある場合は、そのアプリケーションの動作およびデータベースの使用目的の基本事項について知っていることと思われます。Access は、リレーショナル データベースを作成できるという点で他の多くのデータベース アプリケーションと異なります。また、SQL Server などの他のデータベース アプリケーションを操作するためのオプションも多数用意しています。

この記事の内容

Excel ワークシートを Access にインポートする

Excel ワークシートを新しい Office Access 2007 データベースのテーブルとしてインポートする

テーブル正規化ウィザードを使用してデータを整理する

他のプログラムのデータを操作する

Excel ワークシートを Access にインポートする

Excel で一覧を作成してから Access を使用するというのは、ごく一般的な順序です。Excel は一覧の作成に適していますが、一覧のサイズが大きくなるにつれて、整理や更新がしにくくなります。このような場合は、Access に一覧を移動することが必要となります。

データベース テーブルとワークシートは、どちらも行と列にデータが格納されるという点で構造的に似ています。そのため、ワークシートは簡単にデータベース テーブルにインポートできます。データをワークシートに格納する場合とデータベースに格納する場合の主な違いは、データがどのように整理されるかということです。ワークシート全体をデータベースの新しいテーブルとしてインポートするのみでは、データの整理や更新に関連した問題は解決されません。このことは、ワークシートに冗長なデータが含まれている場合に特に当てはまります。これらの問題を解決するには、スプレッドシートのデータを、関連するデータごとにまとめた別々のテーブルに分割する必要があります。テーブル内にデータを配置する方法の詳細については、「データベース設計の基本」を参照してください。

Access には、この処理を行うために使用できるテーブル正規化ウィザードが備わっています。データをテーブルにインポートしてからこのウィザードを使用すると、テーブルをそれぞれが固有のデータのみを含んだ複数のテーブルに分割できます。また、このウィザードでは、テーブル間に必要なリレーションシップも作成されます。

Excel ワークシートを新しい Office Access 2007 データベースのテーブルとしてインポートする

  1. Microsoft Office ボタン Office ボタンの画像 をクリックして、[新規] をクリックします。

  2. [ファイル名] ボックスに新しいデータベースの名前を入力し、[作成] をクリックします。

  3. Table1 を閉じます。

    Table1 のデザインに加えた変更を保存するかどうかを確認するメッセージが表示されたら、[いいえ] をクリックします。

  4. [外部データ] タブの [インポートとリンク] で、[Excel] をクリックします。 ボタン イメージ

  5. [外部データの取り込み] ダイアログ ボックスで [参照] をクリックします。

  6. [ファイルを開く] ダイアログ ボックスを使用して、ファイルを検索します。

  7. ファイルを選んで、[開く] をクリックします。

  8. [外部データの取り込み] ダイアログ ボックスで、[カレント データベースの新しいテーブルにソース データをインポートする] チェック ボックスがオンになっていることを確認します。

  9. [OK] をクリックします。

    ワークシート インポート ウィザードが開き、データに関する質問がいくつか表示されます。

  10. ウィザードの指示に従って操作し、[次へ] または [戻る] をクリックしてページ間を移動します。ウィザードの最後のページで [完了] をクリックします。

    注: 完了したインポート操作に関する詳細情報を保存するかどうかを確認するメッセージが表示されます。同じインポート操作を再び実行する可能性がある場合は、[はい] をクリックし、詳細情報を入力します。[外部データ] タブの [インポート] で [保存済みのインポート操作] をクリックすると、この操作を後で簡単に再生できます。操作の詳細を保存しない場合は、[閉じる] をクリックします。

データが新しいテーブルにインポートされ、ナビゲーション ウィンドウの [すべてのテーブル] に表示されます。

テーブル正規化ウィザードを使用してデータを整理する

データが Access テーブルにインポートされたら、テーブル正規化ウィザードを使って、繰り返しデータをすばやく識別できます。さらに、繰り返しデータを別々のテーブルに整理して、データが効率的に格納されるようにすることもできます。Access では、元のテーブルをバックアップとして保存してから、データベース アプリケーションの基礎として使用できる新しいテーブルが作成されます。

  1. 正規化するテーブルが含まれている Access データベースを開きます。

  2. [データベース ツール] タブの [解析] で [テーブルの正規化] をクリックします。

    テーブル正規化ウィザードが開きます。

    正規化の概念については、ウィザードの 2 ページにわたる概要ページに表示される簡単なチュートリアルで確認できます。このページのボタンをクリックすると、例が表示されます。概要ページは表示されず、[テーブル正規化ウィザードの紹介の画面を表示する] チェック ボックスが表示される場合は、チェック ボックスをオンにして [戻る] を 2 回クリックすると、概要ページが表示されます。概要ページの内容を確認後、今後は表示しないようにするには、このチェック ボックスをオフにします。

  3. 多くの重複データを含むフィールドがあるテーブルを選択してください。」という文章で始まるページで、正規化するテーブルを選択して [次へ] をクリックします。

  4. どのフィールドをどのテーブルに入れるかは、ウィザードに決定させることも、手動で決定することもできます。ウィザードの推奨に従った場合でも、ウィザードの次のページでテーブルのレイアウトを変更できます。

    注: どのフィールドをどのテーブルに入れるかをウィザードに決定させると、データの量が多くない場合などは特に、テーブルのレイアウトがデータに適していないことがあります。ウィザードの処理の結果は必ずよく確認してください。その一方で、ウィザードによって推奨されたレイアウトの方が自分で考えていたものより効率的な場合もあるので、ウィザードの推奨を少なくとも一度試してみることをお勧めします。ウィザードの処理の結果に満足がいかない場合は、フィールドを手動で並べ替えることができ、[戻る] をクリックすれば、いつでもすべてのフィールドを手動で配置できます。

  5. [次へ] をクリックします。このページでは、どのテーブルにどのフィールドを入れるかを指定します。ウィザードに決定させることを選択した場合は、リレーションシップ ラインで接続された複数のテーブルが作成されます。それ以外の場合は、すべてのフィールドを含んだテーブルが 1 つだけ作成されます。いずれの場合も、このページで変更を加えることができます。

    • テーブルのフィールドをこのページの空白領域にドラッグすると、それらのフィールドを含んだ新しいテーブルを作成できます。テーブル名を指定するように求めるメッセージが表示されます。

    • あるテーブルのデータを別のテーブルに移した方が効率的に格納できると考えられる場合は、テーブル間でフィールドをドラッグすることもできます。

    • ほとんどのテーブルには、[ID] フィールドまたは [固有の ID が生成されました] フィールドが含まれています。ID フィールドの詳細を表示するには、ウィザードの右上隅にある [ヒント] をクリックしてください。

    • 変更を元に戻すには、[元に戻す] をクリックします。

    • テーブルの名前を変更するには、テーブルのタイトル バーをダブルクリックして、新しい名前を入力し、[OK] をクリックします。

  6. フィールドのレイアウトが希望どおりになったら、[次へ] をクリックします。

  7. 値が非常に似ているレコードがウィザードによって見つけられると、誤入力の可能性がある値として識別され、画面に表示されます。値が表示されたら、それをどのように処理するかを確認できます。一覧をスクロールして、[候補] 列に値が表示されている項目を見つけたら、ドロップダウン リストの適切な項目をクリックします。[(修正しない)] を選択して、これらの値がウィザードによって変更されないようにします。処理が完了したら、[次へ] をクリックします。

  8. 元のテーブルに似たクエリを作成するかどうかを確認するメッセージが表示されます。元のテーブルに基づいてフォームやレポートを既に作成してある場合は、このクエリを作成することをお勧めします。[作成する] を選択すると、元のテーブル名は "_OLD" を追加したものに変更され、新しいクエリに元のテーブル名が付けられます。テーブルに基づいて作成されたフォームやレポートは、このクエリを使用するようになりますが、以前と同様に機能します。

  9. [完了] をクリックします。

    指定した設定に基づいて新しいテーブルが作成され、自動的に開きます。結果の確認が終わったら、テーブルを閉じます。

セクションの先頭へ

他のプログラムのデータを操作する

Office Access 2007 には、他のプログラムに保存されているデータを使うための機能が用意されています。

  • 別のファイル形式のデータにリンクした新規の Access データベースを作成する    Access では、テキスト、dBASE、スプレッドシートなど、別のファイル形式のファイルを開くことができます。Access データベースの作成とファイルのリンク付けは自動的に行われます。

    1. Access を起動します。

    2. Microsoft Office ボタン Office ボタンの画像 をクリックして、[開く] をクリックします。

    3. [ファイルを開く] ダイアログ ボックスで、開くファイルの種類を一覧からクリックします。ファイルの種類がわからない場合は、[すべてのファイル (*.*)] をクリックします。

    4. 必要な場合は、開くファイルが含まれているフォルダーを参照します。ファイルを見つけたら、ダブルクリックして開きます。

    5. ウィザードに表示される指示に従って操作します。ウィザードの最後のページで [完了] をクリックします。

  • 既存の Access データベースにデータをインポートするか、データベースにデータをリンクする   別のデータ ソースやプログラムのデータを Access テーブルにインポートして、Access ファイルにデータを挿入するか、Access のデータへのリンクを作成して、元のファイル (Access ファイル以外) にデータを残すことができます。

    データをインポートまたはリンクする

    1. [外部データ] タブの [インポート] で、データが格納されている形式をクリックします。

      次の形式のデータをインポートまたはリンクできます。

      • Microsoft Office Access

      • Microsoft Office Excel

      • Microsoft Windows SharePoint Services

      • テキスト ファイル

      • XML ファイル

      • ODBC データベース

      • HTML ドキュメント

      • Microsoft Office Outlook

      • dBase

      • Paradox

      • Lotus 1-2-3

        [外部データの取り込み] ダイアログ ボックスが表示されます。

    2. ダイアログ ボックスに表示される指示に従って操作します。

      データベースにデータがインポートまたはリンクされます。ほとんどの形式の場合、データの場所を指定して、データをデータベースに格納する方法を選択する必要があります。

セクションの先頭へ

ページの先頭へ

複数バージョンの Access で以前のバージョンのデータベースを使用する

Access 2000 またはそれ以降で作成された Access データベースまたは Access プロジェクトは、ファイルのセキュリティが有効になっていても、作成に使用したバージョンまたはそれ以降のすべてのバージョンの Access で使用できます。たとえば、Access 2000 のファイルは Access 2000 から Office Access 2007 で使用でき、Access 2002-2003 のファイルは Access 2002-2003 から Office Access 2007 で使用できます。

以前のバージョンの Access で作成したデータをそのまま保持しながら、それより新しいバージョンの Access を使用しているユーザーは、そのデータにリンクして新しいバージョンの一部の機能を利用したい場合があります。それには、新しいバージョンで (フォーム、レポート、クエリ、マクロが含まれるがテーブルは含まない) 新しい "フロントエンド" データベースを作成して、以前のバージョンで作成したファイルのテーブルにリンクします。データベースが 1 つのファイルに保存されている場合、またはデータベースがフロントエンド/バックエンド アプリケーションに分割されている場合のそれぞれについて、次のいずれかの手順どおりに行います。

複数バージョンの Access で単一ファイルの Access データベースを使用する

複数バージョンの Access でフロントエンド/バックエンド アプリケーションを使用する

複数バージョンの Access で単一ファイルの Access データベースを使用する

Access データベースのテーブルやフォームなどのすべてのオブジェクトが 1 つの .mdb ファイルに格納されていて、複数のバージョンの Access でそのデータベースを使用する場合は、それらのバージョンで新しいフロントエンド データベースを作成し、元のファイルにリンクします。以前のバージョンの Access を使用しているユーザーは、引き続き元のデータベースを使用できます。それより新しいバージョンを使用しているユーザーは、新しいフロントエンド データベースを介して同じデータにリンクできます。

  1. 次の手順に従って、データベースを最新の 3 つの形式 (Access 2000、Access 2002-2003、Access 2007) のいずれかに変換します。このコマンドを実行すると、元のデータベースは元の形式で保持され、指定した形式でデータベースのコピーが作成されます。

    • Access ファイルを閉じます。ファイルがサーバーまたは共有フォルダーに置かれたマルチユーザー Access データベースの場合は、他のユーザーがそのデータベースを開いていないことを確認します。

    • Access 2007 を起動します。

    • Microsoft Office ボタン Office ボタンの画像 をクリックして、[開く] をクリックします。

    • 変換するファイルの場所を参照し、ファイルをダブルクリックして開きます。

      データベースを拡張するかどうかを確認する [データベースの拡張] ダイアログ ボックスが表示されたら、[いいえ] をクリックします。

    • データベースを起動したときにフォームが開いたら、フォームを閉じます。

    • Microsoft Office ボタン Office ボタンの画像 をクリックして、[名前を付けて保存] をポイントし、[データベースを他の形式で保存] で、変換先のファイル形式をクリックします。

    • [名前を付けて保存] ダイアログ ボックスに、新しいデータベースの名前を入力します。

      注: 新しいデータベースを別の場所に保存しない場合、新しいデータベースには元のデータベースとは異なる名前を付ける必要があります。別の場所に保存する場合も、フロントエンド データベースとバックエンド データベースを簡単に区別できるように、別の名前を使用することをお勧めします。ただし、変換先の形式が Access 2007 の場合は、ファイル名の拡張子が .mdb から .accdb に変わるので、同じファイル名を使用できます。

    • [上書き保存] をクリックします。

  2. 変換したデータベースを、以下の手順に従ってフロントエンド/バックエンド アプリケーションに分割します。

    • [データベース ツール] タブの [データの移動] グループで、[Access データベース] をクリックします。 ボタン イメージ

    • [データベース分割ツール] ダイアログ ボックスの [データベースの分割] をクリックします。

    • バックエンド データベースの名前を入力し、[分割] をクリックします。

  3. 元のデータベースを削除しないように注意して、データベース分割ツールによって作成されたバックエンド データベースを削除します。

  4. 新しいフロントエンド データベースを元のデータベースのテーブルにリンクします。[データベース ツール] タブの [データベース ツール] グループで、[リンク テーブル マネージャー] をクリックします。 ボタン イメージ

  5. [すべて選択] をクリックして、[リンク先を更新するためのプロンプトを毎回表示する] チェック ボックスをオンにします。

  6. [OK] をクリックして、古いバージョンのデータベースを参照し、データベースをダブルクリックします。

    すべてが正常に完了すると、選んだすべてのリンク テーブルが正しく更新されたことを示すメッセージが表示されます。

    新しいフロントエンド データベースを拡張して、Access 2000、Access 2002-2003、Access 2007 にアップグレードしたユーザー向けの新しい機能をサポートできるようになりました。以前のバージョンのユーザーは、旧バージョンのデータベースを引き続き使用できます。

    必要に応じて、新しいフロントエンド データベースをさらに別のバージョンに変換することもできます。たとえば、元のデータベースが Access 2000 形式であった場合、Access 2002-2003 のユーザー用に Access 2002-2003 フロントエンド データベースを作成し、Access 2007 のユーザー用には、対象バージョンのフロントエンド データベースを作成できます。こうして、2 つのバージョンのフロントエンド データベースは、Access 2000 ファイルのデータにリンクするようになります。

セクションの先頭へ

複数バージョンの Access でフロントエンド/バックエンド アプリケーションを使用する

Access データベースが既にフロントエンド/バックエンド アプリケーションである場合、必要なのは、フロントエンド データベースを Access 2000、Access 2002-2003、Access 2007 のファイル形式に変換することだけです。バックエンド データベースに必要な変更はありません。

次の手順は、[データベースに名前を付けて保存] を使って、フロントエンド データベースを最新の 3 つの形式 (Access 2000、Access 2002-2003、Access 2007) のいずれかに変換する方法を示したものです。このコマンドを実行すると、元のデータベースは元の形式で保持され、指定した形式でデータベースのコピーが作成されます。

  1. フロントエンド データベースを閉じます。ファイルがサーバーまたは共有フォルダーに置かれたマルチユーザー Access データベースの場合は、他のユーザーがそのデータベースを開いていないことを確認します。

  2. Access 2007 を起動します。

  3. Microsoft Office ボタン Office ボタンの画像 をクリックして、[開く] をクリックします。

  4. フロントエンド データベースの場所を参照し、データベースをダブルクリックして開きます。

    データベースを拡張するかどうかを確認する [データベースの拡張] ダイアログ ボックスが表示されたら、[いいえ] をクリックします。

  5. データベースを開いたときにフォームが表示されたら、フォームを閉じます。

  6. Microsoft Office ボタン Office ボタンの画像 をクリックして、[名前を付けて保存] をポイントし、[データベースを他の形式で保存] で、変換先のファイル形式をクリックします。

  7. [名前を付けて保存] ダイアログ ボックスに、新しいデータベースの名前を入力します。

  8. [上書き保存] をクリックします。

新しいフロントエンド データベースを拡張して、Access 2000、Access 2002-2003、Access 2007 にアップグレードしたユーザー向けの新しい機能をサポートできるようになりました。

セクションの先頭へ

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×