Access 2007 のテンプレートを選択して使用する

この記事の内容

概要

手順 1: テンプレートを選択する

手順 2: テンプレートをカスタマイズする

手順 3: 新しいデータベースにデータを追加する

手順 4: レコードを検索する


概要

Microsoft Office Access には、効果的なデータベースを使用してすぐに作業を始めることができるように、さまざまな種類の本格的なデータベース テンプレートが用意されています。各テンプレートは、変更を加えずに使用することも、必要に応じてカスタマイズすることもできる完全なエンド ツー エンドのソリューションです。各テンプレートには、定義済みのテーブル、フォーム、レポート、クエリ、マクロ、およびリレーションシップが含まれており、独自のデータベースをカスタマイズするための手掛かりとなります。

さらに、Access 内のリンクをクリックすることで、Microsoft Office Online Web サイトから他の Access データベース テンプレートを簡単にダウンロードできます。テンプレートを選択し、必要に応じてカスタマイズしたら、データを追加してレコード間を移動できるようになります。

手順 1: テンプレートを選択する

Access と共にインストールされたテンプレートのいずれかを選択するか、オンラインのテンプレートを参照できます。

インストール済みのテンプレートを選択する

  1. [Microsoft Access - 作業の開始] ウィンドウで、[テンプレート カテゴリ] の [ローカル テンプレート] をクリックします。

    使用できるテンプレート一覧    

テンプレート

用途

資産管理

資産についての情報 (資産の詳細や所有者など) を記録します。資産を分類して、その状態、取得日、場所、および所有者を記録できます。

連絡先管理

チームの取引相手 (顧客やパートナーなど) に関する情報を管理します。名前や住所に関する情報、電話番号、電子メール アドレスを記録できるほか、画像を関連付けることもできます。

イベント管理

次回のミーティングや締め切りなどの重要なイベントを記録します。表題、場所、開始時刻、終了時刻、および説明を記録できるほか、画像を関連付けることもできます。

教職員名簿

教職員に関する重要な情報 (電話番号、住所、緊急時の連絡先情報、雇用データなど) を管理します。

案件管理

一連の案件や問題を管理および記録します。案件の割り当て、優先度付け、および開始から終了までの進捗状況の追跡を行うことができます。

マーケティング プロジェクト

マーケティング プロジェクトに関する詳細情報を管理し、プロジェクトのスケジュール作成と成果物の監視を行います。

プロジェクト

1 つ以上のプロジェクトについて、タスクの監視と予算の記録を行います。

商談管理

少人数の営業担当者間で、見込みのある商談の進捗状況を監視します。

生徒名簿

生徒に関する情報 (緊急時の連絡先、医療情報、保護者に関する情報など) を管理します。

タスク管理

個人またはチームが完了する必要のある一連の作業項目を記録します。

ノースウィンド 2007

受注記録システムを作成します。サンプルとして含まれているデータを削除する必要があります。

  1. データベースのモデルとして使用するテンプレートをクリックします。

  2. [ファイル名] ボックスにデータベース名を入力します。

  3. 新しいデータベースの保存先として特定の場所を指定するには、[ファイル名] ボックスの横にあるフォルダ アイコンをクリックします。

    ヒント: データベースを Windows SharePoint Services サイトにリンクするには、[データベースを作成して、Windows SharePoint Services サイトにリンクする] チェック ボックスをオンにします。

  4. [作成] をクリックします。

これで、新しいデータベースを使用する準備ができました。作成したデータベースは、必要に応じてカスタマイズできます。

オンラインのテンプレートを選択する

  1. [Microsoft Access - 作業の開始] ウィンドウで、次のいずれかの操作を行います。

    • お勧めのオンライン テンプレートをすべて参照するには、[テンプレート カテゴリ] の [お勧め] をクリックし、使用するテンプレートをクリックします。

    • 特定のテーマに基づいてオンライン テンプレートを選択するには、テーマ [Microsoft Office Online] をクリックし、使用するテンプレートを選択します。

  2. [ファイル名] ボックスにテンプレートの新しい名前を入力し、テキスト ボックスの横にあるフォルダ アイコンをクリックして、新しいデータベースを保存する特定の場所を指定します。

  3. [ダウンロード] をクリックします。

ヒント: データベースを Microsoft Windows SharePoint Services サイトにリンクするには、[データベースを作成して、Windows SharePoint Services サイトにリンクする] チェック ボックスをオンにします。

これで、新しいデータベースを使用する準備ができました。作成したデータベースは、必要に応じてカスタマイズできます。

ページの先頭へ

手順 2: テンプレートをカスタマイズする

データベース テンプレートを選択したら、必要に応じてこれをカスタマイズできます。テンプレートから作成したデータベースには、あらかじめデザインされたいくつかのテーブル、フォーム、およびレポートが組み込まれており、すぐに使用できるようになっています。テンプレートからデータベースを作成すると、テンプレートの用途に必要なテーブルなどのオブジェクトが自動的に作成されます。テンプレートによっては、データベース構造が複雑であるために、その構造の一部をカスタマイズすることが必要になる場合もあります。用意されているテーブルのデザインを変更する場合は、既存のリレーションシップを損なわないように注意する必要があります。テンプレートの構造を大きく変更する必要がある場合は、空のデータベースから始めた方が適していることもあります。

テンプレートをカスタマイズするときは、フィールドやテーブルの名前を変更しないようにしてください。これらのフィールドやテーブルは、フォームやレポートなどの他のデータベース オブジェクトで使用されている可能性があるため、名前を変更すると、該当するフィールド名またはテーブル名を参照したり、それらに依存したりしている他のデータベース オブジェクトが、正常に機能しなくなる場合があります。ナビゲーション ウィンドウでテーブル名を変更する場合や、データシート ビューまたはデザイン ビューでフィールド名を変更する場合は、名前の自動修正機能が有効になっていることを事前に確認してください。名前の自動修正機能とは、フィールド、テーブル、フォーム、またはレポートの名前の変更を、データベース全体の他のオブジェクトに自動的に伝達するものです。通常、[名前の自動修正] 設定は、すべての新規データベースに対して既定で有効になっています。

フォームまたはレポートをカスタマイズする

テンプレートのフォームやレポートをカスタマイズするには、いくつかの方法があります。たとえば、フォームの書式を変更するには、フォームをレイアウト ビューで開き、[書式] タブの [オートフォーマット] で新しい書式をクリックします。フォームやレポートにフィールドを追加してカスタマイズすることもできます。フォームまたはレポートにフィールドを追加するときは、そのフォームまたはレポートにコントロールを作成します。テンプレート内の既存のコントロールをカスタマイズするには、そのコントロールのプロパティを変更します。

フォームまたはレポートに新しいコントロールを追加する

  1. ナビゲーション ウィンドウで、コントロールを追加するフォームまたはレポートを右クリックし、[デザイン ビュー] をクリックします。

  2. [デザイン] タブをクリックします。

  3. [コントロール] で追加するコントロールをクリックし、[コントロール ウィザードの使用] をクリックします。

    [コントロール] グループの [コントロール ウィザード] コマンドの使用

  4. ウィザードの手順に従って、新しいコントロールの作成とカスタマイズを行います。

フォームおよびレポートの作成方法の詳細については、[参照] セクションのリンク先を参照してください。

コントロールを変更する

フォームまたはレポートでの既存のコントロールの表示方法は、カスタマイズすることが可能です。表示形式を変更するには、フィールドの "Format/書式" プロパティを変更します。フィールドの "Format/書式" プロパティは、新しいフォームやレポートを作成したときに、そのフィールドに基づくコントロールに自動的に継承されます。

データシート ビューで表示形式を設定する

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックし、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、変更するコントロールを含むデータベースを開きます。

  3. ナビゲーション ウィンドウで、表示形式を設定するフィールドが含まれているテーブルをダブルクリックします。

    テーブルがデータシート ビューで開きます。

  4. 表示書式を設定するフィールドをクリックします。

  5. [データシート] タブの [データの型と表示形式] で、[表示形式] の横にあるドロップダウン リストの矢印をクリックし、表示形式を選択します。 [データ型と書式設定] グループの Access のリボンの画像

    新しい表示形式が適用されたフィールドが表示されます。

デザイン ビューで表示形式を設定する

  1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックし、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、変更するコントロールを含むデータベースを開きます。

  3. ナビゲーション ウィンドウで、表示形式を変更するフィールドを含むテーブルを右クリックし、[デザイン ビュー] をクリックします。

    テーブルがデザイン ビューで開きます。

  4. 表示書式を設定するフィールドをクリックします。

  5. [フィールド プロパティ] の [標準] タブで、[書式] ボックスの一覧の表示形式をクリックします。

  6. 変更内容を保存するには、[クイック アクセス ツール バー] の [上書き保存] をクリックします。

ページの先頭へ

手順 3: 新しいデータベースにデータを追加する

テンプレートを選択して必要なカスタマイズを行ったら、外部データをインポートまたはリンクして、データベースにデータを追加できます。

データをインポートする

インポートできるデータの形式には、Excel ブック、Windows SharePoint Services 3.0 リスト、Outlook アドレス帳、他の Access データベースなどがあります。

  • データをインポートするには、[外部データ] タブの [インポート] で、インポートするファイルの種類に対応するコマンドをクリックします。

    [インポート] グループのコマンド ボタン

    注記: 

    • インポートするデータの種類に対応するアイコンがない場合は、[その他] をクリックし、[外部データの取り込み] ダイアログ ボックスに表示される指示に従って操作します。

    • この方法でも目的の外部データをインポートするコマンドが見つからない場合は、データを最初に作成したプログラムを Access とは別に起動し、そのプログラムを使用してデータを一般的なファイル形式 (区切りテキスト ファイルなど) に変換する必要があります。その後で Access に戻り、いずれかの外部データ コマンドを使用して、そのデータをインポートします。

  • ウィザードの最後のページで、これらのインポート手順の詳細を保存するかどうかをたずねるメッセージが表示される場合があります。今後も同じデータ ソースからデータをインポートする可能性がある場合は、詳細を保存しておくと便利です。これを行うには、[インポート操作の保存] チェック ボックスをオンにし、詳細を入力して、[インポートの保存] をクリックします。これにより、[外部データ] タブの [インポート] で [保存済みのインポート操作] をクリックして、同じインポート操作を繰り返すことが可能になります。このインポート操作の詳細を保存しない場合は、[閉じる] をクリックします。

データをリンクする

データをリンクすると、データを元の場所に格納したままで、新しいデータベースのリンク テーブルにそのデータを表示できます。ほとんどのファイル形式では、Access とデータを作成したプログラムのどちらを使用しても、データを表示および変更できます。これは、どちらの場合も同じ物理データを操作することになるためです。ただし、データの格納先が Excel ブックの場合、Access ではリンクされたデータを表示することしかできず、変更はできません。リンクされたブックのデータを変更するには、Excel を使用する必要があります。

    1. Office ボタンのイメージ (Microsoft Office ボタン) をクリックし、[開く] をクリックします。

    2. [ファイルを開く] ダイアログ ボックスで、データベースを選択して開きます。

    3. [外部データ] タブの [インポート] で、リンク先のファイルの種類に対応するコマンドをクリックします。たとえば、Excel ブック内のデータにリンクするには、[Excel] をクリックします。リンク先のデータの種類に対応するアイコンがない場合は、[その他] をクリックします。

      [外部データの取り込み] ダイアログ ボックスが表示されます。

      注: この方法でも目的の外部データにリンクするコマンドが見つからない場合は、データを最初に作成したプログラムを Access とは別に起動し、そのプログラムを使用してデータを一般的なファイル形式 (区切りテキスト ファイルなど) に変換する必要があります。その後で Access に戻り、いずれかの外部データ コマンドを使用して、そのデータにリンクします。

    4. [外部データの取り込み] ダイアログ ボックスで、[参照] をクリックしてソース データ ファイルを探すか、[ファイル名] ボックスにソース データ ファイルの完全なパスを入力します。

    5. [現在のデータベースのデータの保存方法と保存場所を指定してください] で、必要なオプションをクリックします。

      ほとんどのファイル形式ではウィザードが起動します。ただし、Access データベース内のデータにリンクする場合は、[テーブルのリンク] ダイアログ ボックスが表示されます。この場合、[テーブルのリンク] ダイアログ ボックスで必要なオプションを選択します。それ以外の場合は、手順 6. に進みます。

    6. ウィザードの手順に従って操作します。具体的な操作は、選択したオプションによって異なります。

ページの先頭へ

手順 4: レコードを検索する

データベースにデータをインポートしたら、特定のレコードを検索する効率的な方法が必要になります。レコードを検索するには、データベースの下部にあるツールバーを使用します。

移動ボタン

テーブルまたはビュー (オブジェクト)でレコードを検索するには、次の移動ボタンを使用します。

移動ボタン

移動先

1.

先頭レコード

2.

前のレコード

3.

特定のレコード: テキスト ボックス内をクリックし、レコード番号を入力して Enter キーを押すと、そのレコードが表示されます。レコード番号は、フォームまたはデータシートの先頭から順にカウントされます。

4.

次のレコード

5.

最終レコード

6.

新しい (空の) レコード

7.

フィルタ: フィルタが適用されているかどうかを示すインジケータです。フィルタが適用されていない場合や、すべてのフィルタが削除されている場合は、"フィルタなし" というインジケータが表示されます。

8.

検索ボックス: [検索] ボックスにテキストを入力すると、文字を入力するたびに、一致する最初の値がリアルタイムで強調表示されます。この機能を使用すると、レコードをすばやく検索できます。

レコード検索のその他のオプション

次のいずれかの方法を使用してレコードを検索することもできます。

特定のレコードへ移動する

特定のレコードを検索する

フィルタを適用して特定のレコードセットだけを表示する

クエリを使用して検索操作をカスタマイズする

特定のレコードへ移動する

一部のテンプレートには、[選択] ドロップダウン リストを使用して特定のレコードを表示するオプションが用意されています。たとえば、連絡先管理テンプレートの [連絡先詳細] フォームと、マーケティング プロジェクト テンプレートの [プロジェクト詳細] フォームにこのオプションがあります。このオプションを使用すると、特定のレコードをドロップダウン リストから表示できます。このオプションが使用できる場合、[選択] ボックスは、フォームの左上のセクションに表示されます。

  1. [選択] ボックスの横にある矢印をクリックします。

    [移動先] ボックス

  2. 表示するレコードをクリックします。

特定のレコードを検索する

特定のレコードを検索するには、[検索と置換] ダイアログ ボックスの [検索] タブを使用します。特定のフィールド内か、テーブルまたはビュー全体を検索できます。

注: [検索と置換] ダイアログ ボックスは、テーブルまたはビューに現在データが表示されている場合にのみ使用できます。

  1. 検索対象のテーブルを開き、検索するレコードを含むフィールドをクリックします。

  2. [ホーム] タブの [検索] で [検索] をクリックします。

    [検索] コマンドボタン

  3. [検索と置換] ダイアログ ボックスで、[検索する文字列] ボックスに検索条件を入力します。

  4. [検索方向] ボックスの一覧の [すべて] をクリックし、[次を検索] をクリックします。

[検索と置換] ダイアログ ボックスの使用方法の詳細については、[参照] セクションのリンク先を参照してください。

フィルタを適用して特定のレコードセットだけを表示する

フィルターをオンまたはオフにすることで、同じデータについて、フィルタが適用されたビューと適用されていないビューを簡単に切り替えることができます。

フィルタを適用すると、抽出条件に一致するレコードだけが表示されるように制限できます。フィルタを適用することにより、目的のレコードを見つけやすくなります。たとえば、表示されるレコードをすばやく絞り込むには、値を比較するフィールドを右クリックし、表示される選択メニュー オプションのうち、[に等しい]、[に等しくない]、[を含む]、[を含まない] のいずれかをクリックします。

  • フィルタを適用するテーブルまたはフォームを開きます。

  • テーブルまたはフォームに既に適用されているフィルタを削除するには、[ホーム] タブの [並べ替えとフィルタ] で [詳細設定] をクリックし、[すべてのフィルタのクリア] をクリックします。このコマンドが使用できない (選択不可になっている) 場合、フィルタは適用されていません。

    グループの並べ替えとフィルター

  • フィルタを適用するには、フィルタを適用するフィールドをクリックし、[ホーム] タブの [並べ替えとフィルタ] で [フィルタ] をクリックして、フィルタ オプションを選択します。

  • 選択内容に基づいてフィルタを適用するには、テーブルまたはフォームを開き、フィルタの一部として使用する値を含むレコードに移動します。次に、フィールド内をクリックします。[ホーム] タブの [並べ替えとフィルター] で [選択] をクリックし、適用するフィルターをクリックします。

  • フィールドの一部を選択し、その選択部分に基づいてフィルタを適用するには、目的の文字だけを選択します。 [ホーム] タブの [並べ替えとフィルター] で [選択] をクリックし、適用するフィルターをクリックします。

フィルタの適用方法の詳細については、[参照] セクションのリンク先を参照してください。

クエリを使用して検索操作をカスタマイズする

クエリを使用すると、検索操作のカスタマイズ、カスタマイズしたフィルタの適用、およびレコードの並べ替えを行うことができます。クエリは保存して再利用でき、フォームやレポートの作成にも使用できます。また、クエリを使用して、特定の条件を満たすテーブル レコードだけを検索することもできます。作成するクエリの種類は、抽出するレコードや、検索結果に対して Access で処理を行うかどうかによって異なります。

  1. [作成] タブの [その他] で [クエリ ウィザード] をクリックします。

    [その他] グループの [クエリ ウィザード] コマンド

  2. クエリ ウィザードに表示される手順に従って操作します。

クエリの作成方法の詳細については、[参照] セクションのリンク先を参照してください。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×