Access 2.0 と Access 95 データベースを現在のバージョンにインポートする

Access 2.0 と Access 95 データベースを現在のバージョンにインポートする

Access 2.0 形式 (.mdb)、または場合によっては Access 95 形式 (.mdb) で既存のデータベースを使用する場合は、.accdb ファイル形式を使用するより新しいバージョンの Access にそのデータベースからのテーブル、クエリ、マクロをインポートすることができます。

VBA コード (およびモジュール) を含むフォームとレポートをインポートするには、まず、Microsoft Office Access 2003、Access 2002、または Access 2000 を使用して、Access 2.0 または Access 95 データベースを Access 2002 - 2003 または Access 2000 ファイル形式に変換します。次に、Access 2007 などのより新しいバージョンを使用して、そのファイルを .accdb ファイル形式に変換できます。その後、Access 2010、Access 2013、Access 2016 によって、.accdb ファイル形式を開くことができます。

この記事の以下のセクションでは、これらのタスクを実行する方法について説明します。

Access 2010、Access 2013、または Access 2016 を使用していますか?

Access 2007 は、Access 2.0 と Access 95 の表示、インポート、リンク、エクスポートをサポートしている最後のバージョンでした。Access 1.0 および 2.0 (Red 2、または Jet 2) ファイルおよび Access 95 データベースのデータのエクスポート、インポート、リンクには、Access 2007 が必要です。この場合は、Access 2007 を中間のステップとして使用し、Access 2.0 データベースをこれらのバージョンのいずれかに完全に変換する必要があります。

目的に合ったトピックをクリックしてください

Access 2.0 データベースを Access 2007 で開く

Access 2.0 データベースのデータを Access 2007 にインポートする

Access 95 データベースのデータを Access 2007 にインポートする

Access 2003、Access 2002、または Access 2000 を使用して、Access 2.0 または Access 95 データベースを変換する

Access 2.0 データベースを Access 2007 で開く

Access 2007 で Access 2.0 データベースを開く場合は、多数のプロンプトが表示されます。プロンプトに従うと、最後には「このデータベースは Microsoft Access 2.0 ファイル形式で保存されました」というメッセージが表示されます。

このデータベースは、Microsoft Access 2.0 ファイル形式で保存されました。

Access 2007 データベース (.accdb) には、Access 2.0 データベースのテーブル、クエリ、マクロをインポートできます。Access 2007 データベースにフォーム、レポート、モジュールをインポートするには、まず、以前のバージョンの Access を使用してデータベースを変換します。次に、Access 2007 を使用して変換後のデータベースを開き、そのデータベースを Access 2007 .accdb ファイル形式のデータベースに変換します。詳細については、「Access 2003、Access 2002、Access 2000 を使用して、Access 2.0 または Access 95 データベースを変換する」を参照してください。

Access 2.0 データベースのデータを Access 2007 にインポートする

別のデータベースからオブジェクトをインポートする場合は、インポートするオブジェクトのコピーがインポート先のデータベースに作成されます。ソースは変更されません。Access 2007 に Access 2.0 データベースのデータをインポートするには、最初にデータのインポート先のデータベースを開きます。次に、[外部データ] タブでコマンドを使用して、インポート処理を進めます。これには、インポート ウィザードの呼び出しが含まれます。

  1. Access 2007 を開き、Microsoft Office ボタンをクリックし、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、テーブル、クエリ、マクロのインポート先のデータベースを選択して開きます。

  3. [外部データ] タブの [インポート] グループで、[Access] をクリックします。

  4. [外部データの取り込み] ウィザードの [ファイル名] テキスト ボックスで、ソース データベースの名前を入力するか、[参照] をクリックして [ファイルを開く] ダイアログ ボックスを表示し、ソース データベースの名前を選択するか入力します。

  5. [現在のデータベースにテーブル、クエリ、フォーム、レポート、マクロ、モジュールをインポートする] をオンにして、[OK] をクリックします。

  6. [オブジェクトのインポート] ダイアログ ボックスで、各タブをクリックし、目的のオブジェクトを選択します。Access 2007 には、Access 2.0 データベースのテーブル、クエリ、マクロのみをインポートできることを忘れないでください。

    [オブジェクトのインポート] ダイアログ ボックス

    選んだオブジェクトを取り消すには、もう一度オブジェクトをクリックします。

  7. [オプション] をクリックして追加の設定を指定します。

    以下の表に、各オプションがどのようにインポート結果に影響するかを示します。

    要素

    説明

    [リレーションシップ] チェック ボックス

    選択したテーブル間のリレーションシップをインポートします。

    [メニューとツール バー] チェック ボックス

    ソース データベースに含まれるカスタム メニューとツール バーをインポートします。メニューとツール バーは [アドイン] タブに表示されます。

    [インポート/エクスポートの定義] チェック ボックス

    ソース データベースに含まれる保存済みのインポートまたはエクスポートの定義をインポートします。

    [ナビゲーション ウィンドウ グループ] チェック ボックス

    ソース データベースに含まれるナビゲーション ウィンドウのカスタム グループをインポートします。

    [テーブル構造とデータ] ボタン

    選択したすべてのテーブルの構造とデータをインポートします。

    [テーブル構造のみ] ボタン

    選択したテーブルのフィールドのみをインポートします。ソース レコードはインポートされません。

    [クエリとしてインポート] ボタン

    選択したクエリをクエリとしてインポートします。この場合、クエリと共に基になるテーブルもすべてインポートする必要があります。

    [テーブルとしてインポート] ボタン

    クエリをテーブルとしてインポートします。この場合、基になるテーブルをインポートする必要はありません。

  8. [OK] をクリックし、操作を終了します。

    Access によって問題が検出された場合は、データがコピーされ、エラー メッセージが表示されます。オブジェクトのインポート操作が正常に完了すると、ウィザードの最後のページで、今後利用するために操作の詳細設定をインポート定義として保存できます。

Access 95 データベースのデータを Access 2007 にインポートする

Access 2007 に Access 95 データベースのデータをインポートするには、最初にデータのインポート先の Access 2007 データベースを開きます。次に、[外部データ] タブでコマンドを使用します。これには、インポート ウィザードの呼び出しが含まれます。

Access 2007 データベース (.accdb) には、Access 95 形式 (.mdb) データベースのテーブル、クエリ、マクロをインポートできます。VBA コードを使用しないフォームやレポートもインポートできます。VBA コード (およびモジュール) を含むフォームとレポートをインポートするには、まず、Microsoft Office Access 2003、Access 2002、Access 2000 を使用して、Access 95 データベースを Access 2002 - 2003 または Access 2000 ファイル形式に変換します。次に、Access 2007 を使用してそのファイルを Access 2007 .accdb ファイル形式に変換します。

  1. Access 2007 を開き、Microsoft Office ボタンをクリックし、[開く] をクリックします。

  2. [ファイルを開く] ダイアログ ボックスで、テーブル、クエリ、マクロのインポート先のデータベースを選択して開きます。

  3. [外部データ] タブの [インポート] グループで、[Access] をクリックします。

  4. [外部データの取り込み] ウィザードの [ファイル名] ボックスで、ソース データベースの名前を入力するか、[参照] をクリックして [ファイルを開く] ダイアログ ボックスを表示し、ソース データベースの名前を選択するか入力します。

  5. [現在のデータベースにテーブル、クエリ、フォーム、レポート、マクロ、モジュールをインポートする] をオンにして、[OK] をクリックします。

  6. [オブジェクトのインポート] ダイアログ ボックスで、各タブをクリックし、インポートするオブジェクトを選択します。

    オブジェクトの選択を取り消すには、オブジェクトをもう一度クリックします。

  7. [オプション] をクリックして追加の設定を指定します。これらの追加設定は、オブジェクトの一覧の下にあるグループに表示されます。

  8. [OK] をクリックし、操作を終了します。

    Access によって問題が検出された場合は、データがコピーされ、エラー メッセージが表示されます。オブジェクトのインポート操作が正常に完了すると、ウィザードの最後のページで、今後利用するために操作の詳細設定をインポート定義として保存できます。

Access 2003、Access 2002、Access 2000 を使用して、Access 2.0 または Access 95 データベースを変換する

Access 2.0 データベースは、Access 2000 または Access 2002 - 2003 ファイル形式に変換することができます。これには、次の表に示す Access のバージョンのいずれかを使用します。ただし、そのバージョンの Access を購入し、コンピューターにインストールしている必要があります。Access のバージョンによっては、Access 2.0 コンバーターが既にインストールされています。

バージョン

Access 2.0 コンバーター

Microsoft Office Access 2003

このバージョンでは、Access 2003 用 Access 2.0 コンバーターをダウンロードしてインストールする必要があります。ただし、Access 2003 は延長サポート対象外のため、Microsoft ダウンロード センターからこのツールを入手できません。

Microsoft Access 2002

製品に含まれます。

Microsoft Access 2000

製品に含まれます。

Access 2.0 または Access 95 ファイルは、Access 2000 または Access 2002 - 2003 .mdb ファイル形式に変換する必要があります。次に、Access 2007 を使用して、結果のファイルを Access 2007 .accdb ファイル形式に変換できます。その後、そのデータベースを Access 2007 で使用するか、Access 2010、Access 2013、または Access 2016 で開くことができます。以前のバージョンの Access では、以下の手順が必要な場合があります。

  1. Access 2003、Access 2002、または Access 2000 を開始します。

  2. [ファイル] メニューで、[開く] をクリックし、変換する Access 95 データベースのファイル名をクリックします。

  3. [ツール] メニューで、[データベース ユーティリティ] をクリックし、[データベースの変換] をクリックし、[Access 2000 ファイル形式] をクリックします。

  4. [変換先データベース] ダイアログ ボックスで、新しいファイルのファイル名を入力し、[保存] をクリックします。

    以前のバージョンの Access で変換後のデータベースを使用できないことを警告する情報メッセージが表示される場合があります。このメッセージが表示されたら、[OK] をクリックします。

    Access 2000 ファイル形式でファイルが保存されます。

  5. Access 2007 を起動します。

  6. Microsoft Office ボタンをクリックし、[開く] をクリックします。

  7. [ファイルを開く] ダイアログ ボックスで、変換後のデータベースを選択して開きます。

  8. Microsoft Office ボタンをクリックし、[変換] をクリックします。

  9. [名前を付けて保存] ダイアログ ボックスで、Access 2007 ファイルのファイル名を入力するか、提供されるファイル名を受け入れて、[保存] をクリックします。

    Access 2007 .accdb ファイル形式でファイルが保存されます。

ページの先頭へ

スキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×