(Power Query) を結合するバイナリ ファイルとフォルダー内のファイルを組み合わせる

注:  最新のヘルプ コンテンツをできるだけ早く、お客様がお使いの言語で提供したいと考えております。 このページは、自動翻訳によって翻訳されているため、文章校正のエラーや不正確な情報が含まれている可能性があります。私たちの目的は、このコンテンツがお客様の役に立つようにすることです。お客様にとって役立つ情報であったかどうかを、このページの下部でお知らせください。 簡単に参照できるように、こちらに 英語の記事 があります。

Excel の取得に使用して、1 つのテーブルに 1 つのフォルダーから、同じスキーマを持つ複数のファイルを結合する (Power Query) のエクスペリエンスを変換します。次の例予算ブック内の複数の部門、場所、列、同じですが、行と値の数が異なるブック間で結合することができます。

複数ファイル結合プロセスを開始するには、まず、結合するすべてのファイルを 1 つのファイル フォルダーに格納します。

注: Excel、テキスト、CSV、JSON、XML、Access ファイルがサポートされます。

  1. [データ] タブの [データの取り込み] をクリックして >ファイルから>フォルダーからします。データの取り込み] ボタンが表示されない場合は、新しいクエリをクリックし、>ファイルから>フォルダーから

    ファイルからバイナリを結合する > フォルダーから] オプション

  2. [参照] ボタンをクリックして、フォルダーを選びます。

    フォルダー内のファイルの一覧が表示されます。この例では、4 つの Excel ブックを読み込むしました。必要なすべてのファイルが表示されていることを確認した後は、結合と読み込みオプションを選びます。

    バイナリの結合と読み込み] オプションを結合します。
  3. 各ファイルが分析され、テキストExcelまたはJSONなどの適切なファイル形式を確認します。この例では、最初の Excel ブックからワークシートの一覧が表示されます。、使用するワークシートを選択し、 [OK] をクリックします。結合バイナリがプロセスを変換し、[自動的にクエリを作成する各ファイルからデータを統合して、1 つのワークシートに結果を表示します。

    主な統合対象を選択するための使用可能な Excel ワークシートを表示する [バイナリの結合] ダイアログ
  4. 元のデータ ファイルを変更した場合は、常にインポートしたデータを更新できます。データ範囲内の任意の場所をクリックし、[クエリ ツール] > [更新] に移動します。さらに、自動的に作成される見本クエリを変更することにより、追加の変換または抽出ステップを簡単に適用できます。追加の関数クエリステップを変更または作成する必要はありません。見本クエリに対するすべての変更は、リンクされた関数クエリで自動的に生成されます。

複数ファイル結合プロセスを開始するには、まず、結合するすべてのファイルを 1 つのファイル フォルダーに格納します。

注: Excel、テキスト、CSV、JSON、XML、Access ファイルがサポートされます。

  1. [ Power Query ] タブの [ファイルから] をクリックして >フォルダーからします。

    Power Query > ファイルから > からフォルダー オプション
  2. [参照] ボタンをクリックして、フォルダーを選びます。

    フォルダー内のファイルの一覧が表示されます。[編集] オプションを選んで、クエリ エディターを開きます。この例では、4 つの Excel ブックを読み込んでいます。

    結合するファイルが含まれるバイナリ ファイル結合ダイアログ
  3. 結合するすべてのファイルが一覧に表示されていることを確認し、[コンテンツ] 列の [バイナリの結合] ボタンをクリックします。

    クエリの [コンテンツ] 列または [Power Query] リボンの [結合] セクションから [バイナリの結合] ボタンをクリック
  4. 各ファイルが分析され、正しいファイル形式が決定されます (テキストExcelJSON など)。この例では、最初の Excel ブックのワークシートのリストが表示されています。使うワークシートを選び、[OK] をクリックします。

    主な統合対象を選択するための使用可能な Excel ワークシートを表示する [バイナリの結合] ダイアログ
  5. バイナリ結合変換プロセスにより、各ファイルのデータを統合してプレビューを表示するクエリが自動的に作成されます。結果に問題がなければ、[閉じて読み込む] をクリックします。

    [バイナリの結合] プレビュー ダイアログ。[閉じて読み込む] をクリックし、結果を承諾して、Excel にインポートします。

    一覧のワークシートが 1 つのワークシートに統合されます。

  6. 元のデータ ファイルを変更した場合は、常にインポートしたデータを更新できます。データ範囲内の任意の場所をクリックし、[クエリ ツール] > [更新] に移動します。さらに、自動的に作成される見本クエリを変更することにより、追加の変換または抽出ステップを簡単に適用できます。追加の関数クエリステップを変更または作成する必要はありません。見本クエリに対するすべての変更は、リンクされた関数クエリで自動的に生成されます。

既知の問題

バイナリ結合プロシージャを Excel に読み込むときに、次のエラー メッセージが表示されることがあります。

バイナリの結合エラー メッセージこれは対処中の既知の問題です。

[OK] をクリックしてエラーを無視すると、エラーがあってもバイナリ結合プロセスは完了してデータを正しく読み込みます。エラー修正作業が行われています。

補足説明

Excel Tech Community では、いつでも専門家に質問できます。Microsoft コミュニティでは、サポートを受けられます。また、Excel User Voice では、新機能についての提案や改善案を送信することができます。

関連項目

Excel 2016 の [取得して変換]

外部データ ソースからデータをインポートする

Office のスキルを磨く
トレーニングの探索
新機能を最初に入手
Office Insider に参加する

この情報は役に立ちましたか?

ご意見をいただきありがとうございます。

フィードバックをお寄せいただき、ありがとうございます。Office サポートの担当者におつなぎいたします。

×