データを横棒グラフで表示する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office Excel 2007 では、横棒グラフを作成し、効果的な新しい外観を設定できます。縦棒グラフと同様に、横棒グラフも 1 つまたは複数のデータ系列内でデータ ポイントを比較する場合に役立ちます。

書式を設定した円柱形の集合横棒グラフ

作成した横棒グラフの棒の間隔を変更できます。プロジェクト管理プログラムでよく使用されているガント チャートをシミュレートする場合にも、横棒グラフを使用できます。

この記事の内容

横棒グラフでのデータのプロットについて

複雑な横棒グラフを作成する

棒の間隔を変更する

ガント チャートをシミュレートする

グラフをテンプレートとして保存する

横棒グラフでのデータのプロットについて

横棒グラフは各項目間の比較を示します。

横棒グラフでは、項目を垂直方向の軸に、数値を水平方向の軸に配置します。

3-D 横棒グラフ

次の場合に横棒グラフの使用を検討します。

  • プロットするデータ系列が 1 つ以上あります。

  • データに正の値、負の値、およびゼロ (0) 値が含まれています。

  • 多くの項目のデータを比較します。

  • 軸ラベルが長い。

  • 表示される値が期間である。

横棒グラフの作成時には、次のいずれかの形式を選択できます。

  • 集合横棒および 3-D 効果付き集合横棒   集合横棒グラフは項目ごとに値を比較します。集合横棒グラフでは、通常、項目を縦軸に、値を横軸に表します。3-D 効果付き集合横棒グラフは棒グラフを 3-D 形式で表示するだけで、データを 3 つの軸で表示するものではありません。

    集合横棒グラフおよび 3-D 集合横棒グラフ

  • 積み上げ横棒および 3-D 効果付き積み上げ横棒   各項目と全体との関係を示します。3-D 効果付き積み上げ横棒グラフは棒グラフを 3-D 形式で表示するだけで、データを 3 つの軸で表示するものではありません。

    積み上げ横棒グラフおよび 3-D 積み上げ横棒グラフ

  • 100% 積み上げ横棒および 3-D 効果付き 100% 積み上げ横棒   項目ごとに値の全体に対する比率を比較します。3-D 100% 積み上げ横棒グラフは積み上げ棒グラフを 3-D 形式で表示するだけで、データを 3 つの軸で表示するものではありません。

    100% 積み上げ縦棒グラフと 3-D 100% 縦棒グラフ

  • 円柱形、円錐形、およびピラミッド形の横棒グラフ    これらのグラフにも、通常の横棒グラフの場合と同様に、集合横棒、積み上げ横棒、100% 積み上げ横棒の各形式があります。これらでも同じようにデータの表示と比較が行われます。横棒の代わりに、円柱形、円錐形、またはピラミッド形で表示される点のみ異なります。

    円柱グラフ、円錐グラフ、およびピラミッド グラフ

ページの先頭へ

複雑な横棒グラフを作成する

書式を設定した円柱形の集合横棒グラフ

さて、この横棒グラフはどのようにして作成されたのでしょうか。次の手順を実行すると、同様の結果の横棒グラフを作成できます。このグラフでは、サンプルのワークシート データを使用しています。このデータをワークシートにコピーするか、または独自のデータを使用してください。

  1. サンプルのワークシート データを空のワークシートにコピーするか、または横棒グラフにプロットするデータが含まれているワークシートを開きます。

    サンプルのワークシート データをコピーするには

    1. 空のブックまたはワークシートを作成します。

    2. ヘルプ トピックから使用例を選択します。

      注: 行見出しまたは列見出しは選択しないでください。

      ヘルプから使用例を選択する
      ヘルプから使用例を選択する
    3. Ctrl キーを押しながら C キーを押します。

    4. ワークシートでセル A1 を選択し、Ctrl キーを押しながら V キーを押します。

1

2

3

4

5

6

7

3.6

9

10

A

b

市区町村」、「統計 E

年間の % 平均考えられる SUNSHIN E

アリゾナ州ユマ

90%

テキサス州エルパソ

84%

ネバダ州リノ

79%

フロリダ州キーウェスト

76%

ハワイ州ホノルル

71%

カリフォルニア州サンフランシスコ

66%

ニューヨーク

58%

ワシントン州シアトル

47%

アラスカ州ジュノー

[エンタープライズ日付 30%

  1. 横棒グラフにプロットするデータを選択します。

  2. [挿入] タブの [グラフ] で [横棒​​] をクリックします。

    Excel のリボンのイメージ

  3. [2-D 横棒] で [集合横棒] をクリックします。

  4. グラフのグラフ領域をクリックします。

    これにより、[グラフ ツール] が表示され、[デザイン] タブ、[レイアウト] タブ、および [書式] タブが追加されます。

  5. [デザイン] タブの [グラフのスタイル] で、使用するグラフのスタイルをクリックします。

    Excel のリボン イメージ

    この横棒グラフでは、[スタイル 4] を使用しました。

  6. グラフ内の凡例をクリックし、Del キーを押します。

  7. グラフ タイトルのサイズを小さくするには、タイトルを右クリックし、[サイズ] ボックスから使用するサイズをクリックします。

    この横棒グラフでは、12 という値を使用しました。

  8. 軸ラベルのサイズを小さくするには、水平方向 (項目) の軸を右クリックし、[サイズ] ボックスから使用するサイズをクリックします。

    この横棒グラフでは、8 という値を使用しました。

  9. グラフのプロット エリアをクリックするか、グラフ要素の一覧 ([レイアウト] タブの [現在の選択範囲] の [グラフの要素] ボックス) でプロット エリアを選択します。

  10. [書式] タブの [図形のスタイル] で ボタン イメージ (その他) をクリックし、任意の要素をクリックします。

    この横棒グラフでは、[パステル - アクセント 1] を使用しました。

    Excel リボンの [図形のスタイル] グループ

  11. [バーのすべてを選択するデータ ポイント] をクリックするか、([レイアウト] タブ、現在の選択範囲] グループ、グラフ要素] ボックス)、グラフ要素の一覧からデータ系列を選択します。

  12. [書式] タブの [図形のスタイル] で ボタン イメージ (その他) をクリックし、任意の要素をクリックします。

    この横棒グラフでは、[パステル - アクセント 2] を使用しました。

  13. [書式] タブの [図形のスタイル] で [図形の効果] をクリックします。

  14. [光彩] をクリックし、[光彩の種類] から使用する光彩効果をクリックします。

    この横棒グラフでは、[アクセント 2、8 pt 光彩] を使用しました。

  15. グラフのグラフ エリアをクリックします。

  16. [書式] タブの [図形のスタイル] で ボタン イメージ (その他) をクリックし、任意の要素をクリックします。

    この横棒グラフでは、[枠線のみ - アクセント 1] を使用しました。

  17. グラフのサイズを変更するには、[書式] タブの [サイズ] で [図形の高さ] ボックスから図形のサイズを選択し、Enter キーを押します。

    この横棒グラフでは、[4"] を使用しました。

    Outlook のリボンの画像

  18. ブックに適用される既定のテーマとは異なるテーマの色を使用するには、次の操作を行います。

    1. [ページ レイアウト] タブの [テーマ] で、[テーマ] をクリックします。

      Excel のリボンのイメージ

    2. [組み込み] で、使用するテーマをクリックします。

      この横棒グラフでは、[フレッシュ] テーマを使用しました。

ページの先頭へ

棒の間隔を変更する

横棒グラフの棒の間隔を広くしたり狭くしたりできます。2-D 横棒グラフでは、棒を重ねて表示することもできます。

  1. 変更するデータ系列をグラフでクリックするか、次の操作を実行して、グラフ要素の一覧からデータ系列を選択します。

    1. グラフをクリックします。

      これにより、[グラフ ツール] が表示され、[デザイン] タブ、[レイアウト] タブ、および [書式] タブが追加されます。

    2. [書式] タブの [現在の選択範囲] で、[グラフの要素] ボックスの横にある矢印をクリックし、データ系列をクリックします。

      Excel のリボンの画像

  2. ヒント: 同じ種類のグラフを使うすべてのデータ系列の間隔を変更するには、データ系列を 1 つだけ選択します。

  3. [書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

  4. [系列のオプション] で、次のいずれかの操作を行います。

    1. 2-D 横棒グラフの横棒の重なりを変更するには、スライダをドラッグして系列の重なりのパーセンテージを増減するか、[系列の重なり] ボックスに -100 ~ 100 のパーセンテージを入力します。

      ヒント: 設定する数値が大きいほど、データ マーカーの重なりが大きくなります。

    2. 2-D 横棒グラフまたは 3-D 横棒グラフのデータ マーカーの項目の間隔を変更するには、スライダをドラッグして間隔のパーセンテージを増減するか、[棒の間隔] ボックスに 0 (ゼロ) ~ 500 の値を入力します。

      ヒント: 値を大きくするほど、棒の間隔は大きくなります。

    3. 3-D 横棒グラフのデータ系列の間隔を変更するには、[棒の間隔] ボックスに 0 ~ 500 の値を入力します。

      ヒント: 値を大きくするほど、棒の間隔は大きくなります。

ページの先頭へ

ガント チャートをシミュレートする

Excel にはガント チャートは用意されていませんが、積み上げ横棒グラフを使用して、タスク、タスク期間、および階層を表すようにカスタマイズすると、ガント チャートをシミュレートできます。

Excel のガント チャートの例

次の手順を実行すると、この図と同様のガント チャートを作成できます。このグラフでは、サンプルのワークシート データを使用しています。このデータをワークシートにコピーしてください。同じ列見出しとワークシート構造であれば、独自のデータを使用してもかまいません。

  1. サンプルのワークシート データを空のワークシートにコピーするか、またはガント チャートにプロットするデータが含まれているワークシートを開きます。

    サンプルのワークシート データをコピーするには

    1. 空のブックまたはワークシートを作成します。

    2. ヘルプ トピックから使用例を選択します。

      注: 行見出しまたは列見出しは選択しないでください。

      ヘルプから使用例を選択する
      ヘルプから使用例を選択する
    3. Ctrl キーを押しながら C キーを押します。

    4. ワークシートでセル A1 を選択し、Ctrl キーを押しながら V キーを押します。

1

2

3

4

5

6

A

b

C

仕事

[開始日]

期間

タスク 1

0

51

タスク 2

51

2.7

タスク 3

3.6

9

タスク 4

17

76

タスク 5

[エンタープライズ フラグ 20

5

注: 列 B および C ([開始日] と [期間]) の値は、開始日からの日数およびタスク完了に必要な日数を表します。

  1. ガント チャートにプロットするデータ (このサンプルのワークシート データでは A1:C6) を選択します。

  2. [挿入] タブの [グラフ] で [横棒​​] をクリックします。

  3. [2-D 横棒] の [積み上げ横棒] をクリックします。

  4. グラフで最初のデータ系列をクリックするか、グラフ要素の一覧から最初のデータ系列を選択します ([書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの一覧からデータ系列を選択します)。

  5. [書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

    Excel のリボンの画像

  6. [塗りつぶし] をクリックし、[塗りつぶしなし] をクリックします。

  7. [閉じる] をクリックします。

  8. グラフ上の凡例をクリックし、Del キーを押します。

  9. 水平方向 (値) の軸をクリックするか、グラフ要素の一覧から選択します ([書式] タブの [現在の選択範囲] で [グラフの要素] ボックスの一覧から選択します)。

  10. [書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

  11. [軸のオプション] の [軸を反転する] チェック ボックスをオンにします。

ページの先頭へ

グラフをテンプレートとして保存する

作成したグラフと似たグラフを作成する必要がある場合は、そのグラフをテンプレートとして保存すると、同様のグラフを作成するときの基礎として使用できます。

  1. テンプレートとして保存するグラフをクリックします。

  2. [デザイン] タブの [種類] で、[テンプレートとして保存] をクリックします。

    Excel のリボンのイメージ

  3. [ファイル名] ボックスにテンプレートの名前を入力します。

    ヒント: 別のフォルダーを保存先として指定した場合を除き、テンプレート ファイル (.crtx) は Charts フォルダーに保存され、[グラフの挿入] ダイアログ ボックス ([挿入] タブの [グラフ] で ボタン イメージ (ダイアログ ボックス起動ツール) をクリック) および [グラフの種類の変更] ダイアログ ボックス ([デザイン] タブの [種類] で [グラフの種類の変更] をクリック) の両方の [テンプレート] で、そのテンプレートを使用できるようになります。

    グラフ テンプレートの適用方法の詳細については、「グラフ テンプレートを使ってお気に入りのグラフを再利用する」を参照してください。

注: グラフ テンプレートには、グラフの書式設定が格納され、グラフをテンプレートとして保存するときに使用していた色も格納されます。グラフ テンプレートを使用して別のブックにグラフを作成すると、そのグラフでは、ブックに現在適用されているドキュメントのテーマの色ではなく、グラフ テンプレートの色が使用されます。グラフ テンプレートの色ではなく、ドキュメントのテーマの色を使用するには、グラフ領域を右クリックし、ショートカット メニューの [リセットしてスタイルに合わせる] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

この情報は役に立ちましたか?

ありがとうございます。その他のフィードバックはありませんか?

改善内容をお聞かせください

ご意見をいただきありがとうございます。

×