データを円グラフで表示する

重要:  この記事は機械翻訳されています。機械翻訳についての「免責事項」をお読みください。この記事の英語版を参照するには、ここをクリックしてください。

Microsoft Office Excel 2007 では、データを簡単に円グラフで表示し、見やすくて本格的な外観を設定できます。

書式付き円グラフ

円グラフを作成した後に、各要素を回転させて視点を変えることができます。また、特定の要素を円グラフから切り離して強調したり、グラフの種類を補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフに変更して、円グラフ内の非常に小さな要素を見やすくしたりもできます。

この記事の内容

円グラフでのデータのプロットについて

複雑な円グラフを作成する

円グラフの要素を回転する

円グラフの要素を切り離す

小さな要素を補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフで見やすくする

グラフをテンプレートとして保存する

円グラフでのデータのプロットについて

円グラフは、1 つのデータ系列の各項目の大きさを、項目の合計に対して相対的に示します。円グラフ内のデータ ポイントは、円全体に対するパーセンテージで表示されます。円グラフには 1 つのデータ系列しかプロットできないため、ワークシートのデータは 1 つの列または 1 つの行に配置する必要があります。また、選択範囲の先頭の列または行であれば、分類名を含めることもできます。分類名は、円グラフの凡例として表示されます。

次の場合に円グラフの使用を検討します。

  • プロットするデータ系列が 1 つだけである。

  • プロットする値に負の数がない。

  • プロットする値にゼロ (0) 値が含まれない。

  • 項目数は 7 以下である。

  • 項目は円グラフ全体の一部として表される。

円グラフの作成時には、次のいずれかの形式を選択できます。

  • 円および 3-D 効果付き円   全体に対する各値の割合を、2-D または 3-D 形式で表示します。円グラフの一部を手動で取り出して強調できます。

    2-D 円グラフと 3-D 円グラフの例

  • 補助円グラフ付き円および補助縦棒グラフ付き円   メインの円グラフからユーザー定義によって値を抜粋し、補助円グラフや補助縦棒グラフに結合した円グラフを表示します。メインの円グラフの小さな部分を見やすくする場合に適しています。

    補助円グラフ付き円グラフと補助縦棒グラフ付き円グラフの例

  • 分割円および 3-D 効果付き分割円   分割円グラフは、個々の値を強調しながら、全体に対する値の関係や比較を表します。3-D 効果を付けることもできます。すべての要素または個々の要素の分割設定を変更することはできますが、分割円の要素を手動で移動することはできません。手動で要素を取り出す場合は、代わりに、円グラフまたは 3-D 効果付き円グラフの使用を検討してください。

    2-D と 3-D の分割された円グラフの例

ページの先頭へ

複雑な円グラフを作成する

書式付き円グラフ

さて、この円グラフはどのようにして作成されたのでしょうか。次の手順を実行すると、同様の結果の円グラフを作成できます。このグラフでは、サンプルのワークシート データを使用しています。このデータをワークシートにコピーしてもかまいませんし、独自のデータを使用してもかまいません。

  1. サンプルのワークシート データを空のワークシートにコピーするか、または円グラフにプロットするデータが含まれているワークシートを開きます。

    サンプルのワークシート データをコピーするには

    1. 空白のワークブックまたはワークシートを作成します。

    2. ヘルプ トピックから使用例を選択します。

      注: 行見出しまたは列見出しは選択しないでください。

      ヘルプから使用例を選択する

      ヘルプから使用例を選択する

    3. Ctrl キーを押しながら C キーを押します。

    4. ワークシートでセル A1 を選択し、Ctrl キーを押しながら V キーを押します。

    "1"。

    2

    3

    4

    5

    6

    A

    B

    ランチの売上

    サンドイッチ

    4

    サラダ

    21

    スープ

    1500

    飲料

    9

    デザート

    1500

  2. 円グラフにプロットするデータを選択します。

  3. [挿入] タブの [グラフ] で [円​​] をクリックします。

    Excel のリボン イメージ

  4. [3-D 円] で、[3-D 円] をクリックします。

  5. 円グラフのプロット エリアをクリックします。

    これにより、[グラフ ツール] が表示され、[デザイン] タブ、[レイアウト] タブ、および [書式] タブが追加されます。

  6. [デザイン] タブの [グラフのレイアウト] で、使用するレイアウトを選択します。

    Excel のリボンのイメージ

    この円グラフでは、[レイアウト 2] を使用しました。

    [レイアウト 2] では、凡例が表示されます。グラフの凡例のエントリが多すぎる場合、または凡例のエントリが見分けにくい場合は、凡例を表示する代わりに、円グラフの要素にデータ ラベルを追加できます ([レイアウト] タブの [ラベル] で [データ ラベル] をクリックします)。

  7. [デザイン] タブの [グラフのスタイル] で、使用するグラフのスタイルをクリックします。

    Excel のリボンのイメージ

    この円グラフでは、[スタイル 2] を使用しました。

  8. [書式] タブの [図形のスタイル] で [図形の効果] をクリックし、[面取り] をクリックします。

    Excel リボンの [図形のスタイル] グループ

  9. [3-D オプション] をクリックし、[面取り] の [] および [] で、使用する面取りのオプションをクリックします。

    この円グラフでは、[] を使用しました。

  10. [] および [] の面取りのオプションで、[] ボックスと [高さ] ボックスに目的のポイント サイズを入力します。

    この円グラフでは、「512 pt」という値を使用しました。

  11. [表面] の [質感] をクリックし、使用するオプションをクリックします。

    この円グラフでは、[プラスチック] を使用しました。

  12. [閉じる] をクリックします。

  13. [書式] タブの [図形のスタイル] で [図形の効果] をクリックし、[] をクリックします。

  14. [外側]、[内側]、または [透視投影] で、使用するオプションをクリックします。

    この円グラフでは、[透視投影] の [] を使用しました。

  15. グラフを回転させて視点を調整するには、プロット エリアを選択し、[書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

  16. [グラフの基線位置] で、目的の回転角度になるようにスライダをドラッグするか、0 ~ 360 の範囲の値を入力して基線位置を指定し、[閉じる] をクリックします。

    この円グラフでは、350 という値を使用しました。

  17. グラフのグラフ エリアをクリックします。

  18. [書式] タブの [図形のスタイル] で [図形の効果] をクリックし、[面取り] をクリックします。

  19. [面取り] で、使用するオプションを選択します。

    この円グラフでは、[] を使用しました。

  20. ブックに適用される既定のテーマとは異なるテーマの色を使用するには、次の操作を行います。

    1. [ページ レイアウト] タブの [テーマ] で、[テーマ] をクリックします。

      Excel のリボンの画像

    2. [組み込み] で、使用するテーマをクリックします。

      この円グラフでは、[アース] テーマを使用しました。

ページの先頭へ

円グラフの要素を回転する

Office Excel 2007 で円グラフのデータ系列がプロットされる順序は、ワークシート上のデータの順序によって決まります。360°の円グラフの中で要素を回転させることにより、視点を変えることができます。

円グラフの回転したスライスの例

  1. 円グラフで、データ系列またはデータ ポイントをクリックするか、次の操作を実行して、グラフ要素の一覧から選択します。

    1. グラフをクリックします。

      これにより、[グラフ ツール] が表示され、[デザイン] タブ、[レイアウト] タブ、および [書式] タブが追加されます。

    2. [書式] タブの [現在の選択範囲] で、[グラフの要素] ボックスの横にある矢印をクリックし、目的のデータ系列またはデータ ポイントをクリックします。

      excel のリボン イメージ

  2. [書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

  3. [グラフの基線位置] で、目的の回転角度になるようにスライダをドラッグするか、0 ~ 360 の範囲の値を入力して基線位置を指定します。

ページの先頭へ

円グラフの要素を切り離す

円グラフの各要素を強調するには、グラフを作成するときに、分割円または 3-D 分割円を使用します。分割円グラフは、個々の値を強調しながら、全体に対する値の関係や比較を表します。すべての要素または個々の要素の分割設定を変更することはできますが、分割円の要素を手動で移動することはできません。

分割された円グラフ

要素を手動で切り離す必要がある場合は、代わりに円グラフまたは 3-D 円グラフの使用を検討してください。

1 つの要素が分離された円グラフ

分割円グラフの要素の設定を変更する

  1. 分割円グラフで、データ系列またはデータ ポイントをクリックするか、次の操作を実行して、グラフ要素の一覧からデータ系列を選択します。

    1. グラフをクリックします。

      これにより、[グラフ ツール] が表示され、[デザイン] タブ、[レイアウト] タブ、および [書式] タブが追加されます。

    2. [書式] タブの [現在の選択範囲] で、[グラフの要素] ボックスの横にある矢印をクリックし、データ系列をクリックします。

      excel のリボン イメージ

  2. [書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

  3. [円グラフの切り離し] で、スライダをドラッグして切り離しのパーセンテージを増減するか、パーセンテージ ボックスに目的の切り離しのパーセンテージを入力します。

円グラフの要素を手動で切り離す

円グラフをクリックし、次のいずれかの操作を行います。

  • 円グラフのすべての要素を切り離すには、グラフの中心から外側へドラッグします。

  • 円グラフから個々の要素を切り離すには、切り離す要素をクリックし、その要素を円の中心から外側に向かってドラッグします。

ページの先頭へ

小さな要素を補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフで見やすくする

円グラフに多くのデータ ポイントがあり、全体に対するそれぞれの割合が 5% に満たない場合は、各要素を見分けることが困難になります。

円グラフ

円グラフの小さな要素を見やすくするには、補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフを使用します。どちらのグラフ形式も、メインの円グラフから小さな要素を切り離し、これを補助円グラフまたは補助縦棒グラフで表示します。

補助円グラフ付き円グラフ

補助円グラフのデータ ラベルには、標準の円グラフと同じパーセンテージ値が表示されます。補助円グラフのパーセンテージは、メインの円グラフから切り離された要素を表すため、合計で 100% になりません。すべての要素は、同じデータ系列に属します。

補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフの種類を選択すると、既定では、最後の 3 つのデータ要素が補助グラフに移動します。たとえば、グラフに 7 ~ 9 個のデータ要素がある場合、最後の 3 つのデータ要素が補助グラフにプロットされます。ただし、データ要素をメインの円グラフと補助円グラフに配分する方法、およびその表示方法は変更できます。

補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフを作成する

  1. ワークシートで、補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフにプロットするデータを選択します。

  2. [挿入] タブの [グラフ] で [] をクリックし、[補助円グラフ付き円グラフ] または [補助縦棒付き円] をクリックします。

    Excel のリボン イメージ

    注記: 

    • メイン グラフと補助グラフは、必ず横方向に並べて表示されます。それぞれを個別に移動することはできません。左側のグラフが常にメイン グラフです。

    • グラフを個別に選択したり、別々の書式を設定したりすることはできません。メイン グラフと補助グラフは、両方とも 1 つのデータ系列の一部です。選択して書式設定を適用できるのは、データ系列全体か、または個々のデータ要素に限られます。

    • メイン グラフと補助グラフの関係を示すために、区分線が自動的に追加されます。別の線のスタイルを適用することで、区分線に書式を設定できます。また、区分線を削除することもできます。

    • [セルの書式設定] ダイアログ ボックス ([ホーム] タブの [数値] で ボタン イメージ (ダイアログ ボックス起動ツール) をクリック) の [表示形式] タブで指定したパーセンテージの小数点以下の桁数によっては、データ ラベルに表示されるパーセンテージが丸められ、合計が合わなくなる場合があります。

データ要素の配分と表示を変更する

  1. 補助円グラフ付き円グラフまたは補助縦棒グラフ付き円グラフで、データ系列またはデータ要素を選択するか、次の操作を実行して、グラフ要素の一覧からデータ系列を選択します。

    1. グラフをクリックします。

      これにより、[グラフ ツール] が表示され、[デザイン] タブ、[レイアウト] タブ、および [書式] タブが追加されます。

    2. [書式] タブの [現在の選択範囲] で、[グラフの要素] ボックスの横にある矢印をクリックし、データ系列をクリックします。

      excel のリボン イメージ

  2. [書式] タブの [現在の選択範囲] で [選択対象の書式設定] をクリックします。

  3. [系列の分割] ボックスで、補助グラフに表示するデータの種類をクリックします。

  4. 補助グラフに表示するデータ要素の数を調整するには、次の操作を行います。

    1. 位置で系列を分割する場合は、[補助プロットに含む値の個数] ボックスに、別の値を入力します。

    2. 値またはパーセント値で系列を分割する場合は、[補助プロットに次の値未満をすべて含む] ボックスに、別の値を入力します。

    3. 選択したデータ要素の配置場所を変更するには、[要素のプロット先] ボックスの一覧の [主要プロット] または [補助プロット] をクリックします。

  5. 要素の間隔を変更するには、[円グラフの切り離し] または [要素の切り出し] で、スライダをドラッグして切り離しのパーセンテージを増減するか、パーセンテージ ボックスに目的の切り離しのパーセンテージを入力します。

  6. グラフの間隔を変更するには、[要素の間隔] で、スライダをドラッグして値を増減するか、パーセンテージ ボックスに目的の値を入力します。

    この値は、間隔の幅を補助グラフの幅に対するパーセンテージで表します。

  7. 補助グラフのサイズを変更するには、[補助プロットのサイズ] ボックスで、スライダをドラッグして値を増減するか、パーセンテージ ボックスに目的の値を入力します。

    この値は、補助グラフのサイズをメイン グラフのサイズに対するパーセンテージで表します。

ページの先頭へ

グラフをテンプレートとして保存する

作成したグラフと似たグラフを作成する必要がある場合は、そのグラフをテンプレートとして保存すると、同様のグラフを作成するときの基礎として使用できます。

  1. テンプレートとして保存するグラフをクリックします。

  2. [デザイン] タブの [種類] で、[テンプレートとして保存] をクリックします。

    Excel のリボン イメージ

  3. [ファイル名] ボックスにテンプレートの名前を入力します。

    ヒント: 別のフォルダーを保存先として指定した場合を除き、テンプレート ファイル (.crtx) は Charts フォルダーに保存され、[グラフの挿入] ダイアログ ボックス ([挿入] タブの [グラフ] で ボタン イメージ (ダイアログ ボックス起動ツール) をクリック) および [グラフの種類の変更] ダイアログ ボックス ([デザイン] タブの [種類] で [グラフの種類の変更] をクリック) の両方の [テンプレート] で、そのテンプレートを使用できるようになります。

    グラフ テンプレートの適用方法の詳細については、「グラフ テンプレートを使ってお気に入りのグラフを再利用する」を参照してください。

グラフ テンプレートには、グラフの書式設定が格納され、グラフをテンプレートとして保存するときに使用していた色も格納されます。グラフ テンプレートを使用して別のブックにグラフを作成すると、そのグラフでは、ブックに現在適用されているドキュメントのテーマの色ではなく、グラフ テンプレートの色が使用されます。グラフ テンプレートの色ではなく、ドキュメントのテーマの色を使用するには、グラフ領域を右クリックし、ショートカット メニューの [リセットしてスタイルに合わせる] をクリックします。

ページの先頭へ

注: 機械翻訳についての免責事項: この記事の翻訳はコンピューター システムによって行われており、人間の手は加えられていません。マイクロソフトでは、英語を話さないユーザーがマイクロソフトの製品、サービス、テクノロジに関するコンテンツを理解するのに役立てるため、こうした機械翻訳を提供しています。記事は機械翻訳されているため、用語、構文、文法などに誤りがある場合があります。

この情報は役に立ちましたか?

ありがとうございます。その他のフィードバックはありませんか?

改善内容をお聞かせください

ご意見をいただきありがとうございます。

×